Contenu | Rechercher | Menus

Annonce

Toute l'équipe d'ubuntu-fr vous souhaite un joyeux Noël et une bonne et heureuse année 2018.

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 24/10/2017, à 18:11

Manasian

[Résolu] Plymouth mode texte [Xunbuntu 16.04]

Plymouth s'affiche en mode texte quand je ferme la session, comment résoudre ce souci ? Par contre, au démarrage de la session, je n'ai aucun souci, le logo est bien affiché.

Voilà les commandes que j'ai déjà tenté, sans succès :

user-X75VC:~$ sudo dpkg-reconfigure plymouth
update-initramfs: deferring update (trigger activated)
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
Traitement des actions différées (« triggers ») pour initramfs-tools (0.122ubuntu8.9) ...
update-initramfs: Generating /boot/initrd.img-4.10.0-37-generic
W: Possible missing firmware /lib/firmware/i915/kbl_dmc_ver1_01.bin for module i915
user-X75VC:~$ sudo update-initramfs -u
update-initramfs: Generating /boot/initrd.img-4.10.0-37-generic
W: Possible missing firmware /lib/firmware/i915/kbl_dmc_ver1_01.bin for module i915
user-X75VC:~$

Merci d'avance

Dernière modification par Manasian (Le 31/10/2017, à 17:17)

Hors ligne

#2 Le 24/10/2017, à 22:31

J5012

Re : [Résolu] Plymouth mode texte [Xunbuntu 16.04]

ce n'est pas la faute à plymouth ... c'est la configuration par defaut des services init.d à l'extinction

nota : plymouth ne sert pas au demarrage de session mais au demarrage des services init.d , dans le fonctionnement gnulinux tu dois distinguer le demarrage proprement dit du gestionnaire de session qui est le dernier service à etre lancé ...

Hors ligne

#3 Le 25/10/2017, à 20:07

Manasian

Re : [Résolu] Plymouth mode texte [Xunbuntu 16.04]

D'accord, mais dans ce cas, je dois faire quoi ? A tout hasard, je mets quand même un copier/coller de plymouth/plymouth-log de /etc/init.d/ :

plymouth :

#!/bin/sh

### BEGIN INIT INFO
# Provides:		plymouth
# Required-Start:	udev $remote_fs $all
# Required-Stop:	$remote_fs
# Should-Start:		$x-display-manager
# Should-Stop:		$x-display-manager
# Default-Start:	2 3 4 5
# Default-Stop:		0 6
# Short-Description:	Stop plymouth during boot and start it on shutdown
### END INIT INFO

PATH="/sbin:/bin:/usr/sbin:/usr/bin"
NAME="plymouth"
DESC="Boot splash manager"

test -x /sbin/plymouthd || exit 0

if [ -r "/etc/default/${NAME}" ]
then
	. "/etc/default/${NAME}"
fi

. /lib/lsb/init-functions

set -e

SPLASH="true"
for ARGUMENT in $(cat /proc/cmdline)
do
	case "${ARGUMENT}" in
		splash*)
			SPLASH="true"
			;;

		nosplash*|plymouth.enable=0)
			SPLASH="false"
			;;
	esac
done

case "${1}" in
	start)
		case "${SPLASH}" in
			true)
				/bin/plymouth quit --retain-splash
				;;
		esac
		;;

	stop)
		case "${SPLASH}" in
			true)
				if ! plymouth --ping
				then
					/sbin/plymouthd --mode=shutdown
				fi

				RUNLEVEL="$(/sbin/runlevel | cut -d " " -f 2)"

				case "${RUNLEVEL}" in
					0)
						TEXT="Shutting down system..."
						;;

					6)
						TEXT="Restarting system..."
						;;
				esac

				/bin/plymouth message --text="${TEXT}"

				/bin/plymouth --show-splash
				;;
		esac
		;;

	restart|force-reload)

		;;

	*)
		echo "Usage: ${0} {start|stop|restart|force-reload}" >&2
		exit 1
		;;
esac

exit 0

plymouth-log :

#!/bin/sh

### BEGIN INIT INFO
# Provides:		plymouth-log
# Required-Start:	$local_fs $remote_fs
# Required-Stop:	$local_fs $remote_fs
# Should-Start:
# Should-Stop:
# Default-Start:	S
# Default-Stop:
# Short-Description:	Inform plymouth that /var/log is writable
### END INIT INFO

PATH="/sbin:/bin:/usr/sbin:/usr/bin"
NAME="plymouth-log"
DESC="Boot splash manager (write log file)"

test -x /bin/plymouth || exit 0

if [ -r "/etc/default/${NAME}" ]
then
	. "/etc/default/${NAME}"
fi

. /lib/lsb/init-functions

set -e

case "${1}" in
	start)
		if plymouth --ping
		then
			/bin/plymouth update-root-fs --read-write
		fi
		;;

	stop|restart|force-reload)

		;;

	*)
		echo "Usage: ${0} {start|stop|restart|force-reload}" >&2
		exit 1
		;;
esac

exit 0

Modération : merci d'utiliser les balises code (explications ici).

Dernière modification par cqfd93 (Le 25/10/2017, à 20:16)

Hors ligne

#4 Le 25/10/2017, à 22:12

J5012

Re : [Résolu] Plymouth mode texte [Xunbuntu 16.04]

d'apres le code du service plymouth, c'est le service appelant plymouth qui decide de l'affichage spash ou non ...

la pre-configuration des services par les init-functions ne font que demander la mise à jour de l'etat plymouth (update status)

etat qui va donc dependre de la facon dont il est demarré par grub ...

verifie ton fichier grub dans /etc/default ,
- est-ce que le demarrage noyau en splash est activé ?
- est-ce que le grub est forcé de demarrer en terminal non graphique ?

Hors ligne

#5 Le 26/10/2017, à 17:36

Manasian

Re : [Résolu] Plymouth mode texte [Xunbuntu 16.04]

J'ai ceci dans etc/default/grub :

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" => Cela répond peut-être à ta question ? A vue de nez, je dirais que splash est activé mais vu que je ne suis pas un expert...

PS : Peut-être que je devrais renommer le sujet ? Mettre par exemple "problème config init.d"

Hors ligne

#6 Le 27/10/2017, à 00:56

J5012

Re : [Résolu] Plymouth mode texte [Xunbuntu 16.04]

avec le livecd xubuntu 16.04 , as-tu le splash d'extinction ou non ?

Hors ligne

#7 Le 27/10/2017, à 20:18

Manasian

Re : [Résolu] Plymouth mode texte [Xunbuntu 16.04]

Alors, ma clé de boot ne fonctionne pas j'ai une tâche qui ne se termine pas ("A start job is running for Ubuntu Live CD installer" avec no limit en temps) mais le splash (l'écran avec le logo c'est bien ça ?) d'extinction s'affiche bien quand j’éteins manuellement. C'est valable ou pas ? Vu que ma clé de boot à un problème (pour info, j'utilise multisystem).

Hors ligne

#8 Le 28/10/2017, à 09:01

J5012

Re : [Résolu] Plymouth mode texte [Xunbuntu 16.04]

au moment où tu demandes manuellement l'extinction avec le live , en quelle resolution es-tu ?

normalement le live pour s'adapter au maximum de materiels, utilise des pilotes graphiques libres generiques ...

si avec le live tu obtiens le splash d'extinction, et pas en fonctionnement normal, il faudrait alors verifier le mode graphique dans lequel le bureau boot : pilote utiisé , resolution , palette de couleurs ...

à noter : si ton ordi possede un bios avec uefi, le grub boote en mode terminal non graphique ... , plymouth n'est activé qu'en mode texte ...

Hors ligne

#9 Le 28/10/2017, à 20:14

Manasian

Re : [Résolu] Plymouth mode texte [Xunbuntu 16.04]

Vu que je n'ai pas eu de problème particulier avec le live CD (bug graphique ou autre) à par cette tâche qui ne se finit pas, je dois être sur la résolution matérielle du pc, donc 1600 X 900.
Ah et, je suis justement en bios avec uefi du coup ce n'est pas plymouth qu'il faut que je corrige ?

Hors ligne

#10 Le 29/10/2017, à 19:47

J5012

Re : [Résolu] Plymouth mode texte [Xunbuntu 16.04]

le boot non graphique de grub avec les bios uefi tient je crois (d'apres les infos que j'ai eues je n'ai pas pu les confirmer) à la decision de canonical de ne pas rajouter une surcouche graphique speciale compatible uefi : canonical tenait à ce que plus de materiels uefi possibles soient compatibles avec ubuntu (tous les constructeurs ne programment pas uefi de la meme facon dans leurs ordi, helas) ... c'est d'ailleurs comme ca que dans la doc ubuntu-fr il est dit que si vous obtenez un grub menu en mode non graphique (sans avoir rien modifié), le bios de votre ordi est à coup certain un bios uefi ...

ce que tu peux faire :
- installer les paquets si manquants de plymouth de themes xubuntu logo et autre themes graphiques
- modifier le fichier /etc/default/grub de facon à activer un mode graphique, tente 1024px ou 1600 si tu es certain

precautions : j'ignore totalement la reaction de grub avec les bios uefi lorsque le terminal graphique est activé de cette facon ...

meme si tu as un bios uefi : ton bios est-il toujours configuré en mode uefi ou avais-tu rebasculé sa configuration en mode "csm" ou "legacy" prealablement à l'install ?

Hors ligne

#11 Le 31/10/2017, à 17:11

Manasian

Re : [Résolu] Plymouth mode texte [Xunbuntu 16.04]

Bon, j'ai finalement résolu le souci en installant le paquet "plymouth-dbg" (il me semble, puisque j'ai en fait, installé tous les paquets dispo commençant par plymouth) via synaptic.

Et pour le bios, il est normalement toujours en uefi, j'ai même une partition spécialement pour l'uefi.

Hors ligne

#12 Le 06/01/2018, à 00:28

J5012

Re : [Résolu] Plymouth mode texte [Xunbuntu 16.04]

plymouth-dbg est le composant pour le debugger c++ , le composant ne sert pas en lui-meme sans environnement de developpement ...

mais puisque tu dis avoir installé tous les paquets commencant par plymouth, tu dois avoir fini par installer le bon composant manquant ... wink

Hors ligne