Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

N'oubliez pas de cocher la case « Ajustement pour l'heure d'été » dans votre profil.

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 03/01/2018, à 14:43

osirthet

Premier script hello ne marche pas

Bonjour,

d'abord bonne année à tous.
je débute sous linux .

Et j'essaye d’exécuter un simple script hello pour un test.
et j'ai toujours le même message 'commande introuvable'.
j ai essayer la commande directement dans la console et cela marche bien.

donc là je ne comprend pas!
voici le script très simple:

#!/bin/bash
# Indique au système que l'argument qui suit est le programme utilisé pour exécuter ce fichier
# En règle générale, les "#" servent à mettre en commentaire le texte qui suit comme ici
echo "Mon premier script"

#exit 0

voila merci d'avance


Modération : merci d'utiliser les balises code (explications ici).

Dernière modification par cqfd93 (Le 03/01/2018, à 16:14)

Hors ligne

#2 Le 03/01/2018, à 14:46

pingouinux

Re : Premier script hello ne marche pas

Bonjour,
Si ton script s'appelle mon_script :

. ./mon_script

ou bien

chmod 700 mon_script
./mon_script

Hors ligne

#3 Le 05/01/2018, à 19:05

Hizoka

Re : Premier script hello ne marche pas

salut, ou

bash mon_script

Hors ligne

#4 Le 06/01/2018, à 21:26

cristobal78

Re : Premier script hello ne marche pas

@ osirthet

tu es sur que tu as rendu ton script exécutable (comme le dit pingouinux) ?

Dernière modification par cristobal78 (Le 06/01/2018, à 21:27)


un fixe DELL, 1 laptop LDLC et 1 laptop Lenovo, tous en 16.04.3 LTS - 64 bits

Hors ligne

#5 Le 07/01/2018, à 16:24

osirthet

Re : Premier script hello ne marche pas

Bonjour,

merci de vos reponses avec la commande suivante:
chmod 700 mon_script
./mon_script

cela  marche bien.
je ne sais pas si il faut cloturer la demande et je ne vois pas ou.
par contre ma question du début concerne un autre script qui permet de miner avec une gpu sous linux .
je suis sur le pool nanopool.
j ai telechargé     
Claymore's CryptoNote AMD GPU Miner v11.2

et quand je lance le script il me remet le même message.
voici le script:
./NsGpuCNMiner -xpool stratum+tcp://xmr-eu1.nanopool.org:14444 -xwal 49R2pLwNi383ws32eULoeUeAxHc1**********/MINER1_al_gpUlinux -xpsw x

et voici la reponse dans la console:
pascal@pascalancpcLinux:~/Documents/Claymor_amd_gpu_miner_10.2$ nsgpucnminer
nsgpucnminer : commande introuvable

si j'ai bien compris il ya un pb avec l exécutable nsgpucnminer .

j ai sur certain forum qui faut installer opencl que je ne sais pas faire encore....

mais bon c 'est compliqué commême sous linux  cela me force  à manipuler sous linux.

voila ou j'en suis de mes premiers pas sous linux  galere!!!!!
si vous avez des idées  pour m'aider.
merci d'avance

Hors ligne

#6 Le 07/01/2018, à 17:23

osirthet

Re : Premier script hello ne marche pas

je viens de telecharger opencl

et biensur le script install.sh de opencl ne marche pas .
je desespere là !!!

Hors ligne

#7 Le 07/01/2018, à 17:45

Hizoka

Re : Premier script hello ne marche pas

Avant de te lancer comme ça pour miner, apprends un minimum linux...
ça permet beaucoup de choses, c'est vraiment sympa et pratique mais bon il faut prendre son temps...

Avant de dire je veux conduire une twingo, il faut apprendre...

et dire :

et biensur le script install.sh de opencl ne marche pas .

ne sert absolument à rien... car on ne peut pas t'aider...

je desespere là !!!

Prends ton temps...
car te lancer dans le minage si tu ne sais pas comment installer un logiciel ou lancer une commande c'est vraiment mettre la charrue avant les bœufs...

si j'ai bien compris il ya un pb avec l exécutable nsgpucnminer .

Non... il te dit que la commande est introuvable, pas qu'il y a un problème avec...

Hors ligne