Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 19/12/2017, à 15:18

zest

[presque résolu] Freeze avec driver Nvidia

Bonjour,
Depuis que ubuntu est passé au noyau 4.10 le driver propriétaire Nvidia fait freezer mon pc au bout de quelques minutes de façon aléatoire. J'ai résolu en partie le problème en lançant l'utilitaire Nvidia X Server Settings : Dans "Power Mizer" j'ai choisi "Prefer maximum performance" au lieu de "Auto", réglage par défaut. Depuis plus aucun freeze. Quand je redémarre ma machine le paramètre se remet par défaut sur "Auto" ce qui m'oblige à refaire la manip...  Comment régler ce paramètre une fois pour toute ?  Dans quel fichier faut-il intervenir ?

Hors ligne

#2 Le 19/12/2017, à 15:57

ylag

Re : [presque résolu] Freeze avec driver Nvidia

Salut,

Une fois tes modifications faites dans nvidia-settings, il faut choisir "nvidia-settings Configuration" au bas du panneau de gauche et cliquer sur "Save Current Configuration", ce qui devrait enregistrer ta configuration modifiée dans le fichier caché nommé .nvidia-settings-rc de ton dossier personnel.

A+

Dernière modification par ylag (Le 19/12/2017, à 15:59)

Hors ligne

#3 Le 19/12/2017, à 16:13

zest

Re : [presque résolu] Freeze avec driver Nvidia

Merci de ton aide ylag. J'ai tenté ce que tu indiques. Hélas le paramètre se retrouve à nouveau sur"Auto" après redémarrage. J'ai édité ledit fichier qui a bien été créé :

#
# /home/alain/.nvidia-settings-rc
#
# Configuration file for nvidia-settings - the NVIDIA X Server Settings utility
# Generated on Tue Dec 19 15:02:46 2017
#

# ConfigProperties:

RcFileLocale = C
DisplayStatusBar = Yes
SliderTextEntries = Yes
IncludeDisplayNameInConfigFile = No
ShowQuitDialog = Yes
UpdateRulesOnProfileNameChange = Yes
Timer = PowerMizer_Monitor_(GPU_0),Yes,1000
Timer = Thermal_Monitor_(GPU_0),Yes,1000
Timer = Memory_Used_(GPU_0),Yes,3000

# Attributes:

[DPY:LVDS-0]/RedBrightness=0.000000
[DPY:LVDS-0]/GreenBrightness=0.000000
[DPY:LVDS-0]/BlueBrightness=0.000000
[DPY:LVDS-0]/RedContrast=0.000000
[DPY:LVDS-0]/GreenContrast=0.000000
[DPY:LVDS-0]/BlueContrast=0.000000
[DPY:LVDS-0]/RedGamma=1.000000
[DPY:LVDS-0]/GreenGamma=1.000000
[DPY:LVDS-0]/BlueGamma=1.000000

... et je n'y vois nulle part le paramètre qui nous intéresse.

Hors ligne

#4 Le 19/12/2017, à 18:27

ylag

Re : [presque résolu] Freeze avec driver Nvidia

Salut,

Désolé, je ne connais pas la syntaxe pour paramétrer ce fichier à la main, ni même si c'est possible de le faire....

Sous toute réserve, tu pourrais peut-être tenter l'utilisation des pilotes nvidia proposés sur ce ppa :
https://launchpad.net/~graphics-drivers … ubuntu/ppa

A+

Hors ligne

#5 Le 31/12/2017, à 18:32

zest

Re : [presque résolu] Freeze avec driver Nvidia

Comment savoir quel est le fichier qui est modifié quant on règle ce paramètre dans nvidia settings ? Il doit bien y avoir des fichiers de log ?

Hors ligne

#6 Le 31/12/2017, à 19:38

Rufus T. Firefly

Re : [presque résolu] Freeze avec driver Nvidia

Salut,

A mon avis, il conviendrait de lancer nvidia settings en root (donc avec sudo, dans un terminal).


La provocation est une façon de remettre la réalité sur ses pieds. (Bertolt Brecht)
Il n'y a pas de route royale pour la science et ceux-là seulement ont chance d'arriver à ses sommets lumineux qui ne craignent pas de se fatiguer à gravir ses sentiers escarpés. (Karl Marx)
Il est devenu plus facile de penser la fin du monde que la fin du capitalisme

Hors ligne

#7 Le 31/12/2017, à 21:41

ylag

Re : [presque résolu] Freeze avec driver Nvidia

Salut,

Peut-être une piste dans cette discussion (en anglais, par contre...) :

http://z-issue.com/wp/nvidia-linux-driv … -settings/

Bonne Année, en passant !! smile

A+

Hors ligne

#8 Le 09/01/2018, à 20:29

zest

Re : [presque résolu] Freeze avec driver Nvidia

Rufus T. Firefly, j'avais déjà tenté de lancer nvidia settings en root, ça ne change rien. Merci quand même pour ta suggestion :-)

Hors ligne

#9 Le 01/04/2018, à 08:28

kalagani

Re : [presque résolu] Freeze avec driver Nvidia

Hello zest,
d'abord merci pour m'avoir mis sur la piste du powermizer à changer dans l'interface NVIDIA X server settings! Mais comme toi config perdue à chaque arrêt du PC.
Alors à fouiller sur internet j'ai trouvé 3 solutions:
1) si on a un fichier /etc/X11/xorg.conf
alors dans Section "Device" ajouter la ligne

Option         "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x3322; PowerMizerDefaultAC=0x1"

ce qui donne sur ma config

Section "Device"
    Option         "Coolbits" "28"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    Option         "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x3322; PowerMizerDefaultAC=0x1"
EndSection

2) si on n'a pas de fichier /etc/X11/xorg.conf
a) création d'un script pour y mettre la commande qui modifie powermizer

cd
touch .GPUPowerMizerMode.sh
chmod a+x .GPUPowerMizerMode.sh

dont le contenu sera

#!/bin/sh
nvidia-settings -a '[gpu:0]/GPUPowerMizerMode=1'

b) lancer ce script à chaque démarrage, ici en exemple avec l'interface xfce de xubuntu
Paramètres->Session et Démarrage->Démarrage automatique d'applications
bouton Ajouter renseigner Nom, Description, chemin du script (sur ma conf: GPUPowerMizerMode, Prefer Maximum Performance, /home/kalagani/.GPUPowerMizerMode.sh)

3) si l'on a une carte graphique compatible
essayer avec nvidiux l'"équivalent" libre de NVIDIA X server settings
https://github.com/RunGp/Nvidiux/blob/master/README.md
Perso pas vraiment testé car carte incompatible, mais c'est ce qui a permis de créer le fichier xorg.conf qui n'existait pas sur ma config

1) et 2) testés sous xubuntu LTS 16.04.1 et pilote 340.106

apt list nvidia* --installed
En train de lister... Fait
nvidia-340/xenial,now 340.106-0ubuntu0+gpu16.04.2 amd64  [installé]
nvidia-opencl-icd-340/xenial,now 340.106-0ubuntu0+gpu16.04.2 amd64  [installé, automatique]
nvidia-prime/xenial,now 0.8.2 amd64  [installé, automatique]
nvidia-settings/xenial,now 390.48-0ubuntu0~gpu16.04.1 amd64  [installé, automatique]

sur PC

Machine:   System: ASUSTeK (portable) product: M70Vn v: 1.0
           Mobo: ASUSTeK model: M70Vn v: 1.0 Bios: American Megatrends v: 202 date: 09/15/2008
CPU:       Dual core Intel Core2 Duo P8600 (-MCP-) cache: 3072 KB 
           clock speeds: max: 2401 MHz 1: 2400 MHz 2: 800 MHz
Graphics:  Card: NVIDIA G96M [GeForce 9650M GT]

Remerciements aux auteurs des posts:
http://debian-facile.org/doc:materiel:c … ia:accueil
https://devtalk.nvidia.com/default/topi … ot-346-59/

Dernière modification par kalagani (Le 01/04/2018, à 08:53)

Hors ligne