Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 15/01/2018, à 13:44

emmet grogan

[résolu] problème mise à jour / espace insuffisant

Bonjour,
Je n'arrive plus à faire les mises à jours car l'espace sur mon disque dur est insuffisant. Pouvez-vous m'aider en m'indiquant la procédure à suivre pour résoudre ce problème ?
Merci bien,
E.G.

torvik@emmet:~$ sudo apt-get update
[sudo] password for torvik: 
Réception de : 1 http://download.virtualbox.org trusty InRelease [7 141 B]
Ign http://th.archive.ubuntu.com trusty InRelease                              
Atteint http://th.archive.ubuntu.com trusty-updates InRelease                  
Réception de : 2 http://download.virtualbox.org trusty/contrib amd64 Packages [2 192 B]
Ign http://download.ebz.epson.net lsb3.2 InRelease                             
Atteint https://repo.skype.com stable InRelease                                
Atteint https://repo.skype.com stable/main amd64 Packages                      
Atteint http://th.archive.ubuntu.com trusty-backports InRelease                
Atteint http://download.virtualbox.org trusty/contrib i386 Packages            
Atteint http://download.ebz.epson.net lsb3.2 Release.gpg                       
Atteint http://th.archive.ubuntu.com trusty Release.gpg                        
Ign http://archive.canonical.com trusty InRelease                              
Atteint http://th.archive.ubuntu.com trusty-updates/main amd64 Packages        
Atteint http://th.archive.ubuntu.com trusty-updates/restricted amd64 Packages  
Ign http://extras.ubuntu.com trusty InRelease                                  
Atteint http://th.archive.ubuntu.com trusty-updates/universe amd64 Packages    
Atteint http://download.ebz.epson.net lsb3.2 Release                           
Atteint http://archive.canonical.com trusty Release.gpg                        
Ign http://ppa.launchpad.net trusty InRelease                                  
Atteint http://th.archive.ubuntu.com trusty-updates/multiverse amd64 Packages  
Atteint http://extras.ubuntu.com trusty Release.gpg                            
Atteint http://th.archive.ubuntu.com trusty-updates/main i386 Packages         
Atteint http://download.ebz.epson.net lsb3.2/main amd64 Packages               
Atteint http://archive.canonical.com trusty Release                            
Atteint http://th.archive.ubuntu.com trusty-updates/restricted i386 Packages   
Atteint http://th.archive.ubuntu.com trusty-updates/universe i386 Packages     
Réception de : 3 https://repo.skype.com stable/main Translation-fr_FR          
Atteint http://th.archive.ubuntu.com trusty-updates/multiverse i386 Packages   
Atteint http://extras.ubuntu.com trusty Release                                
Atteint http://download.ebz.epson.net lsb3.2/main i386 Packages                
Atteint http://archive.canonical.com trusty/partner Sources                    
Atteint http://extras.ubuntu.com trusty/main Sources                           
Réception de : 4 http://ppa.launchpad.net trusty InRelease [20,8 kB]           
Réception de : 5 http://download.ebz.epson.net lsb3.2/main Translation-fr_FR   
Atteint http://th.archive.ubuntu.com trusty-updates/main Translation-en        
Ign http://download.virtualbox.org trusty/contrib Translation-fr_FR            
Atteint http://th.archive.ubuntu.com trusty-updates/multiverse Translation-en  
Réception de : 6 http://download.ebz.epson.net lsb3.2/main Translation-fr      
Atteint http://th.archive.ubuntu.com trusty-updates/restricted Translation-en  
Ign http://download.virtualbox.org trusty/contrib Translation-fr               
Atteint http://th.archive.ubuntu.com trusty-updates/universe Translation-en    
Ign http://download.virtualbox.org trusty/contrib Translation-en               
Atteint http://extras.ubuntu.com trusty/main amd64 Packages                    
Atteint http://th.archive.ubuntu.com trusty-backports/main amd64 Packages      
Atteint http://th.archive.ubuntu.com trusty-backports/restricted amd64 Packages
Réception de : 7 http://download.ebz.epson.net lsb3.2/main Translation-en      
Atteint http://th.archive.ubuntu.com trusty-backports/universe amd64 Packages  
Réception de : 8 http://ppa.launchpad.net trusty InRelease [15,4 kB]           
Atteint http://th.archive.ubuntu.com trusty-backports/multiverse amd64 Packages
Atteint http://th.archive.ubuntu.com trusty-backports/main i386 Packages       
Atteint http://th.archive.ubuntu.com trusty-backports/restricted i386 Packages 
Atteint http://extras.ubuntu.com trusty/main i386 Packages                     
Atteint http://th.archive.ubuntu.com trusty-backports/universe i386 Packages   
Atteint http://th.archive.ubuntu.com trusty-backports/multiverse i386 Packages 
Atteint http://th.archive.ubuntu.com trusty-backports/main Translation-en      
Atteint http://th.archive.ubuntu.com trusty-backports/multiverse Translation-en
Atteint http://th.archive.ubuntu.com trusty-backports/restricted Translation-en
Réception de : 9 http://ppa.launchpad.net trusty InRelease [20,9 kB]           
Atteint http://th.archive.ubuntu.com trusty-backports/universe Translation-en  
Atteint http://th.archive.ubuntu.com trusty Release                            
Atteint http://th.archive.ubuntu.com trusty/main amd64 Packages                
Atteint http://th.archive.ubuntu.com trusty/restricted amd64 Packages          
Atteint http://th.archive.ubuntu.com trusty/universe amd64 Packages            
Atteint http://th.archive.ubuntu.com trusty/multiverse amd64 Packages          
Atteint http://th.archive.ubuntu.com trusty/main i386 Packages                 
Atteint http://th.archive.ubuntu.com trusty/restricted i386 Packages           
Atteint http://th.archive.ubuntu.com trusty/universe i386 Packages             
Atteint http://th.archive.ubuntu.com trusty/multiverse i386 Packages           
Atteint http://th.archive.ubuntu.com trusty/main Translation-fr                
Réception de : 10 http://ppa.launchpad.net trusty InRelease [15,4 kB]          
Atteint http://th.archive.ubuntu.com trusty/main Translation-en                
Atteint http://th.archive.ubuntu.com trusty/multiverse Translation-fr          
Atteint http://th.archive.ubuntu.com trusty/multiverse Translation-en          
Atteint http://th.archive.ubuntu.com trusty/restricted Translation-fr          
Atteint http://th.archive.ubuntu.com trusty/restricted Translation-en          
Ign https://repo.skype.com stable/main Translation-fr_FR                       
Réception de : 11 http://ppa.launchpad.net trusty InRelease [15,4 kB]          
Ign https://repo.skype.com stable/main Translation-fr                          
Atteint http://th.archive.ubuntu.com trusty/universe Translation-fr            
Ign https://repo.skype.com stable/main Translation-en                          
Atteint http://th.archive.ubuntu.com trusty/universe Translation-en            
Ign http://ppa.launchpad.net trusty InRelease                                  
Ign http://th.archive.ubuntu.com trusty/main Translation-fr_FR                 
Ign http://th.archive.ubuntu.com trusty/multiverse Translation-fr_FR           
Ign http://ppa.launchpad.net trusty Release.gpg                                
Ign http://th.archive.ubuntu.com trusty/restricted Translation-fr_FR           
Ign http://th.archive.ubuntu.com trusty/universe Translation-fr_FR             
Atteint http://security.ubuntu.com trusty-security InRelease                   
Réception de : 12 http://ppa.launchpad.net trusty/main amd64 Packages [30,8 kB]
Atteint http://security.ubuntu.com trusty-security/main amd64 Packages         
Réception de : 13 http://ppa.launchpad.net trusty/main i386 Packages [30,8 kB] 
Atteint http://ppa.launchpad.net trusty/main Translation-en                    
Ign http://extras.ubuntu.com trusty/main Translation-fr_FR                     
Réception de : 14 http://ppa.launchpad.net trusty/main amd64 Packages [1 016 B]
Ign http://extras.ubuntu.com trusty/main Translation-fr                        
Réception de : 15 http://ppa.launchpad.net trusty/main i386 Packages [1 016 B] 
Ign http://extras.ubuntu.com trusty/main Translation-en                        
Réception de : 16 http://ppa.launchpad.net trusty/main Translation-en [802 B]  
Réception de : 17 http://ppa.launchpad.net trusty/main amd64 Packages [12,8 kB]
Réception de : 18 http://ppa.launchpad.net trusty/main i386 Packages [12,8 kB] 
Atteint http://ppa.launchpad.net trusty/main Translation-en                    
Réception de : 19 http://ppa.launchpad.net trusty/main amd64 Packages [3 693 B]
Réception de : 20 http://ppa.launchpad.net trusty/main i386 Packages [3 693 B] 
Réception de : 21 http://ppa.launchpad.net trusty/main Translation-en [1 683 B]
Réception de : 22 http://ppa.launchpad.net trusty/main amd64 Packages [8 316 B]
Réception de : 23 http://ppa.launchpad.net trusty/main i386 Packages [8 318 B] 
Atteint http://ppa.launchpad.net trusty/main Translation-en                    
Réception de : 24 http://ppa.launchpad.net trusty Release.gpg [316 B]          
Ign http://ppa.launchpad.net trusty Release                                    
Réception de : 25 http://archive.canonical.com trusty/partner amd64 Packages [5 374 B]
Réception de : 26 http://security.ubuntu.com trusty-security/restricted amd64 Packages [14,1 kB]
Réception de : 27 http://ppa.launchpad.net trusty Release [14,0 kB]            
Réception de : 28 http://archive.canonical.com trusty/partner i386 Packages [5 772 B]
Atteint http://security.ubuntu.com trusty-security/universe amd64 Packages     
Réception de : 29 http://archive.canonical.com trusty/partner Translation-en [4 207 B]
Ign http://ppa.launchpad.net trusty/main amd64 Packages/DiffIndex              
Réception de : 30 http://security.ubuntu.com trusty-security/multiverse amd64 Packages [4 803 B]
Ign http://ppa.launchpad.net trusty/main i386 Packages/DiffIndex               
Réception de : 31 http://security.ubuntu.com trusty-security/main i386 Packages [645 kB]
Réception de : 32 http://ppa.launchpad.net trusty/main amd64 Packages [989 B]  
Atteint http://security.ubuntu.com trusty-security/restricted i386 Packages    
Réception de : 33 http://ppa.launchpad.net trusty/main i386 Packages [993 B]   
Atteint http://security.ubuntu.com trusty-security/universe i386 Packages      
Atteint http://security.ubuntu.com trusty-security/multiverse i386 Packages    
Réception de : 34 http://security.ubuntu.com trusty-security/main Translation-en [379 kB]
Réception de : 35 http://security.ubuntu.com trusty-security/multiverse Translation-en [2 564 B]
Réception de : 36 http://security.ubuntu.com trusty-security/restricted Translation-en [3 546 B]
Réception de : 37 http://security.ubuntu.com trusty-security/universe Translation-en [113 kB]
Réception de : 38 http://cran.univ-lyon1.fr trusty/ InRelease                  
100% [38 InRelease gpgv 13 B] [Attente des fichiers d'en-tête]Splitting up /var/lib/apt/lists/partial/cran.univ-lyon1.fr_bin_linux_ubuntu_trusty_InRelease into Ign http://cran.univ-lyon1.fr trusty/ InRelease                
E: Erreur de GPG : http://cran.univ-lyon1.fr trusty/ InRelease : Le fichier signé en clair n'est pas valable, ce qui a été reçu est « NODATA ». Peut-être le réseau nécessite-t-il une authentification.
torvik@emmet:~$ sudo apt-get dist-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 linux-headers-generic-lts-xenial : Dépend: linux-headers-4.4.0-109-generic mais il n'est pas installé
E: Dépendances manquantes. Essayez d'utiliser l'option -f.
torvik@emmet:~$ ^C
torvik@emmet:~$ apt-get -f install
E: Impossible d'ouvrir le fichier verrou /var/lib/dpkg/lock - open (13: Permission non accordée)
E: Impossible de verrouiller le répertoire d'administration (/var/lib/dpkg/). Avez-vous les privilèges du superutilisateur ?
torvik@emmet:~$ sudo apt-get -f install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libasound2:i386 libasound2-plugins:i386 libasyncns0:i386 libaudio2:i386
  libavahi-client3:i386 libavahi-common-data:i386 libavahi-common3:i386
  libcups2:i386 libdbusmenu-qt2:i386 libflac8:i386 libfontconfig1:i386
  libfreetype6:i386 libgcrypt11:i386 libglib2.0-0:i386 libgnutls26:i386
  libgpg-error0:i386 libgssapi-krb5-2:i386 libgstreamer-plugins-base1.0-0:i386
  libgstreamer1.0-0:i386 libice6:i386 libjack-jackd2-0:i386 libjbig0:i386
  libjpeg-turbo8:i386 libjpeg8:i386 libk5crypto3:i386 libkeyutils1:i386
  libkrb5-3:i386 libkrb5support0:i386 libmysqlclient18:i386 libogg0:i386
  liborc-0.4-0:i386 libp11-kit0:i386 libpulse0:i386 libqt4-dbus:i386
  libqt4-declarative:i386 libqt4-network:i386 libqt4-opengl:i386
  libqt4-script:i386 libqt4-sql:i386 libqt4-sql-mysql:i386 libqt4-xml:i386
  libqt4-xmlpatterns:i386 libqtcore4:i386 libqtdbus4:i386 libqtgui4:i386
  libqtwebkit4:i386 libsamplerate0:i386 libsm6:i386 libsndfile1:i386
  libspeexdsp1:i386 libsqlite3-0:i386 libssl1.0.0:i386 libtasn1-6:i386
  libtiff5:i386 libvorbis0a:i386 libvorbisenc2:i386 libwrap0:i386 libxi6:i386
  libxml2:i386 libxrender1:i386 libxslt1.1:i386 libxss1:i386 libxt6:i386
  libxv1:i386 linux-image-4.4.0-98-generic linux-image-extra-4.4.0-98-generic
  linux-lts-xenial-tools-4.4.0-98 linux-tools-4.4.0-98-generic skype-bin:i386
  sni-qt:i386
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés : 
  linux-headers-4.4.0-109-generic
Les NOUVEAUX paquets suivants seront installés :
  linux-headers-4.4.0-109-generic
0 mis à jour, 1 nouvellement installés, 0 à enlever et 9 non mis à jour.
2 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/776 ko dans les archives.
Après cette opération, 15,5 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] 
(Lecture de la base de données... 1199174 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../linux-headers-4.4.0-109-generic_4.4.0-109.132~14.04.1_amd64.deb ...
Dépaquetage de linux-headers-4.4.0-109-generic (4.4.0-109.132~14.04.1) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/linux-headers-4.4.0-109-generic_4.4.0-109.132~14.04.1_amd64.deb (--unpack) :
 erreur pendant la création du répertoire « ./usr/src/linux-headers-4.4.0-109-generic/include/config/snd/soc/intel/cht/bsw »: Aucun espace disponible sur le périphérique
Aucun rapport « apport » n'a été créé car un disque plein a été signalé
                                                                       dpkg-deb : erreur : le sous-processus coller a été tué par le signal (Relais brisé (pipe))
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/linux-headers-4.4.0-109-generic_4.4.0-109.132~14.04.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Dernière modification par emmet grogan (Le 18/01/2018, à 17:40)

Hors ligne

#2 Le 15/01/2018, à 14:07

cqfd93

Re : [résolu] problème mise à jour / espace insuffisant

Bonjour,

Donne les retours de ces commandes :

cat /etc/issue
uname -a
echo "${XDG_CURRENT_DESKTOP}"

et de :

df -Th | grep -Ev "devpts|none|proc|sys|tmpfs|udev"; echo ; df -Ti | grep -Ev "devpts|none|proc|sys|tmpfs|udev"
dpkg -l | grep -Ei "linux-(g|h|i|lo|si|t)" | sort -k3 | tr -s " " | cut -d" " -s -f1,2,3 | column -s" " -t
ls -sS1 /boot

cqfd93

En ligne

#3 Le 15/01/2018, à 14:11

emmet grogan

Re : [résolu] problème mise à jour / espace insuffisant

voici

torvik@emmet:~$ cat /etc/issue
Ubuntu 14.04.5 LTS \n \l

torvik@emmet:~$ uname -a
Linux emmet 4.4.0-109-generic #132~14.04.1-Ubuntu SMP Tue Jan 9 21:46:42 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
torvik@emmet:~$ echo "${XDG_CURRENT_DESKTOP}"
XFCE
torvik@emmet:~$ df -Th | grep -Ev "devpts|none|proc|sys|tmpfs|udev"; echo ; df -Ti | grep -Ev "devpts|none|proc|sys|tmpfs|udev"
Sys. de fichiers Type     Taille Utilisé Dispo Uti% Monté sur
/dev/sda1        ext4        19G     17G  533M  97% /
/dev/sda3        ext4       891G    570G  276G  68% /home

Sys. de fichiers Type       Inœuds  IUtil.   ILibre IUti% Monté sur
/dev/sda1        ext4      1222992 1220621     2371  100% /
/dev/sda3        ext4     59285504  269683 59015821    1% /home
torvik@emmet:~$ dpkg -l | grep -Ei "linux-(g|h|i|lo|si|t)" | sort -k3 | tr -s " " | cut -d" " -s -f1,2,3 | column -s" " -t
ii  linux-tools-common                   3.13.0-139.188
ii  linux-headers-4.2.0-27               4.2.0-27.32~14.04.1
rc  linux-image-extra-4.2.0-27-generic   4.2.0-27.32~14.04.1
ii  linux-headers-4.2.0-27-generic       4.2.0-27.32~14.04.1
rc  linux-image-4.2.0-27-generic         4.2.0-27.32~14.04.1
ii  linux-headers-4.2.0-36               4.2.0-36.42~14.04.1
rc  linux-image-extra-4.2.0-36-generic   4.2.0-36.42~14.04.1
ii  linux-headers-4.2.0-36-generic       4.2.0-36.42~14.04.1
rc  linux-image-4.2.0-36-generic         4.2.0-36.42~14.04.1
ii  linux-headers-4.2.0-38               4.2.0-38.45~14.04.1
ii  linux-image-extra-4.2.0-38-generic   4.2.0-38.45~14.04.1
ii  linux-headers-4.2.0-38-generic       4.2.0-38.45~14.04.1
ii  linux-image-4.2.0-38-generic         4.2.0-38.45~14.04.1
ii  linux-headers-4.2.0-41               4.2.0-41.48~14.04.1
rc  linux-image-extra-4.2.0-41-generic   4.2.0-41.48~14.04.1
ii  linux-headers-4.2.0-41-generic       4.2.0-41.48~14.04.1
rc  linux-image-4.2.0-41-generic         4.2.0-41.48~14.04.1
ii  linux-generic-lts-wily               4.2.0.42.34
ii  linux-headers-generic-lts-wily       4.2.0.42.34
ii  linux-image-generic-lts-wily         4.2.0.42.34
ii  linux-headers-4.2.0-42               4.2.0-42.49~14.04.1
ii  linux-image-extra-4.2.0-42-generic   4.2.0-42.49~14.04.1
ii  linux-headers-4.2.0-42-generic       4.2.0-42.49~14.04.1
ii  linux-image-4.2.0-42-generic         4.2.0-42.49~14.04.1
ii  linux-headers-4.4.0-101              4.4.0-101.124~14.04.1
ii  linux-image-extra-4.4.0-101-generic  4.4.0-101.124~14.04.1
ii  linux-headers-4.4.0-101-generic      4.4.0-101.124~14.04.1
ii  linux-image-4.4.0-101-generic        4.4.0-101.124~14.04.1
ii  linux-tools-4.4.0-101-generic        4.4.0-101.124~14.04.1
ii  linux-headers-4.4.0-103              4.4.0-103.126~14.04.1
ii  linux-image-extra-4.4.0-103-generic  4.4.0-103.126~14.04.1
ii  linux-headers-4.4.0-103-generic      4.4.0-103.126~14.04.1
ii  linux-image-4.4.0-103-generic        4.4.0-103.126~14.04.1
ii  linux-tools-4.4.0-103-generic        4.4.0-103.126~14.04.1
ii  linux-headers-4.4.0-104              4.4.0-104.127~14.04.1
ii  linux-image-extra-4.4.0-104-generic  4.4.0-104.127~14.04.1
ii  linux-headers-4.4.0-104-generic      4.4.0-104.127~14.04.1
ii  linux-image-4.4.0-104-generic        4.4.0-104.127~14.04.1
ii  linux-tools-4.4.0-104-generic        4.4.0-104.127~14.04.1
ii  linux-headers-4.4.0-109              4.4.0-109.132~14.04.1
ii  linux-image-extra-4.4.0-109-generic  4.4.0-109.132~14.04.1
ii  linux-image-4.4.0-109-generic        4.4.0-109.132~14.04.1
ii  linux-tools-4.4.0-109-generic        4.4.0-109.132~14.04.1
iU  linux-generic-lts-xenial             4.4.0.109.92
iU  linux-headers-generic-lts-xenial     4.4.0.109.92
ii  linux-image-generic-lts-xenial       4.4.0.109.92
ii  linux-tools-virtual-lts-xenial       4.4.0.109.92
ii  linux-tools-4.4.0-24-generic         4.4.0-24.43~14.04.1
ii  linux-tools-4.4.0-31-generic         4.4.0-31.50~14.04.1
ii  linux-headers-4.4.0-34               4.4.0-34.53~14.04.1
rc  linux-image-extra-4.4.0-34-generic   4.4.0-34.53~14.04.1
ii  linux-headers-4.4.0-34-generic       4.4.0-34.53~14.04.1
rc  linux-image-4.4.0-34-generic         4.4.0-34.53~14.04.1
ii  linux-tools-4.4.0-34-generic         4.4.0-34.53~14.04.1
ii  linux-headers-4.4.0-36               4.4.0-36.55~14.04.1
ii  linux-image-extra-4.4.0-36-generic   4.4.0-36.55~14.04.1
ii  linux-headers-4.4.0-36-generic       4.4.0-36.55~14.04.1
ii  linux-image-4.4.0-36-generic         4.4.0-36.55~14.04.1
ii  linux-tools-4.4.0-36-generic         4.4.0-36.55~14.04.1
ii  linux-headers-4.4.0-38               4.4.0-38.57~14.04.1
ii  linux-image-extra-4.4.0-38-generic   4.4.0-38.57~14.04.1
ii  linux-headers-4.4.0-38-generic       4.4.0-38.57~14.04.1
ii  linux-image-4.4.0-38-generic         4.4.0-38.57~14.04.1
ii  linux-tools-4.4.0-38-generic         4.4.0-38.57~14.04.1
ii  linux-headers-4.4.0-42               4.4.0-42.62~14.04.1
ii  linux-image-extra-4.4.0-42-generic   4.4.0-42.62~14.04.1
ii  linux-headers-4.4.0-42-generic       4.4.0-42.62~14.04.1
ii  linux-image-4.4.0-42-generic         4.4.0-42.62~14.04.1
ii  linux-tools-4.4.0-42-generic         4.4.0-42.62~14.04.1
ii  linux-headers-4.4.0-45               4.4.0-45.66~14.04.1
rc  linux-image-extra-4.4.0-45-generic   4.4.0-45.66~14.04.1
ii  linux-headers-4.4.0-45-generic       4.4.0-45.66~14.04.1
rc  linux-image-4.4.0-45-generic         4.4.0-45.66~14.04.1
ii  linux-headers-4.4.0-47               4.4.0-47.68~14.04.1
rc  linux-image-extra-4.4.0-47-generic   4.4.0-47.68~14.04.1
ii  linux-headers-4.4.0-47-generic       4.4.0-47.68~14.04.1
rc  linux-image-4.4.0-47-generic         4.4.0-47.68~14.04.1
ii  linux-headers-4.4.0-53               4.4.0-53.74~14.04.1
ii  linux-image-extra-4.4.0-53-generic   4.4.0-53.74~14.04.1
ii  linux-headers-4.4.0-53-generic       4.4.0-53.74~14.04.1
ii  linux-image-4.4.0-53-generic         4.4.0-53.74~14.04.1
ii  linux-tools-4.4.0-53-generic         4.4.0-53.74~14.04.1
ii  linux-headers-4.4.0-57               4.4.0-57.78~14.04.1
ii  linux-image-extra-4.4.0-57-generic   4.4.0-57.78~14.04.1
ii  linux-headers-4.4.0-57-generic       4.4.0-57.78~14.04.1
ii  linux-image-4.4.0-57-generic         4.4.0-57.78~14.04.1
ii  linux-tools-4.4.0-57-generic         4.4.0-57.78~14.04.1
ii  linux-headers-4.4.0-59               4.4.0-59.80~14.04.1
ii  linux-image-extra-4.4.0-59-generic   4.4.0-59.80~14.04.1
ii  linux-headers-4.4.0-59-generic       4.4.0-59.80~14.04.1
ii  linux-image-4.4.0-59-generic         4.4.0-59.80~14.04.1
ii  linux-tools-4.4.0-59-generic         4.4.0-59.80~14.04.1
ii  linux-headers-4.4.0-66               4.4.0-66.87~14.04.1
rc  linux-image-extra-4.4.0-66-generic   4.4.0-66.87~14.04.1
ii  linux-headers-4.4.0-66-generic       4.4.0-66.87~14.04.1
rc  linux-image-4.4.0-66-generic         4.4.0-66.87~14.04.1
ii  linux-headers-4.4.0-70               4.4.0-70.91~14.04.1
rc  linux-image-extra-4.4.0-70-generic   4.4.0-70.91~14.04.1
ii  linux-headers-4.4.0-70-generic       4.4.0-70.91~14.04.1
rc  linux-image-4.4.0-70-generic         4.4.0-70.91~14.04.1
ii  linux-headers-4.4.0-71               4.4.0-71.92~14.04.1
ii  linux-image-extra-4.4.0-71-generic   4.4.0-71.92~14.04.1
ii  linux-headers-4.4.0-71-generic       4.4.0-71.92~14.04.1
ii  linux-image-4.4.0-71-generic         4.4.0-71.92~14.04.1
ii  linux-tools-4.4.0-71-generic         4.4.0-71.92~14.04.1
ii  linux-headers-4.4.0-72               4.4.0-72.93~14.04.1
rc  linux-image-extra-4.4.0-72-generic   4.4.0-72.93~14.04.1
ii  linux-headers-4.4.0-72-generic       4.4.0-72.93~14.04.1
rc  linux-image-4.4.0-72-generic         4.4.0-72.93~14.04.1
ii  linux-headers-4.4.0-75               4.4.0-75.96~14.04.1
ii  linux-image-extra-4.4.0-75-generic   4.4.0-75.96~14.04.1
ii  linux-headers-4.4.0-75-generic       4.4.0-75.96~14.04.1
ii  linux-image-4.4.0-75-generic         4.4.0-75.96~14.04.1
ii  linux-tools-4.4.0-75-generic         4.4.0-75.96~14.04.1
ii  linux-headers-4.4.0-78               4.4.0-78.99~14.04.2
ii  linux-image-extra-4.4.0-78-generic   4.4.0-78.99~14.04.2
ii  linux-headers-4.4.0-78-generic       4.4.0-78.99~14.04.2
ii  linux-image-4.4.0-78-generic         4.4.0-78.99~14.04.2
ii  linux-tools-4.4.0-78-generic         4.4.0-78.99~14.04.2
ii  linux-headers-4.4.0-81               4.4.0-81.104~14.04.1
ii  linux-image-extra-4.4.0-81-generic   4.4.0-81.104~14.04.1
ii  linux-headers-4.4.0-81-generic       4.4.0-81.104~14.04.1
ii  linux-image-4.4.0-81-generic         4.4.0-81.104~14.04.1
ii  linux-tools-4.4.0-81-generic         4.4.0-81.104~14.04.1
ii  linux-headers-4.4.0-83               4.4.0-83.106~14.04.1
ii  linux-image-extra-4.4.0-83-generic   4.4.0-83.106~14.04.1
ii  linux-headers-4.4.0-83-generic       4.4.0-83.106~14.04.1
ii  linux-image-4.4.0-83-generic         4.4.0-83.106~14.04.1
ii  linux-tools-4.4.0-83-generic         4.4.0-83.106~14.04.1
ii  linux-headers-4.4.0-87               4.4.0-87.110~14.04.1
ii  linux-image-extra-4.4.0-87-generic   4.4.0-87.110~14.04.1
ii  linux-headers-4.4.0-87-generic       4.4.0-87.110~14.04.1
ii  linux-image-4.4.0-87-generic         4.4.0-87.110~14.04.1
ii  linux-tools-4.4.0-87-generic         4.4.0-87.110~14.04.1
ii  linux-headers-4.4.0-89               4.4.0-89.112~14.04.1
ii  linux-image-extra-4.4.0-89-generic   4.4.0-89.112~14.04.1
ii  linux-headers-4.4.0-89-generic       4.4.0-89.112~14.04.1
ii  linux-image-4.4.0-89-generic         4.4.0-89.112~14.04.1
ii  linux-tools-4.4.0-89-generic         4.4.0-89.112~14.04.1
ii  linux-headers-4.4.0-93               4.4.0-93.116~14.04.1
rc  linux-image-extra-4.4.0-93-generic   4.4.0-93.116~14.04.1
ii  linux-headers-4.4.0-93-generic       4.4.0-93.116~14.04.1
rc  linux-image-4.4.0-93-generic         4.4.0-93.116~14.04.1
ii  linux-headers-4.4.0-96               4.4.0-96.119~14.04.1
ii  linux-image-extra-4.4.0-96-generic   4.4.0-96.119~14.04.1
ii  linux-headers-4.4.0-96-generic       4.4.0-96.119~14.04.1
ii  linux-image-4.4.0-96-generic         4.4.0-96.119~14.04.1
ii  linux-tools-4.4.0-96-generic         4.4.0-96.119~14.04.1
ii  linux-headers-4.4.0-97               4.4.0-97.120~14.04.1
ii  linux-image-extra-4.4.0-97-generic   4.4.0-97.120~14.04.1
ii  linux-headers-4.4.0-97-generic       4.4.0-97.120~14.04.1
ii  linux-image-4.4.0-97-generic         4.4.0-97.120~14.04.1
ii  linux-tools-4.4.0-97-generic         4.4.0-97.120~14.04.1
ii  linux-headers-4.4.0-98               4.4.0-98.121~14.04.1
ii  linux-image-extra-4.4.0-98-generic   4.4.0-98.121~14.04.1
ii  linux-headers-4.4.0-98-generic       4.4.0-98.121~14.04.1
ii  linux-image-4.4.0-98-generic         4.4.0-98.121~14.04.1
ii  linux-tools-4.4.0-98-generic         4.4.0-98.121~14.04.1
torvik@emmet:~$ ls -sS1 /boot
total 744764
21884 initrd.img-4.4.0-96-generic
21884 initrd.img-4.4.0-109-generic
21880 initrd.img-4.4.0-103-generic
21884 initrd.img-4.4.0-97-generic
21884 initrd.img-4.4.0-98-generic
21880 initrd.img-4.4.0-104-generic
21880 initrd.img-4.4.0-101-generic
21808 initrd.img-4.4.0-89-generic
21800 initrd.img-4.4.0-71-generic
21800 initrd.img-4.4.0-87-generic
21800 initrd.img-4.4.0-78-generic
21804 initrd.img-4.4.0-75-generic
21800 initrd.img-4.4.0-81-generic
21800 initrd.img-4.4.0-83-generic
21796 initrd.img-4.4.0-57-generic
21796 initrd.img-4.4.0-59-generic
21788 initrd.img-4.4.0-53-generic
21744 initrd.img-4.4.0-42-generic
21344 initrd.img-4.4.0-36-generic
21344 initrd.img-4.4.0-38-generic
20876 initrd.img-4.2.0-38-generic
20872 initrd.img-4.2.0-42-generic
 6852 vmlinuz-4.4.0-109-generic
 6844 vmlinuz-4.4.0-104-generic
 6844 vmlinuz-4.4.0-103-generic
 6844 vmlinuz-4.4.0-98-generic
 6844 vmlinuz-4.4.0-101-generic
 6844 vmlinuz-4.4.0-97-generic
 6840 vmlinuz-4.4.0-96-generic
 6840 vmlinuz-4.4.0-89-generic
 6836 vmlinuz-4.4.0-87-generic
 6836 vmlinuz-4.4.0-81-generic
 6836 vmlinuz-4.4.0-83-generic
 6832 vmlinuz-4.4.0-78-generic
 6824 vmlinuz-4.4.0-75-generic
 6824 vmlinuz-4.4.0-71-generic
 6808 vmlinuz-4.4.0-59-generic
 6808 vmlinuz-4.4.0-57-generic
 6804 vmlinuz-4.4.0-53-generic
 6788 vmlinuz-4.4.0-42-generic
 6788 vmlinuz-4.4.0-38-generic
 6780 vmlinuz-4.4.0-36-generic
 6580 vmlinuz-4.2.0-42-generic
 6576 vmlinuz-4.2.0-38-generic
 3816 System.map-4.4.0-109-generic
 3812 System.map-4.4.0-103-generic
 3812 System.map-4.4.0-104-generic
 3812 System.map-4.4.0-101-generic
 3812 System.map-4.4.0-98-generic
 3812 System.map-4.4.0-96-generic
 3812 System.map-4.4.0-97-generic
 3808 System.map-4.4.0-89-generic
 3808 System.map-4.4.0-87-generic
 3808 System.map-4.4.0-83-generic
 3808 System.map-4.4.0-75-generic
 3808 System.map-4.4.0-81-generic
 3808 System.map-4.4.0-78-generic
 3808 System.map-4.4.0-71-generic
 3800 System.map-4.4.0-59-generic
 3800 System.map-4.4.0-57-generic
 3800 System.map-4.4.0-53-generic
 3792 System.map-4.4.0-42-generic
 3792 System.map-4.4.0-38-generic
 3792 System.map-4.4.0-36-generic
 3672 System.map-4.2.0-42-generic
 3672 System.map-4.2.0-38-generic
 2668 initrd.img-4.2.0-36-generic
 1284 abi-4.2.0-42-generic
 1284 abi-4.2.0-38-generic
 1228 abi-4.4.0-109-generic
 1220 abi-4.4.0-98-generic
 1220 abi-4.4.0-101-generic
 1220 abi-4.4.0-103-generic
 1220 abi-4.4.0-104-generic
 1220 abi-4.4.0-96-generic
 1220 abi-4.4.0-97-generic
 1220 abi-4.4.0-89-generic
 1220 abi-4.4.0-87-generic
 1220 abi-4.4.0-83-generic
 1220 abi-4.4.0-78-generic
 1220 abi-4.4.0-81-generic
 1220 abi-4.4.0-75-generic
 1220 abi-4.4.0-71-generic
 1216 abi-4.4.0-59-generic
 1216 abi-4.4.0-57-generic
 1216 abi-4.4.0-53-generic
 1216 abi-4.4.0-42-generic
 1216 abi-4.4.0-38-generic
 1216 abi-4.4.0-36-generic
  188 config-4.4.0-109-generic
  188 config-4.4.0-103-generic
  188 config-4.4.0-104-generic
  188 config-4.4.0-96-generic
  188 config-4.4.0-97-generic
  188 config-4.4.0-98-generic
  188 config-4.4.0-101-generic
  188 config-4.4.0-81-generic
  188 config-4.4.0-83-generic
  188 config-4.4.0-87-generic
  188 config-4.4.0-89-generic
  188 config-4.4.0-78-generic
  188 config-4.4.0-71-generic
  188 config-4.4.0-75-generic
  188 config-4.4.0-59-generic
  188 config-4.4.0-57-generic
  188 config-4.4.0-53-generic
  188 config-4.4.0-42-generic
  188 config-4.4.0-38-generic
  188 config-4.4.0-36-generic
  184 config-4.2.0-42-generic
  184 config-4.2.0-38-generic
  176 memtest86+_multiboot.bin
  176 memtest86+.elf
  176 memtest86+.bin
    4 grub

Hors ligne

#4 Le 16/01/2018, à 03:52

emmet grogan

Re : [résolu] problème mise à jour / espace insuffisant

Bonjour,
Quelle est l'étape suivante ?
Merci,
E.G.

Hors ligne

#5 Le 16/01/2018, à 04:12

Roschan

Re : [résolu] problème mise à jour / espace insuffisant

Déjà,

sudo apt-get autoremove

, comme c'est très clairement indiqué par les retours des toutes premières commandes que tu as posté.

Ensuite, il faudra virer les vieux noyaux, quelqu'un te donnera sans doute une commande adaptée à cela, mais ça ne réglera pas tout :
tes mises à jours ne se font pas car sont interrompues par des erreurs, sans doute liées à ta liste de dépôts anarchique.
Pourrais-tu donner le résultat de

cat /etc/apt/sources.list

et

ls /etc/apt/sources.list.d/

?

Hors ligne

#6 Le 16/01/2018, à 10:43

cqfd93

Re : [résolu] problème mise à jour / espace insuffisant

Bonjour,

Tiens c'est curieux, je n'avais pas vu ta réponse d'hier.

Voila des commandes qui vont libérer un peu de place et débloquer apt :

sudo dpkg -P linux-headers-4.2.0-27 linux-image-extra-4.2.0-27-generic linux-headers-4.2.0-27-generic linux-image-4.2.0-27-generic
sudo dpkg -P linux-headers-4.2.0-36 linux-image-extra-4.2.0-36-generic linux-headers-4.2.0-36-generic linux-image-4.2.0-36-generic
sudo dpkg -P linux-headers-4.2.0-38 linux-image-extra-4.2.0-38-generic linux-headers-4.2.0-38-generic linux-image-4.2.0-38-generic
sudo dpkg -P linux-headers-4.2.0-41 linux-image-extra-4.2.0-41-generic linux-headers-4.2.0-41-generic linux-image-4.2.0-41-generic
sudo dpkg -P linux-generic-lts-wily linux-headers-generic-lts-wily linux-image-generic-lts-wily
sudo apt-get install -f

Et si ça s'est bien passé, tu peux faire :

sudo apt-get clean
[[ $(apt-mark showmanual | egrep 'linux-.*[0-9]') ]] && sudo apt-mark auto $(apt-mark showmanual | egrep linux-.*[0-9])
sudo apt-get autoremove
dpkg -l | grep ^rc | cut -d' ' -f3 | xargs sudo dpkg --purge

Et enfin vérification du résultat :

df -Th | grep -Ev "devpts|none|proc|sys|tmpfs|udev"; echo ; df -Ti | grep -Ev "devpts|none|proc|sys|tmpfs|udev"
dpkg -l | grep -Ei "linux-(g|h|i|lo|si|t)" | sort -k3 | tr -s " " | cut -d" " -s -f1,2,3 | column -s" " -t
ls -sS1 /boot

cqfd93

En ligne

#7 Le 16/01/2018, à 15:26

emmet grogan

Re : [résolu] problème mise à jour / espace insuffisant

Bonjour Roschan et cqfd93,
La commande autoremove renvoyait:

torvik@emmet:~$ sudo apt-get autoremove
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 linux-headers-generic-lts-xenial : Dépend: linux-headers-4.4.0-109-generic mais il n'est pas installé
E: Dépendances manquantes. Essayez d'utiliser l'option -f.

J'ai passé les commandes indquées par cqfd93, voici le résultat:

torvik@emmet:~$ df -Th | grep -Ev "devpts|none|proc|sys|tmpfs|udev"; echo ; df -Ti | grep -Ev "devpts|none|proc|sys|tmpfs|udev"
Sys. de fichiers Type     Taille Utilisé Dispo Uti% Monté sur
/dev/sda1        ext4        19G     11G  6,6G  62% /
/dev/sda3        ext4       891G    570G  276G  68% /home

Sys. de fichiers Type       Inœuds  IUtil.   ILibre IUti% Monté sur
/dev/sda1        ext4      1222992 1008089   214903   83% /
/dev/sda3        ext4     59285504  269947 59015557    1% /home
torvik@emmet:~$ dpkg -l | grep -Ei "linux-(g|h|i|lo|si|t)" | sort -k3 | tr -s " " | cut -d" " -s -f1,2,3 | column -s" " -t
ii  linux-tools-common                   3.13.0-139.188
ii  linux-headers-4.2.0-42               4.2.0-42.49~14.04.1
ii  linux-headers-4.2.0-42-generic       4.2.0-42.49~14.04.1
ii  linux-headers-4.4.0-101              4.4.0-101.124~14.04.1
ii  linux-headers-4.4.0-101-generic      4.4.0-101.124~14.04.1
ii  linux-headers-4.4.0-103              4.4.0-103.126~14.04.1
ii  linux-headers-4.4.0-103-generic      4.4.0-103.126~14.04.1
ii  linux-headers-4.4.0-104              4.4.0-104.127~14.04.1
ii  linux-headers-4.4.0-104-generic      4.4.0-104.127~14.04.1
ii  linux-headers-4.4.0-109              4.4.0-109.132~14.04.1
ii  linux-image-extra-4.4.0-109-generic  4.4.0-109.132~14.04.1
ii  linux-headers-4.4.0-109-generic      4.4.0-109.132~14.04.1
ii  linux-image-4.4.0-109-generic        4.4.0-109.132~14.04.1
ii  linux-tools-4.4.0-109-generic        4.4.0-109.132~14.04.1
ii  linux-generic-lts-xenial             4.4.0.109.92
ii  linux-headers-generic-lts-xenial     4.4.0.109.92
ii  linux-image-generic-lts-xenial       4.4.0.109.92
ii  linux-tools-virtual-lts-xenial       4.4.0.109.92
ii  linux-headers-4.4.0-34               4.4.0-34.53~14.04.1
ii  linux-headers-4.4.0-34-generic       4.4.0-34.53~14.04.1
ii  linux-headers-4.4.0-36               4.4.0-36.55~14.04.1
ii  linux-headers-4.4.0-36-generic       4.4.0-36.55~14.04.1
ii  linux-headers-4.4.0-38               4.4.0-38.57~14.04.1
ii  linux-headers-4.4.0-38-generic       4.4.0-38.57~14.04.1
ii  linux-headers-4.4.0-42               4.4.0-42.62~14.04.1
ii  linux-headers-4.4.0-42-generic       4.4.0-42.62~14.04.1
ii  linux-headers-4.4.0-45               4.4.0-45.66~14.04.1
ii  linux-headers-4.4.0-45-generic       4.4.0-45.66~14.04.1
ii  linux-headers-4.4.0-47               4.4.0-47.68~14.04.1
ii  linux-headers-4.4.0-47-generic       4.4.0-47.68~14.04.1
ii  linux-headers-4.4.0-53               4.4.0-53.74~14.04.1
ii  linux-headers-4.4.0-53-generic       4.4.0-53.74~14.04.1
ii  linux-headers-4.4.0-57               4.4.0-57.78~14.04.1
ii  linux-headers-4.4.0-57-generic       4.4.0-57.78~14.04.1
ii  linux-headers-4.4.0-59               4.4.0-59.80~14.04.1
ii  linux-headers-4.4.0-59-generic       4.4.0-59.80~14.04.1
ii  linux-headers-4.4.0-66               4.4.0-66.87~14.04.1
ii  linux-headers-4.4.0-66-generic       4.4.0-66.87~14.04.1
ii  linux-headers-4.4.0-70               4.4.0-70.91~14.04.1
ii  linux-headers-4.4.0-70-generic       4.4.0-70.91~14.04.1
ii  linux-headers-4.4.0-71               4.4.0-71.92~14.04.1
ii  linux-headers-4.4.0-71-generic       4.4.0-71.92~14.04.1
ii  linux-headers-4.4.0-72               4.4.0-72.93~14.04.1
ii  linux-headers-4.4.0-72-generic       4.4.0-72.93~14.04.1
ii  linux-headers-4.4.0-75               4.4.0-75.96~14.04.1
ii  linux-headers-4.4.0-75-generic       4.4.0-75.96~14.04.1
ii  linux-headers-4.4.0-78               4.4.0-78.99~14.04.2
ii  linux-headers-4.4.0-78-generic       4.4.0-78.99~14.04.2
ii  linux-headers-4.4.0-81               4.4.0-81.104~14.04.1
ii  linux-headers-4.4.0-81-generic       4.4.0-81.104~14.04.1
ii  linux-headers-4.4.0-83               4.4.0-83.106~14.04.1
ii  linux-headers-4.4.0-83-generic       4.4.0-83.106~14.04.1
ii  linux-headers-4.4.0-87               4.4.0-87.110~14.04.1
ii  linux-headers-4.4.0-87-generic       4.4.0-87.110~14.04.1
ii  linux-headers-4.4.0-89               4.4.0-89.112~14.04.1
ii  linux-headers-4.4.0-89-generic       4.4.0-89.112~14.04.1
ii  linux-headers-4.4.0-93               4.4.0-93.116~14.04.1
ii  linux-headers-4.4.0-93-generic       4.4.0-93.116~14.04.1
ii  linux-headers-4.4.0-96               4.4.0-96.119~14.04.1
ii  linux-headers-4.4.0-96-generic       4.4.0-96.119~14.04.1
ii  linux-headers-4.4.0-97               4.4.0-97.120~14.04.1
ii  linux-headers-4.4.0-97-generic       4.4.0-97.120~14.04.1
ii  linux-headers-4.4.0-98               4.4.0-98.121~14.04.1
ii  linux-headers-4.4.0-98-generic       4.4.0-98.121~14.04.1
torvik@emmet:~$ ls -sS1 /boot
total 37168
21884 initrd.img-4.4.0-109-generic
 6852 vmlinuz-4.4.0-109-generic
 3816 System.map-4.4.0-109-generic
 2668 initrd.img-4.2.0-36-generic
 1228 abi-4.4.0-109-generic
  188 config-4.4.0-109-generic
  176 memtest86+_multiboot.bin
  176 memtest86+.elf
  176 memtest86+.bin
    4 grub 

Le résultat des commandes indiquées par Roschan est:

torvik@emmet:~$ cat /etc/apt/sources.list
# deb cdrom:[Xubuntu 14.04.4 LTS _Trusty Tahr_ - Release amd64 (20160217.1)]/ trusty main multiverse restricted universe

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://th.archive.ubuntu.com/ubuntu/ trusty main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://th.archive.ubuntu.com/ubuntu/ trusty-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://th.archive.ubuntu.com/ubuntu/ trusty universe
deb http://th.archive.ubuntu.com/ubuntu/ trusty-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://th.archive.ubuntu.com/ubuntu/ trusty multiverse
deb http://th.archive.ubuntu.com/ubuntu/ trusty-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://th.archive.ubuntu.com/ubuntu/ trusty-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu trusty-security main restricted
deb http://security.ubuntu.com/ubuntu trusty-security universe
deb http://security.ubuntu.com/ubuntu trusty-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu trusty partner
deb-src http://archive.canonical.com/ubuntu trusty partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu trusty main
deb-src http://extras.ubuntu.com/ubuntu trusty main
deb http://cran.univ-lyon1.fr/bin/linux/ubuntu trusty/
# deb-src http://cran.univ-lyon1.fr/bin/linux/ubuntu trusty/
deb http://download.ebz.epson.net/dsc/op/stable/debian/ lsb3.2 main
torvik@emmet:~$ ls /etc/apt/sources.list.d/
kilian-f_lux-trusty.list
libreoffice-ppa-trusty.list
libreoffice-ppa-trusty.list.save
linrunner-tlp-trusty.list
linrunner-tlp-trusty.list.save
mozillateam-firefox-next-trusty.list
mozillateam-firefox-next-trusty.list.save
numix-ppa-trusty.list
numix-ppa-trusty.list.save
otto-kesselgulasch-gimp-trusty.list
otto-kesselgulasch-gimp-trusty.list.save
skype-stable.list
synapse-core-ppa-trusty.list
synapse-core-ppa-trusty.list.save
virtualbox.list
virtualbox.list.save

Merci pour votre aide.

Hors ligne

#8 Le 16/01/2018, à 16:01

cqfd93

Re : [résolu] problème mise à jour / espace insuffisant

J'aurais bien aimé voir les retours complets des commandes dpkg et apt--get install -f mais maintenant c'est trop tard et apparemment ça s'est bien passé.

Pour la deuxième série de commandes, il semblerait que l'autoremove n'ait pas marché (je crois que ça ne marche bien qu'à partir de 16.04 - xenial). Alors comme il y a beaucoup de noyaux à supprimer, on va avoir recours au script kclean (une valeur sûre !).

  • Tu as déjà installé kclean ? Sinon, c'est . Si tu cliques sur le lien .deb, ça doit s'installer, habituellement avec la logithèque.

  • Ensuite, tu peux le lancer avec la commande :

    sudo kclean -k
  • Il va te montrer la liste des noyaux qu'il va supprimer et te demander :

     Voulez vous indiquer manuellement des paquets à conserver ? [o/N] :

    Tu réponds n

  • Ensuite :

     Voulez vous supprimer l'ensemble des paquets indiqués ? [o/N] :

    Tu réponds o

  • Après ça, on regarde le résultat :

    df -Th | grep -Ev "devpts|none|proc|sys|tmpfs|udev"; echo ; df -Ti | grep -Ev "devpts|none|proc|sys|tmpfs|udev"
    dpkg -l | grep -Ei "linux-(g|h|i|lo|si|t)" | sort -k3 | tr -s " " | cut -d" " -s -f1,2,3 | column -s" " -t
    ls -sS1 /boot

cqfd93

En ligne

#9 Le 16/01/2018, à 17:05

moko138

Re : [résolu] problème mise à jour / espace insuffisant

Bigre !
dans /boot les fichiers de 2 noyaux seulement, pour 29 noyaux installés.
  On dirait qu'un ménage manuel sauvage a été pratiqué.

Or déjà dans ce message du 20/6/2016  ./viewtopic.php?pid=21541984#p21541984 tu avais
dans /boot, les fichiers d'un seul noyau (le 4.2.0-38), pour 5 noyaux installés, complètement ou non.
  Là encore, on dirait qu'un ménage manuel sauvage avait été pratiqué.


Comme tu as bientôt cinq ans d'ancienneté, il serait temps que tu arrêtes de fabriquer tes problèmes et d'appeler au secours, alors que la Doc (kernel §"Suppression des anciens noyaux", par exemple) est là pour t'informer. Et qu'elle répond à ta question initiale sur :

la procédure à suivre pour résoudre ce problème ?


%NOINDEX%
Un utilitaire précieux : ncdu
Photo, mini-tutoriel :  À la découverte de dcraw

En ligne

#10 Le 16/01/2018, à 18:46

emmet grogan

Re : [résolu] problème mise à jour / espace insuffisant

Autant pour moi ... J'obtiens ce résultat:

torvik@emmet:~$ sudo kclean -k
[sudo] password for torvik: 
 
Noyau actuellement en cours d'utilisation : 4.4.0-109
Par défaut, seul ce noyau est conservé.
 
Ce script va tenter de trouver la version précédente du noyau pour la conserver.
Verifiez les informations fournies avant de valider la suppression.
 
Aucune version précédente trouvée, il n'y a donc rien à supprimer.
Abandon.

torvik@emmet:~$ sudo kclean -k
[sudo] password for torvik: 
 
Noyau actuellement en cours d'utilisation : 4.4.0-109
Par défaut, seul ce noyau est conservé.
 
Ce script va tenter de trouver la version précédente du noyau pour la conserver.
Verifiez les informations fournies avant de valider la suppression.
 
Aucune version précédente trouvée, il n'y a donc rien à supprimer.
Abandon.
 
torvik@emmet:~$ ^C
torvik@emmet:~$ df -Th | grep -Ev "devpts|none|proc|sys|tmpfs|udev"; echo ; df -Ti | grep -Ev "devpts|none|proc|sys|tmpfs|udev"
Sys. de fichiers Type     Taille Utilisé Dispo Uti% Monté sur
/dev/sda1        ext4        19G     11G  6,6G  62% /
/dev/sda3        ext4       891G    570G  276G  68% /home

Sys. de fichiers Type       Inœuds  IUtil.   ILibre IUti% Monté sur
/dev/sda1        ext4      1222992 1008098   214894   83% /
/dev/sda3        ext4     59285504  269997 59015507    1% /home
torvik@emmet:~$ dpkg -l | grep -Ei "linux-(g|h|i|lo|si|t)" | sort -k3 | tr -s " " | cut -d" " -s -f1,2,3 | column -s" " -t
ii  linux-tools-common                   3.13.0-139.188
ii  linux-headers-4.2.0-42               4.2.0-42.49~14.04.1
ii  linux-headers-4.2.0-42-generic       4.2.0-42.49~14.04.1
ii  linux-headers-4.4.0-101              4.4.0-101.124~14.04.1
ii  linux-headers-4.4.0-101-generic      4.4.0-101.124~14.04.1
ii  linux-headers-4.4.0-103              4.4.0-103.126~14.04.1
ii  linux-headers-4.4.0-103-generic      4.4.0-103.126~14.04.1
ii  linux-headers-4.4.0-104              4.4.0-104.127~14.04.1
ii  linux-headers-4.4.0-104-generic      4.4.0-104.127~14.04.1
ii  linux-headers-4.4.0-109              4.4.0-109.132~14.04.1
ii  linux-image-extra-4.4.0-109-generic  4.4.0-109.132~14.04.1
ii  linux-headers-4.4.0-109-generic      4.4.0-109.132~14.04.1
ii  linux-image-4.4.0-109-generic        4.4.0-109.132~14.04.1
ii  linux-tools-4.4.0-109-generic        4.4.0-109.132~14.04.1
ii  linux-generic-lts-xenial             4.4.0.109.92
ii  linux-headers-generic-lts-xenial     4.4.0.109.92
ii  linux-image-generic-lts-xenial       4.4.0.109.92
ii  linux-tools-virtual-lts-xenial       4.4.0.109.92
ii  linux-headers-4.4.0-34               4.4.0-34.53~14.04.1
ii  linux-headers-4.4.0-34-generic       4.4.0-34.53~14.04.1
ii  linux-headers-4.4.0-36               4.4.0-36.55~14.04.1
ii  linux-headers-4.4.0-36-generic       4.4.0-36.55~14.04.1
ii  linux-headers-4.4.0-38               4.4.0-38.57~14.04.1
ii  linux-headers-4.4.0-38-generic       4.4.0-38.57~14.04.1
ii  linux-headers-4.4.0-42               4.4.0-42.62~14.04.1
ii  linux-headers-4.4.0-42-generic       4.4.0-42.62~14.04.1
ii  linux-headers-4.4.0-45               4.4.0-45.66~14.04.1
ii  linux-headers-4.4.0-45-generic       4.4.0-45.66~14.04.1
ii  linux-headers-4.4.0-47               4.4.0-47.68~14.04.1
ii  linux-headers-4.4.0-47-generic       4.4.0-47.68~14.04.1
ii  linux-headers-4.4.0-53               4.4.0-53.74~14.04.1
ii  linux-headers-4.4.0-53-generic       4.4.0-53.74~14.04.1
ii  linux-headers-4.4.0-57               4.4.0-57.78~14.04.1
ii  linux-headers-4.4.0-57-generic       4.4.0-57.78~14.04.1
ii  linux-headers-4.4.0-59               4.4.0-59.80~14.04.1
ii  linux-headers-4.4.0-59-generic       4.4.0-59.80~14.04.1
ii  linux-headers-4.4.0-66               4.4.0-66.87~14.04.1
ii  linux-headers-4.4.0-66-generic       4.4.0-66.87~14.04.1
ii  linux-headers-4.4.0-70               4.4.0-70.91~14.04.1
ii  linux-headers-4.4.0-70-generic       4.4.0-70.91~14.04.1
ii  linux-headers-4.4.0-71               4.4.0-71.92~14.04.1
ii  linux-headers-4.4.0-71-generic       4.4.0-71.92~14.04.1
ii  linux-headers-4.4.0-72               4.4.0-72.93~14.04.1
ii  linux-headers-4.4.0-72-generic       4.4.0-72.93~14.04.1
ii  linux-headers-4.4.0-75               4.4.0-75.96~14.04.1
ii  linux-headers-4.4.0-75-generic       4.4.0-75.96~14.04.1
ii  linux-headers-4.4.0-78               4.4.0-78.99~14.04.2
ii  linux-headers-4.4.0-78-generic       4.4.0-78.99~14.04.2
ii  linux-headers-4.4.0-81               4.4.0-81.104~14.04.1
ii  linux-headers-4.4.0-81-generic       4.4.0-81.104~14.04.1
ii  linux-headers-4.4.0-83               4.4.0-83.106~14.04.1
ii  linux-headers-4.4.0-83-generic       4.4.0-83.106~14.04.1
ii  linux-headers-4.4.0-87               4.4.0-87.110~14.04.1
ii  linux-headers-4.4.0-87-generic       4.4.0-87.110~14.04.1
ii  linux-headers-4.4.0-89               4.4.0-89.112~14.04.1
ii  linux-headers-4.4.0-89-generic       4.4.0-89.112~14.04.1
ii  linux-headers-4.4.0-93               4.4.0-93.116~14.04.1
ii  linux-headers-4.4.0-93-generic       4.4.0-93.116~14.04.1
ii  linux-headers-4.4.0-96               4.4.0-96.119~14.04.1
ii  linux-headers-4.4.0-96-generic       4.4.0-96.119~14.04.1
ii  linux-headers-4.4.0-97               4.4.0-97.120~14.04.1
ii  linux-headers-4.4.0-97-generic       4.4.0-97.120~14.04.1
ii  linux-headers-4.4.0-98               4.4.0-98.121~14.04.1
ii  linux-headers-4.4.0-98-generic       4.4.0-98.121~14.04.1
torvik@emmet:~$ ls -sS1 /boot
total 37168
21884 initrd.img-4.4.0-109-generic
 6852 vmlinuz-4.4.0-109-generic
 3816 System.map-4.4.0-109-generic
 2668 initrd.img-4.2.0-36-generic
 1228 abi-4.4.0-109-generic
  188 config-4.4.0-109-generic
  176 memtest86+_multiboot.bin
  176 memtest86+.elf
  176 memtest86+.bin
    4 grub

Merci encore.

Hors ligne

#11 Le 16/01/2018, à 19:00

moko138

Re : [résolu] problème mise à jour / espace insuffisant

Je te prie d'exécuter dans l'ordre et de montrer les retours SÉPARÉS de toutes les commandes du #6 de cqfd93, à partir de

Et si ça s'est bien passé, tu peux faire :


EDIT :
Voir ci-dessous.

Dernière modification par moko138 (Le 16/01/2018, à 19:21)


%NOINDEX%
Un utilitaire précieux : ncdu
Photo, mini-tutoriel :  À la découverte de dcraw

En ligne

#12 Le 16/01/2018, à 19:19

moko138

Re : [résolu] problème mise à jour / espace insuffisant

Si tu n'as pas commencé, montre plutôt :

[[ $(apt-mark showmanual | egrep 'linux-.*[0-9]' | grep -v "hwe") ]] && sudo apt-mark auto $(apt-mark showmanual | egrep linux-.*[0-9] | grep -v "hwe")

puis :

cat /etc/apt/apt.conf.d/01autoremove-kernels

et attends-nous pour la suite.


%NOINDEX%
Un utilitaire précieux : ncdu
Photo, mini-tutoriel :  À la découverte de dcraw

En ligne

#13 Le 16/01/2018, à 19:39

emmet grogan

Re : [résolu] problème mise à jour / espace insuffisant

Voici:

torvik@emmet:~$ [[ $(apt-mark showmanual | egrep 'linux-.*[0-9]' | grep -v "hwe") ]] && sudo apt-mark auto $(apt-mark showmanual | egrep linux-.*[0-9] | grep -v "hwe")
torvik@emmet:~$ [[ $(apt-mark showmanual | egrep 'linux-.*[0-9]' | grep -v "hwe") ]] && sudo apt-mark auto $(apt-mark showmanual | egrep linux-.*[0-9] | grep -v "hwe")

puis:

torvik@emmet:~$ cat /etc/apt/apt.conf.d/01autoremove-kernels
// DO NOT EDIT! File autogenerated by /etc/kernel/postinst.d/apt-auto-removal
APT::NeverAutoRemove
{
   "^linux-image-4\.4\.0-109-generic$";
   "^linux-image-4\.4\.0-98-generic$";
   "^linux-headers-4\.4\.0-109-generic$";
   "^linux-headers-4\.4\.0-98-generic$";
   "^linux-image-extra-4\.4\.0-109-generic$";
   "^linux-image-extra-4\.4\.0-98-generic$";
   "^linux-signed-image-4\.4\.0-109-generic$";
   "^linux-signed-image-4\.4\.0-98-generic$";
   "^kfreebsd-image-4\.4\.0-109-generic$";
   "^kfreebsd-image-4\.4\.0-98-generic$";
   "^kfreebsd-headers-4\.4\.0-109-generic$";
   "^kfreebsd-headers-4\.4\.0-98-generic$";
   "^gnumach-image-4\.4\.0-109-generic$";
   "^gnumach-image-4\.4\.0-98-generic$";
   "^.*-modules-4\.4\.0-109-generic$";
   "^.*-modules-4\.4\.0-98-generic$";
   "^.*-kernel-4\.4\.0-109-generic$";
   "^.*-kernel-4\.4\.0-98-generic$";
   "^linux-backports-modules-.*-4\.4\.0-109-generic$";
   "^linux-backports-modules-.*-4\.4\.0-98-generic$";
   "^linux-tools-4\.4\.0-109-generic$";
   "^linux-tools-4\.4\.0-98-generic$";
};
torvik@emmet:~$ 

Dernière modification par emmet grogan (Le 16/01/2018, à 19:43)

Hors ligne

#14 Le 16/01/2018, à 21:47

moko138

Re : [résolu] problème mise à jour / espace insuffisant

Parfait !
Cette fois-ci,

sudo apt-get autoremove --purge -y

devrait finir la purge.
Attention, il y en a peut-être pour quelques minutes !


%NOINDEX%
Un utilitaire précieux : ncdu
Photo, mini-tutoriel :  À la découverte de dcraw

En ligne

#15 Le 17/01/2018, à 04:11

emmet grogan

Re : [résolu] problème mise à jour / espace insuffisant

Bonne nouvelle, voici ce que renvoie apt-get autoremove --purge -y :

torvik@emmet:~$ sudo apt-get autoremove --purge -y[sudo] password for torvik: 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 9 non mis à jour.

Merci encore pour votre aide.

Dernière modification par emmet grogan (Le 17/01/2018, à 14:39)

Hors ligne

#16 Le 17/01/2018, à 04:58

moko138

Re : [résolu] problème mise à jour / espace insuffisant

Ben non, ce n'est pas bon, puisque remove (comme kclean) ne supprime rien !
Re-montre :

df -Th | grep -Ev "devpts|none|proc|sys|tmpfs|udev"; echo ; df -Ti | grep -Ev "devpts|none|proc|sys|tmpfs|udev"
dpkg -l | grep -Ei "linux-(g|h|i|lo|si|t)" | sort -k3 | tr -s " " | cut -d" " -s -f1,2,3 | column -s" " -t

Mais je suppose que les fichiers dans /var/lib/apt/lists sont corrompus. (*)


Reste à trouver la procédure pour les reconstituer à jour. J'ai un doute, je m'abstiens.


(*) AJOUT :
Ça peut résulter d'une suppression manuelle du verrou. Cette opération est dangereuse quand pratiquée inconsidérément !

Dernière modification par moko138 (Le 17/01/2018, à 05:32)


%NOINDEX%
Un utilitaire précieux : ncdu
Photo, mini-tutoriel :  À la découverte de dcraw

En ligne

#17 Le 17/01/2018, à 13:41

emmet grogan

Re : [résolu] problème mise à jour / espace insuffisant

Mince... Je n'ai pas souvenir d'avoir supprimer manuellement le verrou, je ne connais(sais) pas cette notion.

Les commandes indiquées renvoient:

torvik@emmet:~$ df -Th | grep -Ev "devpts|none|proc|sys|tmpfs|udev"; echo ; df -Ti | grep -Ev "devpts|none|proc|sys|tmpfs|udev"
Sys. de fichiers Type     Taille Utilisé Dispo Uti% Monté sur
/dev/sda1        ext4        19G     11G  6,7G  62% /
/dev/sda3        ext4       891G    570G  276G  68% /home

Sys. de fichiers Type       Inœuds  IUtil.   ILibre IUti% Monté sur
/dev/sda1        ext4      1222992 1008076   214916   83% /
/dev/sda3        ext4     59285504  270590 59014914    1% /home

Et:

torvik@emmet:~$ dpkg -l | grep -Ei "linux-(g|h|i|lo|si|t)" | sort -k3 | tr -s " " | cut -d" " -s -f1,2,3 | column -s" " -t
ii  linux-tools-common                   3.13.0-139.188
ii  linux-headers-4.2.0-42               4.2.0-42.49~14.04.1
ii  linux-headers-4.2.0-42-generic       4.2.0-42.49~14.04.1
ii  linux-headers-4.4.0-101              4.4.0-101.124~14.04.1
ii  linux-headers-4.4.0-101-generic      4.4.0-101.124~14.04.1
ii  linux-headers-4.4.0-103              4.4.0-103.126~14.04.1
ii  linux-headers-4.4.0-103-generic      4.4.0-103.126~14.04.1
ii  linux-headers-4.4.0-104              4.4.0-104.127~14.04.1
ii  linux-headers-4.4.0-104-generic      4.4.0-104.127~14.04.1
ii  linux-headers-4.4.0-109              4.4.0-109.132~14.04.1
ii  linux-image-extra-4.4.0-109-generic  4.4.0-109.132~14.04.1
ii  linux-headers-4.4.0-109-generic      4.4.0-109.132~14.04.1
ii  linux-image-4.4.0-109-generic        4.4.0-109.132~14.04.1
ii  linux-tools-4.4.0-109-generic        4.4.0-109.132~14.04.1
ii  linux-generic-lts-xenial             4.4.0.109.92
ii  linux-headers-generic-lts-xenial     4.4.0.109.92
ii  linux-image-generic-lts-xenial       4.4.0.109.92
ii  linux-tools-virtual-lts-xenial       4.4.0.109.92
ii  linux-headers-4.4.0-34               4.4.0-34.53~14.04.1
ii  linux-headers-4.4.0-34-generic       4.4.0-34.53~14.04.1
ii  linux-headers-4.4.0-36               4.4.0-36.55~14.04.1
ii  linux-headers-4.4.0-36-generic       4.4.0-36.55~14.04.1
ii  linux-headers-4.4.0-38               4.4.0-38.57~14.04.1
ii  linux-headers-4.4.0-38-generic       4.4.0-38.57~14.04.1
ii  linux-headers-4.4.0-42               4.4.0-42.62~14.04.1
ii  linux-headers-4.4.0-42-generic       4.4.0-42.62~14.04.1
ii  linux-headers-4.4.0-45               4.4.0-45.66~14.04.1
ii  linux-headers-4.4.0-45-generic       4.4.0-45.66~14.04.1
ii  linux-headers-4.4.0-47               4.4.0-47.68~14.04.1
ii  linux-headers-4.4.0-47-generic       4.4.0-47.68~14.04.1
ii  linux-headers-4.4.0-53               4.4.0-53.74~14.04.1
ii  linux-headers-4.4.0-53-generic       4.4.0-53.74~14.04.1
ii  linux-headers-4.4.0-57               4.4.0-57.78~14.04.1
ii  linux-headers-4.4.0-57-generic       4.4.0-57.78~14.04.1
ii  linux-headers-4.4.0-59               4.4.0-59.80~14.04.1
ii  linux-headers-4.4.0-59-generic       4.4.0-59.80~14.04.1
ii  linux-headers-4.4.0-66               4.4.0-66.87~14.04.1
ii  linux-headers-4.4.0-66-generic       4.4.0-66.87~14.04.1
ii  linux-headers-4.4.0-70               4.4.0-70.91~14.04.1
ii  linux-headers-4.4.0-70-generic       4.4.0-70.91~14.04.1
ii  linux-headers-4.4.0-71               4.4.0-71.92~14.04.1
ii  linux-headers-4.4.0-71-generic       4.4.0-71.92~14.04.1
ii  linux-headers-4.4.0-72               4.4.0-72.93~14.04.1
ii  linux-headers-4.4.0-72-generic       4.4.0-72.93~14.04.1
ii  linux-headers-4.4.0-75               4.4.0-75.96~14.04.1
ii  linux-headers-4.4.0-75-generic       4.4.0-75.96~14.04.1
ii  linux-headers-4.4.0-78               4.4.0-78.99~14.04.2
ii  linux-headers-4.4.0-78-generic       4.4.0-78.99~14.04.2
ii  linux-headers-4.4.0-81               4.4.0-81.104~14.04.1
ii  linux-headers-4.4.0-81-generic       4.4.0-81.104~14.04.1
ii  linux-headers-4.4.0-83               4.4.0-83.106~14.04.1
ii  linux-headers-4.4.0-83-generic       4.4.0-83.106~14.04.1
ii  linux-headers-4.4.0-87               4.4.0-87.110~14.04.1
ii  linux-headers-4.4.0-87-generic       4.4.0-87.110~14.04.1
ii  linux-headers-4.4.0-89               4.4.0-89.112~14.04.1
ii  linux-headers-4.4.0-89-generic       4.4.0-89.112~14.04.1
ii  linux-headers-4.4.0-93               4.4.0-93.116~14.04.1
ii  linux-headers-4.4.0-93-generic       4.4.0-93.116~14.04.1
ii  linux-headers-4.4.0-96               4.4.0-96.119~14.04.1
ii  linux-headers-4.4.0-96-generic       4.4.0-96.119~14.04.1
ii  linux-headers-4.4.0-97               4.4.0-97.120~14.04.1
ii  linux-headers-4.4.0-97-generic       4.4.0-97.120~14.04.1
ii  linux-headers-4.4.0-98               4.4.0-98.121~14.04.1
ii  linux-headers-4.4.0-98-generic       4.4.0-98.121~14.04.1

Dernière modification par emmet grogan (Le 17/01/2018, à 13:43)

Hors ligne

#18 Le 17/01/2018, à 14:17

cqfd93

Re : [résolu] problème mise à jour / espace insuffisant

Bonjour,

On va essayer une simulation de suppression de tous les headers 4.4.0-3* :

sudo apt-get -s remove --purge linux-headers-4\.4\.0-3

cqfd93

En ligne

#19 Le 17/01/2018, à 14:27

emmet grogan

Re : [résolu] problème mise à jour / espace insuffisant

Bonjour,
Voici le résultat de la simulation:

torvik@emmet:~$ sudo apt-get -s remove --purge linux-headers-4\.4\.0-3
[sudo] password for torvik: 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Note : sélection de linux-headers-4.4.0-38-lowlatency pour l'expression rationnelle « linux-headers-4.4.0-3 »
Note : sélection de linux-headers-4.4.0-36-generic pour l'expression rationnelle « linux-headers-4.4.0-3 »
Note : sélection de linux-headers-4.4.0-34-generic pour l'expression rationnelle « linux-headers-4.4.0-3 »
Note : sélection de linux-headers-4.4.0-31 pour l'expression rationnelle « linux-headers-4.4.0-3 »
Note : sélection de linux-headers-4.4.0-34 pour l'expression rationnelle « linux-headers-4.4.0-3 »
Note : sélection de linux-headers-4.4.0-36 pour l'expression rationnelle « linux-headers-4.4.0-3 »
Note : sélection de linux-headers-4.4.0-38 pour l'expression rationnelle « linux-headers-4.4.0-3 »
Note : sélection de linux-headers-4.4.0-34-lowlatency pour l'expression rationnelle « linux-headers-4.4.0-3 »
Note : sélection de linux-headers-4.4.0-31-lowlatency pour l'expression rationnelle « linux-headers-4.4.0-3 »
Note : sélection de linux-headers-4.4.0-36-lowlatency pour l'expression rationnelle « linux-headers-4.4.0-3 »
Note : sélection de linux-headers-4.4.0-31-generic pour l'expression rationnelle « linux-headers-4.4.0-3 »
Note : sélection de linux-headers-4.4.0-38-generic pour l'expression rationnelle « linux-headers-4.4.0-3 »
Package 'linux-headers-4.4.0-31' is not installed, so not removed
Package 'linux-headers-4.4.0-31-generic' is not installed, so not removed
Package 'linux-headers-4.4.0-31-lowlatency' is not installed, so not removed
Package 'linux-headers-4.4.0-34-lowlatency' is not installed, so not removed
Package 'linux-headers-4.4.0-36-lowlatency' is not installed, so not removed
Package 'linux-headers-4.4.0-38-lowlatency' is not installed, so not removed
Les paquets suivants seront ENLEVÉS :
  linux-headers-4.4.0-34* linux-headers-4.4.0-34-generic*
  linux-headers-4.4.0-36* linux-headers-4.4.0-36-generic*
  linux-headers-4.4.0-38* linux-headers-4.4.0-38-generic*
0 mis à jour, 0 nouvellement installés, 6 à enlever et 14 non mis à jour.
Purg linux-headers-4.4.0-34-generic [4.4.0-34.53~14.04.1]
Purg linux-headers-4.4.0-34 [4.4.0-34.53~14.04.1]
Purg linux-headers-4.4.0-36-generic [4.4.0-36.55~14.04.1]
Purg linux-headers-4.4.0-36 [4.4.0-36.55~14.04.1]
Purg linux-headers-4.4.0-38-generic [4.4.0-38.57~14.04.1]
Purg linux-headers-4.4.0-38 [4.4.0-38.57~14.04.1]
torvik@emmet:~$ 

Dernière modification par emmet grogan (Le 17/01/2018, à 14:37)

Hors ligne

#20 Le 17/01/2018, à 14:40

cqfd93

Re : [résolu] problème mise à jour / espace insuffisant

C'est parfait, donc on enlève le "-s" pour supprimer réellement ces paquets :

sudo apt-get remove --purge linux-headers-4\.4\.0-3

Et sur ce modèle, on peut aussi supprimer les 4.4.0-4*, 4.4.0-5*, … ,4.4.0-9* (ça va être long !!!) :

sudo apt-get remove --purge linux-headers-4\.4\.0-4 linux-headers-4\.4\.0-5 linux-headers-4\.4\.0-6 linux-headers-4\.4\.0-7 linux-headers-4\.4\.0-8 linux-headers-4\.4\.0-9

Et les 4.2.0* :

sudo apt-get remove --purge linux-headers-4\.2\.0

Je te rappelle l'astuce pour copier / coller sans risque d'erreur :

  • triple clic gauche pour sélectionner et copier une ligne entière

  • clic molette pour coller dans le terminal

Contrôle :

df -Th | grep -Ev "devpts|none|proc|sys|tmpfs|udev"; echo ; df -Ti | grep -Ev "devpts|none|proc|sys|tmpfs|udev"
dpkg -l | grep -Ei "linux-(g|h|i|lo|si|t)" | sort -k3 | tr -s " " | cut -d" " -s -f1,2,3 | column -s" " -t
ls -sS1 /boot

cqfd93

En ligne

#21 Le 17/01/2018, à 14:42

moko138

Re : [résolu] problème mise à jour / espace insuffisant

Oh, je vous sens bien partis, là !  big_smile


%NOINDEX%
Un utilitaire précieux : ncdu
Photo, mini-tutoriel :  À la découverte de dcraw

En ligne

#22 Le 17/01/2018, à 14:43

cqfd93

Re : [résolu] problème mise à jour / espace insuffisant

Oui, ça va dégager ! smile


cqfd93

En ligne

#23 Le 17/01/2018, à 15:17

nam1962

Re : [résolu] problème mise à jour / espace insuffisant

A l'occasion, comme le serveur semble exotique, il sera intéressant d'avoir les retours de :

cat /etc/apt/sources.list
ls /etc/apt/sources.list.d -1

Dernière modification par nam1962 (Le 17/01/2018, à 15:17)


[ Modéré ]

Hors ligne

#24 Le 17/01/2018, à 15:27

cqfd93

Re : [résolu] problème mise à jour / espace insuffisant

nam1962 a écrit :

A l'occasion, comme le serveur semble exotique, il sera intéressant d'avoir les retours de :

cat /etc/apt/sources.list
ls /etc/apt/sources.list.d -1

Ça a déjà été donné dans le message #7 et je ne pense pas qu'il y ait eu du changement depuis. Dès qu'on en aura fini avec les noyaux, on verra les mises à jour.


cqfd93

En ligne

#25 Le 17/01/2018, à 15:35

nam1962

Re : [résolu] problème mise à jour / espace insuffisant

Oups, j'avais zappé le #7 !
Il sera intéressant de savoir dans quel coin habite emmet grogan : je ne sais pas où est le serveur (pas très à jour) th.ubuntu et il y a aussi de l'université de lyon.
Sinon, f.lux est avantageusement remplacé par redshift (ce qui permet de virer un PPA wink )


[ Modéré ]

Hors ligne