Contenu | Rechercher | Menus

Annonce

T-shirt Seiche Cosmic, Série limitée

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.10
T-shirt Ubuntu-FR « Seiche Cosmique » en série limitée ! Prix spécial pré-vente (15€) jusqu'au 4 novembre 2018.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 12/02/2018, à 23:46

on5cg

Apache2 + Subversion : requêtes http et svn problématiques

Bonjour à tous,

J'ai installé un serveur avec Apache2 2.4.18, Subversion 1.9.3 et WebSVN 2.3.3. Mes postes de travail sont sous Mint 18.04
L'installation n'a pas posé de problème particulier. WebSVN fonctionne, en tout cas, il affiche bien les dépôts, que ce soit en local ou via le web. La configuration d'Apache a été faite classiquement pour Subversion. J'ai créé un dépôt dans /mnt/projets/audiometrie/svn/software. Les ports 80 et 3690 sont ouverts dans ma box.

SANS APACHE :
    Lorsque je lance une commande SVN sur le réseau local, par exemple :
    >> svn checkout --username "machin" --password "brol" svn://192.168.1.240/software   (comme défini dans snvserve.conf : "realm = software")
    tout se passe bien, je récupère mon dépôt.

    Si je lance la même commande via le web directement sur mon adresse ip wan  (ex 124.68.204.25)
    >> svn checkout --username "machin" --password "brol" svn://124.68.204.25:3690/software    (3690 est le port d'écoute par défaut de svn)
    ... je n'ai pas de réponse du tout. Mon terminal "freeze" et devient inutilisable. Le résultat est le même si je n'indique pas le port.

AVEC APACHE :
    Si je lance la commande en http (via la config apache) sur le reseau local ou via le web :
    >> svn checkout --username "machin" --password "brol" http://192.168.1.240/software   (comme défini dans /etc/apache2/mods-enabled/dav_svn.conf : "<Location = /software>")
   
    J'ai la réponse suivante :
        svn: E170013: Unable to connect to a repository at URL 'http://192.168.1.240/software'
        svn: E175002: Unexpected server error 500 'Internal Server Error' on '/software'

J'ai eu beau faire et refaire toute la config, rien n'y fait jusque là. Avec WebSVN, tout est ok, que ce soit l'identification ou l'affichage des dépôts... et pourtant il utilise apache aussi !
Les login et mots de passe sont les mêmes pour tous les systèmes.
Quelqu'un aurait-il rencontré le même problème ?

Merci d'avance pour toute info !

Dernière modification par on5cg (Le 13/02/2018, à 11:01)

Hors ligne