Contenu | Rechercher | Menus

Annonce

Toute l'équipe d'ubuntu-fr vous souhaite un joyeux Noël et une bonne et heureuse année 2018.

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 14/02/2018, à 23:43

alex2423

Comment Installer Opéra posant problème avec libdbus-1-3

Hello tout le monde,

J'aimerai installer Opéra afin de bénéficier facillement de leur VPN tout continuant bien sur d'utiliser Firefox en tant que navigateur principal.

J'ai téléchargé le fichier .deb sur le site et j'ai tenté :

$ sudo dpkg -i opera-stable_51.0.2830.26_amd64.deb [sudo] password for trusty: 
Selecting previously unselected package opera-stable.
(Reading database ... 673142 files and directories currently installed.)
Preparing to unpack opera-stable_51.0.2830.26_amd64.deb ...
Unpacking opera-stable (51.0.2830.26) ...
[b]dpkg: dependency problems prevent configuration of opera-stable:
 opera-stable depends on libdbus-1-3 (>= 1.9.14); however:
  Version of libdbus-1-3:amd64 on system is 1.6.18-0ubuntu4.5.[/b]

dpkg: error processing package opera-stable (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils (0.22-1ubuntu1.1) ...
Processing triggers for mime-support (3.54ubuntu1.1) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for hicolor-icon-theme (0.13-1) ...
Processing triggers for shared-mime-info (1.2-0ubuntu3) ...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'
Errors were encountered while processing:
 opera-stable
trusty@trusty-lap:~/Downloads$ 

mais malheureusement comme vous pouvez le voir, la dernière version de Opéra demande de la librairie libdbus-1-3 une version (>= 1.9.14) alors que je suis en en 1.6.
Il s'agit de la dernière version de ma version de xubuntu. Je suis en 14.4

J'ai du mal à comprendre ce blocage. J'ai installé la dernière version de Firefox sur une version de Ubuntu, plus ancienne et je n'ai pas eu de souci. Opéra a des contraintes fortes à cause de cette librairies.

Si j'ai bien compris, j'ai 2 choix :
- soit j'installe une ancienne version de Opéra qui supportera la version de la libraire libdbus-1-3 de ma xubuntu
- soit je rajoute à la main la dernière version de libdbus-1-3 au risque de rendre instable mon système

Pour Firefox, il est assez facile de trouver les anciennes versions. Mozilla a mis en place un ftp.
Par contre, pour ce qui concerne Opéra, je n'ai rien trouvé. Savez vous ou l'on peut les trouver  ?

Hors ligne

#2 Le 15/02/2018, à 00:03

alex2423

Re : Comment Installer Opéra posant problème avec libdbus-1-3

Bon enfin de compte, j'ai trouvé depuis pas mal d'info.

Je suis loin d'être seul : https://forums.opera.com/topic/24994/ca … -14-04-lts
En conclusion comme je le pensais, il n'y a pas moyen d'avoir la dernière version de Opéra sous Ubuntu 14.04. J'ai du mal à comprendre la stratégie de Opéra.

Et j'ai enfin trouvé le ftp de Opéra : https://ftp.opera.com/ftp/pub/opera/des … .67/linux/
SI j'ai bien compris, la dernière version de Opéra compatible est la version 50

Hors ligne

#3 Le 15/02/2018, à 00:11

Roschan

Re : Comment Installer Opéra posant problème avec libdbus-1-3

J'ai du mal à comprendre la stratégie de Opéra.

La stratégie est de ne pas dépenser des ressources de développement inutilement pour supporter un OS ultra-minoritaire vieux de 4 ans qui sera bientôt obsolète et dont une nouvelle version est gratuitement installable depuis bientôt 2 ans.

Ce n'était pas si difficile à comprendre hmm

En ligne