Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

N'oubliez pas de cocher la case « Ajustement pour l'heure d'été » dans votre profil.

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 23/02/2018, à 21:23

TOSanthony

Compilation minidlna

Bonjour j'ai besoin d'aide pour compiler minidlna sur Ubuntu,j'ai besoin d'une ancienne version avec lequel je veux rajouter une icône custom.
Pourriez vous me venir en aide ?

Si quelqu'un pourrait le faire pour moi ce serait cool, merci d'avance.

Hors ligne

#2 Le 24/02/2018, à 16:22

bruno

Re : Compilation minidlna

Bonjour,

Pourquoi la version des dépôts officiels ne te convient-elle pas ?

En ligne

#3 Le 24/02/2018, à 17:49

TOSanthony

Re : Compilation minidlna

Enfaite j'ai besoin de personnalisé l'icon de minidlna, j'ai créé mon fichier icon.h puis installer les paquets requis pour la compilation.
Pour voir si minidlna marche sur ma version d'Android j'ai téléchargé différentes version sur le site de sourceforge, ces version sont dites static et fonctionne uniquement jusqu'a la version 1.0.26 sur mon android.
Du coup j'aurais voulu compiler ce numéro de build et y inclure mon fichier icon.h

Hors ligne

#4 Le 24/02/2018, à 17:58

bruno

Re : Compilation minidlna

Si je comprends bien ta question ne concerne donc pas Ubuntu mais android…

En ligne

#5 Le 24/02/2018, à 18:03

TOSanthony

Re : Compilation minidlna

Oui car j'ai besoin de compiler sur Ubuntu pour récupérer le fichier elf de sortie et le mettre dans le dossier bin d'android.
Du coup j'ai besoin d'aide car je n'arrive pas à compiler la version static.

Dernière modification par TOSanthony (Le 24/02/2018, à 18:04)

Hors ligne

#6 Le 25/02/2018, à 09:25

bruno

Re : Compilation minidlna

Désolé mais cela dépasse totalement mes compétences.
Normalement pour pouvoir compiler un logiciel il faut avoir installé tous les outils de compilation et aussi toutes les bibliothèques dont dépend la construction de l'application (build-depends).
Dans ton cas il faudrait a priori pouvoir faire de la compilation spécifiquement pour ton système tournant sous Android (amd64 ou x86  ou arm ?)

Sous Ubuntu pour compiler minidlna, il sera donc nécessaire (mais pas forcément suffisant) d'installer ceci :

sudo apt install  build-essential
sudo apt build-dep minidlna

En ligne