Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 10/03/2018, à 08:25

bjc49

Epson V 330 - Xsane ne fontionne qu'en root ???

Bonjour,
Je viens de passer de linux Mate Maya a Kubuntu 17.10.
Il fallu quelques réglages bien sûr mais je n'arrive plus a faire fonction mon scanner a plat Epson V330
Ou plutôt si .....a condition de lancer la commande xsane en superutilisateur ......ce qui n'est conseiller je crois ????
J'ai regardé un tas de fil de discussion dont celui ci https://forum.ubuntu-fr.org/viewtopic.php?id=2023301
Mais je n'ai pas avancé depuis et je lance donc ce nouveau fil en espérant une solution peut être ?????
Merci.
Cordialement.
Jean-Claude


Config :Kubuntu 18-04 --Boitier:Cooler Master Sileo 500--Alim:Cooler Master Silent Pro M 600w--CM:Gigabyte 890GPA-UD3H--Ram:2x2GO
DDR3 Kingston--Proc:AMD Phenom II X4 955--DD:Western Digital Green 1To 64Mo--ecran:IIyama Prolite B2209HDS

Hors ligne

#2 Le 10/03/2018, à 09:15

moko138

Re : Epson V 330 - Xsane ne fontionne qu'en root ???

bjc49 a écrit :

xsane en superutilisateur ......ce qui n'est conseiller je crois ????

1) Puisque tu le sais, pourquoi commettre cette erreur exemplaire ?

  - -

2) Maintenant qu'elle est faite, merci de montrer, depuis ta session normale
les retours complets de :

echo; sudo find /root -iname \*sane\* ; echo -e "-----\n\nroot" ; sudo ls -lA /root  ; echo -e "-----\n\nroot/.cache" ; sudo ls -lA /root/.cache ; echo -e "-----\n\nroot/.config" ; sudo ls -lA /root/.config

et

ls -la $(find ~ -iname \*sane\* 2>/dev/null) ; echo ; uname -mrs

%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#3 Le 13/03/2018, à 08:49

bjc49

Re : Epson V 330 - Xsane ne fontionne qu'en root ???

Bonjour,
Excusez moi pour ma réaction tardive.
Voila ce que j'ai  en retour première commande :

echo; sudo find /root -iname \*sane\* ; echo -e "-----\n\nroot" ; sudo ls -lA /root  ; echo -e "-----\n\nroot/.cache" ; sudo ls -lA /root/.cache ; echo -e "-----\n\nroot/.config" ; sudo ls -lA /root/.config

[sudo] Mot de passe de bjc49 : 
-----

root
total 20
-rw-r--r-- 1 root root 3106 oct.  22  2015 .bashrc
drwxr-xr-x 2 root root 4096 mars  13 08:29 .cache
drwx------ 3 root root 4096 mars   1 08:18 .config
drwx------ 3 root root 4096 mars   2 09:11 .dbus
-rw-r--r-- 1 root root  148 août  17  2015 .profile
-----

root/.cache
total 0
-----

root/.config
total 4
drwx------ 2 root root 4096 mars   1 08:18 bleachbit

Pour l'autre commande :

ls -la $(find ~ -iname \*sane\* 2>/dev/null) ; echo ; uname -mrs
ls : option invalide -- 'V'
Saisissez « ls --help » pour plus d'informations.

Linux 4.13.0-36-generic x86_64

C'est un peu obscur pour moi toutes ces commandes.

Merci de t intéresser a mon soucis.
Peut être aurais je du installer une autre KDE (Néon,Mint,...)

Cordialement.
Jean-Claude


Config :Kubuntu 18-04 --Boitier:Cooler Master Sileo 500--Alim:Cooler Master Silent Pro M 600w--CM:Gigabyte 890GPA-UD3H--Ram:2x2GO
DDR3 Kingston--Proc:AMD Phenom II X4 955--DD:Western Digital Green 1To 64Mo--ecran:IIyama Prolite B2209HDS

Hors ligne

#4 Le 13/03/2018, à 10:12

moko138

Re : Epson V 330 - Xsane ne fontionne qu'en root ???

bjc49 a écrit :

C'est un peu obscur pour moi toutes ces commandes.

On cherche, dans /root puis dans /home/bjc49, des éléments de sane qui appartiendraient indûment à root et empêcheraient ainsi son fonctionnement normal.
  - -

Je vois que tu as utilisé bleachbit en root : tu aimes vivre dangereusement !
  - -

Je suis très étonné par :

ls -la $(find ~ -iname \*sane\* 2>/dev/null) ; echo ; uname -mrs
ls : option invalide -- 'V'

Et si tu lances

find ~ -iname \*sane\* 2>/dev/null | xargs ls -la

ton système sera-t-il plus coopératif ?


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#5 Le 13/03/2018, à 11:59

bjc49

Re : Epson V 330 - Xsane ne fontionne qu'en root ???

Re bonjour,
Voila ce que j'ai pour cette commande :

bjc49@bjc49-GA-890GPA-UD3H:~$ find ~ -iname \*sane\* 2>/dev/null | xargs ls -la
ls : option invalide -- 'V'
Saisissez « ls --help » pour plus d'informations.

Donc le système n'est guère plus coopératif !!!!
Voila ce que donne la partie find ~ -iname \*sane\*  2>/dev/null

bjc49@bjc49-GA-890GPA-UD3H:~$  find ~ -iname \*sane\* 2>/dev/null
/home/bjc49/.sane
/home/bjc49/.sane/xsane
/home/bjc49/.sane/xsane/xsane.mdf
/home/bjc49/.sane/xsane/xsane.rc
/home/bjc49/Musique/orchestre_de_lopera_populaire_de_vienne/les_oeuvres_les_plus_clbre_de_johan_strauss/05_marche_persane_walzer_op_298.ogg
/home/bjc49/Documents/Personnel/Loisirs/Aquarelle/Realisations/1-Avant-2017/tisane.jpg
/home/bjc49/.local/share/Trash/info/.sane.trashinfo
/home/bjc49/.local/share/Trash/files/.sane
/home/bjc49/.local/share/Trash/files/.sane/xsane
/home/bjc49/.local/share/Trash/files/.sane/xsane/xsane.mdf
/home/bjc49/.local/share/Trash/files/.sane/xsane/xsane.rc
/home/bjc49/GENEALOGIES/Recherches/Lieux/72/03 - Lieux, cartes et autres/1-Divers sur la Sarthe/Costumes et art de vivre/Le Mans - Paysane - 132.jpg
/home/bjc49/GENEALOGIES/Recherches/Lieux/72/03 - Lieux, cartes et autres/1-Divers sur la Sarthe/Costumes et art de vivre/Le Mans - Paysane - 132 -V1.jpg
/home/bjc49/GENEALOGIES/Recherches/Lieux/72/03 - Lieux, cartes et autres/1-Divers sur la Sarthe/Costumes et art de vivre/Le Mans - Paysane - 132 -V2.jpg

L'arborescence est elle correcte ?
Je ferais ls -la sur chaque item.

Je vois que tu as utilisé bleachbit en root : tu aimes vivre dangereusement !

C'est une option de Bleachbit  qui existe


Config :Kubuntu 18-04 --Boitier:Cooler Master Sileo 500--Alim:Cooler Master Silent Pro M 600w--CM:Gigabyte 890GPA-UD3H--Ram:2x2GO
DDR3 Kingston--Proc:AMD Phenom II X4 955--DD:Western Digital Green 1To 64Mo--ecran:IIyama Prolite B2209HDS

Hors ligne

#6 Le 13/03/2018, à 12:33

moko138

Re : Epson V 330 - Xsane ne fontionne qu'en root ???

Voila ce que donne la partie find ~ -iname \*sane\*  2>/dev/null

Bon réflexe !  smile
  - -

L'arborescence est elle correcte ?

Ces lignes

/home/toi/.sane
/home/toi/.sane/xsane
/home/toi/.sane/xsane/xsane.mdf
/home/toi/.sane/xsane/xsane.rc

sont normalement présentes et tes ls -la à venir seront bienvenus !

Par contre, dans ma LMDE (distribution différente, donc on ne peut pas extrapoler avec certitude) j'ai en plus dans /home/moko/.sane/xsane :
un sous-répertoire vide :

drwx------ 2 moko moko 4096 janv. 10  2013 batch-lists

et un fichier par scanner ayant été branché :

-rw------- 1 moko moko 1887 janv. 10  2013 Epson:Perfection1250_Photo.drc
-rw------- 1 moko moko 4811 août  23  2014 Epson:PerfectionV300.drc

  - -

Si tu vides ta corbeille, est-ce que les 4 cinq lignes en

/home/toi/.local/share/Trash/

disparaissent bien ?

Dernière modification par moko138 (Le 13/03/2018, à 12:37)


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#7 Le 13/03/2018, à 14:05

bjc49

Re : Epson V 330 - Xsane ne fontionne qu'en root ???

Ces lignes

/home/toi/.sane
/home/toi/.sane/xsane
/home/toi/.sane/xsane/xsane.mdf
/home/toi/.sane/xsane/xsane.rc

sont normalement présentes et tes ls -la à venir seront bienvenus !

Par contre, dans ma LMDE (distribution différente, donc on ne peut pas extrapoler avec certitude) j'ai en plus dans /home/moko/.sane/xsane :

Voila mes ls -al :

bjc49@bjc49-GA-890GPA-UD3H:~$ cd
bjc49@bjc49-GA-890GPA-UD3H:~$ pwd
/home/bjc49
bjc49@bjc49-GA-890GPA-UD3H:~$ ls -al .sane
total 12
drwx------  3 bjc49 bjc49 4096 mars   9 09:06 .
drwxr-xr-x 81 bjc49 bjc49 4096 mars  13 13:38 ..
drwx------  3 bjc49 bjc49 4096 mars  10 08:09 xsane
bjc49@bjc49-GA-890GPA-UD3H:~$ ls -al .sane/xsane
total 36
drwx------ 3 bjc49 bjc49 4096 mars  10 08:09 .
drwx------ 3 bjc49 bjc49 4096 mars   9 09:06 ..
drwx------ 2 root  root  4096 mars  10 08:09 batch-lists
-rw------- 1 root  root  4820 mars  10 08:09 Epson:PerfectionV330Photo.drc
-rw------- 1 root  root  4275 mars  10 08:09 xsane.mdf
-rw------- 1 bjc49 bjc49 5213 mars  10 08:09 xsane.rc

Et la cela a se gâte 2 fichiers en root et ainsi que  le répertoire  batch-lists ?

Après voir vider ma corbeille (via le gestionnaire de fichier Dolphin)
Voila ce que j'ai :

bjc49@bjc49-GA-890GPA-UD3H:~$ pwd
/home/bjc49
bjc49@bjc49-GA-890GPA-UD3H:~$ ls -al .local/share/Trash/
total 48
drwxrwxr-x  4 bjc49 bjc49  4096 mars  13 14:01 .
drwxr-xr-x 61 bjc49 bjc49  4096 mars  13 07:23 ..
drwxrwxr-x  2 bjc49 bjc49 12288 mars  13 14:01 files
drwxrwxr-x  2 bjc49 bjc49 20480 mars  13 14:01 info
-rwxrwxrwx  1 bjc49 bjc49    25 févr. 24 08:08 metadata

Config :Kubuntu 18-04 --Boitier:Cooler Master Sileo 500--Alim:Cooler Master Silent Pro M 600w--CM:Gigabyte 890GPA-UD3H--Ram:2x2GO
DDR3 Kingston--Proc:AMD Phenom II X4 955--DD:Western Digital Green 1To 64Mo--ecran:IIyama Prolite B2209HDS

Hors ligne

#8 Le 13/03/2018, à 15:23

moko138

Re : Epson V 330 - Xsane ne fontionne qu'en root ???

On progresse !
Corbeille saine
  - -

Exécute

cd ~/.sane/xsane/ && sudo chown bjc49:bjc49 -Rv batch-lists  Epson:PerfectionV330Photo.drc  xsane.mdf ; cd

pour récupérer la propriété de ces trois éléments.


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#9 Le 13/03/2018, à 19:25

bjc49

Re : Epson V 330 - Xsane ne fontionne qu'en root ???

Bonsoir
J'ai fait cette commande pour réattribuer le bon groupe et utilisateur

bjc49@bjc49-GA-890GPA-UD3H:~/.sane/xsane$ pwd
/home/bjc49/.sane/xsane
bjc49@bjc49-GA-890GPA-UD3H:~/.sane/xsane$ ls -al
total 36
drwx------ 3 bjc49 bjc49 4096 mars  10 08:09 .
drwx------ 3 bjc49 bjc49 4096 mars   9 09:06 ..
drwx------ 2 bjc49 bjc49 4096 mars  10 08:09 batch-lists
-rw------- 1 bjc49 bjc49 4820 mars  10 08:09 Epson:PerfectionV330Photo.drc
-rw------- 1 bjc49 bjc49 4275 mars  10 08:09 xsane.mdf
-rw------- 1 bjc49 bjc49 5213 mars  13 19:05 xsane.rc

Mais xsane ne fonctionne pas  ----> pas de périphérique disponible ????


Config :Kubuntu 18-04 --Boitier:Cooler Master Sileo 500--Alim:Cooler Master Silent Pro M 600w--CM:Gigabyte 890GPA-UD3H--Ram:2x2GO
DDR3 Kingston--Proc:AMD Phenom II X4 955--DD:Western Digital Green 1To 64Mo--ecran:IIyama Prolite B2209HDS

Hors ligne

#10 Le 13/03/2018, à 20:47

moko138

Re : Epson V 330 - Xsane ne fontionne qu'en root ???

sudo ln -sfr /usr/lib/sane/libsane-epkowa* /usr/lib/x86_64-linux-gnu/sane

puis

sudo service udev restart

%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#11 Le 14/03/2018, à 07:26

bjc49

Re : Epson V 330 - Xsane ne fontionne qu'en root ???

Bonjour,
J'ai fait ces commandes voir rebooter
Mais xsane refuse de fonctionner:(
Pour info voila les liens qui on étés crées

bjc49@bjc49-GA-890GPA-UD3H:/usr/lib/x86_64-linux-gnu/sane$ pwd
/usr/lib/x86_64-linux-gnu/sane
bjc49@bjc49-GA-890GPA-UD3H:/usr/lib/x86_64-linux-gnu/sane$ ls -al libsane-epk*
lrwxrwxrwx 1 root root 28 mars  14 06:53 libsane-epkowa.la -> ../../sane/libsane-epkowa.la
lrwxrwxrwx 1 root root 35 mars  14 06:53 libsane-epkowa.so.1 -> ../../sane/libsane-epkowa.so.1.0.15
lrwxrwxrwx 1 root root 35 mars  14 06:53 libsane-epkowa.so.1.0.15 -> ../../sane/libsane-epkowa.so.1.0.15
bjc49@bjc49-GA-890GPA-UD3H:/usr/lib/x86_64-linux-gnu/sane$ 

Il y a quand des choses bizarres par exemple en m'inspirant d'un fil de discussion : http://pigeonsnest.co.uk/stuff/ubuntu-udev-scanner.html

scanimage -L ne trouve pas de scanner

bjc49@bjc49-GA-890GPA-UD3H:/usr/lib/x86_64-linux-gnu/sane$ scanimage -L

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

J'essaie l'utilitaire "sane-find-scanner" conseiller plus haut -----> pas de scanner

 sane-find-scanner 

  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

could not open USB device 0x04b8/0x0142 at 003:003: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0002 at 003:001: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0001 at 007:001: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0001 at 006:001: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0002 at 002:001: Access denied (insufficient permissions)
could not open USB device 0x046d/0xc050 at 005:002: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0001 at 005:001: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0002 at 001:001: Access denied (insufficient permissions)
could not open USB device 0x04f9/0x001a at 004:002: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0001 at 004:001: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0003 at 009:001: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0002 at 008:001: Access denied (insufficient permissions)
  # No USB scanners found. If you expected something different, make sure that
  # you have loaded a kernel driver for your USB host controller and have setup
  # the USB system correctly. See man sane-usb for details.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.

  # You may want to run this program as root to find all devices. Once you
  # found the scanner devices, be sure to adjust access permissions as
  # necessary.

Ne connaissant pas la langue anglaise : je crois comprendre que l'on peut lancer cette même commande en root

bjc49@bjc49-GA-890GPA-UD3H:/usr/lib/x86_64-linux-gnu/sane$ sudo sane-find-scanner 

  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x04b8 [EPSON], product=0x0142 [EPSON Perfection V33/V330]) at libusb:003:003
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.

Est ce normal qu'il nr fonctionne qu'en root

GRRR !!!


Config :Kubuntu 18-04 --Boitier:Cooler Master Sileo 500--Alim:Cooler Master Silent Pro M 600w--CM:Gigabyte 890GPA-UD3H--Ram:2x2GO
DDR3 Kingston--Proc:AMD Phenom II X4 955--DD:Western Digital Green 1To 64Mo--ecran:IIyama Prolite B2209HDS

Hors ligne

#12 Le 14/03/2018, à 09:30

moko138

Re : Epson V 330 - Xsane ne fontionne qu'en root ???

On commence par le début : que retourne

dpkg -l | grep sane

?


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#13 Le 14/03/2018, à 10:14

bjc49

Re : Epson V 330 - Xsane ne fontionne qu'en root ???

Bonjour,
Voici ce que me retourne la commande


Ci après:

bjc49@bjc49-GA-890GPA-UD3H:~$ dpkg -l | grep sane
ii  libcommon-sense-perl                            3.74-2build1                                amd64        module that implements some sane defaults for Perl programs
ii  libkf5sane-data                                 17.04.3-0ubuntu1                            all          scanner library (data files)
ii  libkf5sane5                                     17.04.3-0ubuntu1                            amd64        scanner library (runtime)
ii  libsane-common                                  1.0.27-1~experimental2ubuntu2.1             all          API library for scanners -- documentation and support files
ii  libsane-extras:amd64                            1.0.22.5                                    amd64        API library for scanners -- extra backends
ii  libsane-extras-common                           1.0.22.5                                    all          API library for scanners -- documentation and support files
ii  libsane-hpaio:amd64                             3.17.7+repack0-3                            amd64        HP SANE backend for multi-function peripherals
ii  libsane1:amd64                                  1.0.27-1~experimental2ubuntu2.1             amd64        API library for scanners
ii  sane                                            1.0.14-12build1                             amd64        scanner graphical frontends
ii  sane-utils                                      1.0.27-1~experimental2ubuntu2.1             amd64        API library for scanners -- utilities
ii  xsane                                           0.999-5ubuntu2                              amd64        featureful graphical frontend for SANE (Scanner Access Now Easy)
ii  xsane-common                                    0.999-5ubuntu2                              all          xsane architecture independent files
ii  xsane-dbg:amd64                                 0.999-5ubuntu2                              amd64        featureful graphical frontend for SANE (Debug files)
bjc49@bjc49-GA-890GPA-UD3H:~$ 

Config :Kubuntu 18-04 --Boitier:Cooler Master Sileo 500--Alim:Cooler Master Silent Pro M 600w--CM:Gigabyte 890GPA-UD3H--Ram:2x2GO
DDR3 Kingston--Proc:AMD Phenom II X4 955--DD:Western Digital Green 1To 64Mo--ecran:IIyama Prolite B2209HDS

Hors ligne

#14 Le 14/03/2018, à 10:57

moko138

Re : Epson V 330 - Xsane ne fontionne qu'en root ???

Je vois que tu as des versions expérimentales de certains paquets ; montre

cat /etc/apt/sources.list | grep -v ^#

et

cat /etc/apt/sources.list.d/*.list | grep -v ^#

= =

Notons en #11 :

found USB scanner (vendor=0x04b8 [EPSON], product=0x0142 [EPSON Perfection V33/V330]) 

%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#15 Le 14/03/2018, à 12:20

bjc49

Re : Epson V 330 - Xsane ne fontionne qu'en root ???

Voici les retours des 2 commandes :

bjc49@bjc49-GA-890GPA-UD3H:~$ cat /etc/apt/sources.list | grep -v ^#

deb http://fr.archive.ubuntu.com/ubuntu/ artful main restricted

deb http://fr.archive.ubuntu.com/ubuntu/ artful-updates main restricted

deb http://fr.archive.ubuntu.com/ubuntu/ artful universe
deb http://fr.archive.ubuntu.com/ubuntu/ artful-updates universe

deb http://fr.archive.ubuntu.com/ubuntu/ artful multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ artful-updates multiverse

deb http://fr.archive.ubuntu.com/ubuntu/ artful-backports main restricted universe multiverse


deb http://security.ubuntu.com/ubuntu artful-security main restricted
deb http://security.ubuntu.com/ubuntu artful-security universe
deb http://security.ubuntu.com/ubuntu artful-security multiverse
bjc49@bjc49-GA-890GPA-UD3H:~$ cat /etc/apt/sources.list.d/*.list | grep -v ^#
deb http://ppa.launchpad.net/s-mankowski/ppa-kf5/ubuntu artful main

Le dépôt s-mankowski activé pour avoir skrooge (comptabilité personnelle) fonctionnel.

Je n'ai compris le #11


Config :Kubuntu 18-04 --Boitier:Cooler Master Sileo 500--Alim:Cooler Master Silent Pro M 600w--CM:Gigabyte 890GPA-UD3H--Ram:2x2GO
DDR3 Kingston--Proc:AMD Phenom II X4 955--DD:Western Digital Green 1To 64Mo--ecran:IIyama Prolite B2209HDS

Hors ligne

#16 Le 14/03/2018, à 15:20

moko138

Re : Epson V 330 - Xsane ne fontionne qu'en root ???

En #11 signifie "dans le message numéro 11".  smile
  - -

D'après ht tps://packages.ubuntu.com/search?keywords=libsane-common
le "experimental" est normal (!), et il existe en deux versions :

artful (libs): API library for scanners -- documentation and support files
1.0.27-1~experimental2ubuntu1: all
artful-updates (libs): API library for scanners -- documentation and support files
1.0.27-1~experimental2ubuntu2.1: all

  - -
La Doc ht tps://doc.ubuntu-fr.org/liste_imprimantes_epson#scanner_perfection dit :

Perfection V330 Photo     Fonctionne après configuration     Fonctionne avec le pilote propriétaire iscan

Donc que donne

dpkg -l | grep iscan

?

Dernière modification par moko138 (Le 14/03/2018, à 15:21)


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#17 Le 14/03/2018, à 17:00

bjc49

Re : Epson V 330 - Xsane ne fontionne qu'en root ???

donne

bjc49@bjc49-GA-890GPA-UD3H:~$ dpkg -l | grep iscan
ii  iscan                                           2.30.2-2                                    amd64        simple, easy to use scanner utility for EPSON scanners
ii  iscan-data                                      1.36.0-1                                    all          Image Scan! for Linux data files

Config :Kubuntu 18-04 --Boitier:Cooler Master Sileo 500--Alim:Cooler Master Silent Pro M 600w--CM:Gigabyte 890GPA-UD3H--Ram:2x2GO
DDR3 Kingston--Proc:AMD Phenom II X4 955--DD:Western Digital Green 1To 64Mo--ecran:IIyama Prolite B2209HDS

Hors ligne

#18 Le 14/03/2018, à 20:13

moko138

Re : Epson V 330 - Xsane ne fontionne qu'en root ???

ii  iscan                   2.30.2-2
ii  iscan-data                 1.36.0-1

Je suis étonné par l'écart des n° de version.

Montre

uname -mrs

et

dpkg -l | grep esci

  - -

J'ai appelé du renfort !  smile


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#19 Le 14/03/2018, à 20:34

moko138

Re : Epson V 330 - Xsane ne fontionne qu'en root ???

found USB scanner (vendor=0x04b8 [EPSON], product=0x0142 [EPSON Perfection V33/V330]) at libusb:003:003

(J'avais coupé libusb:003:003, précédemment).

Avant de modifier les autorisations de /proc/bus/usb/003/003, comme le préconise Epson dans le cas du retour ci-dessus, que retourne

ls -la /proc/bus/usb/003/003

?


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#20 Le 14/03/2018, à 20:52

jeange

Re : Epson V 330 - Xsane ne fontionne qu'en root ???

Bonsoir,
Des lignes de cde, en voici:

jeange@jeange-W65-67SZ:~$ dpkg -l | grep iscan
ii  iscan                                                 2.30.2-2                                            amd64        simple, easy to use scanner utility for EPSON scanners
ii  iscan-data                                            1.36.0-1                                            all          Image Scan! for Linux data files
jeange@jeange-W65-67SZ:~$ 

et cela marche très bien depuis Février 2104 (13.10) et actuellement sous 14.04.
@bjc,
depuis 2009 ce scanner est utilisé avec Image Scan! for Linux (qui est le logiciel qui tourne très bien avec les pilotes fournis par epson) ou avec la daube Xsane qui est très mal suivi ?


PCLF CLEVO W670SZQ i3-4000M Ram 8Go  Haswell HD4600 Ubuntu 14.04  18.04 LTS 64bits
033 V nospE   22.8.2  8.01.2 pmiG  X04D nokiN
Merci de donner les retours avec les balises < > et les allers avec les valises.
%NOINDEX%

Hors ligne

#21 Le 14/03/2018, à 21:04

moko138

Re : Epson V 330 - Xsane ne fontionne qu'en root ???

Merci jeange d'intervenir !  smile

Est-ce que tu te souviens d'avoir eu à faire le
sudo chmod 0666 /proc/bus/usb/003/003
que je vois dans un document d'Epson ?


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#22 Le 14/03/2018, à 21:16

jeange

Re : Epson V 330 - Xsane ne fontionne qu'en root ???

moko a écrit :

Est-ce que tu te souviens d'avoir eu à faire le
sudo chmod 0666 /proc/bus/usb/003/003
que je vois dans un document d'Epson ?

Pour moi c'est un langage aussi abscon qu'inconnu; pour faire simple c'est le regretté Alca qui m'avait initié à l'install de mon V330:
-recherche chez Epson des pilotes
-téléchargement de ces pilotes
-comment les installer DANS L'ORDRE avec Gdebi ou Logithèque
Et depuis pas de problème car je suis toujours sous 14.04 > LTS

Je pense qu'il y a un sens/ordre logique à respecter pour toute installation.
A+ wink


PCLF CLEVO W670SZQ i3-4000M Ram 8Go  Haswell HD4600 Ubuntu 14.04  18.04 LTS 64bits
033 V nospE   22.8.2  8.01.2 pmiG  X04D nokiN
Merci de donner les retours avec les balises < > et les allers avec les valises.
%NOINDEX%

Hors ligne

#23 Le 14/03/2018, à 21:25

xubu1957

Re : Epson V 330 - Xsane ne fontionne qu'en root ???


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#24 Le 14/03/2018, à 21:28

jeange

Re : Epson V 330 - Xsane ne fontionne qu'en root ???

Bonsoir xubu smile
Merci d'avoir retrouvé les fils toiles d'araignées. wink


PCLF CLEVO W670SZQ i3-4000M Ram 8Go  Haswell HD4600 Ubuntu 14.04  18.04 LTS 64bits
033 V nospE   22.8.2  8.01.2 pmiG  X04D nokiN
Merci de donner les retours avec les balises < > et les allers avec les valises.
%NOINDEX%

Hors ligne

#25 Le 14/03/2018, à 21:42

xubu1957

Re : Epson V 330 - Xsane ne fontionne qu'en root ???

jeange a écrit :

Bonsoir xubu smile
Merci d'avoir retrouvé les fils toiles d'araignées. wink

Sur la Toile, et surtout, avec la recherche motorisée. wink


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne