Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 14/03/2018, à 11:24

winux

[RÉSOLU] 16.04.4 : xkill ne fonctionne plus

Bonjour

Jusqu'à récemment lorsque j’avais une appli "gélée" j'allais sur l'icône Ubuntu en haut à gauche et je tapais xkill puis Enter.
le pointeur se transformait en X et  il me suffisait de cliquer sur la fenêtre gelée pour qu'elle disparaisse et ne gêne plus le système.

Apparemment, même après recherche sur le net ça n'existe plus.
j'ai essayé d'installer xkill
puis xorg-xkill
rien ne va

Vous savez comment s'en sortir SVP, merci

Dernière modification par winux (Le 19/03/2018, à 09:36)


http://i3.tinypic.com/4g8nio8.png
Livebox fibre - 990 Mbps mesurés -  Triple  boot : Ubuntu 16.04 & 18.04 / W10 - Ecran : Samsung 22" -
CM : Gigabyte P67A UD3 B3 - CPU : Intel Quad Core i5 3.3 GHz - GPU : nVidia Gigabyte N430
RAM : 4 Go DDR3 - deux HD de 1 To chacun

Hors ligne

#2 Le 14/03/2018, à 12:30

kholo

Re : [RÉSOLU] 16.04.4 : xkill ne fonctionne plus

salut,
et en ouvrant simplement un terminal ?
tu peux voir tout ça à la main :

sudo apt install xkill

lancer une calculatrice
ouvrir un terminal
et tenter un

xkill

Dernière modification par kholo (Le 14/03/2018, à 12:32)

Hors ligne

#3 Le 14/03/2018, à 12:48

Christophe C

Re : [RÉSOLU] 16.04.4 : xkill ne fonctionne plus

Cela existe toujours (sauf sous wayland où cela ne marche pas). Je l'ai sous 18.04.
Normalement l'utilitaire fait partie des paquets de xorg, donc pas installable à part, pour moi.

Pour le lancer :

1. terminal puis xkill
2. ctrl+alt+del (lance xkill).
3. Si xkill marche (peut-être lancé avec le terminal) mais que le raccourcis clavier ne marche pas, tu vas dans le panneau de config > raccourcis clavier et tu crée le raccourcis clavier qui va bien et lance la commande xkill

Si rien ne lance xkill, je pense que tu as un problème dans tes paquets xorg.

Tu peux aussi faire un alt+F2 pour faire apparaitre une zone de commande, et tu tapes pkill nom-application
En fait, le début du nom suffit. Par exemple pkill firef fermera firefox.


XL-WALLPAPER - changeur de fonds d'écran libre et très léger pour Xfce et LXDE.

Hors ligne

#4 Le 14/03/2018, à 15:08

Tmi

Re : [RÉSOLU] 16.04.4 : xkill ne fonctionne plus

Salut

Tu as aussi un applet (à ajouter par la barre des tâches) qui se nomme "force quit".
c'est une croix ou tu clic dessus et sur la fenêtre gelée.
Mais c'est pour cinnamon peut-être existe t'il pour tout les bureaux.


Linux en vie de Lux

Hors ligne

#5 Le 14/03/2018, à 17:48

Christophe C

Re : [RÉSOLU] 16.04.4 : xkill ne fonctionne plus

Clairement non. D'où l'utilité d'un raccourcis clavier.


XL-WALLPAPER - changeur de fonds d'écran libre et très léger pour Xfce et LXDE.

Hors ligne

#6 Le 18/03/2018, à 22:30

winux

Re : [RÉSOLU] 16.04.4 : xkill ne fonctionne plus

Bonjour

Merci à tous pour vos réponses et désolé pour la mienne tardive, car je pensais que comme avec Ubuntu je recevrais une notification par mail à chaque réponse.
Bref je suis passé par hasard et découvert vos contributions.

J'ai une très bonne solution  fournie par Christophe avec le terminal.
par contre je n'ai pas pu aller plus loin car pas trouvé le "panneau de config".

Je sais où il est avec W10 mais pas ici, tu peux m'aider (encore une fois !!)
Merci et bonne soirée

Dernière modification par winux (Le 18/03/2018, à 22:33)


http://i3.tinypic.com/4g8nio8.png
Livebox fibre - 990 Mbps mesurés -  Triple  boot : Ubuntu 16.04 & 18.04 / W10 - Ecran : Samsung 22" -
CM : Gigabyte P67A UD3 B3 - CPU : Intel Quad Core i5 3.3 GHz - GPU : nVidia Gigabyte N430
RAM : 4 Go DDR3 - deux HD de 1 To chacun

Hors ligne

#7 Le 18/03/2018, à 22:55

Coeur Noir

Re : [RÉSOLU] 16.04.4 : xkill ne fonctionne plus

pas trouvé le "panneau de config" → normal, ça s'appelle plutôt « paramètres système » et c'est probablement la partie « clavier » qui te concerne.

Sauf que sous Unity, le raccourci Ctrl+Alt+Suppr est déjà utilisé pour lancer « fermer la session ».

Par ailleurs, il vaudrait mieux savoir pourquoi tu as des appli's qui gèlent et éventuellement faire en sorte que ça n'arrive plus, plutôt qu'user de xkill à tire-larigots, non ?

Dernière modification par Coeur Noir (Le 18/03/2018, à 23:02)

En ligne

#8 Le 18/03/2018, à 23:47

Christophe C

Re : [RÉSOLU] 16.04.4 : xkill ne fonctionne plus

Gestionnaire de paramètres > clavier > raccourcis d'application > ajouter


XL-WALLPAPER - changeur de fonds d'écran libre et très léger pour Xfce et LXDE.

Hors ligne

#9 Le 19/03/2018, à 00:33

winux

Re : [RÉSOLU] 16.04.4 : xkill ne fonctionne plus

Coeur noir : je n'ai aucune appli qui gèle. Ca m'était juste arrivé une fois par le passé et j'avais utilisé la solution qui ne marche plus désormais mais pour laquelle Christophe m'a trouvé un palliatif.
De plus, à ma connaissance il n'y a pas d'Unity sous Lubuntu, juste un menu déroulant, ou alors j'ai loupé un truc !

Christophe : je suis confus mais sous Lubuntu je ne trouve pas non plus "gestionnaire de paramètres". Je suppose qu'il devrait se trouver, dans le menu sous la rubrique "outils système", mais rien, ni même un équivalent voisin.

Je vais essayer demain toutes les rubriques pour essayer de déterrer ce fameux clavier.
Pour le moment dodo car j'ai eu une dure journée

Merci pour ton aide et bonne nuit à toi aussi


http://i3.tinypic.com/4g8nio8.png
Livebox fibre - 990 Mbps mesurés -  Triple  boot : Ubuntu 16.04 & 18.04 / W10 - Ecran : Samsung 22" -
CM : Gigabyte P67A UD3 B3 - CPU : Intel Quad Core i5 3.3 GHz - GPU : nVidia Gigabyte N430
RAM : 4 Go DDR3 - deux HD de 1 To chacun

Hors ligne

#10 Le 19/03/2018, à 01:06

Coeur Noir

Re : [RÉSOLU] 16.04.4 : xkill ne fonctionne plus

je n'ai aucune appli qui gèle → bah pourquoi t'as besoin d'xkill alors ?

Lubuntu → je ne peux pas deviner ton environnement de bureau, hein, puisque tu ne le précises pas toi-même ;-)

Palliatif → non il ne s'agit pas d'un palliatif, si tu peux lancer xkill depuis le terminal, c'est que xkill est bien installé sur ton système ( le contraire eut été très étonnant ) et pour ma part, c'est toujours de cette façon que j'ai vu xkill fonctionner.

Si je comprends bien tu voudrais trouver xkill dans ton menu d'applications.
Pour cela crée un lanceur ( un fichier .desktop ) que tu placeras dans ~/.local/share/applications nommé xkill.desktop

#!/usr/bin/env xdg-open
[Desktop Entry]
Type=Application
Name=Xkill
GenericName=xkill
Comment=kill a graphical process in xorg
Comment[fr]=tuer un processus graphique dans xorg
Terminal=true
Exec=xkill
Icon=applications-utilities

…rendre exécutable ce fichier via clic-droit, propriétés, permissions…

Dernière modification par Coeur Noir (Le 19/03/2018, à 01:58)

En ligne

#11 Le 19/03/2018, à 09:10

winux

Re : [RÉSOLU] 16.04.4 : xkill ne fonctionne plus

Bonjour

Mea culpa à tous, je comprends mieux le quiproquo qui s'est établi entre nous. En fait j'étais persuadé avoir mis le sujet dans la section LXDE car j'ai un autre Pb sur le feu avec mon Lubuntu qui refuse mon sudo update-grub.

Bref, toutes vos réponses sont désormais limpides sous Ubuntu (qui était bien la demande initiale !) et vais les mettre en œuvre de ce pas. Pour LXDE, je garde en tête la solution terminal + xkill qui fera très bien l'affaire.

Merci à Christophe et Coeur Noir, et désolé de vous avoir fait perdre votre temps car je me souviens de vos interventions pertinentes et de bon niveau sur le forum 17.10 et vous suivrai sur 18.04

Bonne journée et encore merci


http://i3.tinypic.com/4g8nio8.png
Livebox fibre - 990 Mbps mesurés -  Triple  boot : Ubuntu 16.04 & 18.04 / W10 - Ecran : Samsung 22" -
CM : Gigabyte P67A UD3 B3 - CPU : Intel Quad Core i5 3.3 GHz - GPU : nVidia Gigabyte N430
RAM : 4 Go DDR3 - deux HD de 1 To chacun

Hors ligne

#12 Le 19/03/2018, à 09:35

winux

Re : [RÉSOLU] 16.04.4 : xkill ne fonctionne plus

Coeur Noir : Wahhoooooooo génial ton truc, je retrouve bien le couteau Suisse dans applis, viens de l'essayer et .... ça marche.

Christophe : Cette fois j'ai mis en oeuvre  ta suggestion sans difficulté ... dans Ubuntu !! entré Ctrl+k comme raccourci, mais quand je le lance il ne se passe rien ? j'ai dû rater un truc sur la fin, mais quoi ? voici la copie de ma commande :

16kaxxt.png

Un grand merci à vous deux (Coeur Noir et Christophe) vous avez résolu mon Pb dans les deux environnement de façon exemplaire, je garde tout ça en mémoire.

Reste plus que le raccourci clavier, juste pour ma culture perso mais pas vital vu que j'ai désormais une solution.

Bonne journée à vous, affaire résolue promptement à partir du moment où on parlait de la même chose roll


http://i3.tinypic.com/4g8nio8.png
Livebox fibre - 990 Mbps mesurés -  Triple  boot : Ubuntu 16.04 & 18.04 / W10 - Ecran : Samsung 22" -
CM : Gigabyte P67A UD3 B3 - CPU : Intel Quad Core i5 3.3 GHz - GPU : nVidia Gigabyte N430
RAM : 4 Go DDR3 - deux HD de 1 To chacun

Hors ligne

#13 Le 19/03/2018, à 10:11

cqfd93

Re : [RÉSOLU] 16.04.4 : xkill ne fonctionne plus

Modération

Bonjour,

Ce sujet n'aurait même pas dû se trouver dans la section « Installation de logiciels et changements de version » puisqu'il n'est pas fait mention de mises à jour mais plutôt dans « Autres logiciels et problèmes généraux » et bien sûr, encore mieux, dans « LXDE ». Comme quoi quand on demande de l'aide il faut toujours veiller à donner un maximum d'informations exactes…

Je déplace dans « LXDE ».


cqfd93

Hors ligne

#14 Le 19/03/2018, à 13:26

Christophe C

Re : [RÉSOLU] 16.04.4 : xkill ne fonctionne plus

Je n'avais pas compris (deviné smile ) que tu étais sous LXDE, mais j'aurais pu demander. Ensuite, tu peux ajouter des raccourcis clavier dans lubuntu. A une époque je faisais ça (je n'utilise plus lubuntu) :

leafpad  /.config/openbox/lubuntu-rc.xml

Ajouter à la fin ton raccourcis, par exemple :

<keybind key="C-A-D">
<action name="Execute">
<command>xkill</command>
</action>
</keybind>

(ou <keybind key="A-F2"> pour alt-f2, ...)

Si /.config/openbox/lubuntu-rc.xml n'existe pas (mais il devrait, sauf erreur), il faut aller le récupérer dans les fichiers système et le copier dans /.config/openbox/

Dernière modification par Christophe C (Le 19/03/2018, à 20:22)


XL-WALLPAPER - changeur de fonds d'écran libre et très léger pour Xfce et LXDE.

Hors ligne

#15 Le 19/03/2018, à 22:49

moko138

Re : [RÉSOLU] 16.04.4 : xkill ne fonctionne plus

Christophe C a écrit :

ajouter des raccourcis clavier dans lubuntu.

leafpad  /.config/openbox/lubuntu-rc.xml

Ajouter à la fin ton raccourcis, par exemple :

<keybind key="C-A-D">
<action name="Execute">
<command>xkill</command>
</action>
</keybind>

(ou <keybind key="A-F2"> pour alt-f2, ...)

Super ! Merci Christophe C !


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#16 Le 19/03/2018, à 23:37

Coeur Noir

Re : [RÉSOLU] 16.04.4 : xkill ne fonctionne plus

Supposition de ma part concernant « entrée Ctrl+k comme raccourci, mais quand je le lance il ne se passe rien ? j'ai dû rater un truc sur la fin, mais quoi ? » :
xkill a besoin du terminal pour fonctionner semble-t-il, c'est pour ça que dans le lanceur que je propose la valeur de Terminal est à true. J'ai essayé avec false ( qui est le cas des appli's ayant une interface graphique ) et dans ce cas l'icône se lance, mais pas le curseur en ×, puis disparaît au bout d'un moment.

On doit pouvoir - dans raccourcis clavier - écrire une commande pour lancer un terminal qui lance xkill ? ? ? Je ne sais pas…

Dernière modification par Coeur Noir (Le 19/03/2018, à 23:39)

En ligne

#17 Le 20/03/2018, à 10:44

Christophe C

Re : [RÉSOLU] 16.04.4 : xkill ne fonctionne plus

Je n'ai plus lubuntu, donc je ne peut pas tester, mais pour moi xkill ne tourne pas seulement dans un terminal. En tout pas dans xfce.


XL-WALLPAPER - changeur de fonds d'écran libre et très léger pour Xfce et LXDE.

Hors ligne

#18 Le 20/03/2018, à 11:50

Coeur Noir

Re : [RÉSOLU] 16.04.4 : xkill ne fonctionne plus

Ah bon ? Ici sous Unity je ne peux le lancer que via un terminal, sans terminal : pas d'instruction affichée ni pointeur de souris en x...

En ligne

#19 Le 20/03/2018, à 14:16

Christophe C

Re : [RÉSOLU] 16.04.4 : xkill ne fonctionne plus

Dans xfce : ctrl+alt+del lance xkill. C'est un raccourcis du système par défaut.
Cela fait apparaître une icone, et il n'y a plus qu'à cliquer sur le prog à fermer.

Pour Unity je ne sais pas, mais je suis raisonnablement sur que le passage par le terminal n'est pas indispensable, et qu'une combinaison de touche marche également.

Au pire, je suppose que alt+F2 puis taper xkill doit aussi marcher ?


XL-WALLPAPER - changeur de fonds d'écran libre et très léger pour Xfce et LXDE.

Hors ligne

#20 Le 21/03/2018, à 00:07

Coeur Noir

Re : [RÉSOLU] 16.04.4 : xkill ne fonctionne plus

alt+F2 puis taper xkill doit aussi marcher ? … ah bah oui bien vu, et point de terminal qui apparaît, direct le pointeur de souris en × !

Bon alors bizarre que ça ne fonctionne pas de même depuis un lanceur… Rrrrôôôooo bah si ça marche !!! Faut dire qu'à l'heure où j'ai testé j'avais p'têt plus les yeux en face des trous, ou pas mes lunettes !

Donc le lanceur peut tout à fait être :

#!/usr/bin/env xdg-open
[Desktop Entry]
Type=Application
Name=Xkill
GenericName=xkill
Comment=kill a graphical process in xorg
Comment[fr]=tuer un processus graphique dans xorg
Terminal=false
Exec=xkill
Icon=applications-utilities

En ligne

#21 Le 21/03/2018, à 15:19

winux

Re : [RÉSOLU] 16.04.4 : xkill ne fonctionne plus

cqfd93 a écrit :

Modération

Bonjour,

Ce sujet n'aurait même pas dû se trouver dans la section « Installation de logiciels et changements de version » puisqu'il n'est pas fait mention de mises à jour mais plutôt dans « Autres logiciels et problèmes généraux » et bien sûr, encore mieux, dans « LXDE ». Comme quoi quand on demande de l'aide il faut toujours veiller à donner un maximum d'informations exactes…
Je déplace dans « LXDE ».

C'est ce que j'ai expliqué dans #11 car j'étais persuadé l'avoir mis au bon endroit, désolé, merci pour le mouvement


http://i3.tinypic.com/4g8nio8.png
Livebox fibre - 990 Mbps mesurés -  Triple  boot : Ubuntu 16.04 & 18.04 / W10 - Ecran : Samsung 22" -
CM : Gigabyte P67A UD3 B3 - CPU : Intel Quad Core i5 3.3 GHz - GPU : nVidia Gigabyte N430
RAM : 4 Go DDR3 - deux HD de 1 To chacun

Hors ligne

#22 Le 21/03/2018, à 15:35

winux

Re : [RÉSOLU] 16.04.4 : xkill ne fonctionne plus

Christophe C a écrit :

Dans xfce : ctrl+alt+del lance xkill. C'est un raccourcis du système par défaut.
Cela fait apparaître une icone, et il n'y a plus qu'à cliquer sur le prog à fermer

Salut
Chez moi en LXDE ça ouvre la fenêtre gestionnaires des tâches, ça ne marche pas tout à fait pareil, dommage !!


http://i3.tinypic.com/4g8nio8.png
Livebox fibre - 990 Mbps mesurés -  Triple  boot : Ubuntu 16.04 & 18.04 / W10 - Ecran : Samsung 22" -
CM : Gigabyte P67A UD3 B3 - CPU : Intel Quad Core i5 3.3 GHz - GPU : nVidia Gigabyte N430
RAM : 4 Go DDR3 - deux HD de 1 To chacun

Hors ligne