Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

N'oubliez pas de cocher la case « Ajustement pour l'heure d'été » dans votre profil.

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 04/04/2018, à 17:59

fraspaeter

[RESOLU] Mauvaise définition écran après MAJ noyau. Radéon RS880

Bonjour,

Ubuntu 17.10
Lors de la dernière MAJ du kernel, le système ne reconnaissait plus ma carte graphique Radéon RS880.
La définition était nettement inférieure au 1920x1080 habituel.
Réponse terminal à : cat /proc/version
"Linux version 4.13.0-38-generic (buildd@lgw01-amd64-042) (gcc version 7.2.0 (Ubuntu 7.2.0-8ubuntu3.2)) #43-Ubuntu SMP Wed Mar 14 15:20:44 UTC 2018"

J'ai mis longtemps à trouver sur le forum, mais voilà ce qui a marché.

Il faut modifier le fichier d'amorçage grub de la façon suivante.
Dans le terminal: sudo nano etc/default/grub

  GNU nano 2.8.6              Fichier : /etc/default/grub                       

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.dpm=0"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

Il faut juste rajouter sur la ligne GRUB_CMDLINE_LINUX_DEFAULT, comme ci-dessus, radeon.dpm=0

Valider (Ctrl o) puis sortir (Ctrl x)
puis saisir : sudo update-grub

Résultats:
Dans les paramètres, détails, je retrouve en carte graphique Radeon RS880 et la définition est à nouveau 1920x1080.

En espérant que ce soit utile à quelqu'un d'autre

Dernière modification par fraspaeter (Le 11/04/2018, à 09:47)

Hors ligne