Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

N'oubliez pas de cocher la case « Ajustement pour l'heure d'été » dans votre profil.

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 26/03/2006, à 03:32

Fukurou

Problème de reconnaissance de casque-micro USB

Bonjour bonjour smile
J'ai un petit problème de matériel sonore...
Mes hauts parleurs fonctionnent, par contre le casque, niet...est-ce qu'il y a quelque chose de spécifique à faire si on veut faire reconnaître un casque-micro sous Ubuntu ?
Voilà, en espérant qu'un aimable Linuxien fera part de ses lumières à un nOOb tout juste sorti de Microsatan XP...
Merci d'avance big_smile

(en passant, j'ai oublié de citer le modèle, ça peut servir : c'est un Trust HS-4100 USB)

Dernière modification par Fukurou (Le 26/03/2006, à 03:40)

Hors ligne

#2 Le 29/03/2006, à 18:57

Fukurou

Re : Problème de reconnaissance de casque-micro USB

C'est pas mon habitude de poster pour rien, mais juste un petit up pour être sûr...personne n'a jamais rencontré ce problème (sous KDE précisémment) ?
Bizarre sad

Hors ligne

#3 Le 30/03/2006, à 13:11

Fukurou

Re : Problème de reconnaissance de casque-micro USB

Bonben voilà, j'ai reçu une réponse par mail du service de chez Trust :

Cher Monsieur,

Ce casque ne supporte en effet pas les systèmes autres que Windows, comme
précidé sur ses minimums requis.

hmm:/:/
Donc j'imagine qu'il n'y aucun moyen d'arranger ça...c'est la même chose en général pour les périph USB ?
Assez décourageant...

Hors ligne

#4 Le 30/03/2006, à 15:51

Fukurou

Re : Problème de reconnaissance de casque-micro USB

Bon, comme je ne suis pas  du genre à abandonner facilement et qu'il arrive que les hotline ne soient pas totalement qualifiées, j'ai poussé la recherche plus loin.

J'entre donc

/bin/dmesg | grep usb

qui me permet de voir les périph USB identifiés.
Et là, que vois-je ?

[4295673.599000] usb 5-5: USB disconnect, address 3
[4295674.307000] usb 3-1: new full speed USB device using uhci_hcd and address 2
[4295674.393000] usb 3-1: not running at top speed; connect to a high speed hub
[4295674.408000] usb-storage: device found at 2
[4295674.408000] usb-storage: waiting for device to settle before scanning
[4295674.577000] usb 3-2: new full speed USB device using uhci_hcd and address 3
[4295674.678000] input: USB HID v1.00 Device [C-Media USB Headphone Set  ] on us                                            b-0000:00:10.2-2
[4295675.266000] usbcore: registered new driver snd-usb-audio
[4295679.595000] usb-storage: device scan complete
[4295699.751000] usb 3-2: USB disconnect, address 3
[4295717.487000] usb 1-2: new full speed USB device using uhci_hcd and address 2
[4295717.783000] input: USB HID v1.00 Device [C-Media USB Headphone Set  ] on us                                            b-0000:00:10.0-2
[4295766.320000] usb 1-2: USB disconnect, address 2
[4295773.220000] usb 3-2: new full speed USB device using uhci_hcd and address 4
[4295773.458000] input: USB HID v1.00 Device [C-Media USB Headphone Set  ] on us                                            b-0000:00:10.2-2
[4295800.456000] usb 3-2: USB disconnect, address 4

Apparemment, le casque est donc bel et bien identifié si j'en crois la dernière ligne.
Maintenant, pourquoi ne transmet-il pas de son ?
Mystère, je continue les recherches à l'aveuglette vu mon niveau, mais si quelqu'un a des conseils, il est bienvenu smile

Hors ligne

#5 Le 30/03/2006, à 16:24

Stemp

Re : Problème de reconnaissance de casque-micro USB

http://www.ubuntuforums.org/showpost.ph … ostcount=5[en]

PS : je me suis permis de modifier ton titre pour faire apparaitre usb wink


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#6 Le 30/03/2006, à 17:55

bergiautaf

Re : Problème de reconnaissance de casque-micro USB

il se peut que ton casque usb soit reconnu par contre ubuntu utilse ta carte son par defaut, en console peut tu faire :

ls /etc/dsp*

Pour voir si tu a plusieur varte son active

Cela dit un casque usb alors qu'un connecteur pour carte son suffit ....

#7 Le 30/03/2006, à 18:01

Fukurou

Re : Problème de reconnaissance de casque-micro USB

Merci, on touche au but je crois.
Mais j'ai peut-être mal compris vu que ça ne amrche toujours pas...en fait, je ne suis pas sûr de la traduction à partir de là :

Then change /etc/modprobe.d/alsa-base so snd_intel8x0 does not grab index 0:

echo "options snd_intel8x0 index=-2" | sudo tee -a /etc/modprobe.d/alsa-base

just ensure snd_usb_audio is not set to index=2

Bon déjà, si avec cat /proc/asound/modules, j'ai autre chose que intel8x0, je remplace par ce que j'ai je suppose.
Mais après je patauge un peu.."do not grab index 0:" ? c'est à dire ?
Pareil pour "echo"  ? C'est une commande, c'est quoi ? Ca ne donne rien en tout cas tel quel...
Enfin bref, concrètement, il faut faire quoi, étape par étape ?
Si quelqu'un avait la gentillesse de me traduire cette partie...je comprends l'anglais mais avec les commandes et tout...j'avoue que je patauge.
En tout cas merci, c'est la bonne voie je pense smile

EDIT : Je viens de tester ta commande mais ça ne donne rien Bergi...enfin je suppose qu'il faut remplacer l'étoile par quelque chose ?

Re-EDIT : Ah, alors en fait il dit qu'il y a pas de répertoire DSP...donc j'ai listé etc, et ça donne :
http://pastebin.com/630955

Dernière modification par Fukurou (Le 30/03/2006, à 18:06)

Hors ligne

#8 Le 31/03/2006, à 18:32

Fukurou

Re : Problème de reconnaissance de casque-micro USB

Mon pastebin a pas l'air d'avoir marché la première fois hmm...j'en ai refait un :
http://pastebin.com/632856
Si quelqu'un peut m'aider à identifier les cartes son là-dedans...

EDIT : le pire c'est que même dans K-mix il reconnaît un casque USB..mais pas de son, c'ets dingue hmm

Dernière modification par Fukurou (Le 31/03/2006, à 19:47)

Hors ligne

#9 Le 01/04/2006, à 02:28

Fukurou

Re : Problème de reconnaissance de casque-micro USB

Yeaaaaaaah !
Près d'une semaine de lutte acharnée, et enfin, ça marche big_smile !
Donc voilà la solution pour ceux qui galèreront aussi sur ce point : il fallait bel et bien appliquer ce qui est dit ici http://www.ubuntuforums.org/showpost.ph … ostcount=5
Sauf que au lieu de taper tel quel

echo "options snd_intel8x0 index=-2" | sudo tee -a /etc/modprobe.d/alsa-base

il fallait taper

options snd_intel8x0 index=-2 | sudo tee -a /etc/modprobe.d/alsa-base

tout simplement ^_^

Hors ligne

#10 Le 01/04/2006, à 11:57

Fukurou

Re : Problème de reconnaissance de casque-micro USB

Ah oui par contre, ça marche bien pour le casque mais plus pour les haut-parleur ensuite...je suis forcé de d'effacer cette, et de redémarrer...ce qui risque d'être un peu contraignant à faire à chaque fois...
Je devrais pouvoir choisir depuis Kmix, mais celui-ci ne me propose plus que le micro une fois la ligne entrée...

Hors ligne

#11 Le 10/04/2006, à 01:57

Fukurou

Re : Problème de reconnaissance de casque-micro USB

Et hop, en tatonnant un peu, la victoire est définitive, je donne ma solution en espérant que ça serve aux autres smile
Tout d'abord, avec le casque USB branché :

cat /proc/asound/modules

pour savoir ce qu'on a comme cartes sons.
En théorie, y'en a deux, chez moi ça donne :

0 snd_usb_audio
1 snd_via82xx

Ensuite,

sudo gedit /etc/modprobe.d/alsa-base

Là dedans, on va tout en bas, et on entre

options snd_usb_audio-modem index=-2
options snd-via82xx-modem index=-2

Avec le usb en premier, surtout (bien entendu si vous n'avez pas eu via82xx au début, vous adaptez).
On sauvegarde en écrasant la précédente version, on ferme le fichier.
Dernière étape :

sudo gedit /etc/modules

On rajoute en bas du fichier

snd_usb_audio
snd_via82xx

On redémarre l'ordi pour finaliser les changements.
Et là, ça devrait marcher.
Si c'est pas le cas, faudra régler Kmix en clickant droit sur l'icone ; puis "choisir un canal", et regler sur usb headphone set.

Et voilà big_smile

Dernière modification par Fukurou (Le 10/04/2006, à 01:59)

Hors ligne

#12 Le 04/06/2006, à 14:26

Zardoz

Re : Problème de reconnaissance de casque-micro USB

Un grand merci à toi !
Grâce à ta manip j'ai pu faire fonctionner mon kit Plantronics USB. big_smile

Hors ligne

#13 Le 04/07/2009, à 21:33

Emmo30

Re : Problème de reconnaissance de casque-micro USB

Et 3 ans plus tard ..., Merci sa a l'air de fonctionner ton truc mais chez moi sa donne rien sad

Dernière modification par Emmo30 (Le 04/07/2009, à 22:02)

Hors ligne

#14 Le 12/04/2018, à 21:06

you-or-me

Re : Problème de reconnaissance de casque-micro USB

Merci infiniment, grâce à tes conseilles ça a bien marché big_smile

Hors ligne

#15 Le 12/04/2018, à 21:27

you-or-me

Re : Problème de reconnaissance de casque-micro USB

Je rajoute ce lien pour ceux qui ont trouvé un souci avec cisco IP communicater
https://ubuntuforums.org/showthread.php?t=2258542

Hors ligne