Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 16/04/2018, à 16:57

aranoa

wordpress

Bonjour,
j'ai suivi plusieurs tutos à la lettre et je n'arrive pas à installer wordpress pouvez vous m'aider merci.

Hors ligne

#2 Le 16/04/2018, à 17:37

elcastor

Re : wordpress

heu oui mais où ?

Hors ligne

#3 Le 16/04/2018, à 19:17

aranoa

Re : wordpress

Je voudrais désinstaller un worpress que j'ai sur le pc et je n'y arrive pas et je n'arrive pas à créer une base de donnée apres le chargement de apache donc je voudrais tout supprimer et reprendre à zéro

Hors ligne

#4 Le 16/04/2018, à 20:15

krodelabestiole

Re : wordpress

aranoa a écrit :

j'ai suivi plusieurs tutos à la lettre

c'est plutôt une mauvaise idée, il vaut mieux suivre un tuto unique. en l'occurrence il y a une page sur la doc : https://doc.ubuntu-fr.org/wordpress

pour te dire comment désinstaller wordpress il faudrait déjà que tu nous dises en détail comment tu l'as installé...

Hors ligne

#5 Le 18/04/2018, à 10:56

aranoa

Re : wordpress

J'ai désinstallé worpress et j'ai voulu réinstaller en commençant par le pile LAMP pour apache2 en suivant https://doc.ubuntu-fr.org/lamp#installation mais arrivé à la commande sudo apt install mysql-server ça ne marche pas et j'ai un message erreur en me disant que le systhéme des paquets est cassé et je n'arrive pas à rétablir la situation donc je suis bloqué pour continuer mon instalation.

jean-henri@jeanhenri-G5342fr-m:~$ sudo apt install apache2 php mysql-server libapache2-mod-php php-mysql
[sudo] Mot de passe de jean-henri : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
libapache2-mod-php est déjà la version la plus récente (1:7.0+35ubuntu6.1).
mysql-server est déjà la version la plus récente (5.7.21-0ubuntu0.16.04.1).
php est déjà la version la plus récente (1:7.0+35ubuntu6.1).
php-mysql est déjà la version la plus récente (1:7.0+35ubuntu6.1).
apache2 est déjà la version la plus récente (2.4.18-2ubuntu3.7).
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
 mysql-server : Dépend: mysql-server-5.7 mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).
jean-henri@jeanhenri-G5342fr-m:~$ sudo apt install php-curl php-gd php-intl php-json php-mbstring php-mcrypt php-xml php-zip
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
php-curl est déjà la version la plus récente (1:7.0+35ubuntu6.1).
php-gd est déjà la version la plus récente (1:7.0+35ubuntu6.1).
php-intl est déjà la version la plus récente (1:7.0+35ubuntu6.1).
php-json est déjà la version la plus récente (1:7.0+35ubuntu6.1).
php-mbstring est déjà la version la plus récente (1:7.0+35ubuntu6.1).
php-mcrypt est déjà la version la plus récente (1:7.0+35ubuntu6.1).
php-xml est déjà la version la plus récente (1:7.0+35ubuntu6.1).
php-zip est déjà la version la plus récente (1:7.0+35ubuntu6.1).
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
 mysql-server : Dépend: mysql-server-5.7 mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).
jean-henri@jeanhenri-G5342fr-m:~$ sudo apt install mysql-server
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
mysql-server est déjà la version la plus récente (5.7.21-0ubuntu0.16.04.1).
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
 mysql-server : Dépend: mysql-server-5.7 mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).
jean-henri@jeanhenri-G5342fr-m:~$ sudo  apt-get -f install
sudo:  apt-get : commande introuvable
jean-henri@jeanhenri-G5342fr-m:~$ sudo mysql -u root
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
jean-henri@jeanhenri-G5342fr-m:~$ sudo apt install mysql-server
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
mysql-server est déjà la version la plus récente (5.7.21-0ubuntu0.16.04.1).
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
 mysql-server : Dépend: mysql-server-5.7 mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).
jean-henri@jeanhenri-G5342fr-m:~$ sudo su
root@jeanhenri-G5342fr-m:/home/jean-henri# sudo mysql -u root
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
root@jeanhenri-G5342fr-m:/home/jean-henri# exit
exit
jean-henri@jeanhenri-G5342fr-m:~$ mysql> ALTER USER 'root'@'localhost' IDENTIFIED WITH mysql_native_password BY 'le_mot_de_pass_choisi';
jean-henri@jeanhenri-G5342fr-m:~$ mysql> FLUSH PRIVILEGES;
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
jean-henri@jeanhenri-G5342fr-m:~$ sudo apt install mysql-server
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
mysql-server est déjà la version la plus récente (5.7.21-0ubuntu0.16.04.1).
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
 mysql-server : Dépend: mysql-server-5.7 mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).
jean-henri@jeanhenri-G5342fr-m:~$ sudo apt-get install -f
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libdbd-mysql-perl libdbi-perl libreadline5 libterm-readkey-perl
  mariadb-common
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets supplémentaires suivants vont être installés :
  mysql-server-5.7
Paquets suggérés :
  tinyca
Les NOUVEAUX paquets suivants seront installés :
  mysql-server-5.7
0 mis à jour, 1 nouvellement installés, 0 à enlever et 28 non mis à jour.
4 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/2 724 ko dans les archives.
Après cette opération, 48,4 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Préconfiguration des paquets...
(Lecture de la base de données... 286380 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../mysql-server-5.7_5.7.21-0ubuntu0.16.04.1_amd64.deb ...
Aborting downgrade from (at least) 10.0 to 5.7.
If are sure you want to downgrade to 5.7, remove the file
/var/lib/mysql/debian-*.flag and try installing again.
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/mysql-server-5.7_5.7.21-0ubuntu0.16.04.1_amd64.deb (--unpack) :
 le sous-processus nouveau script pre-installation a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/mysql-server-5.7_5.7.21-0ubuntu0.16.04.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
jean-henri@jeanhenri-G5342fr-m:~$ 

Hors ligne

#6 Le 18/04/2018, à 11:02

aranoa

Re : wordpress

[img=capture d'écran]file:///home/jean-henri/Images/Capture%20du%202018-04-18%2010-57-28.png[/img]

Hors ligne

#8 Le 18/04/2018, à 11:36

krodelabestiole

Re : wordpress

aranoa a écrit :
Aborting downgrade from (at least) 10.0 to 5.7.

visiblement tu as installé mariadb (d'où l'intérêt de ne pas suivre 18 tutos). il faut que tu choisisses entre mariadb et mysql :
https://doc.ubuntu-fr.org/lamp#conflit_ … et_mariadb

Hors ligne

#9 Le 19/04/2018, à 10:14

aranoa

Re : wordpress

Bonjour j'ai fait ce que tu m'a dit mais il y a un soucis avec les paquets et je n'arrive pas à ouvrir le serveur avec la commande http://127.0.0.1 ou http://localhost pour faire le test .Je serai présent cet aprés midi à partir de 14h si vous êtes la merci.

jean-henri@jeanhenri-G5342fr-m:~$ sudo apt install apache2 php mysql-server libapache2-mod-php php-mysql
[sudo] Mot de passe de jean-henri : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
libapache2-mod-php est déjà la version la plus récente (1:7.0+35ubuntu6.1).
mysql-server est déjà la version la plus récente (5.7.21-0ubuntu0.16.04.1).
php est déjà la version la plus récente (1:7.0+35ubuntu6.1).
php-mysql est déjà la version la plus récente (1:7.0+35ubuntu6.1).
apache2 est déjà la version la plus récente (2.4.18-2ubuntu3.7).
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
 mysql-server : Dépend: mysql-server-5.7 mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).
jean-henri@jeanhenri-G5342fr-m:~$ sudo apt install php-curl php-gd php-intl php-json php-mbstring php-mcrypt php-xml php-zip
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
php-curl est déjà la version la plus récente (1:7.0+35ubuntu6.1).
php-gd est déjà la version la plus récente (1:7.0+35ubuntu6.1).
php-intl est déjà la version la plus récente (1:7.0+35ubuntu6.1).
php-json est déjà la version la plus récente (1:7.0+35ubuntu6.1).
php-mbstring est déjà la version la plus récente (1:7.0+35ubuntu6.1).
php-mcrypt est déjà la version la plus récente (1:7.0+35ubuntu6.1).
php-xml est déjà la version la plus récente (1:7.0+35ubuntu6.1).
php-zip est déjà la version la plus récente (1:7.0+35ubuntu6.1).
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
 mysql-server : Dépend: mysql-server-5.7 mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).
jean-henri@jeanhenri-G5342fr-m:~$ sudo apt install mysql-server
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
mysql-server est déjà la version la plus récente (5.7.21-0ubuntu0.16.04.1).
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
 mysql-server : Dépend: mysql-server-5.7 mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).
jean-henri@jeanhenri-G5342fr-m:~$ 

Dernière modification par aranoa (Le 19/04/2018, à 10:43)

Hors ligne

#10 Le 19/04/2018, à 12:27

krodelabestiole

Re : wordpress

aranoa a écrit :

Bonjour j'ai fait ce que tu m'a dit

c'est à dire ?
pour l'instant il semble que tu aies toujours le même problème.

Hors ligne

#11 Le 19/04/2018, à 13:40

aranoa

Re : wordpress

j'ai suivi le lien que tu m'a envoyé https://doc.ubuntu-fr.org/lamp#conflit_ … et_mariadb et j'ai fait exactement toutes les manips qu'il y a dessus et ensuite j'ai voulu remettre LAMP et la j'ai ce message pour les paquets

Hors ligne

#12 Le 19/04/2018, à 13:57

krodelabestiole

Re : wordpress

tu peux coller ici l'ensemble des retours de la console quand tu fais ces manips stp ?

sudo apt autoremove --purge mysql* mariadb*
sudo apt clean
sudo mv /var/lib/mysql /var/lib/mysql_bak
sudo mv /etc/mysql /etc/mysql_bak
sudo apt install mysql-server

Dernière modification par krodelabestiole (Le 19/04/2018, à 13:58)

Hors ligne

#13 Le 19/04/2018, à 13:59

krodelabestiole

Re : wordpress

(et pas besoin de réinstaller lamp, tout est déjà installé, tu as juste un problème avec le serveur MySQL)

Hors ligne

#14 Le 19/04/2018, à 14:05

aranoa

Re : wordpress

Voila

jean-henri@jeanhenri-G5342fr-m:~$ sudo apt autoremove --purge mysql* mariadb*
[sudo] Mot de passe de jean-henri : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Note, selecting 'mariadb-test' for glob 'mariadb*'
Note, selecting 'mariadb-test-data-10.0' for glob 'mariadb*'
Note, selecting 'mariadb-test-data' for glob 'mariadb*'
Note, selecting 'mariadb-test-5.5' for glob 'mariadb*'
Note, selecting 'mariadb-common' for glob 'mariadb*'
Note, selecting 'mariadb-plugin-connect' for glob 'mariadb*'
Note, selecting 'mariadb-server-core-5.5' for glob 'mariadb*'
Note, selecting 'mariadb-server-5.5' for glob 'mariadb*'
Note, selecting 'mariadb-tokudb-engine-5.5' for glob 'mariadb*'
Note, selecting 'mariadb-server-core-10.0' for glob 'mariadb*'
Note, selecting 'mariadb-connect-engine-10.0' for glob 'mariadb*'
Note, selecting 'mariadb-galera-server' for glob 'mariadb*'
Note, selecting 'mariadb-client-5.5' for glob 'mariadb*'
Note, selecting 'mariadb-server-10.0' for glob 'mariadb*'
Note, selecting 'mariadb-plugin-oqgraph' for glob 'mariadb*'
Note, selecting 'mariadb-plugin-spider' for glob 'mariadb*'
Note, selecting 'mariadb-galera-server-10.0' for glob 'mariadb*'
Note, selecting 'mariadb-plugin-tokudb' for glob 'mariadb*'
Note, selecting 'mariadb-client-10.0' for glob 'mariadb*'
Note, selecting 'mariadb-server' for glob 'mariadb*'
Note, selecting 'mariadb-tokudb-engine-10.0' for glob 'mariadb*'
Note, selecting 'mariadb-client-core-10.0' for glob 'mariadb*'
Note, selecting 'mariadb-client' for glob 'mariadb*'
Note, selecting 'mariadb-test-10.0' for glob 'mariadb*'
Note, selecting 'mariadb-oqgraph-engine-10.0' for glob 'mariadb*'
Note, selecting 'mariadb-galera-server-5.5' for glob 'mariadb*'
Note, selecting 'mariadb-client-core-5.5' for glob 'mariadb*'
Note, selecting 'mariadb-plugin-mroonga' for glob 'mariadb*'
Le paquet « mariadb-server-5.5 » n'est pas installé, et ne peut donc être supprimé
Le paquet « mariadb-client-5.5 » n'est pas installé, et ne peut donc être supprimé
Le paquet « mariadb-client-core-5.5 » n'est pas installé, et ne peut donc être supprimé
Le paquet « mariadb-galera-server-10.0 » n'est pas installé, et ne peut donc être supprimé
Le paquet « mariadb-connect-engine-10.0 » n'est pas installé, et ne peut donc être supprimé
Le paquet « mariadb-oqgraph-engine-10.0 » n'est pas installé, et ne peut donc être supprimé
Le paquet « mariadb-tokudb-engine-10.0 » n'est pas installé, et ne peut donc être supprimé
Le paquet « mariadb-tokudb-engine-5.5 » n'est pas installé, et ne peut donc être supprimé
Le paquet « mariadb-galera-server » n'est pas installé, et ne peut donc être supprimé
Le paquet « mariadb-galera-server-5.5 » n'est pas installé, et ne peut donc être supprimé
Le paquet « mariadb-server-core-5.5 » n'est pas installé, et ne peut donc être supprimé
Le paquet « mariadb-test-10.0 » n'est pas installé, et ne peut donc être supprimé
Le paquet « mariadb-test-5.5 » n'est pas installé, et ne peut donc être supprimé
Le paquet « mariadb-test-data-10.0 » n'est pas installé, et ne peut donc être supprimé
E: Impossible de trouver le paquet mysql
jean-henri@jeanhenri-G5342fr-m:~$ sudo apt clean
jean-henri@jeanhenri-G5342fr-m:~$ sudo mv /var/lib/mysql /var/lib/mysql_bak
mv: impossible d'évaluer '/var/lib/mysql': Aucun fichier ou dossier de ce type
jean-henri@jeanhenri-G5342fr-m:~$ sudo mv /etc/mysql /etc/mysql_bak
mv: impossible d'évaluer '/etc/mysql': Aucun fichier ou dossier de ce type
jean-henri@jeanhenri-G5342fr-m:~$ sudo apt install mysql-server
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
mysql-server est déjà la version la plus récente (5.7.21-0ubuntu0.16.04.1).
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
 mysql-server : Dépend: mysql-server-5.7 mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).
jean-henri@jeanhenri-G5342fr-m:~$ 

Hors ligne

#15 Le 19/04/2018, à 14:16

krodelabestiole

Re : wordpress

ok c'est pas la première fois que tu tapes ces commandes, du coup on peut pas voir ce qui a été désinstallé...

mais maintenant quel est le retour de :

sudo apt install -f

Hors ligne

#16 Le 19/04/2018, à 14:24

aranoa

Re : wordpress

il y a des erreurs

jean-henri@jeanhenri-G5342fr-m:~$ sudo apt install -f
[sudo] Mot de passe de jean-henri : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libdbd-mysql-perl libdbi-perl libreadline5 libterm-readkey-perl
  mariadb-common
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets supplémentaires suivants vont être installés :
  mysql-server-5.7
Paquets suggérés :
  tinyca
Les NOUVEAUX paquets suivants seront installés :
  mysql-server-5.7
0 mis à jour, 1 nouvellement installés, 0 à enlever et 28 non mis à jour.
4 partiellement installés ou enlevés.
Il est nécessaire de prendre 2 724 ko dans les archives.
Après cette opération, 48,4 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de:1 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 mysql-server-5.7 amd64 5.7.21-0ubuntu0.16.04.1 [2 724 kB]
2 724 ko réceptionnés en 1s (1 863 ko/s)      
Préconfiguration des paquets...
(Lecture de la base de données... 286380 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../mysql-server-5.7_5.7.21-0ubuntu0.16.04.1_amd64.deb ...
grep: /etc/mysql/: Aucun fichier ou dossier de ce type
Dépaquetage de mysql-server-5.7 (5.7.21-0ubuntu0.16.04.1) ...
Traitement des actions différées (« triggers ») pour systemd (229-4ubuntu21.2) ...
Traitement des actions différées (« triggers ») pour ureadahead (0.100.0-19) ...
ureadahead will be reprofiled on next reboot
Traitement des actions différées (« triggers ») pour man-db (2.7.5-1) ...
Paramétrage de mysql-client-core-5.7 (5.7.21-0ubuntu0.16.04.1) ...
Paramétrage de mysql-client-5.7 (5.7.21-0ubuntu0.16.04.1) ...
Paramétrage de mysql-server-core-5.7 (5.7.21-0ubuntu0.16.04.1) ...
Paramétrage de mysql-server-5.7 (5.7.21-0ubuntu0.16.04.1) ...
Installation de la nouvelle version du fichier de configuration /etc/apparmor.d/usr.sbin.mysqld ...
Installation de la nouvelle version du fichier de configuration /etc/init.d/mysql ...
Installation de la nouvelle version du fichier de configuration /etc/logrotate.d/mysql-server ...

Fichier de configuration « /etc/mysql/debian-start »
 ==> Supprimé (par vous ou par un script) depuis l'installation.
 ==> Le distributeur du paquet a fourni une version mise à jour.
   Que voulez-vous faire ? Vos options sont les suivantes :
    Y ou I  : installer la version du responsable du paquet
    N ou O  : garder votre version actuellement installée
      D     : afficher les différences entre les versions
      Z     : suspendre ce processus pour examiner la situation
 L'action par défaut garde votre version actuelle.
*** debian-start (Y/I/N/O/D/Z) [défaut=N] ? y
Installation de la nouvelle version du fichier de configuration /etc/mysql/debian-start ...
update-alternatives: erreur: le chemin alternatif /etc/mysql/mysql.cnf n'existe pas
dpkg: erreur de traitement du paquet mysql-server-5.7 (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 2
dpkg: des problèmes de dépendances empêchent la configuration de mysql-server :
 mysql-server dépend de mysql-server-5.7 ; cependant :
 Le paquet mysql-server-5.7 n'est pas encore configuré.

dpkg: erreur de traitement du paquet mysql-server (--configure) :
 problèmes de dépendances - laissé non configuré
Aucun rapport « apport » n'a été créé car le message d'erreur indique une erreur consécutive à un échec précédent.
                                  Traitement des actions différées (« triggers ») pour systemd (229-4ubuntu21.2) ...
Traitement des actions différées (« triggers ») pour ureadahead (0.100.0-19) ...
Des erreurs ont été rencontrées pendant l'exécution :
 mysql-server-5.7
 mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)
jean-henri@jeanhenri-G5342fr-m:~$ 

Hors ligne

#17 Le 19/04/2018, à 14:40

krodelabestiole

Re : wordpress

aranoa a écrit :
update-alternatives: erreur: le chemin alternatif /etc/mysql/mysql.cnf n'existe pas

j'ai l'impression que mysql n'a pas été bien désinstallé, je crois que la commande précédente était pas super.
ça donne quoi ça :

sudo apt autoremove --purge mysql\* mariadb\*

Dernière modification par krodelabestiole (Le 19/04/2018, à 14:40)

Hors ligne

#18 Le 19/04/2018, à 14:47

aranoa

Re : wordpress

jean-henri@jeanhenri-G5342fr-m:~$ sudo apt autoremove --purge mysql\* mariadb\*
[sudo] Mot de passe de jean-henri : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Note, selecting 'mysqltcl' for glob 'mysql*'
Note, selecting 'mysql-mmm-agent' for glob 'mysql*'
Note, selecting 'mysql-workbench' for glob 'mysql*'
Note, selecting 'mysql-client-5.5' for glob 'mysql*'
Note, selecting 'mysql-client-5.6' for glob 'mysql*'
Note, selecting 'mysql-client-5.7' for glob 'mysql*'
Note, selecting 'mysql-mmm-tools' for glob 'mysql*'
Note, selecting 'mysql-common-5.6' for glob 'mysql*'
Note, selecting 'mysql-server-5.0' for glob 'mysql*'
Note, selecting 'mysql-server-5.1' for glob 'mysql*'
Note, selecting 'mysql-server-5.5' for glob 'mysql*'
Note, selecting 'mysql-server-5.6' for glob 'mysql*'
Note, selecting 'mysql-server-5.7' for glob 'mysql*'
Note, selecting 'mysql-utilities' for glob 'mysql*'
Note, selecting 'mysql-testsuite' for glob 'mysql*'
Note, selecting 'mysql-mmm-common' for glob 'mysql*'
Note, selecting 'mysql-server' for glob 'mysql*'
Note, selecting 'mysql-client' for glob 'mysql*'
Note, selecting 'mysql-sandbox' for glob 'mysql*'
Note, selecting 'mysql-client-core-5.5' for glob 'mysql*'
Note, selecting 'mysql-client-core-5.6' for glob 'mysql*'
Note, selecting 'mysql-client-core-5.7' for glob 'mysql*'
Note, selecting 'mysql-testsuite-5.5' for glob 'mysql*'
Note, selecting 'mysql-testsuite-5.6' for glob 'mysql*'
Note, selecting 'mysql-testsuite-5.7' for glob 'mysql*'
Note, selecting 'mysql-common' for glob 'mysql*'
Note, selecting 'mysql-mmm-monitor' for glob 'mysql*'
Note, selecting 'mysqltuner' for glob 'mysql*'
Note, selecting 'mysql-workbench-data' for glob 'mysql*'
Note, selecting 'mysql-server-core-5.1' for glob 'mysql*'
Note, selecting 'mysql-server-core-5.5' for glob 'mysql*'
Note, selecting 'mysql-server-core-5.6' for glob 'mysql*'
Note, selecting 'mysql-server-core-5.7' for glob 'mysql*'
Note, selecting 'mysql-source-5.7' for glob 'mysql*'
Le paquet « mysql-client-5.5 » n'est pas installé, et ne peut donc être supprimé
Le paquet « mysql-client-5.6 » n'est pas installé, et ne peut donc être supprimé
Le paquet « mysql-server-core-5.6 » n'est pas installé, et ne peut donc être supprimé
Le paquet « mysql-client-core-5.5 » n'est pas installé, et ne peut donc être supprimé
Le paquet « mysql-client-core-5.6 » n'est pas installé, et ne peut donc être supprimé
Note : sélection de « mysql-common » au lieu de « mysql-common-5.6 »
Le paquet « mysql-server-5.5 » n'est pas installé, et ne peut donc être supprimé
Le paquet « mysql-server-5.6 » n'est pas installé, et ne peut donc être supprimé
Le paquet « mysql-server-core-5.5 » n'est pas installé, et ne peut donc être supprimé
Le paquet « mysql-testsuite-5.5 » n'est pas installé, et ne peut donc être supprimé
Le paquet « mysql-testsuite-5.6 » n'est pas installé, et ne peut donc être supprimé
Le paquet « mysql-server-5.0 » n'est pas installé, et ne peut donc être supprimé
Le paquet « mysql-server-5.1 » n'est pas installé, et ne peut donc être supprimé
Le paquet « mysql-server-core-5.1 » n'est pas installé, et ne peut donc être supprimé
Note, selecting 'mariadb-test' for glob 'mariadb*'
Note, selecting 'mariadb-test-data-10.0' for glob 'mariadb*'
Note, selecting 'mariadb-test-data' for glob 'mariadb*'
Note, selecting 'mariadb-test-5.5' for glob 'mariadb*'
Note, selecting 'mariadb-common' for glob 'mariadb*'
Note, selecting 'mariadb-plugin-connect' for glob 'mariadb*'
Note, selecting 'mariadb-server-core-5.5' for glob 'mariadb*'
Note, selecting 'mariadb-server-5.5' for glob 'mariadb*'
Note, selecting 'mariadb-tokudb-engine-5.5' for glob 'mariadb*'
Note, selecting 'mariadb-server-core-10.0' for glob 'mariadb*'
Note, selecting 'mariadb-connect-engine-10.0' for glob 'mariadb*'
Note, selecting 'mariadb-galera-server' for glob 'mariadb*'
Note, selecting 'mariadb-client-5.5' for glob 'mariadb*'
Note, selecting 'mariadb-server-10.0' for glob 'mariadb*'
Note, selecting 'mariadb-plugin-oqgraph' for glob 'mariadb*'
Note, selecting 'mariadb-plugin-spider' for glob 'mariadb*'
Note, selecting 'mariadb-galera-server-10.0' for glob 'mariadb*'
Note, selecting 'mariadb-plugin-tokudb' for glob 'mariadb*'
Note, selecting 'mariadb-client-10.0' for glob 'mariadb*'
Note, selecting 'mariadb-server' for glob 'mariadb*'
Note, selecting 'mariadb-tokudb-engine-10.0' for glob 'mariadb*'
Note, selecting 'mariadb-client-core-10.0' for glob 'mariadb*'
Note, selecting 'mariadb-client' for glob 'mariadb*'
Note, selecting 'mariadb-test-10.0' for glob 'mariadb*'
Note, selecting 'mariadb-oqgraph-engine-10.0' for glob 'mariadb*'
Note, selecting 'mariadb-galera-server-5.5' for glob 'mariadb*'
Note, selecting 'mariadb-client-core-5.5' for glob 'mariadb*'
Note, selecting 'mariadb-plugin-mroonga' for glob 'mariadb*'
Le paquet « mariadb-server-5.5 » n'est pas installé, et ne peut donc être supprimé
Le paquet « mariadb-client-5.5 » n'est pas installé, et ne peut donc être supprimé
Le paquet « mariadb-client-core-5.5 » n'est pas installé, et ne peut donc être supprimé
Le paquet « mariadb-galera-server-10.0 » n'est pas installé, et ne peut donc être supprimé
Le paquet « mariadb-connect-engine-10.0 » n'est pas installé, et ne peut donc être supprimé
Le paquet « mariadb-oqgraph-engine-10.0 » n'est pas installé, et ne peut donc être supprimé
Le paquet « mariadb-tokudb-engine-10.0 » n'est pas installé, et ne peut donc être supprimé
Le paquet « mariadb-tokudb-engine-5.5 » n'est pas installé, et ne peut donc être supprimé
Le paquet « mariadb-galera-server » n'est pas installé, et ne peut donc être supprimé
Le paquet « mariadb-galera-server-5.5 » n'est pas installé, et ne peut donc être supprimé
Le paquet « mariadb-server-core-5.5 » n'est pas installé, et ne peut donc être supprimé
Le paquet « mariadb-test-10.0 » n'est pas installé, et ne peut donc être supprimé
Le paquet « mariadb-test-5.5 » n'est pas installé, et ne peut donc être supprimé
Le paquet « mariadb-test-data-10.0 » n'est pas installé, et ne peut donc être supprimé
Le paquet « mysql-mmm-agent » n'est pas installé, et ne peut donc être supprimé
Le paquet « mysql-mmm-common » n'est pas installé, et ne peut donc être supprimé
Le paquet « mysql-mmm-monitor » n'est pas installé, et ne peut donc être supprimé
Le paquet « mysql-mmm-tools » n'est pas installé, et ne peut donc être supprimé
Le paquet « mysql-sandbox » n'est pas installé, et ne peut donc être supprimé
Le paquet « mysql-utilities » n'est pas installé, et ne peut donc être supprimé
Le paquet « mysql-workbench » n'est pas installé, et ne peut donc être supprimé
Le paquet « mysql-workbench-data » n'est pas installé, et ne peut donc être supprimé
Le paquet « mysqltcl » n'est pas installé, et ne peut donc être supprimé
Le paquet « mysqltuner » n'est pas installé, et ne peut donc être supprimé
Le paquet « mysql-client » n'est pas installé, et ne peut donc être supprimé
Le paquet « mariadb-client » n'est pas installé, et ne peut donc être supprimé
Le paquet « mariadb-client-core-10.0 » n'est pas installé, et ne peut donc être supprimé
Le paquet « mariadb-plugin-connect » n'est pas installé, et ne peut donc être supprimé
Le paquet « mariadb-plugin-mroonga » n'est pas installé, et ne peut donc être supprimé
Le paquet « mariadb-plugin-oqgraph » n'est pas installé, et ne peut donc être supprimé
Le paquet « mariadb-plugin-spider » n'est pas installé, et ne peut donc être supprimé
Le paquet « mariadb-plugin-tokudb » n'est pas installé, et ne peut donc être supprimé
Le paquet « mariadb-server » n'est pas installé, et ne peut donc être supprimé
Le paquet « mariadb-server-core-10.0 » n'est pas installé, et ne peut donc être supprimé
Le paquet « mariadb-test » n'est pas installé, et ne peut donc être supprimé
Le paquet « mariadb-test-data » n'est pas installé, et ne peut donc être supprimé
Le paquet « mysql-source-5.7 » n'est pas installé, et ne peut donc être supprimé
Le paquet « mysql-testsuite » n'est pas installé, et ne peut donc être supprimé
Le paquet « mysql-testsuite-5.7 » n'est pas installé, et ne peut donc être supprimé
Les paquets supplémentaires suivants vont être installés :
  dbconfig-no-thanks
Les paquets suivants seront ENLEVÉS :
  dbconfig-mysql* libdbd-mysql-perl* libdbi-perl* libmysqlclient20*
  libqt4-sql-mysql* libreadline5* libterm-readkey-perl* mariadb-client-10.0*
  mariadb-common* mariadb-server-10.0* mysql-client-5.7*
  mysql-client-core-5.7* mysql-common* mysql-server* mysql-server-5.7*
  mysql-server-core-5.7*
Les NOUVEAUX paquets suivants seront installés :
  dbconfig-no-thanks
0 mis à jour, 1 nouvellement installés, 16 à enlever et 28 non mis à jour.
2 partiellement installés ou enlevés.
Il est nécessaire de prendre 1 314 o dans les archives.
Après cette opération, 168 Mo d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] o
Réception de:1 http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 dbconfig-no-thanks all 2.0.4ubuntu1 [1 314 B]
1 314 o réceptionnés en 0s (13,7 ko/s)         
(Lecture de la base de données... 286452 fichiers et répertoires déjà installés.)
Suppression de mysql-server (5.7.21-0ubuntu0.16.04.1) ...
Suppression de mysql-server-5.7 (5.7.21-0ubuntu0.16.04.1) ...
update-alternatives: avertissement: l'alternative /etc/mysql/mariadb.cnf (qui fait partie du groupe de liens my.cnf) n'a pas été trouvée ; suppression de la liste des alternatives
update-alternatives: avertissement: l'alternative /etc/mysql/my.cnf.fallback (qui fait partie du groupe de liens my.cnf) n'a pas été trouvée ; suppression de la liste des alternatives
update-alternatives: avertissement: /etc/alternatives/my.cnf pointe dans le vide ; sera mis à jour avec le choix le plus adapté
Purge des fichiers de configuration de mysql-server-5.7 (5.7.21-0ubuntu0.16.04.1) ...
dpkg: dbconfig-mysql : problème de dépendance, mais suppression comme demandé :
 phpmyadmin dépend de dbconfig-mysql | dbconfig-no-thanks | dbconfig-common (<< 2.0.0) ; cependant :
  Le paquet dbconfig-mysql doit être supprimé.
  Le paquet dbconfig-no-thanks n'est pas installé.
  La version de dbconfig-common sur le système est 2.0.4ubuntu1.

Suppression de dbconfig-mysql (2.0.4ubuntu1) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.5-1) ...
Sélection du paquet dbconfig-no-thanks précédemment désélectionné.
(Lecture de la base de données... 286361 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../dbconfig-no-thanks_2.0.4ubuntu1_all.deb ...
Dépaquetage de dbconfig-no-thanks (2.0.4ubuntu1) ...
(Lecture de la base de données... 286362 fichiers et répertoires déjà installés.)
Suppression de libdbd-mysql-perl (4.033-1ubuntu0.1) ...
Suppression de libdbi-perl (1.634-1build1) ...
Suppression de libqt4-sql-mysql:amd64 (4:4.8.7+dfsg-5ubuntu2) ...
Suppression de libmysqlclient20:amd64 (5.7.21-0ubuntu0.16.04.1) ...
Suppression de libreadline5:amd64 (5.2+dfsg-3build1) ...
Suppression de libterm-readkey-perl (2.33-1build1) ...
Suppression de mariadb-client-10.0 (10.0.34-0ubuntu0.16.04.1) ...
Purge des fichiers de configuration de mariadb-client-10.0 (10.0.34-0ubuntu0.16.04.1) ...
Suppression de mariadb-common (10.0.34-0ubuntu0.16.04.1) ...
Purge des fichiers de configuration de mariadb-common (10.0.34-0ubuntu0.16.04.1) ...
Suppression de mariadb-server-10.0 (10.0.34-0ubuntu0.16.04.1) ...
Purge des fichiers de configuration de mariadb-server-10.0 (10.0.34-0ubuntu0.16.04.1) ...
Suppression de mysql-client-5.7 (5.7.21-0ubuntu0.16.04.1) ...
Suppression de mysql-client-core-5.7 (5.7.21-0ubuntu0.16.04.1) ...
Suppression de mysql-common (5.7.21-0ubuntu0.16.04.1) ...
Purge des fichiers de configuration de mysql-common (5.7.21-0ubuntu0.16.04.1) ...
Suppression de mysql-server-core-5.7 (5.7.21-0ubuntu0.16.04.1) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.5-1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.23-0ubuntu10) ...
Paramétrage de dbconfig-no-thanks (2.0.4ubuntu1) ...
jean-henri@jeanhenri-G5342fr-m:~$ 

Hors ligne

#19 Le 19/04/2018, à 14:52

krodelabestiole

Re : wordpress

ok c'est mieux, on voit que mariadb était encore installé.

sudo apt clean
sudo apt install mysql-server

Hors ligne

#20 Le 19/04/2018, à 14:55

aranoa

Re : wordpress

jean-henri@jeanhenri-G5342fr-m:~$ sudo apt clean
[sudo] Mot de passe de jean-henri : 
jean-henri@jeanhenri-G5342fr-m:~$ sudo apt install mysql-server
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants vont être installés :
  mysql-client-5.7 mysql-client-core-5.7 mysql-common mysql-server-5.7
  mysql-server-core-5.7
Paquets suggérés :
  tinyca
Les NOUVEAUX paquets suivants seront installés :
  mysql-client-5.7 mysql-client-core-5.7 mysql-common mysql-server
  mysql-server-5.7 mysql-server-core-5.7
0 mis à jour, 6 nouvellement installés, 0 à enlever et 28 non mis à jour.
Il est nécessaire de prendre 18,6 Mo dans les archives.
Après cette opération, 160 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de:1 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 mysql-common all 5.7.21-0ubuntu0.16.04.1 [15,7 kB]
Réception de:2 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 mysql-client-core-5.7 amd64 5.7.21-0ubuntu0.16.04.1 [6 363 kB]
Réception de:3 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 mysql-client-5.7 amd64 5.7.21-0ubuntu0.16.04.1 [1 676 kB]
Réception de:4 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 mysql-server-core-5.7 amd64 5.7.21-0ubuntu0.16.04.1 [7 809 kB]
Réception de:5 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 mysql-server-5.7 amd64 5.7.21-0ubuntu0.16.04.1 [2 724 kB]
Réception de:6 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 mysql-server all 5.7.21-0ubuntu0.16.04.1 [10,2 kB]
18,6 Mo réceptionnés en 8s (2 158 ko/s)                                        
Préconfiguration des paquets...
Sélection du paquet mysql-common précédemment désélectionné.
(Lecture de la base de données... 285977 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../mysql-common_5.7.21-0ubuntu0.16.04.1_all.deb ...
Dépaquetage de mysql-common (5.7.21-0ubuntu0.16.04.1) ...
Sélection du paquet mysql-client-core-5.7 précédemment désélectionné.
Préparation du dépaquetage de .../mysql-client-core-5.7_5.7.21-0ubuntu0.16.04.1_amd64.deb ...
Dépaquetage de mysql-client-core-5.7 (5.7.21-0ubuntu0.16.04.1) ...
Sélection du paquet mysql-client-5.7 précédemment désélectionné.
Préparation du dépaquetage de .../mysql-client-5.7_5.7.21-0ubuntu0.16.04.1_amd64.deb ...
Dépaquetage de mysql-client-5.7 (5.7.21-0ubuntu0.16.04.1) ...
Sélection du paquet mysql-server-core-5.7 précédemment désélectionné.
Préparation du dépaquetage de .../mysql-server-core-5.7_5.7.21-0ubuntu0.16.04.1_amd64.deb ...
Dépaquetage de mysql-server-core-5.7 (5.7.21-0ubuntu0.16.04.1) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.5-1) ...
Paramétrage de mysql-common (5.7.21-0ubuntu0.16.04.1) ...
update-alternatives: utilisation de « /etc/mysql/my.cnf.fallback » pour fournir « /etc/mysql/my.cnf » (my.cnf) en mode automatique
Sélection du paquet mysql-server-5.7 précédemment désélectionné.
(Lecture de la base de données... 286133 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../mysql-server-5.7_5.7.21-0ubuntu0.16.04.1_amd64.deb ...
Dépaquetage de mysql-server-5.7 (5.7.21-0ubuntu0.16.04.1) ...
Sélection du paquet mysql-server précédemment désélectionné.
Préparation du dépaquetage de .../mysql-server_5.7.21-0ubuntu0.16.04.1_all.deb ...
Dépaquetage de mysql-server (5.7.21-0ubuntu0.16.04.1) ...
Traitement des actions différées (« triggers ») pour systemd (229-4ubuntu21.2) ...
Traitement des actions différées (« triggers ») pour ureadahead (0.100.0-19) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.5-1) ...
Paramétrage de mysql-client-core-5.7 (5.7.21-0ubuntu0.16.04.1) ...
Paramétrage de mysql-client-5.7 (5.7.21-0ubuntu0.16.04.1) ...
Paramétrage de mysql-server-core-5.7 (5.7.21-0ubuntu0.16.04.1) ...
Paramétrage de mysql-server-5.7 (5.7.21-0ubuntu0.16.04.1) ...
update-alternatives: utilisation de « /etc/mysql/mysql.cnf » pour fournir « /etc/mysql/my.cnf » (my.cnf) en mode automatique
Renaming removed key_buffer and myisam-recover options (if present)
Paramétrage de mysql-server (5.7.21-0ubuntu0.16.04.1) ...
Traitement des actions différées (« triggers ») pour systemd (229-4ubuntu21.2) ...
Traitement des actions différées (« triggers ») pour ureadahead (0.100.0-19) ...
jean-henri@jeanhenri-G5342fr-m:~$ 

Hors ligne

#21 Le 19/04/2018, à 15:04

krodelabestiole

Re : wordpress

super ça a l'air joli maintenant !

j'ai corrigé la doc.

Hors ligne

#22 Le 19/04/2018, à 15:06

aranoa

Re : wordpress

ok merci je reprends ou stp

Hors ligne

#23 Le 19/04/2018, à 15:08

krodelabestiole

Re : wordpress

tu as installé lamp, tu peux reprendre à "Une fois la pile LAMP installée..." :
https://doc.ubuntu-fr.org/wordpress#prerequis

Hors ligne

#24 Le 19/04/2018, à 15:29

aranoa

Re : wordpress

ce tableau doit être vide comment je le vide avant de continuer

  GNU nano 2.5.3 Fichier : ...c/apache2/sites-available/wordpress.conf Modifié  

<VirtualHost *:80>
        ServerName wordpress
        DocumentRoot /var/www/wordpress
        <Directory /var/www/wordpress>
                AllowOverride all
                Require all granted
        </Directory>
        ErrorLog /var/log/apache2/error.wordpress.log
        CustomLog /var/log/apache2/access.wordpress.log combined
</VirtualHost><VirtualHost *:80>
        ServerName wordpress
        DocumentRoot /var/www/wordpress
        <Directory /var/www/wordpress>
                AllowOverride all
                Require all granted
        </Directory>
        ErrorLog /var/log/apache2/error.wordpress.log
        CustomLog /var/log/apache2/access.wordpress.log combined
</VirtualHost>

^G Aide      ^O Écrire    ^W Chercher  ^K Couper    ^J Justifier ^C Pos. cur.
^X Quitter   ^R Lire fich.^\ Remplacer ^U Coller    ^T Orthograp.^_ Aller lig.

Hors ligne

#25 Le 19/04/2018, à 15:33

krodelabestiole

Re : wordpress

tu peux utiliser les touches ordinaires : flèche pour déplacer le curseur, backspace ou delete pour supprimer du texte, etc.

et pour aller plus vite : ctrl+k pour supprimer une ligne

Hors ligne