Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

N'oubliez pas de cocher la case « Ajustement pour l'heure d'été » dans votre profil.

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#26 Le 16/04/2018, à 09:00

neck75

Re : Libgnat

Apparemment pas de succès ....

Hors ligne

#27 Le 16/04/2018, à 14:45

eric63

Re : Libgnat

bon visiblement il y a quelque chose qui lui va pas
essaye un

sudo apt-get -f install

vérifier
(donne le retour de commande bien sur)


kdeïste convaincu avec Kubuntu 17.10 + PPA backports KDE plasma 5.12.4 et KDE framaworks 5.44.0 Qt 5.9.1
pour installer une multifonction brother pour en savoir plus sur plasma5: https://www.kde.org/index

Hors ligne

#28 Le 16/04/2018, à 20:30

neck75

Re : Libgnat

bonsoir,

et bien voici :

michel@michel-W54-55-94-95-97AU-AUQ:~$ sudo apt-get -f install
[sudo] Mot de passe de michel : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-image-4.4.0-112-generic linux-image-extra-4.4.0-112-generic
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 9 non mis à jour.
michel@michel-W54-55-94-95-97AU-AUQ:~$

Hors ligne

#29 Le 16/04/2018, à 21:16

eric63

Re : Libgnat

ben là je sèche
les version 0.34 et 0.35 sont à priori des binaires et de surcroît il existe 2 fichiers par version
mais je suis incapable de savoir ce qui doit être fait avec et la doc n'est pas clair en plus les liens ne fonctionne plus.
Je pense toujours que ta version 0.33 est trop ancienne et ne capte pas libgnat.
Désolé de ne pas t'être plus utile


kdeïste convaincu avec Kubuntu 17.10 + PPA backports KDE plasma 5.12.4 et KDE framaworks 5.44.0 Qt 5.9.1
pour installer une multifonction brother pour en savoir plus sur plasma5: https://www.kde.org/index

Hors ligne

#30 Le 16/04/2018, à 21:33

xubu1957

Re : Libgnat

Bonjour,

J'ai trouvé cette page > difficulty-to-download-ghdl-with-ubuntu-16-04.


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300 - HP 7100 DC - Asus 1015BX -Fujitsu Siemens Scaleo J3000  Membre de Linux-Azur

En ligne

#31 Le 16/04/2018, à 21:52

eric63

Re : Libgnat

merci xubu1957
ça peut marcher ça

sudo apt install gnat
sudo apt-get update 

puis retente la version 0.33 (en deb)

sudo dpkg --install ghdl_0.33-1ubuntu1_amd64.deb

kdeïste convaincu avec Kubuntu 17.10 + PPA backports KDE plasma 5.12.4 et KDE framaworks 5.44.0 Qt 5.9.1
pour installer une multifonction brother pour en savoir plus sur plasma5: https://www.kde.org/index

Hors ligne

#32 Le 16/04/2018, à 23:41

neck75

Re : Libgnat

ok voilà ce que ça donne :

michel@michel-W54-55-94-95-97AU-AUQ:~$ sudo apt install gnat
[sudo] Mot de passe de michel : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
gnat est déjà la version la plus récente (4.9ubuntu2).
gnat passé en « installé manuellement ».
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-image-4.4.0-112-generic linux-image-extra-4.4.0-112-generic
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 9 non mis à jour.
michel@michel-W54-55-94-95-97AU-AUQ:~$ 

après :

michel@michel-W54-55-94-95-97AU-AUQ:~$ sudo apt-get update 
Atteint:1 http://fr.archive.ubuntu.com/ubuntu xenial InRelease
Atteint:2 http://fr.archive.ubuntu.com/ubuntu xenial-updates InRelease         
Atteint:3 http://fr.archive.ubuntu.com/ubuntu xenial-backports InRelease       
Atteint:4 http://archive.canonical.com/ubuntu xenial InRelease                 
Réception de:5 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
Atteint:6 https://repo.skype.com/deb stable InRelease         
Réception de:7 http://security.ubuntu.com/ubuntu xenial-security/main amd64 DEP-11 Metadata [67,5 kB]
Réception de:8 http://security.ubuntu.com/ubuntu xenial-security/main DEP-11 64x64 Icons [77,2 kB]
Réception de:9 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 DEP-11 Metadata [107 kB]
Réception de:10 http://security.ubuntu.com/ubuntu xenial-security/universe DEP-11 64x64 Icons [147 kB]
Atteint:11 https://dl.winehq.org/wine-builds/ubuntu xenial InRelease
501 ko réceptionnés en 2s (176 ko/s)
Lecture des listes de paquets... Fait
michel@michel-W54-55-94-95-97AU-AUQ:~$

final :

michel@michel-W54-55-94-95-97AU-AUQ:~$ sudo dpkg --install ghdl_0.33-1ubuntu1_amd64.deb
Sélection du paquet ghdl précédemment désélectionné.
(Lecture de la base de données... 204675 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de ghdl_0.33-1ubuntu1_amd64.deb ...
Dépaquetage de ghdl (0.33-1ubuntu1) ...
dpkg: des problèmes de dépendances empêchent la configuration de ghdl :
 ghdl dépend de libgnat-4.8 (>= 4.8.2-8ubuntu3) ; cependant :
  Le paquet libgnat-4.8 n'est pas installé.

dpkg: erreur de traitement du paquet ghdl (--install) :
 problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour man-db (2.7.5-1) ...
Traitement des actions différées (« triggers ») pour install-info (6.1.0.dfsg.1-5) ...
Des erreurs ont été rencontrées pendant l'exécution :
 ghdl
michel@michel-W54-55-94-95-97AU-AUQ:~$

toujours la même chose...

Hors ligne

#33 Le 16/04/2018, à 23:42

neck75

Re : Libgnat

xubu1957 a écrit :

Bonjour,

J'ai trouvé cette page > difficulty-to-download-ghdl-with-ubuntu-16-04.

je l'avais vu ce site et j'ai utilisé leur méthode mais que dalle.

Hors ligne

#34 Le 17/04/2018, à 00:05

neck75

Re : Libgnat

bien sur après ce problème j'ai fait cela :

sudo apt-get -f install

Comme cela le sens interdit disparaît en haut à droite.

Hors ligne

#35 Le 17/04/2018, à 22:48

neck75

Re : Libgnat

Bonsoir,
voilà le lien qui serait peut être la solution, je suppose qu'il faut prendre en adéquation avec le type de processeur mais je ne vois pas de i5...

Hors ligne

#36 Le 17/04/2018, à 22:57

neck75

Re : Libgnat

j'avais oublié le lien !

https://packages.ubuntu.com/fr/trusty/libgnat-4.8

j'ai essayer amd64 alors ça à l'air de démarrer l'instal mais au bout de 3 secondes ça s'arrête...

Hors ligne

#37 Le 19/04/2018, à 21:55

neck75

Re : Libgnat

Bon et bien je pense que je suis coincé avec ce truc c'est bien dommage.

Hors ligne

#38 Le 20/04/2018, à 18:43

eric63

Re : Libgnat

neck75 a écrit :

j'avais oublié le lien !

https://packages.ubuntu.com/fr/trusty/libgnat-4.8

j'ai essayer amd64 alors ça à l'air de démarrer l'instal mais au bout de 3 secondes ça s'arrête...

je sais pas ce que tu fait avec une version trusty (c'est la 14.04) mais c'est "obsolète"
il ne faut pas mélanger les dépots trusty et xenial (ça n'a pas de sens sauf à vouloir planter ton ordi)
Je ne crois pas que tu as bien assimilé les dépots
on n'extrait rien de ce lien
apparement ghdl est conçu pour trusty (14.04) et il n'y a pas eut de dépots pour xénial (16.04) et supérieur il y a juste des sources à compiler pour avoir ce programme
est ce  que tu as cherché d'autre logiciels équivalents qui feraient l'affaire ?

Dernière modification par eric63 (Le 20/04/2018, à 18:52)


kdeïste convaincu avec Kubuntu 17.10 + PPA backports KDE plasma 5.12.4 et KDE framaworks 5.44.0 Qt 5.9.1
pour installer une multifonction brother pour en savoir plus sur plasma5: https://www.kde.org/index

Hors ligne

#39 Le 20/04/2018, à 22:15

neck75

Re : Libgnat

En fait je me suis trompé dès le départ il fallait utiliser i386, mais après compléter avec des dépendances qui manquaient, quelqu'un me l'a fait, mais il y a des avertissements avec marqué dégradation, mais je n'ai pas de plantage heureusement, reste à voir gtkwaves je ne le trouve plus.

Bien sur j'ai autre chose de très connu : Modelsim que j'ai installé avec wine tout c'est bien passé mais la licence gratuite que l'on te fourni ne doit pas fonctionner, bilan je peux compiler et corriger les erreurs mais je ne peux pas simuler,  j'ai un message comme quoi c'est réservé à ''higher education'' je suis pas seul beaucoup on le problème, et Mentor graphic ne fait pas de support quand c'est une licence gratuite, c'est pour cela que j'essaye ghdl.

Hors ligne

#40 Aujourd'hui à 08:45

neck75

Re : Libgnat

Et bien c'est bon ! Grâce à un collègue du travail qui est sur Ubuntu comme moi, en fait c'était un problème de dépendances, et pas qu'un peu ! En effet à chaque fois qu'on essayait, il y avait toujours une nouvelle dépendance qui manquait, et puis j'oubliais à la base je faisais une erreur du choix ce n'était pas AMD64 mais i386, mais avec un i5 je ne savais pas quoi faire.

Éventuellement si cela intéresse je peux mettre sur le site ce que j'ai du installer mais je ne sais pas faire.

Hors ligne

#41 Aujourd'hui à 08:53

xubu1957

Re : Libgnat

Bonjour,

Éventuellement si cela intéresse je peux mettre sur le site ce que j'ai du installer mais je ne sais pas faire.

Et en partant des commandes dans ton terminal :

history

?

Je t'ai aussi rajouté un message dans une vieille discussion > plus de son sur la barre en haut à droite suite passage à la version12


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300 - HP 7100 DC - Asus 1015BX -Fujitsu Siemens Scaleo J3000  Membre de Linux-Azur

En ligne