Contenu | Rechercher | Menus

Annonce

T-shirt Seiche Cosmic, Série limitée

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.10
T-shirt Ubuntu-FR « Seiche Cosmique » en série limitée ! Prix spécial pré-vente (15€) jusqu'au 4 novembre 2018.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 06/05/2018, à 18:38

nibbler869

[Résolu] Transition fluide entre l'écran de login et le bureau

Bonjour à tous,

J'ai récemment essayé Elementary OS et j'ai noté une fonctionnalité très élégante : la transition totalement fluide entre l'écran de login et le bureau qui utilisent tous les deux le même fond d'écran. J'ai réussi à mettre le même fond d'écran dans Ubuntu (17.10 et 18.04), par contre je n'arrive pas à éliminer l'écran violet foncé qui apparaît pendant une demi-seconde après le login ainsi que l'effet de zoom arrière lorsque le bureau apparaît. J'ai beaucoup cherché une solution pour reproduire la transition (ou plutôt l'absence de transition) en vain. Comme Elementary est basé sur Ubuntu, je me dis que la solution doit bien exister, aussi, en dernier recours, je m'adresse à la vaillante communauté Ubuntu :-).

Dernière modification par nibbler869 (Le 07/05/2018, à 21:20)

Hors ligne

#2 Le 06/05/2018, à 19:11

Roschan

Re : [Résolu] Transition fluide entre l'écran de login et le bureau

Installer Pantheon et LightDM

En ligne

#3 Le 07/05/2018, à 12:52

nibbler869

Re : [Résolu] Transition fluide entre l'écran de login et le bureau

Merci pour cette réponse, c'est effectivement une solution. Comme je suis difficile big_smile j'essaye de reproduire ce fonctionnement avec gnome et gdm.
En continuant de creuser, j'ai trouvé une piste intéressante ici : https://ubuntuforums.org/showthread.php … st13736129
Ca permet de remplacer le fond violet par une autre image (en l'occurrence le même fond que le login et le bureau), par contre pour l'instant je n'arrive pas encore à la mettre en plein écran. J'utilise ces règles css dans gnome-shell.css qui est ensuite utilisé pour générer le fichier gdm .gresource (Lighthouse_at_sunrise_by_Frenchie_Smalls.jpg est donné à titre d'exemple) :

#lockDialogGroup {
  background: #607D8B url("file:///usr/share/backgrounds/Lighthouse_at_sunrise_by_Frenchie_Smalls.jpg");
  background-size: cover;
  background-position: center;
  background-repeat: no-repeat; }

Dernière modification par nibbler869 (Le 07/05/2018, à 12:53)

Hors ligne

#4 Le 07/05/2018, à 14:35

Roschan

Re : [Résolu] Transition fluide entre l'écran de login et le bureau

Avoir une image de la taille de l'écran est, à ma connaissance, le moyen le plus simple de mettre l'image en plein écran, mais je te conseille de faire un script pour automatiser les manips que tu fais, car ça risque fort d'être écrasé à chaque mise à jour

En ligne

#5 Le 07/05/2018, à 15:10

grandtoubab

Re : [Résolu] Transition fluide entre l'écran de login et le bureau

Salut
Pour panthéon j'ai essayé ça https://gandalfn.ovh/

Pas de problèmes d'installation de pantheon ni d'ouverture de session sauf que l'horloge au centre et les icones à droite ne s'affichent pas.
Peut être un pb de concurrence avec gnome-shell qui est installé en même temps.
Je n'ai pas persisté


Linux tout seul sur HP Pavilion DV7 et Acer Aspire T650
Debian 10 Buster Gnome/Xorg, Gnome/Wayland, Weston/Wayland
Canon MG3650 en wifi
https://bidouilledebian.wordpress.com/

Hors ligne

#6 Le 07/05/2018, à 20:27

nibbler869

Re : [Résolu] Transition fluide entre l'écran de login et le bureau

Merci à vous pour toutes vos suggestions. En redimensionnant l'image de fond à la taille de l'écran comme suggéré par Roschan, cela fonctionne bien.
[edit] Pour l'effet zoom lors de l'ouverture du bureau, le plus simple est de désactiver l'animation des fenêtres :

gsettings set org.gnome.desktop.interface enable-animations false

Bien sûr, ça désactive l'animation pour toutes les fenêtres. Je n'ai pas trouvé comment le faire que pour le bureau.

Dernière modification par nibbler869 (Le 07/05/2018, à 21:19)

Hors ligne