Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 08/05/2018, à 12:51

Mene

[Résolu] Ubuntu 18.04 HDMI pas détécté sur DELL XPS 9560 (GTX1050)

Bonjour,

J'ai installé Ubuntu 18.04 et lorsque je branche mon écran de bureau via HDMI, il ne le detecte pas.
Je suis sur un Dell XPS 9560, avec une GTX 1050 sous driver Xorg.
Quelqu'un a deja eu ce probleme? Plusieurs tickets sur ce sujet sont ouverts sur AskUbuntu sans que personne sache quoi faire sad

Merci d'avance!

https://i.stack.imgur.com/0oIR1.png
https://i.stack.imgur.com/3eOfr.png

xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1920 x 1080, current 1920 x 1080, maximum 1920 x 1080
default connected primary 1920x1080+0+0 0mm x 0mm
   1920x1080     77.00*

Dernière modification par Mene (Le 08/05/2018, à 18:02)

Hors ligne

#2 Le 08/05/2018, à 13:00

Mene

Re : [Résolu] Ubuntu 18.04 HDMI pas détécté sur DELL XPS 9560 (GTX1050)

Aussi, Nvidia X Server Settings ne se launch pas sad

Hors ligne

#3 Le 08/05/2018, à 13:11

Naziel

Re : [Résolu] Ubuntu 18.04 HDMI pas détécté sur DELL XPS 9560 (GTX1050)

Bonjour,

Tu peux donner le retour de

cat /etc/default/grub | grep GRUB_CMDLINE_LINUX

Hors ligne

#4 Le 08/05/2018, à 14:49

Mene

Re : [Résolu] Ubuntu 18.04 HDMI pas détécté sur DELL XPS 9560 (GTX1050)

Voici:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=noaer"
GRUB_CMDLINE_LINUX="nomodeset"

Merci!

Hors ligne

#5 Le 08/05/2018, à 15:02

Naziel

Re : [Résolu] Ubuntu 18.04 HDMI pas détécté sur DELL XPS 9560 (GTX1050)

Actuellement, la carte graphique est ignorée par le paramètre nomodeset.

Petite précision: il semble qu'il y ait des problèmes avec la 18.04 avec la technologie optimus (intel+CG nvidia), on va voir ce que cela donne (je viens à l'instant de l'apprendre). Si vraiment on y arrive pas, peut être qu'il faudrait repasser sur la 16.04.4 en attendant que le ciel se dégage sur la 18.04 (à noter que la 16.04.4 est supportée jusqu'en avril 2021, donc cela reste une possibilité)

On va avoir besoin d'accéder au menu grub (je te laisse vérifier que tu arrives à y accéder): pour cela, au démarrage du pc (donc avant le démarrage d'ubuntu), tu fais shift et tu auras un menu qui te proposera ubuntu, les options avancées, et windows si tu as un dual boot (d'ailleurs dans ce cas, pas besoin de faire shift vu que tu as ce menu à chaque démarrage). La première entrée permet de lancer ubuntu.

Peux tu confirmer que tu arrives à accéder à ce menu?

Edit: et pci=noaer, c'est vraiment obligatoire?

Dernière modification par Naziel (Le 08/05/2018, à 15:02)

Hors ligne

#6 Le 08/05/2018, à 15:03

Mene

Re : [Résolu] Ubuntu 18.04 HDMI pas détécté sur DELL XPS 9560 (GTX1050)

Oui j'y accede sans probleme j'avais meme mis nomodeset en appuyant sur e puis F10 sans ca Linux ne s'installé même pas. Je suis en dual boot btw

Hors ligne

#7 Le 08/05/2018, à 15:05

Naziel

Re : [Résolu] Ubuntu 18.04 HDMI pas détécté sur DELL XPS 9560 (GTX1050)

Oui, c'est normal que nomodeset soit obligatoire à l'installation: le pilote libre nouveau veut s'occuper de ta carte graphique mais il ne sais pas faire...
Pour pci=noaer, pourquoi as tu mis cette option?

Hors ligne

#8 Le 08/05/2018, à 15:09

Mene

Re : [Résolu] Ubuntu 18.04 HDMI pas détécté sur DELL XPS 9560 (GTX1050)

J'ai trouvé ça comme une solution potentielle sur askubuntu mais qui n'a pas changé grand chose.

Hors ligne

#9 Le 08/05/2018, à 15:30

Naziel

Re : [Résolu] Ubuntu 18.04 HDMI pas détécté sur DELL XPS 9560 (GTX1050)

Ok, alors on va l'effacer.

Dans un terminal, tu fais

sudo nano /etc/default/grub

Un éditeur de texte apparaît. Tu transformes ensuite

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=noaer"
GRUB_CMDLINE_LINUX="nomodeset"

en

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

puis tu fais ctrl+o puis entrée pour enregistrer, puis ctrl+x pour quitter.

De retour dans le terminal, tu fais

sudo update-grub

Ensuite, tu redémarres. Sur le menu grub, tu fais e sur la première entrée, et tu ajoutes nomodeset entre quiet et spash puis tu faisF10 pour démarrer. Normalement, ubuntu démarre, dans pilotes additionnels, tu sélectionnes nvidia-driver-390 (si ça marche, tu pourras essayer le 396) et tu appliques les changements. Tu redémarres ensuite sans nomodeset (donc tu fais un redémarrage normal), ubuntu devrait démarrer normalement avec le pilote propriétaire (nvidia-driver n'est pas open source).

Hors ligne

#10 Le 08/05/2018, à 18:02

Mene

Re : [Résolu] Ubuntu 18.04 HDMI pas détécté sur DELL XPS 9560 (GTX1050)

MERCI ENORMEMENT big_smile big_smile big_smile

Ca a résolu le probleme et au redemarrage ca s'est mis autmatquement sur le driver 396, la commu francaise en FORCE je met un lien vers tes réponses pour tous les tickets ouverts sur ask ubuntu!

Thanks again!

Hors ligne

#11 Le 08/05/2018, à 19:57

Naziel

Re : [Résolu] Ubuntu 18.04 HDMI pas détécté sur DELL XPS 9560 (GTX1050)

Content pour toi smile
Pour une fois que c'est les anglais qui font du google translate big_smile (te sens pas obligé de répondre à tous les tickets ouverts sur ask ubuntu parce qu'il doit y en avoir un sacré paquet, c'est pas grave si tu le fais pas)

Par curiosité, tu peux donner

lspci -vnn | grep -A 12 '\''[030[02]\]' | grep -Ei "vga|3d|display|kernel"

Hors ligne

#12 Le 05/08/2018, à 17:30

duduklein

Re : [Résolu] Ubuntu 18.04 HDMI pas détécté sur DELL XPS 9560 (GTX1050)

Naziel,

Merci pour ce tuto. ça a marché nickel sur mon DELL Precision M4800 Xubuntu 18.04 avec full encryption.

Je n'ai pas eu besoin de rajouter le nomodeset dans le boot. Le 390 a été choisi automatiquement comme pour Mene.

La sortie de la commande

lspci -vnn | grep -A 12 '\''[030[02]\]' | grep -Ei "vga|3d|display|kernel"

dans mon cas est :

00:02.0 VGA compatible controller [0300]: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06) (prog-if 00 [VGA controller])
	Kernel driver in use: i915
	Kernel modules: i915
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK106GLM [Quadro K2100M] [10de:11fc] (rev a1) (prog-if 00 [VGA controller])
	Kernel driver in use: nvidia
	Kernel modules: nvidiafb, nouveau, nvidia_drm, nvidia

Merci encore

Hors ligne