Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 08/05/2018, à 15:40

dylan7581

Code php se met en commentaire [RESOLU]

Bonjour,

J'ai un petit soucis et je pense qu'il est dû au passage de Ubuntu 17.10 en 18.04. Lorsque j'ouvre une page php sur firefox en passant par l'adresse : localhost/test.php, je vois dans le code html (avec l'outil examiner l’élément) que mon code qui est par exemple :

<?php echo 2+2 ; ?>

devient:

<!--?php echo 2+2 ; ?-->

Pour essayer de remédier à ce problème, j'ai réinstaller Lamp. Et grâce à cela, la commande

$ php test.php

m'affiche bien le résultat '4', ce qui n'était pas le cas avant la réinstallation. Mais l'autre problème n'est pas résolu, et j'ai cherché sur internet et je suis un peu sur la touche en ce moment.

Donc je fais appel à vous big_smile

Dernière modification par dylan7581 (Le 09/05/2018, à 13:36)

Hors ligne

#2 Le 08/05/2018, à 17:52

bruno

Re : Code php se met en commentaire [RESOLU]

Bonjour,

Ton code PHP n'est peut-être tout simplement pas interprété. Il l'est en ligne de commande (par php-cli) mais sans doute pas par le serveur web.

Essaie dans le navigateur en mettant dans ton fichier test.php :

<?php phpinfo(); ?>

Si cela ne fonctionne pas vérifie que le mod php d'apache est bien installé :

sudo apt install libapache2-mod-php

Hors ligne

#3 Le 08/05/2018, à 20:10

dylan7581

Re : Code php se met en commentaire [RESOLU]

Bonjour,

Non cela ne fonctionne pas et libapache2-mod-php :

est déjà la version la plus récente (1:7.2+60ubuntu1)

Hors ligne

#4 Le 08/05/2018, à 20:37

bruno

Re : Code php se met en commentaire [RESOLU]

Il faut voir si le module est activé, retour de :

sudo apache2ctl -M

Hors ligne

#5 Le 08/05/2018, à 20:44

dylan7581

Re : Code php se met en commentaire [RESOLU]

AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
Loaded Modules:
 core_module (static)
 so_module (static)
 watchdog_module (static)
 http_module (static)
 log_config_module (static)
 logio_module (static)
 version_module (static)
 unixd_module (static)
 access_compat_module (shared)
 alias_module (shared)
 auth_basic_module (shared)
 authn_core_module (shared)
 authn_file_module (shared)
 authz_core_module (shared)
 authz_host_module (shared)
 authz_user_module (shared)
 autoindex_module (shared)
 deflate_module (shared)
 dir_module (shared)
 env_module (shared)
 filter_module (shared)
 mime_module (shared)
 mpm_event_module (shared)
 negotiation_module (shared)
 reqtimeout_module (shared)
 setenvif_module (shared)
 status_module (shared)

Hors ligne

#6 Le 08/05/2018, à 20:47

bruno

Re : Code php se met en commentaire [RESOLU]

Je ne vois pas de php7_module. Pour l'activer :

sudo a2enmod php7.2

mais normalement cela aurait du être fait automatiquement à l'installation de libapache2-mod-php

Hors ligne

#7 Le 08/05/2018, à 21:08

dylan7581

Re : Code php se met en commentaire [RESOLU]

Voici le retour de la commande :

Considering dependency mpm_prefork for php7.2:
Considering conflict mpm_event for mpm_prefork:
ERROR: Module mpm_event is enabled - cannot proceed due to conflicts. It needs to be disabled first!
Considering conflict mpm_worker for mpm_prefork:
ERROR: Could not enable dependency mpm_prefork for php7.2, aborting

Hors ligne

#8 Le 08/05/2018, à 21:33

dylan7581

Re : Code php se met en commentaire [RESOLU]

D'ailleurs je sais pas si il y a un rapport, mais lorsque je tape avec mon autre pc, l'ip de ce pc dans firefox pour accéder à mon projet. Je n'arrive plus a accéder à mon projet. Pourtant apache2 est active :

● apache2.service - The Apache HTTP Server
   Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset: enabled)
  Drop-In: /lib/systemd/system/apache2.service.d
           └─apache2-systemd.conf
   Active: active (running) since Tue 2018-05-08 19:49:48 CEST; 1h 29min ago
  Process: 900 ExecStart=/usr/sbin/apachectl start (code=exited, status=0/SUCCESS)
 Main PID: 975 (apache2)
    Tasks: 55 (limit: 4413)
   CGroup: /system.slice/apache2.service
           ├─975 /usr/sbin/apache2 -k start
           ├─976 /usr/sbin/apache2 -k start
           └─977 /usr/sbin/apache2 -k start

mai 08 19:49:45 anonymed06 systemd[1]: Starting The Apache HTTP Server...
mai 08 19:49:48 anonymed06 apachectl[900]: AH00558: apache2: Could not relia…age
mai 08 19:49:48 anonymed06 systemd[1]: Started The Apache HTTP Server.
Hint: Some lines were ellipsized, use -l to show in full.

Dernière modification par dylan7581 (Le 08/05/2018, à 21:35)

Hors ligne

#9 Le 09/05/2018, à 10:25

bruno

Re : Code php se met en commentaire [RESOLU]

Désactiver le MPM event qui est i compatible avec le module php :


sudo a2dismod mpm_event

Activer le MPM prefork :

sudo a2enmod mpm_prefork

relancer Apache :

sudo systemctl restart apache2

Activer le module php :

sudo a2enmod php7.2

et relancer à nouveau apache.

Hors ligne

#10 Le 09/05/2018, à 13:34

dylan7581

Re : Code php se met en commentaire [RESOLU]

Merci beaucoup bruno, ça fonctionne à nouveau big_smile

Hors ligne