Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 16/05/2018, à 11:06

Klitisse Woude

Démarrage difficile sur Gimp 2.10

Bonjour,
Je viens d'installer Gimp 2.10
Dell XPS 13 - ubuntu 16.04 LTS
Je n'arrive pas à l'avoir en français.
Il y a une discussion qui date d'il y a 10 ans :
https://forum.ubuntu-fr.org/viewtopic.php?id=268580
Aujourd'hui que faire ?
Sur http://scrapavecgimp.canalblog.com/arch … 05628.html
J'ai trouvé qu'il fallait faire :
sous linux : "en mode console, taper LANGUAGE=fr gimp"
1) ça n'a pas marché
2) je n'ai plus mes fenêtres latérales sur Gimp 2.8.22
J'ai donc deux questions principales qui sont comment faire pour :
1) récupérer mes fenêtres latérales sur Gimp 2.8.22 ?
2) avoir Gimp 2.10 en Français ?
Merci d'avance à tous.

Hors ligne

#2 Le 16/05/2018, à 11:13

Coeur Noir

Re : Démarrage difficile sur Gimp 2.10

Comment as-tu installer ce Gimp 2.10 ?
→ s'il s'agit du paquet snap, le français n'y semble pas disponible,
→ s'il s'agit du flatpak, le français devrait y être disponible ( mais chez moi ça veut pas… )
→ s'il s'agit du .deb issu du ppa d'Otto, il est en français ( mais attention, avant d'utiliser ce ppa, il faut d'abord désinstaller Gimp 2.8 de ton système )

Voir https://forum.ubuntu-fr.org/viewtopic.php?id=2025700 pour quelques infos sur ces différents « packages ».

Dernière modification par Coeur Noir (Le 16/05/2018, à 11:16)

Hors ligne

#3 Le 16/05/2018, à 16:24

Klitisse Woude

Re : Démarrage difficile sur Gimp 2.10

Je l’ai installé avec « Logiciel », le soft qui remplace « Logithèque ».
Là, j’ai désinstallé 2.8.22 et 2.10 ; pas de jaloux.
Je suis allé chercher
org.gimp.GIMP.flatpakref
Mais je ne sais pas vraiment quoi en faire. Je n’ai pas compris l’utilité du truc.
J’ai aussi téléchargé gimp-2.10.0-RC1.tar.bz2 je ne sais pas plus…
Voilà, voilà, voilà…

Hors ligne

#4 Le 16/05/2018, à 16:26

Klitisse Woude

Re : Démarrage difficile sur Gimp 2.10

J'ajoute des remerciements émus à ceux qui ont le courage et la gentillesse d'aider les quiches dans mon genre.

Hors ligne

#5 Le 16/05/2018, à 18:50

Coeur Noir

Re : Démarrage difficile sur Gimp 2.10

Oublie flatpak, Snap et tarbz, ces solutions s'adressent à des aguerris de Linux - ce qui n'a pas l'air d'être ton cas, et c'est pas grave, hein ;-)

Je te recommande d'installer GIMP 2.10 en paquet deb via un ppa dédié.

Étant sur téléphone c'est galère le copier coller de lien donc regarde dans la documentation du forum ce qu'est un ppa, comment on l'active.

Un fois le ppa qui va bien activé, installe GIMP depuis logiciels ou synaptic ou ligne de commande
sudo apt install gimp

Hors ligne

#6 Le 16/05/2018, à 18:54

michel_04

Re : Démarrage difficile sur Gimp 2.10

Bonjour,

Coeur Noir a écrit :

Je te recommande d'installer GIMP 2.10 en paquet deb via un ppa dédié.
Étant sur téléphone c'est galère le copier coller de lien donc regarde dans la documentation du forum ce qu'est un ppa, comment on l'active.
Un fois le ppa qui va bien activé, installe GIMP depuis logiciels ou synaptic ou ligne de commande

sudo apt install gimp

Là   --->   Pour disposer des dernières versions stables.
Penser (après mise en place du ppa) au :

sudo apt update

A+

Dernière modification par michel_04 (Le 16/05/2018, à 18:56)

Hors ligne

#7 Le 18/05/2018, à 09:14

Klitisse Woude

Re : Démarrage difficile sur Gimp 2.10

Je n’ai pas pu raconter mes palpitantes aventures depuis le 16, mais j'ai essayé de trouver un bon ppa, j'ai même désinstallé les Gimp 2.8.22 et 2.10.0, j’ai renommé le dossier .Gimp-2.8
J’ai ouvert un terminal et tapé :
sudo add-apt-repository ppa:otto-kesselgulasch/gimp
sudo apt-get update
sudo apt-get install gimp
Suite à quoi devant mes yeux esbaudis s’ouvrait Gimp 2.8.22
J’ai eu à ce moment un immense instant de solitude.
Je confesse avoir poussé un cri de rage et de désespoir (cri intérieur ; j’ai des voisins).
Il y a des jours comme ça…

Hors ligne

#8 Le 18/05/2018, à 09:40

michel_04

Re : Démarrage difficile sur Gimp 2.10

Bonjour,

Klitisse Woude a écrit :

J’ai ouvert un terminal et tapé :
sudo add-apt-repository ppa:otto-kesselgulasch/gimp
sudo apt-get update
sudo apt-get install gimp

Dans la Doc il est indiqué 2.8 pour ce ppa.

Et juste en dessous, pour Bionic :

Version 2.10 RC1 pour Bionic et Artful
Cette version n'est pas stable.

    Ajoutez le PPA ppa:otto-kesselgulasch/gimp-edge5) dans vos sources de logiciels ;
    Rechargez la liste des paquets.
    Installez le paquet gimp,gimp-gmic

.

A+

Dernière modification par michel_04 (Le 18/05/2018, à 09:43)

Hors ligne

#9 Le 18/05/2018, à 10:14

Klitisse Woude

Re : Démarrage difficile sur Gimp 2.10

J'ai essayé.
Ça donne ça :
klitisse@xps:~$ sudo add-apt-repository ppa:otto-kesselgulasch/gimp-edge5)
bash: erreur de syntaxe près du symbole inattendu « ) »
klitisse@xps:~$ sudo add-apt-repository ppa:otto-kesselgulasch/gimp-edge5
[sudo] Mot de passe de klitisse :
Cannot add PPA: 'ppa:~otto-kesselgulasch/ubuntu/gimp-edge5'.
The user named '~otto-kesselgulasch' has no PPA named 'ubuntu/gimp-edge5'
Please choose from the following available PPAs:
* 'clementine':  clementine
* 'gimp':  gimp
* 'gimp-edge':  gimp-edge
* 'gimp-standalone':  gimp-standalone
* 'inkscape':  Inkscape
* 'kdevelop':  Kdevelop
* 'krita':  Krita
* 'krita-edge':  Krita-Edge
* 'lightzone':  lightzone
* 'misc':  misc
* 'plesk':  Plesk
* 'samba':  Samba
* 'samba-builddep':  samba-builddep
* 'supertux':  supertux
* 'team':  team
* 'testbildtest':  testbildtest
* 'vlc':  vlc
klitisse@xps:~$
-
J'ai essayé aussi de modifier le ppa par "paramètre système", autres logiciels, ajouter, et quand je réactualise ça dit que je dois revoir ma connexion internet qui fonctionne par ailleurs (chargement rapide de pages internet).
Je désespère un peu.

Hors ligne

#10 Le 18/05/2018, à 10:19

michel_04

Re : Démarrage difficile sur Gimp 2.10

Re,

Regarde là : https://launchpad.net/~otto-kesselgulas … ter=bionic
Supprime les ppa installés avant.

A+

Hors ligne

#11 Le 18/05/2018, à 10:35

moko138

Re : Démarrage difficile sur Gimp 2.10

Klitisse Woude a écrit :

devant mes yeux esbaudis s’ouvrait Gimp 2.8.22
J’ai eu à ce moment un immense instant de solitude.
Je confesse avoir poussé un cri de rage et de désespoir (cri intérieur ; j’ai des voisins)

Mais que reproches-tu à la version officielle et stable ?

EDIT : et à la version stable du ppa, cette 2.8.22 ?

Dernière modification par moko138 (Le 18/05/2018, à 10:50)


%NOINDEX%
Un utilitaire méconnu : ncdu

En ligne

#12 Le 18/05/2018, à 10:39

jeange

Re : Démarrage difficile sur Gimp 2.10

Bonjour,
Après les avis de Cœur Noir et michel_04, pourquoi s'entêter à vouloir 2.10 ppa instable alors que 2.8.22 ppa est très efficace, de plus

Klitisse Woude a écrit :

J'ai donc deux questions principales qui sont comment faire pour :
1) récupérer mes fenêtres latérales sur Gimp 2.8.22 ?

Onglet Fenêtres > Fenêtre unique.


PCLF CLEVO W670SZQ i3-4000M Ram 8Go  Haswell HD4600 Ubuntu 14.04  18.04 LTS 64bits
033 V nospE   22.8.2  8.01.2 pmiG  X04D nokiN
Merci de donner les retours avec les balises < > et les allers avec les valises.
%NOINDEX%

En ligne

#13 Le 18/05/2018, à 13:16

Coeur Noir

Re : Démarrage difficile sur Gimp 2.10

Klitisse Woude a écrit :

sudo add-apt-repository ppa:otto-kesselgulasch/gimp
sudo apt-get update
sudo apt-get install gimp
Suite à quoi devant mes yeux esbaudis s’ouvrait Gimp 2.8.22
J’ai eu à ce moment un immense instant de solitude.

Aïe oui pardon j'ai oublié de préciser un truc : gimp2.10 n'est pas encore disponible dans le ppa d'Otto pour la 16.04 ( il l'est bien pour 17.10 et 18.04 par contre ).

La 2.10 est présentée comme stable il me semble sur le site de Gimp. Elle amène un bon lot de nouveautés, techniques, ergonomiques donc je comprends qu'on puisse vouloir s'y mettre.

En attendant la 2.8.x reste utilisable, hein ;-)

…entre les nouveautés de gimp2.10, les nouveautés de snap et flatpak, difficiles de cerner ce qui coince dans l'un ou l'autre cas… Je dirais que cette accumulation de nouveautés coïncide un peu mal avec la sortie d'une nouvelle LTS…

Hors ligne

#14 Le 18/05/2018, à 18:17

GammaDraconis

Re : Démarrage difficile sur Gimp 2.10

Le paquet snap de Gimp est aussi en français chez moi (comme pour Flatpak) pour info.

Vous pouvez avoir Gimp 2.10 de 3 manières différentes :

- Via le PPA : c'est le plus simple pour les débutants
- Via le Snap : c'est simple aussi mais les performances seront peut être un peu inférieur pour le lancer
- Via Flatpak : une autre alternative mais surtout intéressante sur les autres distribution comme Debian (qui n'a pas de PPA) ou Mint (car ils ont choisi Flatpak et non Snap par défaut).
- Peut être aussi au format universel portable AppImage (pas vérifié)

Dernière modification par GammaDraconis (Le 18/05/2018, à 18:19)


PC1 perso (Xiaomi Air 13) : dualboot avec Archlinux/Xfce et Ubuntu 18.04LTS/Gnome
PC2 perso (Lenovo Legion Y520) : quadrupleboot avec Archlinux/Plasma, Ubuntu 18.10/Gnome, OpenSuSe Tumbleweed/Mate, Win10
PC3 pro : OpenSuSe Leap 15/Plasma
Besoin d'un script de post-install pour la 18.04 ? c'est ici : https://forum.ubuntu-fr.org/viewtopic.php?id=2026344

En ligne

#15 Le 18/05/2018, à 23:20

Klitisse Woude

Re : Démarrage difficile sur Gimp 2.10

moko138 a écrit :
Klitisse Woude a écrit :

devant mes yeux esbaudis s’ouvrait Gimp 2.8.22
J’ai eu à ce moment un immense instant de solitude.
Je confesse avoir poussé un cri de rage et de désespoir (cri intérieur ; j’ai des voisins)

Mais que reproches-tu à la version officielle et stable ?
EDIT : et à la version stable du ppa, cette 2.8.22 ?

Je ne reproche rien à la version officielle et stable. Je la voudrais juste en français…
Je voulais essayer 2.10.
Si des types se sont donnés la peine de nous faire un beau truc avec plein d’améliorations c’est bien de s’en servir, ne serait-ce que pour les encourager et si on tombe sur un bug leur en faire part pour faire avancer le schmilblick.

Hors ligne

#16 Le 18/05/2018, à 23:22

Klitisse Woude

Re : Démarrage difficile sur Gimp 2.10

jeange a écrit :

Bonjour,
Après les avis de Cœur Noir et michel_04, pourquoi s’entêter à vouloir 2.10 ppa instable alors que 2.8.22 ppa est très efficace, de plus

Klitisse Woude a écrit :

J’ai donc deux questions principales qui sont comment faire pour :
1) récupérer mes fenêtres latérales sur Gimp 2.8.22 ?

Onglet Fenêtres > Fenêtre unique.

J’ai essayé sans et ça n’a pas fonctionné. Quand Gimp 2.8.22 s’est installé en lieu et place du 2.10 espéré il avait son nombre de fenêtres.
Ensuite, question du 2.8.22, il est bien ; ça fait lurette que je l’utilise avec bonheur, sauf que ça fait un certain temps que l’outil cage fait tout planter.

Coeur Noir a écrit :

[…] Aïe oui pardon j’ai oublié de préciser un truc : gimp 2.10 n’est pas encore disponible dans le ppa d’Otto pour la 16.04 (il l’est bien pour 17.10 et 18.04 par contre).

Je vais donc d’abord passer à Ubuntu 18.4 LTS et ensuite migrer vers Gimp  2.10

Coeur Noir a écrit :

La 2.10 est présentée comme stable il me semble sur le site de Gimp. Elle amène un bon lot de nouveautés, techniques, ergonomiques donc je comprends qu’on puisse vouloir s’y mettre.

Absolument.
J’ai la bonde dans ton sens.

Coeur Noir a écrit :

En attendant la 2.8.x reste utilisable, hein ;-)

C’est pas faut. Et je vais rester là-dessus quelques jours encore.

Coeur Noir a écrit :

…entre les nouveautés de gimp 2.10, les nouveautés de snap et flatpak, difficiles de cerner ce qui coince dans l’un ou l’autre cas… Je dirais que cette accumulation de nouveautés coïncide un peu mal avec la sortie d’une nouvelle LTS…

Les nouveautés de Gimp, j’assume ; une nouvelle LTS, je vais m’y mettre ; mais les nouveautés de snap et flatpak, là, je ne vois pas bien. J’ai lu des explications prenant l’exemple de bacs à sable, c’est resté très opaque pour moi. Je vais attendre que ça se mette en route sans que je m’en rende compte.
J’ajoute un grand merci à tous que vous êtes de vous être donné de la peine pour moi et les autres quiches dans mon genre. La lecture de mes aventures les éclairera certainement.

Hors ligne

#17 Le 18/05/2018, à 23:27

lool_lauris

Re : Démarrage difficile sur Gimp 2.10

Klitisse Woude a écrit :

Je ne reproche rien à la version officielle et stable. Je la voudrais juste en français…

N'as-tu pas lancé la prise en charge des langues ?
=> Paramètres système... > Prise en charge des langues > la vérification devrait se lancer toute seule. Si des paquets de langues propres aux applis en place sont à installer, ça te sera signifié.

EDIT : Personnellement, j'attendrais un peu avant d'installer la 18.04.

Dernière modification par lool_lauris (Le 18/05/2018, à 23:28)


Soutenez le Libre => http://www.april.org/

Hors ligne

#18 Le 19/05/2018, à 00:33

Klitisse Woude

Re : Démarrage difficile sur Gimp 2.10

lool_lauris a écrit :
Klitisse Woude a écrit :

Je ne reproche rien à la version officielle et stable. Je la voudrais juste en français…

N'as-tu pas lancé la prise en charge des langues ?
=> Paramètres système... > Prise en charge des langues > la vérification devrait se lancer toute seule. Si des paquets de langues propres aux applis en place sont à installer, ça te sera signifié.

Non, je n'ai pas pensé à faire ça.
Mais si on me dit que Gimp 2.10 est instable sur Ubuntu 16.4, je vais attendre un peu

lool_lauris a écrit :

EDIT : Personnellement, j'attendrais un peu avant d'installer la 18.04.

Oui ?
Où y a-t-il un problème particulier ?

Hors ligne

#19 Le 19/05/2018, à 02:22

moko138

Re : Démarrage difficile sur Gimp 2.10

Klitisse Woude a écrit :

Si des types se sont donnés la peine de nous faire un beau truc avec plein d’améliorations c’est bien de s’en servir, ne serait-ce que pour les encourager et si on tombe sur un bug leur en faire part pour faire avancer le schmilblick.

D'accord, c'est un choix qui assume les bugs.
  - -

Klitisse Woude a écrit :
moko138 a écrit :

Mais que reproches-tu à la version officielle et stable ?
EDIT : et à la version stable du ppa, cette 2.8.22 ?

Je ne reproche rien à la version officielle et stable. Je la voudrais juste en français…

Pour les versions en .deb (la version des dépôts officiels, comme celles des ppa) :

sudo apt-get update ; sudo apt-get install gimp-help-fr

%NOINDEX%
Un utilitaire méconnu : ncdu

En ligne

#20 Le 19/05/2018, à 16:18

Klitisse Woude

Re : Démarrage difficile sur Gimp 2.10

J’ai voulu transformer une image.
Je n’ai retrouvé ni Gimp 2.8.22 ni 2.10…
En désespoir de cause j’ai lancé « Logiciels Ubuntu ».
J’ai cliqué sur « installer Gimp » ;
Les détails sont :
Channel    stable
Version    2.10.0
License        GPL-3.0+
Développeur     snapcrarfters
Source        Snap Store
Taille        209,1 Mo
-
J’ai ouvert un terminal et tapé :
sudo apt-get update ; sudo apt-get install gimp-help-fr
Ça n’a rien changé.
-
C’est en français.
Ça marche.
L’aide n’est pas installée, j’ai coché « aide en ligne ».
On dit « résolu » ?
-
Et je dit merci à ceux qui ont bien voulu se pencher sur mes misères ?
MERCI LES GARS !

Hors ligne

#21 Le 19/05/2018, à 16:25

moko138

Re : Démarrage difficile sur Gimp 2.10

Klitisse Woude a écrit :
lool_lauris a écrit :

Personnellement, j'attendrais un peu avant d'installer la 18.04.

Oui ?
Où y a-t-il un problème particulier ?

Vois ./viewtopic.php?pid=21912913#p21912913.


%NOINDEX%
Un utilitaire méconnu : ncdu

En ligne

#22 Le 20/05/2018, à 09:48

Klitisse Woude

Re : Démarrage difficile sur Gimp 2.10

L’avertissement me semble pertinent et utile.
J’attendrai la fin de l’année pour migrer.
Merci de ton avis avisé.

Hors ligne

#23 Le 20/05/2018, à 13:34

Coeur Noir

Re : Démarrage difficile sur Gimp 2.10

…par ailleurs si tu as l'habitude d'ajouter des scripts ( filtres, outils divers, etc… ) à Gimp, la version 2.10 n'acceptera pas nécessairement ceux prévus pour la 2.8 - gimp-plugin-registry et autres add-ons ko…

De plus, pas mal d'effets dans Gimp 2.10, appliqués à du texte, enlèvent l'attribut texte au calque d'origine !!! Alors qu'auparavant ces mêmes effets créaient un calque supplémentaire. Aujourd'hui le calque texte + le calque effet sont fusionnés en un seul : pour moi c'est une catastrophe…

Sans compter quelques effets par défaut qui semblent un peu cassés ( bordure ), ou quelques grands classiques toujours manquants ( contour, biseautage, estampage… )

Dernière modification par Coeur Noir (Le 20/05/2018, à 13:43)

Hors ligne

#24 Le 21/05/2018, à 21:17

jeange

Re : Démarrage difficile sur Gimp 2.10

Klitisse Woude a écrit :

Merci de ton avis avisé.

Je dirais même plus (à un pro de Gimp alias moko le cent trente huitième de la dynastie...) Merci de ton avi avertissement; sans oublier la prosternation d'usage. cool


PCLF CLEVO W670SZQ i3-4000M Ram 8Go  Haswell HD4600 Ubuntu 14.04  18.04 LTS 64bits
033 V nospE   22.8.2  8.01.2 pmiG  X04D nokiN
Merci de donner les retours avec les balises < > et les allers avec les valises.
%NOINDEX%

En ligne

#25 Le 22/05/2018, à 13:00

moko138

Re : Démarrage difficile sur Gimp 2.10

Euh !   Le pro de gimp, c'est jeange (cent-avertunième du nom) qui me regonfle quand gimp regimbe.


%NOINDEX%
Un utilitaire méconnu : ncdu

En ligne