Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#26 Le 03/06/2018, à 19:43

arkine38

Re : installation UBUNTU 18.04 sur PX753VD-GC081R

J'avance ...

Je viens de comprendre que la mise à jour, que j'ai fait cet après midi, a mis mon PC comme celui de ft dans le 1er lien (messsage 1420) :

ft a écrit :

C'est bon, j'ai de nouveau une conso basse avec les drivers proprio (gpu M1000M) :
- régler Prime sur Intel
- dans /etc/default/grub, virer l'option "nouveau.runpm=0" puis ne pas oublier de faire update-grub
- dans /etc/default/tlp, ne pas exclure nouveau du PM par :  RUNTIME_PM_DRIVER_BLACKLIST=""
- ne rien changer dans /etc/modprobe.d
- rebooter

Je tente de faire plus ou moins la même chose, mais moi, je n'ai plus accès à Nvidia settings et quand je tente de modifier Grub par nano, il ne vaut pas me l'enregistrer :

sudo update-grub
/usr/sbin/grub-mkconfig: 35: /etc/default/grub: Syntax error: EOF in backquote substitution

Bon en plus, le message de ft n'est pas des plus limpides pour le novice que je suis ... (bien que je comprenne qu'il va falloir installer tlp si je ne dis pas de bêtises ...)

Hors ligne

#27 Le 03/06/2018, à 19:49

arkine38

Re : installation UBUNTU 18.04 sur PX753VD-GC081R

pour te répondre, avec nomodeset, la résolution est pas trop mal ... Mais le pc fait un bruit de fou et chauffe un peu

Hors ligne

#28 Le 05/06/2018, à 10:40

arkine38

Re : installation UBUNTU 18.04 sur PX753VD-GC081R

Toujours en galère ...

Impossible d'enregistrer nomodeset en dur dans le grub et impossible de retrouver Nvidia settings !

Décidément, J'ai l'impression que Ubuntu,Nvidia et ordi portable ne font pas bon ménage du tout !

Comment savoir avec quelle carte graphique je fonctionne et comment désactiver la GTX 1050 ?

Si je ne fonctionnais qu'avec la carte graphique intel intégrée, je n'aurai pas ce souci de sur-consommation et de surchauffe ?

Que fait exactement nomodeset ?

J'ai ubuntu sur un fixe (16.04) et je n'ai vraiment aucun souci ...

Hors ligne

#29 Le 05/06/2018, à 18:33

lucmars

Re : installation UBUNTU 18.04 sur PX753VD-GC081R

Avec Nano, t'as du oublié un guillemet, mais bon si ça chauffe aussi avec nomodeset qui signifie No Mode Set (le profil bas en gros) alors oublies.

Je pense que la 180400 est née sous une mauvaise étoile, aussi attends la 180401.

Dans l'attente, essaies la 160405, voir si les emmerdes persistent ou non ou en moins. C'est une LTS qui te proposera la 180400, puis la 180401, pour upgrader (opération souvent casse-gueule).

Hors ligne

#30 Le 05/06/2018, à 21:53

arkine38

Re : installation UBUNTU 18.04 sur PX753VD-GC081R

Merci Lucmars pour ton soutien !

Pour nano, j'avais trouvé sur le foru en tapant le code d'erreur en recherche. Par contre, j'ai galéré car quelqu'un expliquait que l'erreur était à la ligne 35 (soit la dernière + 1) ... Et en fait c'est après "quiet splash"  ... Ce qui est normal puisque c'est là où on corrige le plus souvent je pense !

Donc maintenant, je passe uniquement avec la commande "gedit admin:///chemin/du/document" ... Au moins, je vois ce que je fais ...

Sinon je crois que tu as raison, je vais peut-être essayer la 160405 car je crois que paradoxalement, le noyau est plus récent ... Du coup, mon prochain portable sera sans carte dédiée Nvidia (ils nous prennent un peu pour des quiches si j'ai bien compris ... Cf le lien 1)

Nepenthes a écrit :

Il faudrait avertir les utilisateurs que la 18.04 est une catastrophe sur les laptops Nvidia Optimus récents.
Là où la 17.10 brillait par son support de ces configs dès l'installation, la gestion de l'énergie est ici absente.

Le module bbswitch qui servait à économiser de l'énergie et limiter la chaleur dégagée n'est plus utilisé par nvidia-prime, l'outil fourni (le module n'est plus maintenu, donc les devs d'Ubuntu ont choisi de ne plus l'utiliser).
À sa place, le driver nouveau est chargé et tente de désactiver la carte nvidia dédiée... Ce qui ne fonctionne pas et cause un freeze sur les cartes de série 10xx.
Sur les configs récentes, ce comportement est interdit par la configuration par défaut, ce qui revient à admettre qu'Ubuntu ne gère plus l'énergie sur les laptops Nvidia Optimus.

Je suis dégoûté et je pense downgrader mon installation, impossible d'utiliser mon laptop dans ces conditions.

EDIT: J'ai réussi à désactiver la carte intel en créant un service systemd qui appelle bbswitch. Nouveau doit aussi être backlisté pour que ça fonctionne. Si quelqu'un veut des instructions détaillées, je pourrai faire un tuto.

Nepenthes a écrit :

@ft Ton problème est lié au changement dans nvidia-prime, le script de sélection de carte graphique et de gestion de l'énergie, que je décris un peu plus haut :
- bbswitch, le module appelé par nvidia-prime pour activer ou désactiver la carte Nvidia sur Ubuntu 17.10, n'est plus maintenu. Les devs d'Ubuntu ont donc choisi de ne plus l'inclure par défaut ;
- nvidia-prime s'appuie à présent sur le pilote libre nouveau pour désactiver la carte graphique dédiée Nvidia ;
- nouveau freeze les systèmes équipés de cartes nvidia de séries 10xx, lorsqu'on tente un login graphique (https://bugs.freedesktop.org/show_bug.cgi?id=101665) ;
- par défaut, Ubuntu 18.04 désactive la gestion de l'énergie par nouveau, pour éviter le bug (nouveau.runpm=0 ajouté aux options du kernel).

On peut en conclure que la gestion de l'énergie sur les systèmes Nvidia Optimus ne sera pas fonctionnelle sur Ubuntu 18.04 (peut être jusqu'en 18.10 ou au delà si nouveau n'est pas corrigé dans une 18.04.1, .2 ou .3...).
Et ouais, je pense qu'une telle régression est un scandale.

Pour contourner le problème et toujours désactiver la carte nvidia dédiée, on peut blacklister nouveau au niveau du kernel, installer manuellement bbswitch, et créer un service systemd qui appelle bbswitch au démarrage.


Ceci étant, je vois que certains ont l'air d'avoir réussi à bricoler un truc pour désactiver la carte Nvidia. Si ils passent sur le forum, ils peuvent venir me faire un ti coucou, je serai heureux. smile Je sais pas si on peut contacter les membres du forum par un message direct et surtout, si c'est dans les habitudes du forum ...

Quand je vois que j'ai mis la 180400 sur le vieux portable entrée de gamme de ma chérie et que ça tourne nickel ! Et elle me nargue en plus !!! tongue

A + et encore merci Lucmars

Hors ligne