Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 07/06/2018, à 00:33

Coeur Noir

Bluetooth toujours « on » au démarrage alors que… [ résolu ]

Hello,

Comment / Pourquoi ? À chaque démarrage d'Ubuntu-Budgie, le bluetooth est actif alors que je le passe en mode avion systématiquement en cours de session.

N'est-il pas sensé rester dans cet état à la prochaine session ?

( Je le passe en mode avion depuis son icône dans la zone de notification )

Dernière modification par Coeur Noir (Le 22/06/2018, à 17:04)

En ligne

#2 Le 07/06/2018, à 00:42

seebz

Re : Bluetooth toujours « on » au démarrage alors que… [ résolu ]

Salut Coeur Noir,
en fait, c'est une option par défaut de blueman qui fout la m**.. j'en parle là

seebz a écrit :

Par défaut, blueman active la carte bluetooth au lancement de la session, il existe une config pour empêcher cela :

$ gsettings set org.blueman.plugins.powermanager auto-power-on false

De cette façon, la carte bluetooth restera dans l'état précédent (comprendre au moment de la fermeture de la session).

source: https://wiki.archlinux.org/index.php/Bl … o_power-on

Hors ligne

#3 Le 07/06/2018, à 02:04

Coeur Noir

Re : Bluetooth toujours « on » au démarrage alors que… [ résolu ]

Alors de bon cœur je te crois sur parole mais à priori point de blueman :

coeur-noir@asgard:~$ dpkg -l | grep blue
ii  bluez                                 5.48-0ubuntu3                           amd64        Bluetooth tools and daemons
ii  bluez-cups                            5.48-0ubuntu3                           amd64        Bluetooth printer driver for CUPS
ii  bluez-obexd                           5.48-0ubuntu3                           amd64        bluez obex daemon
ii  gnome-bluetooth                       3.28.0-2                                amd64        GNOME Bluetooth tools
ii  libbluetooth3:amd64                   5.48-0ubuntu3                           amd64        Library to use the BlueZ Linux Bluetooth stack
ii  libgnome-bluetooth13:amd64            3.28.0-2                                amd64        GNOME Bluetooth tools - support library
ii  pulseaudio-module-bluetooth           1:11.1-1ubuntu7.1                       amd64        Bluetooth module for PulseAudio sound server
coeur-noir@asgard:~$

Si j'essaie la ligne que tu proposes, comment je « l'enlève » au cas où elle ne change rien ?

Dernière modification par Coeur Noir (Le 07/06/2018, à 02:50)

En ligne

#4 Le 07/06/2018, à 07:58

seebz

Re : Bluetooth toujours « on » au démarrage alors que… [ résolu ]

Coeur Noir a écrit :

Alors de bon cœur je te crois sur parole mais à priori point de blueman

Effectivement, c'est chelou. Mais je suis quand même vachement intérressé de connaitre le fin mot de l'histoire donc je m'abonne à la discussion ^^

Coeur Noir a écrit :

Si j'essaie la ligne que tu proposes, comment je « l'enlève » au cas où elle ne change rien ?

Dans ce cas, tu auras une erreur du style Le schéma « org.blueman.plugins.powermanager » n’existe pas... du coup pas la peine de supprimer quoi que ce soit.

Hors ligne

#5 Le 07/06/2018, à 08:02

xubu1957

Re : Bluetooth toujours « on » au démarrage alors que… [ résolu ]

Bonjour,

Et dans cette réponse > Arrêter la connexion automatique au bluetooth, rien d'exploitable ?


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#6 Le 07/06/2018, à 08:08

seebz

Re : Bluetooth toujours « on » au démarrage alors que… [ résolu ]

Une autre piste sinon :

sudo systemctl mask bluetooth
smebellis@discourse a écrit :

Unmasking it will allow you to start/stop the service again.

https://discourse.ubuntubudgie.org/t/bl … tup/231/10

Hors ligne

#7 Le 07/06/2018, à 15:00

Coeur Noir

Re : Bluetooth toujours « on » au démarrage alors que… [ résolu ]

Bon déjà faut que je vérifie si c'est spécifique à budgie, ou à 18.04 plus largement.

Ensuite ce qui me gêne, c'est le on par défaut. Je préfère allumer le bluetooth seulement quand j'en ai besoin.

Donc je crains que le mask soit un peu radical.

En ligne

#8 Le 21/06/2018, à 07:37

danylord

Re : Bluetooth toujours « on » au démarrage alors que… [ résolu ]

bonjour,

j'ai un lenovo T420 avec le bluetooth intégré. pour contourner le truc j'ai été dans préférence puis dans application au démarrage.
j'ai fait ajouter / j'ai mis une commande "rfkill block 0" et à chaque démarrage le blutooth est éteint.

Par contre il faut faire une commande rfkill dans une ligne de commande pour vérifier si 0 correspond bien au bluetooth sur ta machine.
sinon il faut changer le 0 par la valeur correspondant au bluetooth.


PC portable lenovo T420 / OS: Ubuntu Budgie 18.04 LTS

Hors ligne

#9 Le 22/06/2018, à 03:06

Coeur Noir

Re : Bluetooth toujours « on » au démarrage alors que… [ résolu ]

Excellente idée Danylord, merci !

En ligne

#10 Le 22/06/2018, à 11:10

danylord

Re : Bluetooth toujours « on » au démarrage alors que… [ résolu ]

de rien si je peux rendre service big_smile


PC portable lenovo T420 / OS: Ubuntu Budgie 18.04 LTS

Hors ligne

#11 Le 22/06/2018, à 14:30

ylag

Re : Bluetooth toujours « on » au démarrage alors que… [ résolu ]

Bonjour,

Coeur Noir a écrit :

Donc je crains que le mask soit un peu radical.

Peut-être avec:

sudo systemctl disable bluetooth.service

?

Dernière modification par ylag (Le 22/06/2018, à 14:31)

Hors ligne

#12 Le 22/06/2018, à 16:31

Coeur Noir

Re : Bluetooth toujours « on » au démarrage alors que… [ résolu ]

Aïe, le gag… d'un redémarrage à l'autre bluetooth et wifi ne gardent pas le même id ( 0 ou 1 dans rfkill ) !
Et pas vu de moyen d'utiliser le type ou le nom de périphérique avec rfkill block [id].

Pas testé mais je crains qu'avec :

sudo systemctl disable bluetooth.service

il faudra à nouveau passer par une commande sudo pour ré-activer le bt…

Dernière modification par Coeur Noir (Le 22/06/2018, à 16:39)

En ligne

#13 Le 22/06/2018, à 17:04

Coeur Noir

Re : Bluetooth toujours « on » au démarrage alors que… [ résolu ]

Et beh si on peut rentrer le « type » !

Donc la commande à passer est :

rfkill block bluetooth

Ça en causait là : https://discourse.ubuntubudgie.org/t/bl … tartup/231

En ligne