Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 10/06/2018, à 09:21

arkine38

Reglage frequence CPU

Bonjour à tous

Nouvelle installation de Ubuntu 18.04. Tout fonctionne bien à priori mais je trouve que le pc mouline plus qu'il ne le devrait ... Et je n'arrive pas à régler correctement la fréquence du CPU malgré l'installation de Cpufrequtils et Indicator-cpufreq. En fait, j'ai dû désinstaller Indicator car il se déconnectait sans arrêt avec un message d'erreur. Dans les limites matérielles, la CPu est max à 1.80 GH alors qu'elle peut monter normalement un peu plus ... (CPU 8250U).

Le PC est un asus P1501UA-DM598R

Merci pour votre aide

Hors ligne

#2 Le 10/06/2018, à 10:27

f.x0

Re : Reglage frequence CPU

Bonjour arkine38,

Si la réponse de la commande ci-dessous renvoie CONFIG_X86_INTEL_PSTATE=y
ou  CONFIG_X86_INTEL_PSTATE=yes

grep -i pstate /boot/config-$(uname -r)

postes le retour de

cat /etc/init.d/cpufrequtils

SOPI

Hors ligne

#3 Le 10/06/2018, à 10:47

arkine38

Re : Reglage frequence CPU

Merci de me répondre

Voici la réponse :

anthony@AR-X542UAR:~$ grep -i pstate /boot/config-$(uname -r)
CONFIG_X86_INTEL_PSTATE=y
anthony@AR-X542UAR:~$ cat /etc/init.d/cpufrequtils
#!/bin/sh
### BEGIN INIT INFO
# Provides:       cpufrequtils
# Required-Start: $remote_fs loadcpufreq
# Required-Stop:
# Default-Start:  2 3 4 5
# Default-Stop:
# Short-Description: set CPUFreq kernel parameters
# Description: utilities to deal with CPUFreq Linux 
#	kernel support
### END INIT INFO
# 

DESC="CPUFreq Utilities"

PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
CPUFREQ_SET=/usr/bin/cpufreq-set
CPUFREQ_INFO=/usr/bin/cpufreq-info
CPUFREQ_OPTIONS=""

# use lsb-base
. /lib/lsb/init-functions

# Which governor to use. Must be one of the governors listed in:
#   cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors
#
# and which limits to set. Both MIN_SPEED and MAX_SPEED must be values
# listed in:
#   cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_frequencies
# a value of 0 for any of the two variables will disabling the use of 
# that limit variable.
#
# WARNING: the correct kernel module must already be loaded or compiled in.
# 
# Set ENABLE to "true" to let the script run at boot time.
# 
# eg:	ENABLE="true"
#	GOVERNOR="ondemand"
#	MAX_SPEED=1000
#	MIN_SPEED=500

ENABLE="true"
GOVERNOR="ondemand"
MAX_SPEED="0"
MIN_SPEED="0"

check_governor_avail() {
	info="/sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors"
	if [ -f $info ] && grep -q "\<$GOVERNOR\>" $info ; then
		return 0;
	fi
	return 1;
}

[ -x $CPUFREQ_SET ] || exit 0

if [ -f /etc/default/cpufrequtils ] ; then
	. /etc/default/cpufrequtils
fi

# if not enabled then exit gracefully
[ "$ENABLE" = "true" ] || exit 0

if [ -n "$MAX_SPEED" ] && [ $MAX_SPEED != "0" ] ; then
	CPUFREQ_OPTIONS="$CPUFREQ_OPTIONS --max $MAX_SPEED"
fi

if [ -n "$MIN_SPEED" ] && [ $MIN_SPEED != "0" ] ; then
	CPUFREQ_OPTIONS="$CPUFREQ_OPTIONS --min $MIN_SPEED"
fi

if [ -n "$GOVERNOR" ] ; then
	CPUFREQ_OPTIONS="$CPUFREQ_OPTIONS --governor $GOVERNOR"
fi

CPUS=$(cat /proc/stat|sed -ne 's/^cpu\([[:digit:]]\+\).*/\1/p')
RETVAL=0
case "$1" in
	start|force-reload|restart|reload)
		log_action_begin_msg "$DESC: Setting $GOVERNOR CPUFreq governor"
		if check_governor_avail ; then
			for cpu in $CPUS ; do
				log_action_cont_msg "CPU${cpu}"
				$CPUFREQ_SET --cpu $cpu $CPUFREQ_OPTIONS 2>&1 > /dev/null || \
					RETVAL=$?
			done
			log_action_end_msg $RETVAL ""
		else
			log_action_cont_msg "disabled, governor not available"
			log_action_end_msg $RETVAL
		fi
		;;
	stop)
		;;
	*)
		echo "Usage: $0 {start|stop|restart|reload|force-reload}"
		exit 1
esac

exit 0

anthony@AR-X542UAR:~$ 

Pour info, en ce qui concerne la limite matérielle, j'avais désactivé intel paste dans le grub pour accéder à plus de réglages de gouverneurs (à la demande et conservateur ...). Je l'ai enlevé et je ne retrouve plus que performances ou powersave ... Mais la limite matérielle est enlevée et j'ai bien 3.40 Gh en performance.

Hors ligne