Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 13/06/2018, à 09:43

airvb

Apache2 Vhost 2 serveurs

Bonjour.
Soit 2 serveurs sur la même machine ubuntu serveur 1604
1 : Serveur nextcloud qui fonctionne bien. il est accessible aussi bien depuis l’intérieur et l’extérieur du réseau. ( 80 & 443 ) .
2 : Un serveur à usage local  ( 80 uniquement pour l'instant )  uniquement accessible depuis les machines locales 192.168.1.1/24

Sur les machines locales ou je peux renseigner le /etc/hosts avec 192.168.1.105 rvserveur le serveur local passe bien . ( 105 c'est bien l'ip du serveur ! )
En revanche sur une tablette ou smartphone ou le etc/hosts n'est pas modifiable j'ai une erreur : ERR_NAME_NOT_RESOLVED

cpy des fichiers de conf nextcloud :

master@rvserveur:/etc/apache2/sites-available$ cat nextcloud.conf 
<VirtualHost *:80>
	ServerAdmin airvb@free.fr
        ServerName airvb.net
	DocumentRoot /var/www/html/nextcloud/

     <Directory /var/www/html/nextcloud/>
        Options +FollowSymlinks
        AllowOverride All
        Require all granted
          <IfModule mod_dav.c>
            Dav off
          </IfModule>
        SetEnv HOME /var/www/html/nextcloud
        SetEnv HTTP_HOME /var/www/html/nextcloud
     </Directory>

     ErrorLog ${APACHE_LOG_DIR}/error.log
     CustomLog ${APACHE_LOG_DIR}/access.log combined

</VirtualHost>

Le 443 nextcloud :

master@rvserveur:/etc/apache2/sites-available$ cat nextcloud-le-ssl.conf 
<IfModule mod_ssl.c>
<VirtualHost *:443>
     DocumentRoot /var/www/html/nextcloud/
	ServerAdmin airvb@free.fr
        ServerName airvb.net
     <Directory /var/www/html/nextcloud/>
        Options +FollowSymlinks
        AllowOverride All
        Require all granted
          <IfModule mod_dav.c>
            Dav off
          </IfModule>
        SetEnv HOME /var/www/html/nextcloud
        SetEnv HTTP_HOME /var/www/html/nextcloud
     </Directory>

	<IfModule mod_headers.c>
                Header always set Strict-Transport-Security "max-age=15552000; includeSubDomains"
        </IfModule>


     ErrorLog ${APACHE_LOG_DIR}/error.log
     CustomLog ${APACHE_LOG_DIR}/access.log combined

SSLCertificateFile /etc/letsencrypt/live/airvb.net/fullchain.pem
SSLCertificateKeyFile /etc/letsencrypt/live/airvb.net/privkey.pem
Include /etc/letsencrypt/options-ssl-apache.conf
</VirtualHost>

</IfModule>

Et enfin la conf du serveur local :

master@rvserveur:/etc/apache2/sites-available$ cat rvserveur.conf
<VirtualHost *:80>
	ServerName rvserveur
	ServerAdmin webmaster@localhost
	DocumentRoot /var/www/html/perso

	<Directory /var/www/html/perso>

	#        Options Indexes FollowSymLinks Includes
	
		Require ip 192.168.1 127.0.0

#		ErrorLog ${APACHE_LOG_DIR}/error.log
#		CustomLog ${APACHE_LOG_DIR}/access.log combined
	 </Directory>

</VirtualHost>

copy Dump_vhosts

master@rvserveur:/etc/apache2/sites-available$ sudo apache2ctl -t -D DUMP_VHOSTS
[Wed Jun 13 09:41:06.183534 2018] [so:warn] [pid 29538] AH01574: module php7_module is already loaded, skipping
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1. Set the 'ServerName' directive globally to suppress this message
VirtualHost configuration:
*:443                  airvb.ddns.net (/etc/apache2/sites-enabled/nextcloud-le-ssl.conf:2)
*:80                   is a NameVirtualHost
         default server airvb.ddns.net (/etc/apache2/sites-enabled/nextcloud.conf:1)
         port 80 namevhost airvb.ddns.net (/etc/apache2/sites-enabled/nextcloud.conf:1)
         port 80 namevhost rvserveur (/etc/apache2/sites-enabled/rvserveur.conf:1)
master@rvserveur:/etc/apache2/sites-available$ 


Une idée . Merci par avance .

Dernière modification par airvb (Le 13/06/2018, à 09:45)

Hors ligne

#2 Le 13/06/2018, à 13:00

krodelabestiole

Re : Apache2 Vhost 2 serveurs

airvb a écrit :

En revanche sur une tablette ou smartphone ou le etc/hosts n'est pas modifiable j'ai une erreur : ERR_NAME_NOT_RESOLVED

Une idée . Merci par avance .

enregistrer des vrais noms de domaine (ou sous domaines), éventuellement en DNS dynamiques ?
https://freedns.afraid.org

Hors ligne

#3 Le 14/06/2018, à 08:33

airvb

Re : Apache2 Vhost 2 serveurs

Bonjour , le site nextcloud est bien un site avec un vrai nom de domaine .

Le site intérieur n'est pas référencé . c'est  juste un site perso qui n'a pas vocation à être accessible depuis internet.

Hors ligne

#4 Le 14/06/2018, à 11:36

bruno

Re : Apache2 Vhost 2 serveurs

airvb a écrit :

Le site intérieur n'est pas référencé . c'est  juste un site perso qui n'a pas vocation à être accessible depuis internet.

Cela n'empêche pas d'avoir un vrai nom de domaine.
Le site en question a de toute façon sont accès restreint par la directive Require ip

Hors ligne

#5 Le 14/06/2018, à 13:40

krodelabestiole

Re : Apache2 Vhost 2 serveurs

airvb a écrit :

Le site intérieur n'est pas référencé . c'est  juste un site perso qui n'a pas vocation à être accessible depuis internet.

un nom de domaine ça n'a pas de rapport direct avec le référencement.

si tu peux pas modifier le fichier hosts, soit tu créés un ndd, soit tu accèdes à ton contenu web à l'url http://ip_du_serveur/contenu_web en créant un alias par ex. pour l'emplacement /contenu_web, soit tu sers ce contenu spécifiquement sur un port autre que le port 80 et tu y accèdes par ex. via http://ip_du_serveur:8080

Dernière modification par krodelabestiole (Le 14/06/2018, à 13:40)

Hors ligne

#6 Le 15/06/2018, à 16:27

airvb

Re : Apache2 Vhost 2 serveurs

Merci pour vos réponses.

J'ai commencé par retirer le site nextcloud en 80 et 443
Après j'ai aussi viré mon site perso en 80.

Reste donc que le site perso en 443.

Avec l'allias sur le dossier /perso ca fonctionne enfin sauf que lorsque je réactive le site nexcloud, nexcloud "préempte le 443"  et je tombe sur une page de nexcloud avec une histoire de trusted domain . J'ai laissé tomber.

Après moulte essai divers .
J'ai passé le site perso sur le port 8080 en https et là tout fonctionne ( en ajoutant bien sur listen 8080 ds apache2.conf .....

@krodelabestiole
Une dernière q , c'est quoi ndd ?

Merci

Hors ligne

#7 Le 15/06/2018, à 16:33

krodelabestiole

Re : Apache2 Vhost 2 serveurs

le port 443 est réservé au HTTPS, donc évite si tu veux pas mettre en place un certificat signé.
mais au contraire force le si tu veux échanger des données sensibles avec ton serveur sur internet (mot de passe nextcloud ou autre)

ndd c'est nom de domaine

Hors ligne