Contenu | Rechercher | Menus

Annonce

T-shirt Seiche Cosmic, Série limitée

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.10
T-shirt Ubuntu-FR « Seiche Cosmique » en série limitée ! Prix spécial pré-vente (15€) jusqu'au 4 novembre 2018.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#2351 Le 16/06/2018, à 21:07

jna

Re : Script d'installation pour imprimantes Brother

Merci Éric pour les tentatives,
alors voici, j'ai tout fait suivant tes indications, seul chose la phrase au début :ls: impossible d'accéder à '/etc/udev/rules.d/*.rules': Aucun fichier ou dossier de ce type

jean-noel@jeannoel-Vostro-1015:~$ sudo dpkg -i /home/jean-noel/Téléchargements/brother-udev-rule-type1-1.0.2-0.all.deb 
(Lecture de la base de données... 211851 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../brother-udev-rule-type1-1.0.2-0.all.deb ...
Dépaquetage de brother-udev-rule-type1 (1.0.2) sur (1.0.0-1) ...
Paramétrage de brother-udev-rule-type1 (1.0.2) ...
ls: impossible d'accéder à '/etc/udev/rules.d/*.rules': Aucun fichier ou dossier de ce type
jean-noel@jeannoel-Vostro-1015:~$ sane-find-scanner 

  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

could not open USB device 0x5986/0x01a2 at 002:003: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0002 at 002:001: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0001 at 008:001: Access denied (insufficient permissions)
could not open USB device 0x04b3/0x310b at 007:002: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0001 at 007:001: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0001 at 006:001: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0002 at 001:001: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0001 at 005:001: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0001 at 004:001: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0001 at 003:001: Access denied (insufficient permissions)
  # No USB scanners found. If you expected something different, make sure that
  # you have loaded a kernel driver for your USB host controller and have setup
  # the USB system correctly. See man sane-usb for details.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.

  # You may want to run this program as root to find all devices. Once you
  # found the scanner devices, be sure to adjust access permissions as
  # necessary.
jean-noel@jeannoel-Vostro-1015:~$ scanimage -L 

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).
jean-noel@jeannoel-Vostro-1015:~$ dpkg -l | grep Brother 
ii  brmfc7840wlpr                                2.0.2-1                             i386         Brother MFC-7840W LPR driver
ii  brother-udev-rule-type1                      1.0.2                               all          Brother udev rule type 1
ii  brscan-skey                                  0.2.4-1                             i386         Brother Linux scanner S-KEY tool
ii  brscan3                                      0.2.13-1                            i386         Brother Scanner Driver
ii  cupswrappermfc7840w                          2.0.2-1                             i386         Brother MFC7840W CUPS wrapper driver
jean-noel@jeannoel-Vostro-1015:~$ sudo apt-get install sane
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Paquets suggérés :
  gimp
Les NOUVEAUX paquets suivants seront installés :
  sane
0 mis à jour, 1 nouvellement installés, 0 à enlever et 19 non mis à jour.
Il est nécessaire de prendre 86,7 ko dans les archives.
Après cette opération, 290 ko d'espace disque supplémentaires seront utilisés.
Réception de:1 http://ca.archive.ubuntu.com/ubuntu bionic/universe i386 sane i386 1.0.14-12build1 [86,7 kB]
86,7 ko réceptionnés en 1s (151 ko/s)
Sélection du paquet sane précédemment désélectionné.
(Lecture de la base de données... 211851 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../sane_1.0.14-12build1_i386.deb ...
Dépaquetage de sane (1.0.14-12build1) ...
Paramétrage de sane (1.0.14-12build1) ...
Traitement des actions différées (« triggers ») pour man-db (2.8.3-2) ...
jean-noel@jeannoel-Vostro-1015:~$ sudo apt-get install libsane-extras 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
libsane-extras est déjà la version la plus récente (1.0.22.5).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 19 non mis à jour.
jean-noel@jeannoel-Vostro-1015:~$ sudo add-apt-repository ppa:rolfbensch/sane-git
 Ubuntu SANE packages from SANE daily git snapshots (http://www.sane-project.org/snapshots/).

Unchanged SANE daily git snapshots are ignored!

Please send scanner related questions to the SANE mailing list <email address hidden>.

If you need the last released scanner driver, you can use my other PPA: https://launchpad.net/~rolfbensch/+archive/ubuntu/sane-release.
 Plus d’info : https://launchpad.net/~rolfbensch/+archive/ubuntu/sane-git
Appuyez sur [ENTRÉE] pour continuer ou sur Ctrl-c pour annuler l'ajout.

Atteint:1 http://ca.archive.ubuntu.com/ubuntu bionic InRelease
Réception de:2 http://security.ubuntu.com/ubuntu bionic-security InRelease [83,2 kB]                 
Réception de:3 http://ca.archive.ubuntu.com/ubuntu bionic-updates InRelease [83,2 kB]                
Réception de:4 http://ca.archive.ubuntu.com/ubuntu bionic-backports InRelease [74,6 kB]              
Réception de:5 http://security.ubuntu.com/ubuntu bionic-security/main i386 DEP-11 Metadata [204 B]   
Réception de:6 http://security.ubuntu.com/ubuntu bionic-security/universe i386 DEP-11 Metadata [2452 B]
Réception de:7 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main i386 DEP-11 Metadata [105 kB] 
Réception de:8 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main DEP-11 48x48 Icons [18,0 kB]  
Réception de:9 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main DEP-11 64x64 Icons [34,3 kB]
Réception de:10 http://ppa.launchpad.net/rolfbensch/sane-git/ubuntu bionic InRelease [15,4 kB]     
Réception de:11 http://ca.archive.ubuntu.com/ubuntu bionic-updates/universe i386 DEP-11 Metadata [120 kB]
Réception de:12 http://ca.archive.ubuntu.com/ubuntu bionic-updates/universe DEP-11 48x48 Icons [127 kB]
Réception de:13 http://ca.archive.ubuntu.com/ubuntu bionic-updates/universe DEP-11 64x64 Icons [197 kB]
Réception de:14 http://ca.archive.ubuntu.com/ubuntu bionic-backports/universe i386 DEP-11 Metadata [5096 B]
Réception de:15 http://ppa.launchpad.net/rolfbensch/sane-git/ubuntu bionic/main i386 Packages [1364 B]
Réception de:16 http://ppa.launchpad.net/rolfbensch/sane-git/ubuntu bionic/main Translation-en [972 B]
868 ko réceptionnés en 2s (430 ko/s)                
Lecture des listes de paquets... Fait
jean-noel@jeannoel-Vostro-1015:~$ sudo apt-get update
Atteint:1 http://security.ubuntu.com/ubuntu bionic-security InRelease
Atteint:2 http://ppa.launchpad.net/rolfbensch/sane-git/ubuntu bionic InRelease                       
Atteint:3 http://ca.archive.ubuntu.com/ubuntu bionic InRelease                                       
Atteint:4 http://ca.archive.ubuntu.com/ubuntu bionic-updates InRelease
Atteint:5 http://ca.archive.ubuntu.com/ubuntu bionic-backports InRelease
Lecture des listes de paquets... Fait                         
jean-noel@jeannoel-Vostro-1015:~$ sudo apt-get upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants seront mis à jour :
  apport apport-gtk command-not-found command-not-found-data cups-pk-helper desktop-file-utils
  gnome-software gnome-software-common gnome-software-plugin-snap im-config libsane-common libsane1
  netplan.io nplan python3-apport python3-commandnotfound python3-distupgrade python3-problem-report
  sane-utils ubuntu-release-upgrader-core ubuntu-release-upgrader-gtk wireless-regdb
22 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 7570 ko dans les archives.
Après cette opération, 1041 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de:1 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main i386 netplan.io i386 0.36.2 [59,9 kB]
Réception de:2 http://ppa.launchpad.net/rolfbensch/sane-git/ubuntu bionic/main i386 libsane1 i386 1.0.27+git20180607-bionic0 [2197 kB]
Réception de:3 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main i386 nplan all 0.36.2 [1364 B]
Réception de:4 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main i386 command-not-found all 18.04.5 [5184 B]
Réception de:5 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main i386 python3-commandnotfound all 18.04.5 [9020 B]
Réception de:6 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main i386 command-not-found-data i386 18.04.5 [999 kB]
Réception de:7 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main i386 ubuntu-release-upgrader-gtk all 1:18.04.19 [9368 B]
Réception de:8 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main i386 ubuntu-release-upgrader-core all 1:18.04.19 [24,4 kB]
Réception de:9 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main i386 python3-distupgrade all 1:18.04.19 [103 kB]
Réception de:10 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main i386 python3-problem-report all 2.20.9-0ubuntu7.2 [9624 B]
Réception de:11 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main i386 python3-apport all 2.20.9-0ubuntu7.2 [81,3 kB]
Réception de:12 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main i386 apport all 2.20.9-0ubuntu7.2 [124 kB]
Réception de:13 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main i386 apport-gtk all 2.20.9-0ubuntu7.2 [9600 B]
Réception de:14 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main i386 desktop-file-utils i386 0.23-1ubuntu3.18.04.1 [51,3 kB]
Réception de:15 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main i386 gnome-software-plugin-snap i386 3.28.1-0ubuntu4.18.04.1 [30,5 kB]
Réception de:16 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main i386 gnome-software i386 3.28.1-0ubuntu4.18.04.1 [527 kB]
Réception de:17 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main i386 gnome-software-common all 3.28.1-0ubuntu4.18.04.1 [2482 kB]
Réception de:18 http://ppa.launchpad.net/rolfbensch/sane-git/ubuntu bionic/main i386 libsane-common all 1.0.27+git20180607-bionic0 [539 kB]
Réception de:19 http://ppa.launchpad.net/rolfbensch/sane-git/ubuntu bionic/main i386 sane-utils i386 1.0.27+git20180607-bionic0 [222 kB]
Réception de:20 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main i386 im-config all 0.34-1ubuntu1.1 [23,4 kB]
Réception de:21 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main i386 wireless-regdb all 2018.05.09-0ubuntu1~18.04.1 [11,1 kB]
Réception de:22 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main i386 cups-pk-helper i386 0.2.6-1ubuntu1.2 [52,8 kB]
7570 ko réceptionnés en 7s (1140 ko/s)                                                             
Préconfiguration des paquets...
(Lecture de la base de données... 211868 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../00-libsane1_1.0.27+git20180607-bionic0_i386.deb ...
Dépaquetage de libsane1:i386 (1.0.27+git20180607-bionic0) sur (1.0.27-1~experimental3ubuntu2) ...
Préparation du dépaquetage de .../01-libsane-common_1.0.27+git20180607-bionic0_all.deb ...
Dépaquetage de libsane-common (1.0.27+git20180607-bionic0) sur (1.0.27-1~experimental3ubuntu2) ...
Préparation du dépaquetage de .../02-sane-utils_1.0.27+git20180607-bionic0_i386.deb ...
Dépaquetage de sane-utils (1.0.27+git20180607-bionic0) sur (1.0.27-1~experimental3ubuntu2) ...
Préparation du dépaquetage de .../03-netplan.io_0.36.2_i386.deb ...
Dépaquetage de netplan.io (0.36.2) sur (0.36.1) ...
Préparation du dépaquetage de .../04-nplan_0.36.2_all.deb ...
Dépaquetage de nplan (0.36.2) sur (0.36.1) ...
Préparation du dépaquetage de .../05-command-not-found_18.04.5_all.deb ...
Dépaquetage de command-not-found (18.04.5) sur (18.04.4) ...
Préparation du dépaquetage de .../06-python3-commandnotfound_18.04.5_all.deb ...
Dépaquetage de python3-commandnotfound (18.04.5) sur (18.04.4) ...
Préparation du dépaquetage de .../07-command-not-found-data_18.04.5_i386.deb ...
Dépaquetage de command-not-found-data (18.04.5) sur (18.04.4) ...
Préparation du dépaquetage de .../08-ubuntu-release-upgrader-gtk_1%3a18.04.19_all.deb ...
Dépaquetage de ubuntu-release-upgrader-gtk (1:18.04.19) sur (1:18.04.18) ...
Préparation du dépaquetage de .../09-ubuntu-release-upgrader-core_1%3a18.04.19_all.deb ...
Dépaquetage de ubuntu-release-upgrader-core (1:18.04.19) sur (1:18.04.18) ...
Préparation du dépaquetage de .../10-python3-distupgrade_1%3a18.04.19_all.deb ...
Dépaquetage de python3-distupgrade (1:18.04.19) sur (1:18.04.18) ...
Préparation du dépaquetage de .../11-python3-problem-report_2.20.9-0ubuntu7.2_all.deb ...
Dépaquetage de python3-problem-report (2.20.9-0ubuntu7.2) sur (2.20.9-0ubuntu7.1) ...
Préparation du dépaquetage de .../12-python3-apport_2.20.9-0ubuntu7.2_all.deb ...
Dépaquetage de python3-apport (2.20.9-0ubuntu7.2) sur (2.20.9-0ubuntu7.1) ...
Préparation du dépaquetage de .../13-apport_2.20.9-0ubuntu7.2_all.deb ...
Dépaquetage de apport (2.20.9-0ubuntu7.2) sur (2.20.9-0ubuntu7.1) ...
Préparation du dépaquetage de .../14-apport-gtk_2.20.9-0ubuntu7.2_all.deb ...
Dépaquetage de apport-gtk (2.20.9-0ubuntu7.2) sur (2.20.9-0ubuntu7.1) ...
Préparation du dépaquetage de .../15-desktop-file-utils_0.23-1ubuntu3.18.04.1_i386.deb ...
Dépaquetage de desktop-file-utils (0.23-1ubuntu3.18.04.1) sur (0.23-1ubuntu3) ...
Préparation du dépaquetage de .../16-gnome-software-plugin-snap_3.28.1-0ubuntu4.18.04.1_i386.deb ...
Dépaquetage de gnome-software-plugin-snap (3.28.1-0ubuntu4.18.04.1) sur (3.28.1-0ubuntu4) ...
Préparation du dépaquetage de .../17-gnome-software_3.28.1-0ubuntu4.18.04.1_i386.deb ...
Dépaquetage de gnome-software (3.28.1-0ubuntu4.18.04.1) sur (3.28.1-0ubuntu4) ...
Préparation du dépaquetage de .../18-gnome-software-common_3.28.1-0ubuntu4.18.04.1_all.deb ...
Dépaquetage de gnome-software-common (3.28.1-0ubuntu4.18.04.1) sur (3.28.1-0ubuntu4) ...
Préparation du dépaquetage de .../19-im-config_0.34-1ubuntu1.1_all.deb ...
Dépaquetage de im-config (0.34-1ubuntu1.1) sur (0.34-1ubuntu1) ...
Préparation du dépaquetage de .../20-wireless-regdb_2018.05.09-0ubuntu1~18.04.1_all.deb ...
Dépaquetage de wireless-regdb (2018.05.09-0ubuntu1~18.04.1) sur (2016.06.10-0ubuntu1) ...
Préparation du dépaquetage de .../21-cups-pk-helper_0.2.6-1ubuntu1.2_i386.deb ...
Dépaquetage de cups-pk-helper (0.2.6-1ubuntu1.2) sur (0.2.6-1ubuntu1) ...
Paramétrage de gnome-software-common (3.28.1-0ubuntu4.18.04.1) ...
Paramétrage de im-config (0.34-1ubuntu1.1) ...
Traitement des actions différées (« triggers ») pour mime-support (3.60ubuntu1) ...
Traitement des actions différées (« triggers ») pour ureadahead (0.100.0-20) ...
ureadahead will be reprofiled on next reboot
Paramétrage de desktop-file-utils (0.23-1ubuntu3.18.04.1) ...
Traitement des actions différées (« triggers ») pour libglib2.0-0:i386 (2.56.1-2ubuntu1) ...
Paramétrage de wireless-regdb (2018.05.09-0ubuntu1~18.04.1) ...
Paramétrage de netplan.io (0.36.2) ...
Paramétrage de libsane-common (1.0.27+git20180607-bionic0) ...
Installation de la nouvelle version du fichier de configuration /etc/sane.d/agfafocus.conf ...
Installation de la nouvelle version du fichier de configuration /etc/sane.d/artec.conf ...
Installation de la nouvelle version du fichier de configuration /etc/sane.d/artec_eplus48u.conf ...
Installation de la nouvelle version du fichier de configuration /etc/sane.d/avision.conf ...
Installation de la nouvelle version du fichier de configuration /etc/sane.d/canon_dr.conf ...
Installation de la nouvelle version du fichier de configuration /etc/sane.d/canon_pp.conf ...
Installation de la nouvelle version du fichier de configuration /etc/sane.d/dc210.conf ...
Installation de la nouvelle version du fichier de configuration /etc/sane.d/dc240.conf ...
Installation de la nouvelle version du fichier de configuration /etc/sane.d/dc25.conf ...
Installation de la nouvelle version du fichier de configuration /etc/sane.d/dell1600n_net.conf ...
Installation de la nouvelle version du fichier de configuration /etc/sane.d/epjitsu.conf ...
Installation de la nouvelle version du fichier de configuration /etc/sane.d/epson.conf ...
Installation de la nouvelle version du fichier de configuration /etc/sane.d/epson2.conf ...
Installation de la nouvelle version du fichier de configuration /etc/sane.d/fujitsu.conf ...
Installation de la nouvelle version du fichier de configuration /etc/sane.d/gphoto2.conf ...
Installation de la nouvelle version du fichier de configuration /etc/sane.d/gt68xx.conf ...
Installation de la nouvelle version du fichier de configuration /etc/sane.d/hp3900.conf ...
Installation de la nouvelle version du fichier de configuration /etc/sane.d/hpsj5s.conf ...
Installation de la nouvelle version du fichier de configuration /etc/sane.d/kodakaio.conf ...
Installation de la nouvelle version du fichier de configuration /etc/sane.d/leo.conf ...
Installation de la nouvelle version du fichier de configuration /etc/sane.d/magicolor.conf ...
Installation de la nouvelle version du fichier de configuration /etc/sane.d/matsushita.conf ...
Installation de la nouvelle version du fichier de configuration /etc/sane.d/mustek.conf ...
Installation de la nouvelle version du fichier de configuration /etc/sane.d/mustek_pp.conf ...
Installation de la nouvelle version du fichier de configuration /etc/sane.d/mustek_usb.conf ...
Installation de la nouvelle version du fichier de configuration /etc/sane.d/plustek.conf ...
Installation de la nouvelle version du fichier de configuration /etc/sane.d/plustek_pp.conf ...
Installation de la nouvelle version du fichier de configuration /etc/sane.d/sharp.conf ...
Installation de la nouvelle version du fichier de configuration /etc/sane.d/tamarack.conf ...
Installation de la nouvelle version du fichier de configuration /etc/sane.d/teco2.conf ...
Installation de la nouvelle version du fichier de configuration /etc/sane.d/u12.conf ...
Installation de la nouvelle version du fichier de configuration /etc/sane.d/umax.conf ...
Installation de la nouvelle version du fichier de configuration /etc/sane.d/umax_pp.conf ...
Installation de la nouvelle version du fichier de configuration /etc/sane.d/xerox_mfp.conf ...
Paramétrage de python3-problem-report (2.20.9-0ubuntu7.2) ...
Paramétrage de cups-pk-helper (0.2.6-1ubuntu1.2) ...
Installation de la nouvelle version du fichier de configuration /etc/dbus-1/system.d/org.opensuse.CupsPkHelper.Mechanism.conf ...
Traitement des actions différées (« triggers ») pour libc-bin (2.27-3ubuntu1) ...
Traitement des actions différées (« triggers ») pour udev (237-3ubuntu10) ...
Paramétrage de nplan (0.36.2) ...
Paramétrage de gnome-software (3.28.1-0ubuntu4.18.04.1) ...
Traitement des actions différées (« triggers ») pour systemd (237-3ubuntu10) ...
Traitement des actions différées (« triggers ») pour man-db (2.8.3-2) ...
Paramétrage de libsane1:i386 (1.0.27+git20180607-bionic0) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-11ubuntu1) ...
Traitement des actions différées (« triggers ») pour dbus (1.12.2-1ubuntu1) ...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.17-2) ...
Paramétrage de command-not-found-data (18.04.5) ...
Paramétrage de sane-utils (1.0.27+git20180607-bionic0) ...
Paramétrage de python3-distupgrade (1:18.04.19) ...
Paramétrage de python3-commandnotfound (18.04.5) ...
Paramétrage de gnome-software-plugin-snap (3.28.1-0ubuntu4.18.04.1) ...
Paramétrage de command-not-found (18.04.5) ...
Paramétrage de ubuntu-release-upgrader-core (1:18.04.19) ...
Paramétrage de python3-apport (2.20.9-0ubuntu7.2) ...
Paramétrage de apport (2.20.9-0ubuntu7.2) ...
Paramétrage de ubuntu-release-upgrader-gtk (1:18.04.19) ...
Paramétrage de apport-gtk (2.20.9-0ubuntu7.2) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.27-3ubuntu1) ...
jean-noel@jeannoel-Vostro-1015:~$ 

J'ai fait un reboot après mais rien de nouveau
bref on va vivre sans en attendant !
au plaisir

Hors ligne

#2352 Le 16/06/2018, à 22:58

jna

Re : Script d'installation pour imprimantes Brother

Pour compléter, dans /etc/udev/rules.d/ j'ai le fichier 60-brother-libsane-type1.rules
dont voici le contenu

#
#   udev rules sample for Brother MFP
#         version 1.0.2-0
#
#   Copyright (C) 2012-2016 Brother. Industries, Ltd.
#
#   copy to /etc/udev/rules.d or /lib/udev/rules.d
#

ACTION!="add", GOTO="brother_mfp_end"

SUBSYSTEM=="usb", GOTO="brother_mfp_udev_1"
SUBSYSTEM!="usb_device", GOTO="brother_mfp_end"
LABEL="brother_mfp_udev_1"

SYSFS{idVendor}=="04f9", GOTO="brother_mfp_udev_2"
ATTRS{idVendor}=="04f9", GOTO="brother_mfp_udev_2"
GOTO="brother_mfp_end"
LABEL="brother_mfp_udev_2"

#  ATTRS{bInterfaceNumber}=="01", GOTO="brother_mfp_udev_3"
#  ATTRS{bInterfaceNumber}=="02", GOTO="brother_mfp_udev_3"
#  ATTRS{bInterfaceNumber}=="03", GOTO="brother_mfp_udev_3"
#  GOTO="brother_mfp_end"
#  LABEL="brother_mfp_udev_3"

ATTRS{bInterfaceClass}!="0ff", GOTO="brother_mfp_end"
ATTRS{bInterfaceSubClass}!="0ff", GOTO="brother_mfp_end"
ATTRS{bInterfaceProtocol}!="0ff", GOTO="brother_mfp_end"

#MODE="0666"
#GROUP="scanner"
ENV{libsane_matched}="yes"
#SYMLINK+="scanner-%k"

LABEL="brother_mfp_end"

Hors ligne

#2353 Le 17/06/2018, à 17:19

eric63

Re : Script d'installation pour imprimantes Brother

bon je sais pas si ça peut t'aider
j'ai installé kubuntu 18.04 64 bits sur mon fixe vu que j'ai changé la carte mère.
donc forcément mon imprimante branchée en usb sur le fixe n'est pas complètement reconnu (vu mais pas de pilotes) pas plus que mon scanner
donc le script a foiré
le scanner n'a pas été pris en compte.
il manque :

libusb-0.1-4
libc6-i386

donc

sudo apt install libusb-0.1-4 libusb-0.1-4:i386
sudo apt install libc6-i386

j'ai installé le paquet

sane 

sane util et libsane-Hpiao étaient installés

scanimage -L

ne donne rien à ce stade
mais
après avoir crée le lien

sudo ln -s /usr/lib64/sane /usr/lib/sane

scanimage -L a reconnu le scanner et ça a fonctionné avec skanlite

conclusion :je pense qu'il manque des libs dans /usr/lib/sane pour jna puisque tu n'as pas de lib64 (tu es en 32bits)

Dernière modification par eric63 (Le 17/06/2018, à 17:41)


kdeïste convaincu avec Kubuntu 18.04 + backports = plasma 5.12.6 et KDE framaworks 5.47.0 Qt 5.9.5
pour installer une multifonction brother pour en savoir plus sur plasma5: https://www.kde.org/index
N'oubliez pas les balises codes

Hors ligne

#2354 Le 14/07/2018, à 17:13

fifi84

Re : Script d'installation pour imprimantes Brother

Après une install de Ubuntu 18-04 version 32 bits, impossible d'utiliser le scanner sur une Brother DCP-L2520DW.
Elle fonctionne très bien avec une 14-04.....
J'ai fait une install avec le script Brother. Impossible de trouver le scan ou d'utiliser brscan-skey.
Après moultes essais infructueux, j'ai fait :

sudo ln -s /usr/lib/sane/libsane-brother4.so /usr/lib/i386-linux-gnu/sane
sudo ln -s /usr/lib/sane/libsane-brother4.so.1 /usr/lib/i386-linux-gnu/sane
sudo ln -s /usr/lib/sane/libsane-brother4.so.1.0.7 /usr/lib/i386-linux-gnu/sane

Et là, miracle mon scanner s'est réveillé.
Ceci peut vous aider à résoudre le souci des Brother avec le scanner.

Dernière modification par fifi84 (Le 14/07/2018, à 17:53)


1 PC avec Debian 9 Mate
1 PC avec 14.04 Mate
1PC avec 18.04 Mate

Hors ligne

#2355 Le 28/07/2018, à 06:54

b.poiraud

Re : Script d'installation pour imprimantes Brother

Bonjour,
j'ai bien l'habitude d'installer des Brother avec le script de Demonipuch, mais dans les explications données ici :  https://doc.ubuntu-fr.org/utilisateurs/ … pt_brother
    il est écrit de faire : chmod +x install.sh
    Est-ce que cela ne serait pas, plutôt, chmod +x brprinter-installer  ??

Merci.


b.poiraud - femme - 76 ans - Accessdvlinux sur plusieurs ordinateurs et Lubuntu sur d'autres. Je connais aussi PrimTux et Linux-Mint.

Hors ligne

#2356 Le 28/07/2018, à 12:20

fabux

Re : Script d'installation pour imprimantes Brother

Salut,

ton lien est cassé. Je le remets ici.
Et j'ai modifié le chmod wink

Hors ligne

#2357 Le 29/07/2018, à 18:53

b.poiraud

Re : Script d'installation pour imprimantes Brother

Merci !


b.poiraud - femme - 76 ans - Accessdvlinux sur plusieurs ordinateurs et Lubuntu sur d'autres. Je connais aussi PrimTux et Linux-Mint.

Hors ligne

#2358 Le 13/08/2018, à 16:46

cinaptix

Re : Script d'installation pour imprimantes Brother

Je viens de mettre à jour vers Xubuntu 18.04.1 et de réinstaller mon imprimante Brother DCP-7055 avec le script de demonipuch et ça fonctionne nickel.
Le script installe 2 imprimantes (7055 et 7055-2). La première ne fonctionnait pas du tout et avec la 2e tout marche impeccablement. Scanner et imprimante avec Simple-scan et Xsane.
UN GRAND MERCI AU DÉVELOPPEUR GÉNIAL !


MS-DOS 3.21 - MS-Windows 3.11, 98, NT 4, XP - Ubuntu 7.04 > 10.04 - Xubuntu 13.04 >>
① - Xubuntu 18.04 (64 bits)
- CM Gigabyte GA-B85M-D3H - Pentium G3420 à 3,2 Ghz - RAM 8 Go à 1600 Mhz - SSD 64 Go + HDD 500 Go.
② - Raspberry Pi 3 (Raspbian Stretch)
③ - Tablette 10' (Android 6)

Hors ligne

#2359 Le 22/08/2018, à 18:01

Alain_Le_Bel

Re : Script d'installation pour imprimantes Brother

Toutes et tous bonjour, smile
Je viens d'installer Ubuntu 18-04,
En cours d'essai pour voir si je n'ai rien perdu de grave, le scanner ne répond plus ! hmm
Je passe mes longues recherche et vous met ce que j'ai utilisé dans l'ordre :

alain@alain-GA-870A-UD3:~$ dpkg -l | grep -i brother
ii  brscan4                                    0.4.4-3                                    amd64        Brother Scanner Driver
ii  mfcj6510dwcupswrapper:i386                 3.0.0-1                                    i386         Brother CUPS Inkjet Printer Definitions
ii  mfcj6510dwlpr:i386                         3.0.0-1                                    i386         Brother lpr Inkjet Printer Definitions
ii  printer-driver-brlaser                     4-1                                        amd64        printer driver for (some) Brother laser printers
ii  printer-driver-ptouch                      1.4.2-3                                    amd64        printer driver Brother P-touch label printers
alain@alain-GA-870A-UD3:~$ 

Là c'est ce qui restait après ma mise à jour, voici les ligne que j'ai utilisé sans succès :

sudo ln -s /usr/lib/sane/libsane-brother4.so /usr/lib/i386-linux-gnu/sane
sudo ln -s /usr/lib/sane/libsane-brother4.so.1 /usr/lib/i386-linux-gnu/sane
sudo ln -s /usr/lib64/sane /usr/lib/sane
sudo cp -R /usr/lib64/* /usr/lib
sudo cp -R /usr/lib64/* /usr/lib/x86_64-linux-gnu

Mes excuses pour les auteurs Eric63, Fifi84, certains n'ont pas fonctionné, j'ai oublié de copier à chaque essai.
Voici ce qui a fonctionner sans être certain que les lignes précédentes n'aient pas servi...

sudo gedit

Ce qui m'a permis d'ouvrir dans  /etc/sane.d/dll.conf
Et d'y ajouter en fin de fichier brother4 et d'enregistrer ma modification.
Il reste l'ancien défaut, quand je ferme Xsane, 2 alerte me signalent que je ne dispose pas des droits pour enregistrer.
Alors que la numérisation a bien fonctionné et que le fichier est bien enregistrer.
Merci toutes et Tous wink


Merci ! Si c'était facile... Ce ne serait pas pour nous...
Ubuntu 16.04 LTS ; Mémoire : 3,9 Gio ; Processeur : AMD Athlon(tm) II X2 265 Processor × 2 ; Carte Graphique : disparue depuis 14.04 (GeForce GTS 450 1024MB GDDR5) ; Type d'OS : 64-bit ; Disque : 233,2 Go
Je n'arrive pas à mettre de commentaires sur les forums matériel... Un portable LDLC 17 pouces

Hors ligne

#2360 Le 22/08/2018, à 21:12

eric63

Re : Script d'installation pour imprimantes Brother

salut
est ce que tu as refait le script après ta mise a jour
ton sudo gedit suivi du rajout de la ligne brother4 dans /etc/sane.d/dll.conf a fait beaucoup
sans ça pas de scan.
Pour tes deux alertes je lancerais dans un terminal et procederais à un scan et un enregistrement pour voir si tu as pas d'autres informations par le terminal

Dernière modification par eric63 (Le 22/08/2018, à 21:14)


kdeïste convaincu avec Kubuntu 18.04 + backports = plasma 5.12.6 et KDE framaworks 5.47.0 Qt 5.9.5
pour installer une multifonction brother pour en savoir plus sur plasma5: https://www.kde.org/index
N'oubliez pas les balises codes

Hors ligne

#2361 Le 23/08/2018, à 07:37

Alain_Le_Bel

Re : Script d'installation pour imprimantes Brother

Eric63 bonjour, smile
Non je n'ai pas refait le script car j"ai vu que l'imprimante a été conservée et que les fichiers étaient présents.
Oui dans ce fichier il n'y avait pas de brother, la ligne a suffit. smile
Pour le teste par le terminal, je vais chercher la commande du scan xsane.
Je reporterai le résultat, je pense que lorsque l'on quitte, il veut enregistrer les paramètres...
Je copierai le texte exacte des fenêtres, 2 fenêtres identiques.
A suivre,
Merci ! wink


Merci ! Si c'était facile... Ce ne serait pas pour nous...
Ubuntu 16.04 LTS ; Mémoire : 3,9 Gio ; Processeur : AMD Athlon(tm) II X2 265 Processor × 2 ; Carte Graphique : disparue depuis 14.04 (GeForce GTS 450 1024MB GDDR5) ; Type d'OS : 64-bit ; Disque : 233,2 Go
Je n'arrive pas à mettre de commentaires sur les forums matériel... Un portable LDLC 17 pouces

Hors ligne

#2362 Le 25/08/2018, à 09:27

ahbr31

Re : Script d'installation pour imprimantes Brother

Bonjour,
j'utilise linux mint depuis10 ans environ mais reste assez malhabile avec les lignes de commandes (je peux copier coller mais ne maîtrise pas ce que je fais.
Mon problème vient de l'installation de mon imprimante brother MFC 9330CDW en wifi. Je l'utilise depuis longtemps. J'ai déjà fait le script avec succès. Mais au printemps après le changement successif de box internet (2 fois) je n'ai pas réussi à me reconnecter à l'imprimante .
Donc je viens d'installer mint 19 (en ecrasant tout) pour faire une installation propre (imprimante éteinte) . Je viens de dérouler le script. (avec l'adresse IP de mon imprimante sur le réseau wifi -EXT de mon prolongateur de wifi) .
Après allumage de l'imprimante : échec du test : Traitement en cours - The printer is unreachable at this time
Pouvez vous m'aider ? Merci

Resolu.
L'adresse Ip de l'imprimante 192.168.001.131 ne correspondait pas à celle de la box 192.168.0.254.
J'ai rentré en manuel sur l'imprimante 192.168.000.131 et cela fonctionne
Merci quand même
Au plaisir de vous lire.

Dernière modification par ahbr31 (Le 25/08/2018, à 11:35)

Hors ligne

#2363 Le 25/08/2018, à 09:33

michel_04

Re : Script d'installation pour imprimantes Brother

Bonjour,

ahbr31 a écrit :

PS : j'ai utilisé le script d'un wiki... et pas celui de cette page

Lorsque tu veux ajouter une info à un de tes messages, tu cliques sur Modifier (en bas à droite).
Ça évite de recréer un autre message.

A+

Hors ligne

#2364 Le 25/08/2018, à 09:39

michel_04

Re : Script d'installation pour imprimantes Brother

michel_04 a écrit :

Bonjour,

ahbr31 a écrit :

PS : j'ai utilisé le script d'un wiki... et pas celui de cette page

Lorsque tu veux ajouter une info à un de tes messages, tu cliques sur Modifier (en bas à droite).
Ça évite de recréer un autre message.

A+

Utilise les balises Code.

Hors ligne

#2365 Le 25/08/2018, à 16:07

Alain_Le_Bel

Re : Script d'installation pour imprimantes Brother

Toutes et Tous bonjour smile

eric63 a écrit :

salut
Pour tes deux alertes je lancerais dans un terminal et procéderais à un scan et un enregistrement pour voir si tu as pas d'autres informations par le terminal

Voici la commande par terminal

alain@alain-GA-870A-UD3:~$ xsane
Gtk-Message: 15:45:04.060: Failed to load module "canberra-gtk-module" :(
alain@alain-GA-870A-UD3:~$ 

Pour les fenêtre je les ai copier en copie d'écran, voici le texte qui s'y affiche :

Erreur
Erreur de création de fichier : permission non accordée.
Fermer

Une fois fermée, la 2ème fenêtre apparaît :

Erreur
Erreur de création de fichier : permission non accordée.
Fermer

Avant ces fenêtre j'ai pu numériser et enregistrer mon document où je le souhaitais. hmm
J'espère que tu t'y retrouveras, merci ! wink


Merci ! Si c'était facile... Ce ne serait pas pour nous...
Ubuntu 16.04 LTS ; Mémoire : 3,9 Gio ; Processeur : AMD Athlon(tm) II X2 265 Processor × 2 ; Carte Graphique : disparue depuis 14.04 (GeForce GTS 450 1024MB GDDR5) ; Type d'OS : 64-bit ; Disque : 233,2 Go
Je n'arrive pas à mettre de commentaires sur les forums matériel... Un portable LDLC 17 pouces

Hors ligne

#2366 Le 25/08/2018, à 17:42

eric63

Re : Script d'installation pour imprimantes Brother

cherche dans ta logithèque si le paquet gnome-session-canberra est installé essaye de les installer vérifie avec xsane si tu as toujours les messages d'erreurs. Si le paquet te demande trop de dépendences essaye libcanberra (mais c'est plus vaste et vague) qui se rapproche le plus de la demande en regardant les dépendances.


kdeïste convaincu avec Kubuntu 18.04 + backports = plasma 5.12.6 et KDE framaworks 5.47.0 Qt 5.9.5
pour installer une multifonction brother pour en savoir plus sur plasma5: https://www.kde.org/index
N'oubliez pas les balises codes

Hors ligne

#2367 Le 25/08/2018, à 20:19

Alain_Le_Bel

Re : Script d'installation pour imprimantes Brother

Bonsoir, smile
Merci du retour rapide,
Dans la logitèque aucun gnome cession disponible, pas plus de canberra ni de libcanberra hmm
Je viens de vérifier plus de logitèque non plus mais la valise logiciels Ubuntu...
Certainement la raison pour que je n'ai rien trouvé...
Merci ! wink
Je viens de vérifier depuis le terminal, voici le résultat :

alain@alain-GA-870A-UD3:~$ logitèque
logitèque : commande introuvable
alain@alain-GA-870A-UD3:~$ sudo apt-get install gnome-session-canberra
[sudo] Mot de passe de alain : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
gnome-session-canberra est déjà la version la plus récente (0.30-5ubuntu1).
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-image-4.4.0-133-generic linux-image-extra-4.4.0-133-generic
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 18 non mis à jour.
alain@alain-GA-870A-UD3:~$

J'ai fait le nettoyage recommandé.
Il doit y avoir autre chose... hmm wink
Merci !

Dernière modification par Alain_Le_Bel (Le 25/08/2018, à 20:44)


Merci ! Si c'était facile... Ce ne serait pas pour nous...
Ubuntu 16.04 LTS ; Mémoire : 3,9 Gio ; Processeur : AMD Athlon(tm) II X2 265 Processor × 2 ; Carte Graphique : disparue depuis 14.04 (GeForce GTS 450 1024MB GDDR5) ; Type d'OS : 64-bit ; Disque : 233,2 Go
Je n'arrive pas à mettre de commentaires sur les forums matériel... Un portable LDLC 17 pouces

Hors ligne

#2368 Le 29/08/2018, à 11:36

pescadou999

Re : Script d'installation pour imprimantes Brother

encore merçi à Demonipuch (#1) , encore une fois suite à l'install de la 18 le scanner ne fonctionnait plus mais c'était sans compter sur Demonipuch pour ma Brother DCP-195C

Hors ligne

#2369 Le 29/08/2018, à 20:00

Alain_Le_Bel

Re : Script d'installation pour imprimantes Brother

Toutes et Tous bonsoir, smile
Je viens d'installer Ubuntu 18.04 sur mon portable LDLC.
Cette fois j'ai commencé par une impression tout vas bien sur ma Brother MFC-6510DW,
Je suis passé à la numérisation... Comme avec ma tour la numérisation ne trouve pas le scanner... sad
Pour vérifier par rapport aux essais précédents, j'ai commencé par mon dernier essai

dans le terminal : sudo gedit
Ce qui m'a permis d'ouvrir dans  /etc/sane.d/dll.conf
Et d'y ajouter en fin de fichier brother4 et d'enregistrer ma modification.

J'ai relancer la machine avant de faire le teste, au lancement la reconnaissance a été longue mais bonne.
Seul inconvénient, à la première demande de prévisualisation le scanner ne bouge pas et j'ai une fenêtre d'échec, hmm
A partir de là tout va bien même la fermeture.
Ce défaut exister avant donc je ne me plains pas.
Merci ! wink


Merci ! Si c'était facile... Ce ne serait pas pour nous...
Ubuntu 16.04 LTS ; Mémoire : 3,9 Gio ; Processeur : AMD Athlon(tm) II X2 265 Processor × 2 ; Carte Graphique : disparue depuis 14.04 (GeForce GTS 450 1024MB GDDR5) ; Type d'OS : 64-bit ; Disque : 233,2 Go
Je n'arrive pas à mettre de commentaires sur les forums matériel... Un portable LDLC 17 pouces

Hors ligne

#2370 Le 11/09/2018, à 22:51

eric63

Re : Script d'installation pour imprimantes Brother

bon petite avancée
visiblement les trois librairies libsane-brotherX.so libsane-brotherX.so.1 libsane-brotherX.so.1.0.7 (X remplace le chiffre de votre paquet brscan) ne sont pas copié au bon endroit suivant l'architecture de votre ordi (32 ou 64 bits) surtout 32bits
verifié si votre paquet brscanX est en 32bits (i386) cela peut être le cas si votre ordi est en 64bits et que le paquet n'existe pas en 64bits.
Donc brscan installe en 32 bits les librairies dans usr/lib/sane mais il existe maintenant un dossier qui se nomme /usr/lib/i386-linux-gnu et donc les librairies maintenant devrait s'installer là aussi mais ce n'est pris en compte par le script de demonipuch ni par le script de brother.
Pour remédier au problème il faut créer des liens des trois librairies de /usr/lib/sane vers /usr/lib/i386-linux-gnu/sane

sudo ln -s /usr/lib/sane/libsane-brother* /usr/lib/i386*/sane

ou faire une copie de ces librairies

sudo cp /usr/lib/sane/libsane-brother* /usr/lib/i386*/sane

(je ne sais pas lequel est le plus pertinent: le lien ou la copie ? mais pas les deux je penche plus pour la copie question évolution de l'architecture et normalisation de l'arbre)
bravo à fifi84 qui a trouvé la solution et qui m'a mis sur cette piste mais comme je suis en 64 bits je n'ai pas percuté sur le coup.
si le brscanX est un paquet 64 bits il faut

sudo cp /usr/lib64/sane/* /usr/lib/x86_64-linux-gnu/sane

Avec ça et le script de demonipuch qui devrait l'intégré dans le script s'il le valide ça devrait être ok pour une bonne partie des ordis.

On attend les cas spécs

Dernière modification par eric63 (Le 11/09/2018, à 22:52)


kdeïste convaincu avec Kubuntu 18.04 + backports = plasma 5.12.6 et KDE framaworks 5.47.0 Qt 5.9.5
pour installer une multifonction brother pour en savoir plus sur plasma5: https://www.kde.org/index
N'oubliez pas les balises codes

Hors ligne

#2371 Le 16/09/2018, à 20:02

Joris-38

Re : Script d'installation pour imprimantes Brother

Je viens d'installer Ubuntu 18 sur mon portable
et j'ai utilisé le script de Demonipuch:
- j'ai branché et connecté l'imprimante-scanner DCP-195C avant de lancer le script
- à la fin: ni impression ni scanner
- dans "gestion des imprimantes" j'ai trouvé deux DCP-195C inefficaces: je les ai supprimées et demandé une nouvelle imprimante. A la suite de cette manœuvre j'ai pu imprimer mais pas de scan
- le scanner est "arrivé" après rebootage
Tout va bien
merci Demonipuch ! peut-être pourrais-tu indiquer aux nuls comme moi :
- s'il faut brancher l'imprimante avant de lancer ton script
- l'utilité de supprimer  les imprimantes de "gestion des imprimantes" puis de demander l'installation d'une nouvelle
- le rebootage pour obtenir le scanner
bien cordialement à tous
Georges

Hors ligne

#2372 Le 18/09/2018, à 10:44

jibel

Re : Script d'installation pour imprimantes Brother

Si c'est possible installer "xscan et sane" avec synaptic. Puis voir ce qui s'affiche avec ta printer Brother, si le scanner est bien présent, si le scan d'une page peut être indiqué dans les transferts vers le dossier ?
Soit on suit les explications de demonipuch pas a pas, surtout depuis quelques modifs récentes selon que l'imprimante soit ou non branchée .


Plus grande est la face, plus grand est le dos!
Toutes les fautes de frappe, d'orthographe, de grammaire et de syntaxe ci-dessus, sont la propriété intellectuelle de l'auteur.Elles doivent être reproduites et même corrigées sans l'accord préalable du susdit.

Avec Mint.17.3, Xub 16.04, VoyagerX2,X8, Debian 9.4 strecht, Pearl linux, Hybryde 14.04 .PC medion akira  DD 1T + 2 .

Hors ligne

#2373 Le 18/09/2018, à 16:04

Alain_Le_Bel

Re : Script d'installation pour imprimantes Brother

Toutes et Tous bonjour, smile

eric63 a écrit :

bon petite avancée
visiblement les trois librairies libsane-brotherX.so libsane-brotherX.so.1 libsane-brotherX.so.1.0.7 (X remplace le chiffre de votre paquet brscan) ne sont pas copié au bon endroit suivant l'architecture de votre ordi (32 ou 64 bits) surtout 32bits
verifié si votre paquet brscanX est en 32bits (i386) cela peut être le cas si votre ordi est en 64bits et que le paquet n'existe pas en 64bits.
Donc brscan installe en 32 bits les librairies dans usr/lib/sane mais il existe maintenant un dossier qui se nomme /usr/lib/i386-linux-gnu et donc les librairies maintenant devrait s'installer là aussi mais ce n'est pris en compte par le script de demonipuch ni par le script de brother.
Pour remédier au problème il faut créer des liens des trois librairies de /usr/lib/sane vers /usr/lib/i386-linux-gnu/sane

sudo ln -s /usr/lib/sane/libsane-brother* /usr/lib/i386*/sane

ou faire une copie de ces librairies

sudo cp /usr/lib/sane/libsane-brother* /usr/lib/i386*/sane

(je ne sais pas lequel est le plus pertinent: le lien ou la copie ? mais pas les deux je penche plus pour la copie question évolution de l'architecture et normalisation de l'arbre)
bravo à fifi84 qui a trouvé la solution et qui m'a mis sur cette piste mais comme je suis en 64 bits je n'ai pas percuté sur le coup.
si le brscanX est un paquet 64 bits il faut

sudo cp /usr/lib64/sane/* /usr/lib/x86_64-linux-gnu/sane

Avec ça et le script de demonipuch qui devrait l'intégré dans le script s'il le valide ça devrait être ok pour une bonne partie des ordis.

On attend les cas spécs

Je viens d'essayer la dernière ligne, il m'a été indiqué que les fichiers existants sont identique.
Certainement du aux manipulations précédentes... hmm
A la première visualisation message d'alerte indiquant

Echec du démarrage du scanner : paramètre non valable

une seule fois au démarrage après plus de problème.
Je suis sur mon portable à la fermeture aucun message, il est vrai que je suis passé en 18.04, ceci explique peut-être.
Je ferais l'essai avec ma tour.
Merci ! wink


Merci ! Si c'était facile... Ce ne serait pas pour nous...
Ubuntu 16.04 LTS ; Mémoire : 3,9 Gio ; Processeur : AMD Athlon(tm) II X2 265 Processor × 2 ; Carte Graphique : disparue depuis 14.04 (GeForce GTS 450 1024MB GDDR5) ; Type d'OS : 64-bit ; Disque : 233,2 Go
Je n'arrive pas à mettre de commentaires sur les forums matériel... Un portable LDLC 17 pouces

Hors ligne

#2374 Le 18/09/2018, à 17:36

jibel

Re : Script d'installation pour imprimantes Brother

C'est vraiment très drôle des fois avec les OSs installés avec brother comme printer. Je viens d'installer un OS différent et avec leur gestionnaire de paquets je tombe sur tout ce qui concerne  les brother's printer  en pagaille ! Le modèle que j'ai a fonctionné non seulement avec le tuto de demonipuch, mais aussi avec le modèle que j'ai qui a été vérifié pour son bon fonctionnement...incroyable , mais vrai... whaou ! roll


Plus grande est la face, plus grand est le dos!
Toutes les fautes de frappe, d'orthographe, de grammaire et de syntaxe ci-dessus, sont la propriété intellectuelle de l'auteur.Elles doivent être reproduites et même corrigées sans l'accord préalable du susdit.

Avec Mint.17.3, Xub 16.04, VoyagerX2,X8, Debian 9.4 strecht, Pearl linux, Hybryde 14.04 .PC medion akira  DD 1T + 2 .

Hors ligne

#2375 Le 21/09/2018, à 08:45

charlene

Re : Script d'installation pour imprimantes Brother

Bonjour,
Je souhaite installer l'imprimante Brother DCP-353.
J'ai suivi le protocole de Demonipuch.
https://doc.ubuntu-fr.org/utilisateurs/ … pt_brother
L'impression fonctionne mais impossible de lancer le scanner.

J'ai suivi le point "4. Pour scanner en 64 bits" de Demonipuch.
J'ai éteint et rallumé l'ordi, l'imprimante.
J'ai débranché le cable usb.
J'ai tenté de lancer le scan via le bouton "scan" de l'imprimante, et via Simple Scan.
Mais aucune connection se fait entre le PC et l'imprimante.

Voici ce qui s'affiche dans mon terminal
1537512260.png

et dans Simple scan
1537512288.png

J'ai la version d'ubuntu 16.04.

Merci beaucoup pour vos conseils.
Bonne journée,
Charlène

Hors ligne