Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 03/08/2018, à 08:07

J-F_R_44

Simple Scan ne voit pas le scanner [Résolu]

Bonjour,

multifonction CANON TS6150, imprimante OK, Scanner OK avec scangearmp2 qui est peut pratique,
mais KO pour Simple Scan très pratique.
Si quelqu'un peut me dire ce qui ne va pas dans ceci :

roux@roux-P5Q:~$ sudo chown -R roux:roux ~/.cache/simple-scan
[sudo] Mot de passe de roux : 
roux@roux-P5Q:~$ simple-scan -d
[+0,01s] DEBUG: simple-scan.vala:637: Starting Simple Scan 3.28.0, PID=6143
[+0,36s] CRITICAL: g_action_print_detailed_name: assertion 'g_action_name_is_valid (action_name)' failed
[+0,36s] CRITICAL: gtk_application_set_accels_for_action: assertion 'detailed_action_name != NULL' failed
[+0,68s] DEBUG: app-window.vala:1714: Loading state from /home/roux/.cache/simple-scan/state
[+0,69s] DEBUG: app-window.vala:1671: Restoring window to 600x400 pixels
[+0,69s] DEBUG: autosave-manager.vala:64: Loading autosave information
[+0,69s] DEBUG: autosave-manager.vala:259: Waiting to autosave...
[+1,65s] DEBUG: autosave-manager.vala:281: Autosaving book information
[+1,70s] DEBUG: scanner.vala:1454: sane_init () -> SANE_STATUS_GOOD
[+1,70s] DEBUG: scanner.vala:1460: SANE version 1.0.27
[+1,70s] DEBUG: scanner.vala:1521: Requesting redetection of scan devices
[+1,70s] DEBUG: scanner.vala:806: Processing request
[+2,23s] DEBUG: app-window.vala:1775: Saving state to /home/roux/.cache/simple-scan/state
[+2,49s] DEBUG: app-window.vala:1775: Saving state to /home/roux/.cache/simple-scan/state
[+3,02s] DEBUG: app-window.vala:1775: Saving state to /home/roux/.cache/simple-scan/state
[+7,74s] DEBUG: scanner.vala:341: sane_get_devices () -> SANE_STATUS_GOOD
[+7,74s] DEBUG: scanner.vala:1521: Requesting redetection of scan devices
[+7,74s] DEBUG: scanner.vala:806: Processing request
[+7,86s] DEBUG: app-window.vala:1775: Saving state to /home/roux/.cache/simple-scan/state
[+11,84s] DEBUG: scanner.vala:341: sane_get_devices () -> SANE_STATUS_GOOD
[+11,94s] DEBUG: app-window.vala:1775: Saving state to /home/roux/.cache/simple-scan/state
[+17,36s] DEBUG: app-window.vala:1775: Saving state to /home/roux/.cache/simple-scan/state
[+17,41s] DEBUG: autosave-manager.vala:195: Deleting autosave records
[+17,41s] DEBUG: scanner.vala:1597: Stopping scan thread
[+17,41s] DEBUG: scanner.vala:806: Processing request
[+17,46s] DEBUG: scanner.vala:1608: sane_exit ()
roux@roux-P5Q:~$

Modération : merci d'utiliser les balises code (explications ici).

Dernière modification par J-F_R_44 (Le 16/08/2018, à 21:35)

Hors ligne

#2 Le 06/08/2018, à 14:14

J-F_R_44

Re : Simple Scan ne voit pas le scanner [Résolu]

Bonjour,

pas de réponse ?
Quelqu'un aurait une autre application à me conseiller, aussi bien faite que Simple Scan ?

Hors ligne

#3 Le 10/08/2018, à 08:24

J-F_R_44

Re : Simple Scan ne voit pas le scanner [Résolu]

Bonjour,

c'est le vacances pas grand monde sur le pont.
Conclusion avant je ne ferme cette discussion, après avoir beaucoup beaucoup lu et presque tout essayer Simple Scan ne fonctionne pas sur 18.04 LTS, c'est donc une régression et il n'y a pas d'équivalent pour Ubuntu,
je vais donc me contenter de scangearmp2 de Canon qui n'est vraiment pas terrible...

Une dernière question, après tout les essais et installations sans succès comment nettoyer Ubuntu 18.04 sans rien casser ?

Hors ligne

#4 Le 10/08/2018, à 09:54

p.lrt

Re : Simple Scan ne voit pas le scanner [Résolu]

Chez moi, SimpleScan fonctionne correctement  sous Xubuntu 18.04.01 sans aucune modification (Scanner Canon N1240U)

@+


ASUS K53E - Xubuntu 16.04.1  64bits  + Xubuntu 18.04 en essai ---    SONY VGN38E Xubuntu 16.04.1 64bits

Hors ligne

#5 Le 10/08/2018, à 11:41

J-F_R_44

Re : Simple Scan ne voit pas le scanner [Résolu]

Merci je pense en effet que pour certains çà fonctionne, mais en suivant quel tuto svp ?

Hors ligne

#6 Le 10/08/2018, à 16:30

DRbuntu91

Re : Simple Scan ne voit pas le scanner [Résolu]

Bonjour,
J'ai un ordi de test avec 18.04 mais je n'avais pas encore pris le temps pour tester la fonction d'impression et scan.
Mon imprimante est une HP ENVY en WiFI avec une @IP fixe.
Ubuntu a trouvé tout seul l'imprimante puis ensuite j'en ai profité pour lancer un simple-scan en mode debug:

boul1804@M4600:~$ simple-scan -d
[+0,00s] DEBUG: simple-scan.vala:637: Starting Simple Scan 3.28.0, PID=3322
[+0,04s] CRITICAL: g_action_print_detailed_name: assertion 'g_action_name_is_valid (action_name)' failed
[+0,04s] CRITICAL: gtk_application_set_accels_for_action: assertion 'detailed_action_name != NULL' failed
[+0,06s] DEBUG: app-window.vala:1714: Loading state from /home/boul1804/.cache/simple-scan/state
[+0,06s] DEBUG: app-window.vala:1671: Restoring window to 1005x770 pixels
[+0,06s] DEBUG: autosave-manager.vala:64: Loading autosave information
[+0,06s] DEBUG: autosave-manager.vala:259: Waiting to autosave...
[+0,12s] DEBUG: scanner.vala:1454: sane_init () -> SANE_STATUS_GOOD
[+0,12s] DEBUG: scanner.vala:1460: SANE version 1.0.27
[+0,12s] DEBUG: scanner.vala:1521: Requesting redetection of scan devices
[+0,12s] DEBUG: scanner.vala:806: Processing request
[+0,16s] DEBUG: autosave-manager.vala:281: Autosaving book information
[+0,30s] DEBUG: app-window.vala:1775: Saving state to /home/boul1804/.cache/simple-scan/state
[+0,44s] DEBUG: app-window.vala:1775: Saving state to /home/boul1804/.cache/simple-scan/state
[+6,30s] DEBUG: scanner.vala:341: sane_get_devices () -> SANE_STATUS_GOOD
[+6,30s] DEBUG: scanner.vala:353: Device: name="hpaio:/net/ENVY_5640_series?hostname=HPC8D3FFC8F7A3.local" vendor="Hewlett-Packard" model="ENVY_5640_series" type="all-in-one"
[+6,30s] DEBUG: scanner.vala:353: Device: name="hpaio:/net/envy_5640_series?ip=192.168.0.51&queue=false" vendor="Hewlett-Packard" model="envy_5640_series" type="all-in-one"
[+6,41s] DEBUG: app-window.vala:1775: Saving state to /home/boul1804/.cache/simple-scan/state

Si je compare mes traces avec les tiens on a l'impression que ton simple-scan n'a pas trouvé d'imprimante (les 2 lignes après "sane_get_devices") mais je suis incapable de dire pourquoi.
Faudra attendre de l'aide d'un expert.
Bon courage


Portable CLEVO W550SU, Intel i5-4200M, RAM=8Go, DD=500Go SSD, BIOS 4.6.5 AMI, Ubuntu 16.04.3 LTS
Puis pour bidouiller un vieux portable Dell Precision M4600 avec W10 + Ub16.4 + Ub18.4 et un ACER Aspire 7720 avec Xubuntu 16.04 LTS
Utilisateur Ubuntu depuis Janvier 2017

Hors ligne

#7 Le 12/08/2018, à 21:51

J-F_R_44

Re : Simple Scan ne voit pas le scanner [Résolu]

Merci j'ajoute un retour de commande :

sane-find-scanner
  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x04a9 [Canon], product=0x1822 [TS6100 series]) at libusb:002:019
could not open USB device 0x1d6b/0x0002 at 002:001: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0001 at 008:001: Access denied (insufficient permissions)
could not open USB device 0x04f2/0x0116 at 007:003: Access denied (insufficient permissions)
could not open USB device 0x093a/0x2510 at 007:002: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0001 at 007:001: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0001 at 006:001: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0002 at 001:001: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0001 at 005:001: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0001 at 004:001: Access denied (insufficient permissions)
could not open USB device 0x1d6b/0x0001 at 003:001: Access denied (insufficient permissions)
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.

  # You may want to run this program as root to find all devices. Once you
  # found the scanner devices, be sure to adjust access permissions as
  # necessary.

ce serait le port qui pose problème, mais pour l'impression pas de problème.

Dernière modification par J-F_R_44 (Le 14/08/2018, à 10:52)

Hors ligne

#8 Le 12/08/2018, à 21:52

xubu1957

Re : Simple Scan ne voit pas le scanner [Résolu]

Bonjour,

Pour ajouter toi-même les balises code à ton précédent message #7 :                Merci            wink

  • Cliquer sur  le lien « Modifier » en bas à droite du message

  • Sélectionner le texte

  • Cliquer sur le <> de l'éditeur de message

1530289742.png

comme indiqué dans le : Retour utilisable de commande

Dernière modification par xubu1957 (Le 15/08/2018, à 09:47)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#9 Le 13/08/2018, à 06:05

Brunod

Re : Simple Scan ne voit pas le scanner [Résolu]

J'ai un canon Lide 210; il tournait parfaitement (et tourne toujours) sous Ubuntu 10.04
Mais depuis que je suis sur une version plus récente, il n'est plus reconnu correctement. Le bug traîne depuis des années...
Vérifie donc si ta version de scanner n'a pas de problème de compatibilité.
Je garde ma 10.04 rien que pour lui hmm


Windows est un système d'exploitation de l'homme par l'ordinateur. Linux, c'est le contraire...
37 pc linux convertis

Hors ligne

#10 Le 13/08/2018, à 14:35

DRbuntu91

Re : Simple Scan ne voit pas le scanner [Résolu]

Bonjour J-F_R_44
J'ai l’impression que sane-find-scanner ne cherche pas les scanners en réseau (wifi ou ethernet) par ce que chez moi le scanner marche  alors que j'obtiens le même résultat que toi (j'ai utilisé sudo pour ne pas avoir les erreurs USB).

boul1804@M4600:~$ sudo sane-find-scanner
[sudo] Mot de passe de boul1804 : 

  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

  # No USB scanners found. If you expected something different, make sure that
  # you have loaded a kernel driver for your USB host controller and have setup
  # the USB system correctly. See man sane-usb for details.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.

Portable CLEVO W550SU, Intel i5-4200M, RAM=8Go, DD=500Go SSD, BIOS 4.6.5 AMI, Ubuntu 16.04.3 LTS
Puis pour bidouiller un vieux portable Dell Precision M4600 avec W10 + Ub16.4 + Ub18.4 et un ACER Aspire 7720 avec Xubuntu 16.04 LTS
Utilisateur Ubuntu depuis Janvier 2017

Hors ligne

#11 Le 14/08/2018, à 10:56

J-F_R_44

Re : Simple Scan ne voit pas le scanner [Résolu]

mon imprimante multi fonction est raccordé en port USB direct.
Je vois que nous sommes de plus en plus nombreux à avoir un problème avec 18.04.
J'ai lu des choses intéressantes, mais il faut trouver le temps de les essayer.

Hors ligne

#12 Le 14/08/2018, à 11:14

DRbuntu91

Re : Simple Scan ne voit pas le scanner [Résolu]

Bonjour J-F_R_44
Désolé mais je n'avais pas lu en détail ton message #7
Voici l'extrait:

found USB scanner (vendor=0x04a9 [Canon], product=0x1822 [TS6100 series]) at libusb:002:019
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

J'en déduis que la commande sane-find-scanner a bien trouvé ton scanner Canon connecté en USB (d’ailleurs je suppose que la commande lssub aurait trouvé la même chose)
En dessous il te conseille d"émettre la commande scanimage -L
Tu as essayé cette commande?


Portable CLEVO W550SU, Intel i5-4200M, RAM=8Go, DD=500Go SSD, BIOS 4.6.5 AMI, Ubuntu 16.04.3 LTS
Puis pour bidouiller un vieux portable Dell Precision M4600 avec W10 + Ub16.4 + Ub18.4 et un ACER Aspire 7720 avec Xubuntu 16.04 LTS
Utilisateur Ubuntu depuis Janvier 2017

Hors ligne

#13 Le 14/08/2018, à 12:27

Coraline

Re : Simple Scan ne voit pas le scanner [Résolu]

Bonjour,

Nouvelle sous Linux, je profite des vacances pour m'atteler à quelques problèmes et me suis enfin inscrite sur le forum. J'ai, je crois, le même problème qu'évoqué dans cette discussion. J'ai une HP deskjet 3630, j'imprime sans fil sans problème mais le scanner n'est reconnu que si je me branche en USB. Et je suis sous ubuntu 18.04.1. Et je suis moins avancée que vous en commandes...
Bonne journée et merci pour l'aide éventuelle
Coraline

Hors ligne

#14 Le 15/08/2018, à 09:41

J-F_R_44

Re : Simple Scan ne voit pas le scanner [Résolu]

~$ scanimage -L

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

voici la réponse,
ce matin j'ai modifier le fichier 60-libsane1.rules en ajoutant
#TS6100 series
ATTR{idVendor}=="04a9", ATTR{idProduct}=="1822", MODE="666"
#TS6000 series
ATTR{idVendor}=="04a9", ATTR{idProduct}=="1801", MODE="666"
comme indiqué sur certains posts sans succès.
je suis allé voir les sites http://www.sane-project.org/man/sane-pixma.5.html et https://gitlab.com/sane-project/backends
que comprendre dans toute cette littérature...

Hors ligne

#15 Le 16/08/2018, à 00:20

jvcharles

Re : Simple Scan ne voit pas le scanner [Résolu]

Coraline a écrit :

le même problème qu'évoqué dans cette discussion. J'ai une HP deskjet 3630, j'imprime sans fil sans problème mais le scanner n'est reconnu que si je me branche en USB. Et je suis sous ubuntu 18.04.1.

J'ai la même imprimante HP deskjet 3632 (pilote 3630) sous Ubuntu 18.04.1. et tous fonctionne A1.

Voici comment faire Wiki ubuntu-fr - HP

avec l'imprimante presse sur le bouton " i ", sa va imprimé une feuille avec de l'information, utile pour l'adresse IP

ou suivre l'information 3.3.2 Installation du wiki

hp-setup IP_adresse

Je pense n'avoir rien oublier, avec simple Scan fonctionne en réseau sans fil

Dernière modification par jvcharles (Le 16/08/2018, à 00:23)


Ubuntu 18.04 gnome avec Windows 10 (pour les jeux)
Asus Desktop Intel i7, Geforce 1050Ti
moto G4 Plus

Hors ligne

#16 Le 16/08/2018, à 08:10

J-F_R_44

Re : Simple Scan ne voit pas le scanner [Résolu]

Merci à jvcharles j'espère que pour Coraline tout va fonctionner.
Pour ma part toujours au même point après 2H d'essais hier, installation via Synaptic de quelques paquets au hasard qui avait dans le  commentaire "Scanner".
Installation de "gscan2pdf", réinstallation de "xsane" et donc pas plus que "simple scan" ces applis ne voient  pas le scanner,
alors que comme écrit en #1 "scangearmp2" l'application propriétaire CANON le voit.
Est-ce qu'il y a intérêt à utiliser le fichier source "scangearmp2-source-3.50-1.tar.gz" et comment l'utiliser ?

Dernière modification par J-F_R_44 (Le 16/08/2018, à 08:21)

Hors ligne

#17 Le 16/08/2018, à 10:26

DRbuntu91

Re : Simple Scan ne voit pas le scanner [Résolu]

Bonjour J-F_R_44
D'après le nom du fichier j'imagine qu'il s'agit du code source, donc a compiler. Tu as regardé le contenu?

En suivant le lient donné par jvcharles je suis arrivé  sur cette page ou on voit une Canon TS-6151 (c'est la plus proche de ton modèle il me semble)

Ce qui m'a amené ici

Par-contre il faut l'avis d'un expert par ce que je ne vois aucune version pour "bionic" (18.04)


Portable CLEVO W550SU, Intel i5-4200M, RAM=8Go, DD=500Go SSD, BIOS 4.6.5 AMI, Ubuntu 16.04.3 LTS
Puis pour bidouiller un vieux portable Dell Precision M4600 avec W10 + Ub16.4 + Ub18.4 et un ACER Aspire 7720 avec Xubuntu 16.04 LTS
Utilisateur Ubuntu depuis Janvier 2017

Hors ligne

#18 Le 16/08/2018, à 10:35

J-F_R_44

Re : Simple Scan ne voit pas le scanner [Résolu]

Merci de la réponse DRbuntu91,
je connais ces pages mais là aussi que choisir et comment faire exactement comme tu le dit un expert serait très utile.
j'ai fait une recherche "bionic" sur le site, réponse sur cette page :
https://github.com/Ordissimo/scangearmp2
et là encore je fais quoi ?

Dernière modification par J-F_R_44 (Le 16/08/2018, à 10:39)

Hors ligne

#19 Le 16/08/2018, à 11:15

DRbuntu91

Re : Simple Scan ne voit pas le scanner [Résolu]

As-tu essayé ceci?

C'est pour Ubuntu 17.04 - je ne sais pas si compatible avec 18.04....


Portable CLEVO W550SU, Intel i5-4200M, RAM=8Go, DD=500Go SSD, BIOS 4.6.5 AMI, Ubuntu 16.04.3 LTS
Puis pour bidouiller un vieux portable Dell Precision M4600 avec W10 + Ub16.4 + Ub18.4 et un ACER Aspire 7720 avec Xubuntu 16.04 LTS
Utilisateur Ubuntu depuis Janvier 2017

Hors ligne

#20 Le 16/08/2018, à 12:57

J-F_R_44

Re : Simple Scan ne voit pas le scanner [Résolu]

j'avoue que je ne sais plus trop, je pense que non, donc j'essayerai ce soir, merci.
j'avais téléchargé les fichiers du site Canon :
https://www.canon.fr/support/consumer_p … 20(64-bit)
IJ Printer Driver v. 5.50 for Linux (debian Packagearchive)
IJ Printer Driver v. 5.50 for Linux (rpm Packagearchive)
IJ Printer Driver v. 5.50 for Linux (Fichier source)
ScanGear MP v. 3.50 for Linux (rpm Packagearchive)
ScanGear MP v. 3.50 for Linux (Fichier source)

et sur https://doc.ubuntu-fr.org/liste_imprimantes_canon
je ne trouve pas ma Canon TS6150, mais TS-6151 seulement pour le scanner et je dois allez sur "github" malheureusement en anglais :
https://github.com/Ordissimo/scangearmp2/releases
j'y trouve  :
Add new printers
@Ordissimo Ordissimo released this on 5 Dec 2017 · 12 commits to master since this release
Assets
    scangearmp2-dbgsym_3.50-2ubuntu.artful_amd64.ddeb
    scangearmp2.spec
    scangearmp2_3.50-2ubuntu.artful.dsc
    scangearmp2_3.50-2ubuntu.artful.tar.xz
    scangearmp2_3.50-2ubuntu.artful_amd64.deb
    Source code (zip)
    Source code (tar.gz)

Hors ligne

#21 Le 16/08/2018, à 15:06

gégé

Re : Simple Scan ne voit pas le scanner [Résolu]

Bonjour,
J'ai également bien galéré avec mon vieux scanner HP SCANJET 5300C.
Ça fait pas mal de temps qu'il ne fonctionnait pas, et n'était même pas reconnu sous les différentes version UBUNTU post 12.04.
Je viens de mettre à niveau en 18.04 et là... il est reconnu. Mais, hélas, si le scanner réagit il se fige et ne scanne pas.
Je continue à m'en servir en utilisant la version 12.04, soit sur clé USB, soit sur virtualbox; ça fonctionne malgré quelques petits bugs.
Voilà, si ça peut aider ou dépanner.

Dernière modification par gégé (Le 16/08/2018, à 15:07)

Hors ligne

#22 Le 16/08/2018, à 20:27

jvcharles

Re : Simple Scan ne voit pas le scanner [Résolu]

il y à ceci, le même lien que J-F_R_44 mais avec des .deb
https://doc.ubuntu-fr.org/liste_imprimantes_canon
ce qui nous mène là
https://github.com/Ordissimo/scangearmp2/releases
deb par pour bionic, mais si ta pas le choix, force l'installation


Ubuntu 18.04 gnome avec Windows 10 (pour les jeux)
Asus Desktop Intel i7, Geforce 1050Ti
moto G4 Plus

Hors ligne

#23 Le 16/08/2018, à 21:35

J-F_R_44

Re : Simple Scan ne voit pas le scanner [Résolu]

c'est bon ça marche avec
scangearmp2_3.50.6_amd64.deb
de la page :
https://github.com/Ordissimo/scangearmp2/releases
le tout était de tomber sur le bon, il ne reste plus qu'à nettoyer le reste.

Hors ligne