Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 12/08/2018, à 13:18

PetitRodin

Screen Tearing Vidéo sur Ubuntu 18.04

Bonjour à toutes et à tous,

Ce post pour témoigner d'un problème que j'ai eu sur 2 PC (un portable et un fixe) sur Ubuntu 18.04 64bit.

Conf du portable:
CPU: AMD Ryzen 3
GPU: Radeon Vega Graphics

Conf du fixe:
CPU: Intel core i5
GPU: Intel Graphics

Quand je regarde des vidéos, j'ai un mauvais refresh qui génère des bandes horizontales, surtout quand la caméra fait un panoramique...
Ce phénomène est appelé "Tearing vidéo" et j'ai vraiment galéré pour le supprimer.
Mettre à jour les drivers graphiques Xorg ne m'a pas résolu le problème.
De même, la soluce trouvée sur le net sur la création ou mise à jour du fichier xorg.conf m'a fait crashé le PC et j'ai du réinstaller Ubuntu.

La solution (qui fonctionne sur mes 2 PCs) me concernant est de passer sur Compiz.
Je suis sur Ubuntu Mate 18.04.
Pour cela aller dans Menu > Préférences > MATE Tweak > Fenêtres > Gestionnaire des fenêtres > Compiz
...et voilà !
J'espère que ce post évitera des galères à ceux qui souffrent du tearing !

Hors ligne

#2 Le 12/08/2018, à 14:22

GammaDraconis

Re : Screen Tearing Vidéo sur Ubuntu 18.04

Normale ça dépend du compositeur de fenêtre, Compiz n'a pas de tearing (il remplace le compositeur Marco de Mate) mais ce n'est pas le cas non plus avec "Compton" qui est proposé aussi en liste.

Par ailleurs, la technique en modifiant le fichier de Xorg fonctionne aussi mais ça s'applique uniquement pour les chipset graphique Intel, autrement dit pour ta 2ème config (Intel Graphics), si ça a planté c'est que tu t'es trompé dans la modif. Par contre pour ton pc avec une Radeon, là oui c'est possible que ça ne fonctionne pas.

Dernière modification par GammaDraconis (Le 12/08/2018, à 14:22)


PC1 (Xiaomi Air 13) : dualboot avec Ubuntu 18.04LTS/Gnome et ArchLinux/Xfce (rolling)
PC2 (Lenovo Legion Y520) : quadrupleboot avec ArchLinux/Plasma, Ubuntu 18.04LTS/Gnome, OpenSuSe Tumbleweed/Plasma (rolling), win10
Besoin d'un script de post-install pour la 18.04 ? c'est ici : https://forum.ubuntu-fr.org/viewtopic.php?id=2026344

Hors ligne