Contenu | Rechercher | Menus

Annonce

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 07/09/2018, à 19:45

Sky3RN

[RÉSOLU] Pas de WiFi sur Lenovo YOGA 530 ?

Bonjour,

J'ai acheté aujourd'hui un ordinateur portable Lenovo YOGA 530 et tout fonctionne très bien sous Windows 10 fournit avec.

J'ai installé Ubuntu 18.04 et là.. C'est la catastrophe.
Mon trackpad n'est pas reconnu (du coup j'y branche une souris USB) et pire, WiFi et Bluetooth ne fonctionnent pas ! Le PC portable est en mode avion. J'ai réussi à retirer le mode avion mais impossible de me connecter (je passe actuellement par mon téléphone portable branché en filaire et un partage de connexion).
C'est embêtant parce que j'ai acheté ce PC pour quand je suis en déplacement, justement. À la maison j'ai une tour que je ne compte pas lâcher !

Un rfkill list me retourne ceci :

root@skyern-lenovo:/home/skyern# rfkill list
0: ideapad_wlan: Wireless LAN
	Soft blocked: no
	Hard blocked: yes
1: ideapad_bluetooth: Bluetooth
	Soft blocked: no
	Hard blocked: yes
2: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
3: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no

Après m'être un peu renseigné il semblerait que le hard blocked soit généralement quelque chose de "physique", je suis allé vérifier dans le BIOS et la carte WiFi est bien active (sinon je ne pourrai pas me connecter quand je suis sous Windows), et je n'ai visiblement pas de communtateur sur l'ordi' en lui-même (idem : je ne pourrai pas me connecter sinon).

J'ai beau cliquer sur l'option pour activer le WiFi dans Ubuntu, rien ne se passe.

J'en suis au stade où j'essaie d'installer ma vieille clé WiFi USB mais impossible de compiler !

root@skyern-lenovo:/home/skyern# cd Téléchargements/TL-WN823N_V1_150909/TL-WN823N_V1_150909/Driver/
root@skyern-lenovo:/home/skyern/Téléchargements/TL-WN823N_V1_150909/TL-WN823N_V1_150909/Driver# make
"******************************************"
"NO SKRC,we will use default KSRC"
"******************************************"
make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.15.0-33-generic/build M=/home/skyern/Téléchargements/TL-WN823N_V1_150909/TL-WN823N_V1_150909/Driver  modules
make[1] : on entre dans le répertoire « /usr/src/linux-headers-4.15.0-33-generic »
Makefile:976: "Cannot use CONFIG_STACK_VALIDATION=y, please install libelf-dev, libelf-devel or elfutils-libelf-devel"
"******************************************"
"NO SKRC,we will use default KSRC"
"******************************************"
  CC [M]  /home/skyern/Téléchargements/TL-WN823N_V1_150909/TL-WN823N_V1_150909/Driver/core/rtw_cmd.o
In file included from /home/skyern/Téléchargements/TL-WN823N_V1_150909/TL-WN823N_V1_150909/Driver/core/rtw_cmd.c:23:0:
/home/skyern/Téléchargements/TL-WN823N_V1_150909/TL-WN823N_V1_150909/Driver/include/osdep_service.h: In function ‘_init_timer’:
/home/skyern/Téléchargements/TL-WN823N_V1_150909/TL-WN823N_V1_150909/Driver/include/osdep_service.h:957:8: error: ‘_timer {aka struct timer_list}’ has no member named ‘data’
  ptimer->data = (unsigned long)cntx;
        ^~
/home/skyern/Téléchargements/TL-WN823N_V1_150909/TL-WN823N_V1_150909/Driver/include/osdep_service.h:958:2: error: implicit declaration of function ‘init_timer’; did you mean ‘_init_timer’? [-Werror=implicit-function-declaration]
  init_timer(ptimer);
  ^~~~~~~~~~
  _init_timer
In file included from /home/skyern/Téléchargements/TL-WN823N_V1_150909/TL-WN823N_V1_150909/Driver/core/rtw_cmd.c:23:0:
/home/skyern/Téléchargements/TL-WN823N_V1_150909/TL-WN823N_V1_150909/Driver/include/osdep_service.h: In function ‘thread_enter’:
/home/skyern/Téléchargements/TL-WN823N_V1_150909/TL-WN823N_V1_150909/Driver/include/osdep_service.h:1480:2: error: implicit declaration of function ‘allow_signal’; did you mean ‘do_signal’? [-Werror=implicit-function-declaration]
  allow_signal(SIGTERM);
  ^~~~~~~~~~~~
  do_signal
/home/skyern/Téléchargements/TL-WN823N_V1_150909/TL-WN823N_V1_150909/Driver/include/osdep_service.h: In function ‘flush_signals_thread’:
/home/skyern/Téléchargements/TL-WN823N_V1_150909/TL-WN823N_V1_150909/Driver/include/osdep_service.h:1493:6: error: implicit declaration of function ‘signal_pending’; did you mean ‘timer_pending’? [-Werror=implicit-function-declaration]
  if (signal_pending (current))
      ^~~~~~~~~~~~~~
      timer_pending
/home/skyern/Téléchargements/TL-WN823N_V1_150909/TL-WN823N_V1_150909/Driver/include/osdep_service.h:1495:3: error: implicit declaration of function ‘flush_signals’; did you mean ‘do_signal’? [-Werror=implicit-function-declaration]
   flush_signals(current);
   ^~~~~~~~~~~~~
   do_signal
cc1: some warnings being treated as errors
scripts/Makefile.build:332: recipe for target '/home/skyern/Téléchargements/TL-WN823N_V1_150909/TL-WN823N_V1_150909/Driver/core/rtw_cmd.o' failed
make[2]: *** [/home/skyern/Téléchargements/TL-WN823N_V1_150909/TL-WN823N_V1_150909/Driver/core/rtw_cmd.o] Error 1
Makefile:1552: recipe for target '_module_/home/skyern/Téléchargements/TL-WN823N_V1_150909/TL-WN823N_V1_150909/Driver' failed
make[1]: *** [_module_/home/skyern/Téléchargements/TL-WN823N_V1_150909/TL-WN823N_V1_150909/Driver] Error 2
make[1] : on quitte le répertoire « /usr/src/linux-headers-4.15.0-33-generic »
Makefile:731: recipe for target 'modules' failed
make: *** [modules] Error 2

Voici ce que retourne iwconfig :

root@skyern-lenovo:/home/skyern/Téléchargements/TL-WN823N_V1_150909/TL-WN823N_V1_150909/Driver# iwconfig
enp3s0f3u2u4  no wireless extensions.

lo        no wireless extensions.

wlx30b5c213a68b  IEEE 802.11  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Encryption key:off
          Power Management:on

Et enfin, lspci :

root@skyern-lenovo:/home/skyern/Téléchargements/TL-WN823N_V1_150909/TL-WN823N_V1_150909/Driver# lspci
00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15d0
00:00.2 IOMMU: Advanced Micro Devices, Inc. [AMD] Device 15d1
00:01.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) PCIe Dummy Host Bridge
00:01.2 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 15d3
00:01.7 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 15d3
00:08.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) PCIe Dummy Host Bridge
00:08.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 15db
00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD] FCH SMBus Controller (rev 61)
00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD] FCH LPC Bridge (rev 51)
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15e8
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15e9
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15ea
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15eb
00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15ec
00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15ed
00:18.6 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15ee
00:18.7 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15ef
01:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter
02:00.0 Non-Volatile memory controller: Device 1c5c:1327
03:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Vega [Radeon Vega 8 Mobile] (rev c4)
03:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Device 15de
03:00.2 Encryption controller: Advanced Micro Devices, Inc. [AMD] Device 15df
03:00.3 USB controller: Advanced Micro Devices, Inc. [AMD] Device 15e0
03:00.4 USB controller: Advanced Micro Devices, Inc. [AMD] Device 15e1
03:00.6 Audio device: Advanced Micro Devices, Inc. [AMD] Device 15e3
03:00.7 Non-VGA unclassified device: Advanced Micro Devices, Inc. [AMD] Device 15e6

Si vous avez des idées, ça me sauverait peut-être la vie !

Merci. smile

Dernière modification par Sky3RN (Le 07/09/2018, à 20:24)

Hors ligne

#2 Le 07/09/2018, à 20:06

xubu1957

Re : [RÉSOLU] Pas de WiFi sur Lenovo YOGA 530 ?

Bonjour,

Il faut fournir, en te servant du  Retour utilisable de commande, un wificheck rassemblant les informations > Configuration wifi.

Nota : un fichier wificheck.log est créé dans votre répertoire personnel, collez l'intégralité de son contenu dans votre discussion.

cqfd93 a écrit :

Astuce pour copier / coller sans erreur :

  • triple clic gauche pour sélectionner et copier une ligne entière

  • clic molette pour coller dans le terminal


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#3 Le 07/09/2018, à 20:23

Sky3RN

Re : [RÉSOLU] Pas de WiFi sur Lenovo YOGA 530 ?

Attends y a du nouveau !
Dans le BIOS j'ai changé UEFI pour Legacy et la carte WiFi fonctionne sous Ubuntu !

Je passe en résolu mais si quelqu'un peut m'expliquer le pourquoi du comment ça sera utile pour toute personne qui a ce problème.

(Ceci-dit je cherche toujours comment faire fonctionner le touchpad.)

Dernière modification par Sky3RN (Le 07/09/2018, à 20:25)

Hors ligne

#4 Le 07/09/2018, à 20:37

xubu1957

Re : [RÉSOLU] Pas de WiFi sur Lenovo YOGA 530 ?

Pour ta carte :

Network controller: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter

Je n'ai trouvé qu'une discussion sur le forum > Carte WIFI RTL 8821CE non reconnue.

Tu n'as pas désactivé le secure-boot ?

Regarde au § 2 et début du § 3 (documentation) > [Tuto] Pas de Wi-fi ? Eléments importants à vérifier

_ _ _

Je viens de voir > askubuntu.com/questions/990378/wi-fi-not-working-on-lenovo-thinkpad-e570-realtek-rtl8821ce

avec un lien vers > no wifi adapter found ubuntu 18.04

Et :

praseodym a écrit :

There it is. Driver installation
Le voilà. Installation du pilote

sudo apt-get install --reinstall git dkms build-essential linux-headers-$(uname -r)
git clone https://github.com/tomaspinho/rtl8821ce
cd rtl8821ce
chmod +x dkms-install.sh
chmod +x dkms-remove.sh
sudo ./dkms-install.sh

Reboot and deactivate SecureBoot
Redémarrer et désactiver SecureBoot

Dernière modification par xubu1957 (Le 07/09/2018, à 21:03)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#5 Le 08/09/2018, à 06:34

xubu1957

Re : [RÉSOLU] Pas de WiFi sur Lenovo YOGA 530 ?

Bonjour,

Pour :

(Ceci-dit je cherche toujours comment faire fonctionner le touchpad.)

Tu devrais créer un nouveau sujet pour ce problème, en suivant les indications :  Initier une nouvelle discussion dans la section Autres types de matériel.


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#6 Le 15/12/2018, à 12:04

xubu1957

Re : [RÉSOLU] Pas de WiFi sur Lenovo YOGA 530 ?

Bonjour,

Vu cette remarque dans ta discussion > RÉSOLU] Pas de pavé tactile et écran tactile ?

Le 15/12/2018, Sky3RN a écrit :

J'ai cependant remarqué un petit bug avec la Wi-Fi depuis que j'ai réussi à installer le pavé et l'écran tactiles.
Lorsque j'essaie de changer de réseau, ça tourne dans le vent et se déconnecte.
Je suis obligé de désactiver / réactiver le réseau Wi-Fi pour que ça se reconnecte automatiquement au premier réseau automatique choisi. C'est très chiant.

Et dans ton retour au #1 :

 rfkill list
0: ideapad_wlan: Wireless LAN
	Soft blocked: no
        Hard blocked: yes

3: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no

Avais-tu utilisé la commande :

echo "blacklist ideapad_laptop" | sudo tee /etc/modprobe.d/ideapad.conf

?

- § 6 - C) pour des ordinateurs Lenovo > [Tuto] Pas de Wi-fi ? Eléments importants à vérifier  Les conflits de modules (plusieurs modules wifi gérant la même carte)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#7 Le 15/12/2018, à 12:12

Sky3RN

Re : [RÉSOLU] Pas de WiFi sur Lenovo YOGA 530 ?

Oui, déjà fait. smile

Par contre ce que tu cites concernant mon post #1 est erroné, ça a été réglé depuis.
C'est pour ça que j'ai pas relancé ici mais dans l'autre topic puisque ça a sauté suite a la correction de l'autre bug !

Hors ligne

#8 Le 15/12/2018, à 12:23

xubu1957

Re : [RÉSOLU] Pas de WiFi sur Lenovo YOGA 530 ?

Pour du Wi-Fi, il vaut mieux utiliser cette discussion !

Donne :

iwconfig

et :

nmcli dev wifi

Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#9 Le 15/12/2018, à 12:26

Sky3RN

Re : [RÉSOLU] Pas de WiFi sur Lenovo YOGA 530 ?

skyern@skyern-lenovo:~$ iwconfig
lo        no wireless extensions.

wlp1s0    IEEE 802.11bgn  ESSID:"Espace Charenton Fibre HD"  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Frequency:2.472 GHz  Access Point: 34:FA:9F:1D:2F:18   
          Bit Rate:72.2 Mb/s   Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=75/100  Signal level=31/100  Noise level=0/100
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

skyern@skyern-lenovo:~$ nmcli dev wifi
IN-USE  SSID  MODE  CHAN  RATE  SIGNAL  BARS  SECURITY 
skyern@skyern-lenovo:~$

Hors ligne

#10 Le 15/12/2018, à 12:28

xubu1957

Re : [RÉSOLU] Pas de WiFi sur Lenovo YOGA 530 ?

Ta Box est bien chiffrée sur du WPA2 seul ?

_ _ _

Tente :

sudo modprobe -a 8821ce

Dernière modification par xubu1957 (Le 15/12/2018, à 12:33)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#11 Le 15/12/2018, à 12:47

Sky3RN

Re : [RÉSOLU] Pas de WiFi sur Lenovo YOGA 530 ?

Je suis pas chez moi, je teste sur la connexion qu'il y a au boulot. smile

Et en général je me connecte sur la Wi-Fi de mon téléphone en partage de connexion.

Déjà testé le modprobe, ça n'avait rien changé.

Pour résumer : Depuis que j'ai réglé le problème du tactile (Cf l'autre topic), quand je démarre l'ordi' ça se connecte au Wi-Fi enregistré en connexion automatique, si je tente de changer (par exemple me connecter sur mon téléphone ou un autre réseau) ça tourne en boucle sans se connecter, puis ça échoue. Et si je tente de revenir sur le réseau sur lequel c'était connecté, même chose. Obligé de désactiver / réactiver network-manager et même comme ça je ne peux pas changer de réseau.

Comme j'ai dit tout à l'heure, j'ai contourné le problème grâce à Wicd. Mais bon, à voir ce que ça donnera sur le long terme !

Hors ligne

#12 Le 15/12/2018, à 12:53

xubu1957

Re : [RÉSOLU] Pas de WiFi sur Lenovo YOGA 530 ?

Je donne l'info :

Le 07/03/2018, un expert du wifi sur Ubuntu, chili555 a écrit :

Please check the settings in the router. WPA2-AES is preferred; not any WPA and WPA2 mixed mode and certainly not TKIP. Second, if your router is capable of N speeds, you may have better connectivity with a channel width of 20 MHz in the 2.4 GHz band instead of automatic 20/40 MHz, although it is likely to affect N speeds. I also have better luck with a fixed channel, either 1, 6 or 11, rather than automatic channel selection. Also, be certain the router is not set to use N speeds only; auto B, G and N is preferred. After making these changes, reboot the router.

Veuillez vérifier les paramètres dans le routeur. WPA2-AES est préférable ; pas de mode mixte WPA et WPA2 et certainement pas de TKIP. Deuxièmement, si votre routeur est capable du mode N, vous pouvez avoir une meilleure connectivité avec une largeur de canal de 20 MHz dans la bande 2,4 GHz au lieu de 20/40 MHz automatique, bien que cela puisse affecter  mode N. J'ai aussi plus de chance avec un canal fixe, 1, 6 ou 11, plutôt que la sélection automatique des canaux. Assurez-vous également que le routeur n'est pas configuré pour utiliser uniquement du mode N; Auto B, G et N sont préférés. Après avoir apporté ces modifications, redémarrez le routeur.

> AC600 usb wifi adapter 17.10 need help -wireless script pastebin inc...

_ _ _

Fournis le noyau actif :

uname -a

Dernière modification par xubu1957 (Le 15/12/2018, à 12:55)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#13 Le 15/12/2018, à 13:16

Sky3RN

Re : [RÉSOLU] Pas de WiFi sur Lenovo YOGA 530 ?

Non mais là le souci ne vient pas de la box sur laquelle je suis connecté mais de network-manager. smile
C'est sûr à 98%.

J'ai jamais eu ce problème avant, alors que j'utilise exactement les mêmes réseaux que toutes les autres fois.

skyern@skyern-lenovo:~$ uname -a
Linux skyern-lenovo 4.19.9-041909-generic #201812130432 SMP Thu Dec 13 09:34:53 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Hors ligne

#14 Le 15/12/2018, à 13:33

xubu1957

Re : [RÉSOLU] Pas de WiFi sur Lenovo YOGA 530 ?

Pour le réseau, je ne suis pas au point !

Il faut des aidants spécialistes.


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne