Contenu | Rechercher | Menus

Annonce

T-shirt Seiche Cosmic, Série limitée

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.10
T-shirt Ubuntu-FR « Seiche Cosmique » en série limitée ! Prix spécial pré-vente (15€) jusqu'au 4 novembre 2018.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

Heure d'hiver: N'oubliez pas de décochez l'heure d'été dans votre profil.

#1 Le 12/09/2018, à 08:33

Christophe C

PDF - norme ISO 32000-2:2017

Bonjour,

La norme ISO actuelle est ISO 32000-2:2017. La précédente datait de 2009.

Des lecteurs PDF comme evince ou atril sont basés sur la librairie Poppler, qui décode les PDF. Je n'arrive pas à savoir si poppler est compatible ISO 32000-2:2017, ou pas.

Quelqu'un a t'il l'info ?

https://poppler.freedesktop.org/


XL-WALLPAPER - changeur de fonds d'écran libre et très léger pour Xfce et LXDE.

Hors ligne

#2 Le 15/09/2018, à 14:04

LeoMajor

Re : PDF - norme ISO 32000-2:2017

bonjour,

cela correspond au pdf 2.0
sous une 16.04,   poppler-utils Version: 0.41.0-0ubuntu1.8

apt-file list poppler-utils

poppler-utils: /usr/bin/pdfdetach
poppler-utils: /usr/bin/pdffonts
poppler-utils: /usr/bin/pdfimages
poppler-utils: /usr/bin/pdfinfo
poppler-utils: /usr/bin/pdfseparate
poppler-utils: /usr/bin/pdftocairo
poppler-utils: /usr/bin/pdftohtml
poppler-utils: /usr/bin/pdftoppm
poppler-utils: /usr/bin/pdftops
poppler-utils: /usr/bin/pdftotext
poppler-utils: /usr/bin/pdfunite
pdfinfo "/tmp/Simple PDF 2.0 file.pdf"

Syntax Warning: May not be a PDF file (continuing anyway)
Syntax Error (8): Illegal character <21> in hex string
Syntax Error (10): Illegal character <4f> in hex string
Syntax Error (12): Illegal character <54> in hex string
Syntax Error (13): Illegal character <59> in hex string
Syntax Error (14): Illegal character <50> in hex string
Syntax Error (17): Illegal character <68> in hex string
...
Syntax Error: Couldn't read xref table

visiblement incompatible
à toi de voir sous une 18.04, ou compiler la 0.68

Hors ligne

#3 Le 15/09/2018, à 18:33

kevlar

Re : PDF - norme ISO 32000-2:2017

Bonsoir. Comme je développe (sous langage C+Gtk) des logiciels utilisant la bibliothèque "poppler-glib" je confirme qu'elle est limitée (ou en retard) : par exemple, lors du Google Summit Of Code 2014, un patch intéressant a été soumis (ajout de l'édition des zones de texte libres), et à ma connaissance, bien que fonctionnel, le patch n'a toujours pas été intégré (alors que ceci fonctionnait déjà sous Qt à la même époque). Je ne suis donc pas trop surpris de ce que je lis ci-dessus.
Dès lors, je ne peux que réitérer toujours et encore le même conseil : utiliser Okular.
J'ajoute que le module qui gère l'impression des PDF sous Gtk a, à mon humble avis, un problème (mais peut-être est-ce dû à Popller ?) ; dans certains cas, des PDF avec des codes barres (exemple : auto-affranchissements postaux), des surlignements de textes ajoutés dans le PDF, etc. ne sortent pas en impression depuis Evince alors qu'ils sont rendus sans problème (lors de l'impression) avec Okular.
Voilà, comme nous restons sur du libre, c'est je pense une bonne solution.

Hors ligne

#4 Le 16/09/2018, à 07:33

serged

Re : PDF - norme ISO 32000-2:2017

Côté pratique, les utilitaires comme evince ou autres ne lisent pas certains documents, comme les formulaires de l'administration voir par exemple cette discussion.


Linux-Mint 18.3 Sylvia 64 (Cinnamon) sur ASUS F2A55/AMD A8-5600K APU

Hors ligne

#5 Le 16/09/2018, à 08:04

Christophe C

Re : PDF - norme ISO 32000-2:2017

@serged, oui, mais rien à voir avec ma question : ces formulaires utilisent xfa, une extension de adobe qui n'appartient pas à la norme PDF, que ce soit la 2009 ou la 2017.
Cela ne nous dit rien sur ce que font les dernières versions de poppler hors xfa.

@LeoMajor : je demande si poppler est compatible en 2018 avec la norme 2017, tu me répond qu'en 2016 ce n'était pas le cas .... certes, puisque la norme 2017 n'était pas sortie hmm

@kevlar : ok, merci de l'info. Manifestement poppler n'est pas compatible avec toute la norme, peut-être même pas avec celle de 2009.
Concernant okular, ce n'est pas réaliste, il veut m'installer 203 fichier (dans cosmic). Le niveau de dépendance est trop élevé. manifestement il y a un gros bout de kde.

Dernière modification par Christophe C (Le 16/09/2018, à 08:13)


XL-WALLPAPER - changeur de fonds d'écran libre et très léger pour Xfce et LXDE.

Hors ligne

#6 Le 16/09/2018, à 09:11

JBF

Re : PDF - norme ISO 32000-2:2017

Christophe C a écrit :

@kevlar : ok, merci de l'info. Manifestement poppler n'est pas compatible avec toute la norme, peut-être même pas avec celle de 2009.
Concernant okular, ce n'est pas réaliste, il veut m'installer 203 fichier (dans cosmic). Le niveau de dépendance est trop élevé. manifestement il y a un gros bout de kde.

Et alors ? Okular reste le meilleur lecteur de PDF sous Linux et je ne lui ai trouvé aucun problème de cohabitation avec Gnome.


LibreOffice : http://fr.libreoffice.org/ (téléchargement, documentation, FAQ, assistance, contribuer, ...)
Aide pour LibreOffice par la communauté francophone : https://ask.libreoffice.org/fr/

Hors ligne

#7 Le 16/09/2018, à 09:53

Christophe C

Re : PDF - norme ISO 32000-2:2017

C'est lourd quand même. Mais si la différence le justifie, pourquoi pas ?

Sur le fonds (je veux dire par là hors questions d'interface), qu'a t'il de plus ?
Implémente t'il la norme pdf de 2017 ?

je suppose qu'il ne gère pas non plus les xfa ?


XL-WALLPAPER - changeur de fonds d'écran libre et très léger pour Xfce et LXDE.

Hors ligne

#8 Le 16/09/2018, à 10:01

GammaDraconis

Re : PDF - norme ISO 32000-2:2017

Nan il faut éviter d'installer Okular sur une base Gnome, il y a beaucoup trop de dépendance KDE.
ça pourrai le justifier si il supporterai tous les formulaires XFA comme Adobe Reader mais ce n'est pas le cas, il a le même comportement que Evince.
(a noté que dans le sens inverse aussi : il faut éviter d'installer Evince sur une base Kde)

Donc pour la lecture PDF c'est simple à comprendre :

- Pour une base Gnome (gnome shell, mate, cinnamon...) : c'est Evince
- Pour une base Kde/Plasma : c'est Okular
- Et pour ceux qui ont besoin de régulièrement lire des formulaires XFA, il faut ajouter en + le logiciel propriétaire "Pdf Mater Editor"

Dernière modification par GammaDraconis (Le 16/09/2018, à 10:02)


PC1 perso (Xiaomi Air 13) : dualboot avec Archlinux/Xfce et Ubuntu 18.04LTS/Gnome
PC2 perso (Lenovo Legion Y520) : quadrupleboot avec Archlinux/Plasma, Ubuntu 18.10/Gnome, OpenSuSe Tumbleweed/Mate, Win10
PC3 pro : OpenSuSe Leap 15/Plasma
Besoin d'un script de post-install pour la 18.04 ? c'est ici : https://forum.ubuntu-fr.org/viewtopic.php?id=2026344

Hors ligne

#9 Le 16/09/2018, à 18:28

kevlar

Re : PDF - norme ISO 32000-2:2017

Pas du tout, mais alors pas du tout d'accord (amicalement, bien sûr, je ne suis pas un bouledogue) avec la prétendue lourdeur d'Okular liée à Kde : comme je l'ai déjà écrit, je suis fidèle à Gtk, mais quand çà ne tient pas la route, il faut également le dire et utiliser les excellentes applications fondées sur Qt (K3b, Kdenlive, Vlc, QPdf, etc.)
Le  "monstre" que j'utilise tous les jours (c'est ma machine de bureau, eh oui) :
- Acer Aspire de 2005 trouvé à Emmaüs, avec  AMD Sempron 2200 Mhz+2Go de Ram+disique dur 250 Go+Lubuntu -
Donc, on peut dire que je n'ai pas "intérêt" à trop charger, et pourtant, pour le bureau à distance, pareil, j'utilise une pure application Kde (Krdc) parce qu'elle marche, contrairement à Remina ... et j'uilise vraiment à fond Krdc sur mon "petit vieux" car indispensable pour le travail.
Pour revenir aux PDF, s'il y a 5 secs d'écart entre un 1er lancement d'Evince et le même pour Okular, c'est le bout du monde.
Et en ce qui concerne les programmes proprios, soit ils sont sous Java (et là, c'est vraiment du lourd : Master PDF editor), soit ils sont sous Qt (Foxit par exemple). Il y a bien longtemps (vers 2010 de mémoire) qu'Adobe a lâché Gtk.

Hors ligne

#10 Le 17/09/2018, à 07:36

Christophe C

Re : PDF - norme ISO 32000-2:2017

Ok, mais quels sont les plus d'Okular ?


XL-WALLPAPER - changeur de fonds d'écran libre et très léger pour Xfce et LXDE.

Hors ligne

#11 Le 17/09/2018, à 21:58

JBF

Re : PDF - norme ISO 32000-2:2017

Christophe C a écrit :

Ok, mais quels sont les plus d'Okular ?

Affichage de meilleure qualité à mon goût, pixellise moins
Capable d'ouvrir de gros PDF nettement plus rapidement
Annotations plus pratiques


LibreOffice : http://fr.libreoffice.org/ (téléchargement, documentation, FAQ, assistance, contribuer, ...)
Aide pour LibreOffice par la communauté francophone : https://ask.libreoffice.org/fr/

Hors ligne

#12 Le 18/09/2018, à 01:43

melixgaro

Re : PDF - norme ISO 32000-2:2017

salut,

Je pense que

sudo apt install --no-install-recommends okular

tirera vachement moins de dépendance.

J'utilise Xubuntu et j'installe toujours le quatuor evince-atril-okular-xpdf car certains pdf sont capricieux et s'ouvrent mieux avec certaines applis que d'autres.


Linux depuis ~2007. Xubuntu seulement.

Hors ligne

#13 Le 19/09/2018, à 18:25

kevlar

Re : PDF - norme ISO 32000-2:2017

Christophe C a écrit :

Ok, mais quels sont les plus d'Okular ?

plus rapide, possibilité d'annoter sous forme de texte libre ou de pop-ups, de tracer des lignes, de surligner, de mettre un tampon, simplicité pour copier dans le presse-papiers une zone graphique (idem sur QPdf, très bien également et ultra-léger), ébauche de reconnaissance de tableaux (mais peu convaincu pour ma part), etc.
Simplicité pour compléter des formulaires, encore testé en début de semaine ;-)

@melixgero : c'est drôle, il me semble qu'Atrill doit être un dérivé d'evince, en quoi est-il plus adapté ?

Hors ligne

#14 Le 19/09/2018, à 18:52

melixgaro

Re : PDF - norme ISO 32000-2:2017

Oui, atril dérive d'evince. Je l'ai découvert avec ubuntu mate et est maintenant devenu l'appli par défaut sur xubuntu. Déjà, l'interface d'atril est fidèle au evince de l'époque Gnome 2 (menu classique, pas de gros boutons). Ensuite, je n'ai pas d'argument très tangibles : certains pdf passent mieux avec evince qu'avec atril (mais atril reste ma visionneuse principale, les autres c'est vraiment pour des cas d'usage particuliers).

PS : c'est melixgAro wink


Linux depuis ~2007. Xubuntu seulement.

Hors ligne

#15 Le 20/09/2018, à 09:54

Christophe C

Re : PDF - norme ISO 32000-2:2017

Il est très surprenant que atril ou evince affiche les choses différemment : ils utilisent tous les 2 la librairies Poppler pour décoder le PDF.

Donc soit ils n'utilisent pas la même version (temporairement), soit ils font de l'optimisation post-Poppler. C'est étonnant, quand même.


XL-WALLPAPER - changeur de fonds d'écran libre et très léger pour Xfce et LXDE.

Hors ligne

#16 Le 20/09/2018, à 13:05

melixgaro

Re : PDF - norme ISO 32000-2:2017

Je ne donne que mon expérience, je ne peux pas être moins vague car je ne me souviens pas avec quel PDF ça passait mieux avec l'un ou l'autre. J'en étais arrivé à la conclusion, peut-être à tort, qu'il y a plus qu'une différence d'aspect graphique entre atril et evince.


Linux depuis ~2007. Xubuntu seulement.

Hors ligne

#17 Le 21/09/2018, à 12:12

frenchy82

Re : PDF - norme ISO 32000-2:2017

melixgaro a écrit :

salut,

Je pense que

sudo apt install --no-install-recommends okular

tirera vachement moins de dépendance.

J'utilise Xubuntu et j'installe toujours le quatuor evince-atril-okular-xpdf car certains pdf sont capricieux et s'ouvrent mieux avec certaines applis que d'autres.

udo apt install --no-install-recommends okular
[sudo] Mot de passe de cartes : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-image-4.15.0-29-generic linux-modules-4.15.0-29-generic
  linux-modules-extra-4.15.0-29-generic linux-tools-4.15.0-29
  linux-tools-4.15.0-29-generic
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés : 
  kinit kio kpackagetool5 libaccounts-glib0 libaccounts-qt5-1
  libdbusmenu-qt5-2 libfam0 libkaccounts1 libkf5activities5 libkf5archive5
  libkf5attica5 libkf5auth-data libkf5auth5 libkf5bookmarks-data
  libkf5bookmarks5 libkf5codecs-data libkf5codecs5 libkf5completion-data
  libkf5completion5 libkf5config-data libkf5configcore5 libkf5configgui5
  libkf5configwidgets-data libkf5configwidgets5 libkf5coreaddons-data
  libkf5coreaddons5 libkf5crash5 libkf5dbusaddons-data libkf5dbusaddons5
  libkf5declarative-data libkf5declarative5 libkf5doctools5
  libkf5globalaccel-data libkf5globalaccel5 libkf5guiaddons5 libkf5i18n-data
  libkf5i18n5 libkf5iconthemes-data libkf5iconthemes5 libkf5itemviews-data
  libkf5itemviews5 libkf5jobwidgets-data libkf5jobwidgets5 libkf5js5
  libkf5jsapi5 libkf5kexiv2-15.0.0 libkf5kiocore5 libkf5kiontlm5
  libkf5kiowidgets5 libkf5notifications-data libkf5notifications5
  libkf5package-data libkf5package5 libkf5parts-data libkf5parts5
  libkf5pty-data libkf5pty5 libkf5purpose-bin libkf5purpose5
  libkf5quickaddons5 libkf5service-bin libkf5service-data libkf5service5
  libkf5solid5 libkf5solid5-data libkf5sonnet5-data libkf5sonnetcore5
  libkf5sonnetui5 libkf5textwidgets-data libkf5textwidgets5
  libkf5threadweaver5 libkf5wallet-bin libkf5wallet-data libkf5wallet5
  libkf5widgetsaddons-data libkf5widgetsaddons5 libkf5windowsystem-data
  libkf5windowsystem5 libkf5xmlgui-bin libkf5xmlgui-data libkf5xmlgui5
  libkwalletbackend5-5 libmarkdown2 libokular5core8 libphonon4qt5-4
  libpolkit-qt5-1-1 libpoppler-qt5-1 libqca-qt5-2 libqmobipocket2
  libqt5script5 libqt5texttospeech5 libqt5xml5 libsignon-qt5-1 phonon4qt5
  phonon4qt5-backend-vlc qml-module-org-kde-kquickcontrolsaddons
  qml-module-ubuntu-onlineaccounts
Paquets suggérés :
  fam kde-telepathy-send-file jovie okular-extra-backends texlive-binaries
  phonon4qt5-backend-gstreamer
Paquets recommandés :
  kaccounts-providers kactivities-bin kactivitymanagerd libkf5config-bin
  libkf5dbusaddons-bin kpackagelauncherqml libkf5globalaccel-bin
  libkf5iconthemes-bin libkf5parts-plugins kdeconnect nodejs | nodejs-legacy
  qml-module-org-kde-purpose sonnet-plugins kwayland-integration qtwayland5
  libqca-qt5-2-plugins qtspeech5-flite-plugin
Les NOUVEAUX paquets suivants seront installés :
  kinit kio kpackagetool5 libaccounts-glib0 libaccounts-qt5-1
  libdbusmenu-qt5-2 libfam0 libkaccounts1 libkf5activities5 libkf5archive5
  libkf5attica5 libkf5auth-data libkf5auth5 libkf5bookmarks-data
  libkf5bookmarks5 libkf5codecs-data libkf5codecs5 libkf5completion-data
  libkf5completion5 libkf5config-data libkf5configcore5 libkf5configgui5
  libkf5configwidgets-data libkf5configwidgets5 libkf5coreaddons-data
  libkf5coreaddons5 libkf5crash5 libkf5dbusaddons-data libkf5dbusaddons5
  libkf5declarative-data libkf5declarative5 libkf5doctools5
  libkf5globalaccel-data libkf5globalaccel5 libkf5guiaddons5 libkf5i18n-data
  libkf5i18n5 libkf5iconthemes-data libkf5iconthemes5 libkf5itemviews-data
  libkf5itemviews5 libkf5jobwidgets-data libkf5jobwidgets5 libkf5js5
  libkf5jsapi5 libkf5kexiv2-15.0.0 libkf5kiocore5 libkf5kiontlm5
  libkf5kiowidgets5 libkf5notifications-data libkf5notifications5
  libkf5package-data libkf5package5 libkf5parts-data libkf5parts5
  libkf5pty-data libkf5pty5 libkf5purpose-bin libkf5purpose5
  libkf5quickaddons5 libkf5service-bin libkf5service-data libkf5service5
  libkf5solid5 libkf5solid5-data libkf5sonnet5-data libkf5sonnetcore5
  libkf5sonnetui5 libkf5textwidgets-data libkf5textwidgets5
  libkf5threadweaver5 libkf5wallet-bin libkf5wallet-data libkf5wallet5
  libkf5widgetsaddons-data libkf5widgetsaddons5 libkf5windowsystem-data
  libkf5windowsystem5 libkf5xmlgui-bin libkf5xmlgui-data libkf5xmlgui5
  libkwalletbackend5-5 libmarkdown2 libokular5core8 libphonon4qt5-4
  libpolkit-qt5-1-1 libpoppler-qt5-1 libqca-qt5-2 libqmobipocket2
  libqt5script5 libqt5texttospeech5 libqt5xml5 libsignon-qt5-1 okular
  phonon4qt5 phonon4qt5-backend-vlc qml-module-org-kde-kquickcontrolsaddons
  qml-module-ubuntu-onlineaccounts
0 mis à jour, 98 nouvellement installés, 0 à enlever et 5 non mis à jour.
Il est nécessaire de prendre 18,9 Mo dans les archives.
Après cette opération, 100 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] 

Il n'y a pas trop de paquets recommandés donc du coup cela fait encore pas mal de paquets a installer

Hors ligne