Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 14/09/2018, à 11:22

ManuC

[RESOLU] Freeze sur install Asus UX580GD

Bonjour.

Je souhaite installer Ubuntu sur mon nouvel ordinateur Asus UX580GD en dual boot avec win10.

J'ai donc réservé la moitié du HDD pour une partition linux.
J'installe à partir d'une clé USB, qui a déjà fonctionnée sur d'autres machines
Malheureusement, cela freeze dans les premières dizaines de seconde, que ce soit en install UBUNTU (j'arrive une fois sur deux au menu du choix de la langue, puis freeze) ou en "try ubuntu without installing". j'ai la souris qui peut encore se deplacer mais plus rien n'est "clickable"...

Je tiens à préciser que je suis novice dans linux/ubuntu mais je souhaite vraiment à démarrer l'apprentissage de ce systeme.
Y aurait il une bonne ame pour me guider?
C'est peut etre un probleme de carte graphique (nvidia gtx 1050), mais il n'est pas possible de la desactiver dans l'uefi pour la remplacer par l'intel.
Au plaisir de vous lire.

Manu

Dernière modification par ManuC (Le 17/09/2018, à 08:22)

Hors ligne

#2 Le 14/09/2018, à 11:31

NicoApi73

Re : [RESOLU] Freeze sur install Asus UX580GD

Bonjour,

Ta carte graphique est très mal prise en charge par le driver libre nouveau. Il faut installer le driver propriétaire nVidia. Pour pouvoir booter, il faut passer un paramètre au kernel. Comme tu es en dual boot, grub s'affiche pour te permettre de choisir ubuntu ou windows. A ce moment là, tu appuies sur la lettre e

- descendre avec les touches (curseur) jusqu'à tomber sur

Linux          /boot/vmlinuz.efi...

- avec le curseur, le déplacer pour le mettre après splash.
- écrire "modprobe.blacklist=nouveau" entre splash et la fin ($), avec un espace après splash. Remarque, il n'y a aucun espace dans modprobe.blacklist=nouveau (quand le clavier est un clavier AZERTY il faut taper ,odprobe:blqcklist=nouvequ pour que s'affiche modprobe.blacklist=nouveau)
- Bien vérifier que c'est modprobe.blacklist=nouveau qui s'affiche
- valider par F10

Une fois que tu as booté, tu vas dans Gestionnaire de mise à jour, Paramètres, Pilotes additionnels et tu sélectionnes le driver nVidia (probablement le 390)

Tu rebootes normalement et ça devrait fonctionner.

Ensuite ouvre un shell (terminal) et donne le retour de la commande suivante (entre balises code) :

dmesg -lerr

On va regarder ce que remonte le noyau comme erreur. Certaines sont sans importance, d'autres nécessitent d'être corrigées ou masquées.

Dernière modification par NicoApi73 (Le 14/09/2018, à 11:34)

Hors ligne

#3 Le 14/09/2018, à 11:34

Mornagest

Re : [RESOLU] Freeze sur install Asus UX580GD

Salut,

C'est en effet peut-être lié à ta carte. Il y a moyen de la désactiver (tout en gardant quand même l'affichage de base tongue), même durant l'installation : https://doc.ubuntu-fr.org/kernel#modifi … ssion-live

Tu choisis donc Autre (en faisant F6) et tu devrais arriver sur le menu GRUB. Là, tu édites l'entrée en appuyant sur "e". Dans la série des lignes que tu vois, cherche $vt_handoff

Le paramètre que tu dois ajouter juste avant $vt_handoff est acpi=off (attention, ton clavier sera très probablement en qwerty, vérifie bien ce qui s'affiche).

Enfin, tu démarres avec la touche F10 et le programme d'installation devrait s'afficher smile

edit @ Nico :  je crois que l'installation n'est pas encore effectuée (ou alors, j'ai mal compris ?).

Dernière modification par Mornagest (Le 14/09/2018, à 11:35)

Hors ligne

#4 Le 14/09/2018, à 11:54

NicoApi73

Re : [RESOLU] Freeze sur install Asus UX580GD

Au temps pour moi, tu as raison Mornagest, j'avais mal compris.

F6, c'est pour une installation en legacy. Je pense qu'il va être en UEFI, il peut appuyer sur e dès que grub lui propose le choix entre l'installation et try without installing.

@ManuC :
Il y a plusieurs paramètres possibles :
- acpi=off arrête un certain nombre de services acpi. C'est assez général, permet souvent de démarrer et a parfois des effets de bord sur d'autres Entrée.sortie, comme le clavier
- modprobe.blacklist=nouveau empêche le driver nouveau de se charger. C'est très ciblé et s'il y a autre chose qui bloque, ça ne le traite pas.
- il y a d'autres paramètres possibles

Hors ligne

#5 Le 14/09/2018, à 11:56

Mornagest

Re : [RESOLU] Freeze sur install Asus UX580GD

D'un autre côté, tu as raison aussi tongue blacklister Nouveau seul peut suffire, plutôt que l'artillerie lourde.

Hors ligne

#6 Le 14/09/2018, à 12:16

ManuC

Re : [RESOLU] Freeze sur install Asus UX580GD

Merci à tous pour vos réponses, je regarde et essaye ce que vous proposez et je reviens vers vous.
Manu

Hors ligne

#7 Le 14/09/2018, à 15:16

ManuC

Re : [RESOLU] Freeze sur install Asus UX580GD

Merci beaucoup pour votre réactivité.
Grace à vos deux post/méthode, j'ai enfin réussi à booter ubuntu...
Je n'ai pas fait acpi=off, seulement modprobe.blacklist=nouveau et ca a suffit.
J'ai ensuite suivi le post @nikoApi73 et c'est ok.

Voici

xxxxxxxx@xxxxxxxx:~$ dmesg -lerr
[    0.064165] ACPI Error: [_SB_.PCI0.RP05.PXSX] Namespace lookup failure, AE_NOT_FOUND (20170831/dswload2-191)
[    0.064172] ACPI Exception: AE_NOT_FOUND, During name lookup/catalog (20170831/psobject-252)
[    0.064174] ACPI Error: Method parse/execution failed \_SB.PCI0.RP04.PXSX, AE_NOT_FOUND (20170831/psparse-550)
[    0.065572] ACPI Error: [_SB_.PCI0.RP09.PXSX] Namespace lookup failure, AE_NOT_FOUND (20170831/dswload2-191)
[    0.065577] ACPI Exception: AE_NOT_FOUND, During name lookup/catalog (20170831/psobject-252)
[    0.065578] ACPI Error: Method parse/execution failed \_SB.PCI0.RP08.PXSX, AE_NOT_FOUND (20170831/psparse-550)
[    0.066974] ACPI Error: [_SB_.PCI0.RP13.PXSX] Namespace lookup failure, AE_NOT_FOUND (20170831/dswload2-191)
[    0.066978] ACPI Exception: AE_NOT_FOUND, During name lookup/catalog (20170831/psobject-252)
[    0.066980] ACPI Error: Method parse/execution failed \_SB.PCI0.RP12.PXSX, AE_NOT_FOUND (20170831/psparse-550)
[    0.865068] tpm tpm0: A TPM error (378) occurred get tpm pcr allocation
[    0.931129] Couldn't get size: 0x800000000000000e
[    1.581826] PKCS#7 signature not signed with a trusted key
[    1.595277] PKCS#7 signature not signed with a trusted key
[    1.596772] PKCS#7 signature not signed with a trusted key
[    2.642885] PKCS#7 signature not signed with a trusted key
[    2.730326] genirq: Setting trigger mode 2 for irq 128 failed (intel_gpio_irq_type+0x0/0x140)
[    2.936996] i2c_hid i2c-GDX1505:00: failed to change power setting.
[    3.297403] genirq: Setting trigger mode 1 for irq 145 failed (intel_gpio_irq_type+0x0/0x140)
[    3.604176] i2c_hid i2c-GDX1505:00: failed to change power setting.
[    3.636100] i2c_hid i2c-GDX1505:00: failed to change power setting.
[    6.108556] xhci_hcd 0000:3a:00.0: xHCI host controller not responding, assume dead
[   31.936363] i2c_hid i2c-GDX1505:00: failed to change power setting.
[   57.587545] xhci_hcd 0000:3a:00.0: xHCI host controller not responding, assume dead

Si vous voyez un soucis...:)
Encore merci.

Question subsidiaire, je voudrais crypter ma partition linux, le plus simple me semble t il est de recommencer l'install et de crypter. Mais y a t il une solution simple pour crypter une partition sans reinstall ??
Bonne journée.
Manu

Dernière modification par ManuC (Le 14/09/2018, à 16:38)

Hors ligne

#8 Le 14/09/2018, à 15:46

Mornagest

Re : [RESOLU] Freeze sur install Asus UX580GD

Pour le chiffrage de ta partition, je ne suis pas sûr que ce soit possible de le faire après coup. À confirmer !

Au niveau de ton installation, tu as donc installé les pilotes nVidia avec les pilotes additionnels ? As-tu redémarré la machine depuis ?

Hors ligne

#9 Le 14/09/2018, à 15:47

NicoApi73

Re : [RESOLU] Freeze sur install Asus UX580GD

Je te déconseille de crypter ta partition, sauf besoin spécifique. En cas de problème, c'est difficile d'intervenir. Pose toi bien la question à quel besoin tu veux répondre avant de crypter!

Tu as une série d'erreur non critique relative à l'USB. Le tpm c'est du classique... Aucune erreur qui à première vue me choque wink

Hors ligne

#10 Le 14/09/2018, à 15:48

NicoApi73

Re : [RESOLU] Freeze sur install Asus UX580GD

@Mornagest : cette fois-ci c'est moi, à 1 minutes près...:P

Dernière modification par NicoApi73 (Le 14/09/2018, à 15:48)

Hors ligne

#11 Le 14/09/2018, à 15:50

Mornagest

Re : [RESOLU] Freeze sur install Asus UX580GD

big_smile

Sur mon portable, j'ai chiffré mes données, honnêtement... ça n'a pas beaucoup d'intérêt. Sauf bien sûr si tu travailles sur des plans de centrales nucléaires, un programme de parti ou ce genre de choses tongue

Ce qui est bien plus utile, c'est d'avoir des sauvegardes sûres sur disques durs externes. Parce qu'un disque dur, c'est loin d'être éternel...

Hors ligne

#12 Le 14/09/2018, à 16:25

ManuC

Re : [RESOLU] Freeze sur install Asus UX580GD

oui j'ai bien redémarré, tout est ok maintenant.
je n'ai juste pas le pad, donc souris externe avant de trouver la solution.

J'ai réussi à crypter ma partition ubuntu ( j'ai crée un /boot sur une partition non cryptée de 512MO, puis une partition avec un volume crypté en / ).
L'uefi gère bien l'histoire, et j'ai bien mes deux systèmes win 10 et ubuntu au démarrage. ca tourne nickel !!
Un vraiment grand merci à vous.

C'est une obligation professionnelle le cryptage, je m'en serai bien passé sinon...

Allez je me lance dans l'histoire du pad
Bonne fin de journée.
Manu

Hors ligne

#13 Le 14/09/2018, à 16:27

xubu1957

Re : [RESOLU] Freeze sur install Asus UX580GD

Bonjour,

Pour ajouter toi-même les balises code à ton précédent message #7 :            Merci             wink

  • Cliquer sur  le lien « Modifier » en bas à droite du message

  • Sélectionner le texte

  • Cliquer sur le <> de l'éditeur de message

1535555994.png

comme indiqué dans le : Retour utilisable de commande

Dernière modification par xubu1957 (Le 18/09/2018, à 18:27)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne