Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#151 Le 25/09/2018, à 09:44

xubu1957

Re : {Résolu}Bugs depuis mercredi 04 juillet TBI Promethean Activinspire

Bonjour,

@moko138

Le système avait été nettoyé :

#54, le 25/08/2018,fwehrli a écrit :
utilisateyur@utilisateyur-Aspire-E5-575:~$ echo; dpkg -l | grep -Ei "linux-(g|h|i|lo|si|t)" | grep -v ^rc | sort -k3 | tr -s " " | cut -d" " -s -f1,2,3,4 | column -s" " -t ; echo ; uname -mr

ii  linux-headers-4.13.0-45              4.13.0-45.50~16.04.1  all
ii  linux-image-extra-4.13.0-45-generic  4.13.0-45.50~16.04.1  amd64
ii  linux-headers-4.13.0-45-generic      4.13.0-45.50~16.04.1  amd64
ii  linux-image-4.13.0-45-generic        4.13.0-45.50~16.04.1  amd64
ii  linux-headers-4.15.0-24              4.15.0-24.26~16.04.1  all
ii  linux-headers-4.15.0-24-generic      4.15.0-24.26~16.04.1  amd64
ii  linux-image-4.15.0-24-generic        4.15.0-24.26~16.04.1  amd64
ii  linux-headers-4.15.0-33              4.15.0-33.36~16.04.1  all
ii  linux-headers-4.15.0-33-generic      4.15.0-33.36~16.04.1  amd64
ii  linux-image-4.15.0-33-generic        4.15.0-33.36~16.04.1  amd64
ii  linux-generic-hwe-16.04              4.15.0.33.55          amd64
ii  linux-headers-generic-hwe-16.04      4.15.0.33.55          amd64
ii  linux-image-generic-hwe-16.04        4.15.0.33.55          amd64

4.15.0-33-generic x86_64
utilisateyur@utilisateyur-Aspire-E5-575:~$ 

Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#152 Le 25/09/2018, à 10:55

moko138

Re : {Résolu}Bugs depuis mercredi 04 juillet TBI Promethean Activinspire

xubu1957,
Tu oublies le  | grep -v ^rc ("sauf les paquets "rc"), bien utile dans un 1er temps pour aller à l'essentiel. Et qu'on voit dans le message que tu cites https://forum.edubuntu-fr.org/viewtopic … #p21959861


%NOINDEX%
Un utilitaire précieux : ncdu
Photo, mini-tutoriel :  À la découverte de dcraw

En ligne

#153 Le 25/09/2018, à 11:52

fwehrli

Re : {Résolu}Bugs depuis mercredi 04 juillet TBI Promethean Activinspire

Désolé j'avais fait les deux redémarrages mais je n'avais plus internet (problème de ligne car sur windows ça ne fonctionnait pas non plus). Tout fonctionne à nouveau sur le noyau 4.13.
Comme prévu sur le 4.15 le tbi n'est pas détecté... Promothean pas à jour depuis juin

Sur le noyau 4.15 voici le résultat:

utilisateyur@utilisateyur-Aspire-E5-575:~$ uname -mr
4.15.0-34-generic x86_64
utilisateyur@utilisateyur-Aspire-E5-575:~$ 

Sur le noyau 4.13:

utilisateyur@utilisateyur-Aspire-E5-575:~$ uname -mr
4.13.0-45-generic x86_64
utilisateyur@utilisateyur-Aspire-E5-575:~$ 

Hors ligne

#154 Le 25/09/2018, à 11:56

fwehrli

Re : {Résolu}Bugs depuis mercredi 04 juillet TBI Promethean Activinspire

Tout semble fonctionner comme avant. Du coup il vaut mieux que je ne fasse plus de mises à jour (du noyau Linux) tant que Promothean n'est pas à jour pour le 4.15?
Si non je risque de perdre l'accès au 4.13 et d'être dans la panade.
Merci pour votre aide à tous en tous cas.

Hors ligne

#155 Le 25/09/2018, à 12:41

moko138

Re : {Résolu}Bugs depuis mercredi 04 juillet TBI Promethean Activinspire

fwehrli a écrit :

Tout semble fonctionner comme avant.

smile

Du coup il vaut mieux que je ne fasse plus de mises à jour (du noyau Linux) tant que Promothean n'est pas à jour pour le 4.15?
Si non je risque de perdre l'accès au 4.13 et d'être dans la panade.

Au contraire ! Fais toutes tes mises à jour soigneusement :
     pour la sécurité,
     et pour les pilotes
(améliorés ou nouveaux).

Et relis :

ces erreurs, donc, résultent clairement de mon chattr +i (immuable) manifestement intempestif.
Donc nous le défaisons partiellement ! Option -i (au lieu de +i précédemment)
mais en laissant l'option +u (indestructible) :

cd /boot && sudo chattr -i  abi-4.13.0-45-generic  config-4.13.0-45-generic  initrd.img-4.13.0-45-generic  retpoline-4.13.0-45-generic  System.map-4.13.0-45-generic  vmlinuz-4.13.0-45-generic

Donc tu pourras toujours démarrer sur ton 4.13.0-45.  smile
Tu peux même recommencer à faire des

sudo apt-get clean ; sudo apt-get autoremove

en nettoyage hebdomadaire !


Et le jour où tu n'auras plus besoin du noyau 4.13, il suffira de retirer l'attribut "u" (undeletable) comme nous avons retiré l'attribut "i" ce matin.  smile


%NOINDEX%
Un utilitaire précieux : ncdu
Photo, mini-tutoriel :  À la découverte de dcraw

En ligne

#156 Le 25/09/2018, à 13:00

fwehrli

Re : {Résolu}Bugs depuis mercredi 04 juillet TBI Promethean Activinspire

Super merci encore à tous!

Hors ligne

#157 Le 25/09/2018, à 14:38

moko138

Re : {Résolu}Bugs depuis mercredi 04 juillet TBI Promethean Activinspire

Pour ceux qui viendront...

Le problème :
le tbi (tableau blanc interactif) n'était plus reconnu quand la 16.04-hwe a intégré le noyau 4.15.


La solution :
télécharger et sauvegarder dans un répertoire spécifique les paquets du noyau 4.13.0-45 :

mkdir ~/sauv-noyau-413 ; cd ~/sauv-noyau-413 && apt-get download  linux-headers-4.13.0-45  linux-image-extra-4.13.0-45-generic  linux-headers-4.13.0-45-generic  linux-image-4.13.0-45-generic ; ls

Réinstaller ces paquets :

cd ~/sauv-noyau-413 && sudo dpkg -i *.deb

Mettre à jour l'image de démarrage avec 4.13.0-45 :

sudo update-initramfs -u -k 4.13.0-45-generic

Conférer l'attribut "indestructible" aux fichiers "4.13.0-45" contenus dans /boot/ :

cd /boot && sudo chattr +u $(ls /boot | grep "4.13.0-45")

Reprendre le cours normal des nettoyages et des mises à jour.


Démarrer sur le noyau 4.13 (par les options avancées de grub), sauf quand un nouveau noyau 4.15 vient d'être installé et qu'on désire voir s'il prend enfin en charge le "tbi".

= =

Se rappeler que le jour où on n'aura plus besoin du noyau 4.13 - et pas avant ce jour-là ! - il faudra, pour pouvoir désinstaller ce noyau, retirer l'attribut "u" (undeletable) :

cd /boot && sudo chattr -u $(ls /boot | grep "4.13.0-45")

= =

fwehrli,
Afin de faciliter l'accès à ton fil via les moteurs de recherche, par tes compagnons d'infortune, si d'ici quelques jours, aucun imprévu n'est venu ternir cette solution, pense à noter [Résolu] en tête du titre, en éditant ton premier message. Et à inclure aussi TBI, voire promethean, dans le titre !

Dernière modification par moko138 (Le 25/09/2018, à 14:45)


%NOINDEX%
Un utilitaire précieux : ncdu
Photo, mini-tutoriel :  À la découverte de dcraw

En ligne

#158 Le 05/11/2018, à 08:20

moko138

Re : {Résolu}Bugs depuis mercredi 04 juillet TBI Promethean Activinspire

bibi a écrit :

fwehrli,
Afin de faciliter l'accès à ton fil via les moteurs de recherche, par tes compagnons d'infortune, (...), pense (...) en éditant ton premier message (...) à inclure (...) promethean, dans le titre !

Donc promEthean, dans le titre.
Merci !


%NOINDEX%
Un utilitaire précieux : ncdu
Photo, mini-tutoriel :  À la découverte de dcraw

En ligne

#159 Le 29/11/2019, à 09:11

fwehrli

Re : {Résolu}Bugs depuis mercredi 04 juillet TBI Promethean Activinspire

Bonjour,
J'ai testé le noyau 4.18 avec le tbi sur un ordinateur cobaye. Le tableau interactif est détecté. Je vais pouvoir faire ma mise à niveau d'ubuntu 16 à 18 en déclarant le noyau 4.18 ou 4.15 comme immortel.
Est-ce qu'il faut enlever la déclaration du noyau 4.13 comme immortel avant la mise à niveau ou la mise à niveau le détruira tout de même?
Merci d'avance

Hors ligne

#160 Le 29/11/2019, à 11:26

moko138

Re : {Résolu}Bugs depuis mercredi 04 juillet TBI Promethean Activinspire

Hum...
La mise à niveau ne détruira pas ton 4.13.0-45.
Mais
1) Ton test est insuffisant. Car la 18.04.1 garde un noyau 4.15 qui ne supporte pas ton TBI.
Et les 18.04 hwe ont dépassé le 4.18, elles en sont au noyau 5.0 ( et même 5.3 pour les 18.04 hwe-edge).
  En général, les drivers inclus dans un noyau de rang supérieur y restent, mais il y a quelques cas de régression.

2) D'autre part j'ignore si une 18.04 sera irréprochable avec un noyau de 15.10...

Je crois donc que, si tu veux une certitude,
tu as besoin sur le pc cobaye, de tester ou la 19.10 ou la 18.04 hwe redémarrée après une mise à jour complète.


%NOINDEX%
Un utilitaire précieux : ncdu
Photo, mini-tutoriel :  À la découverte de dcraw

En ligne

#161 Le 29/11/2019, à 12:28

fwehrli

Re : {Résolu}Bugs depuis mercredi 04 juillet TBI Promethean Activinspire

Sur l'ordi que j'ai testé c'est un noyau 5.0 qui est installé. J'ai installé le noyau 4.18 en plus pour démarrer dessus.
Est-ce qu'il ne faudrait pas mieux que je reste avec un ubuntu 16.04 et que je passe au noyau 4.15 (qui est LTS) à la place du 4.13?
Ou je tente quand même une mise à niveau vers une 18.04, puis j'installe le noyau 4.18?
Merci d'avance.

Hors ligne

#162 Le 29/11/2019, à 14:59

moko138

Re : {Résolu}Bugs depuis mercredi 04 juillet TBI Promethean Activinspire

Tu as déjà testé des noyaux 4.15.
Tu peux toujours réessayer avec le plus récent.

Mais comme

Sur l'ordi que j'ai testé c'est un noyau 5.0 qui est installé.

oublie le 4.18 qui n'est sans doute déjà plus maintenu, laisse faire les mises à jour d'une 18.04.2 et tu te retrouveras avec un noyau 5.0.0.nn, opérationnel.  smile
Et bientôt un noyau 5.3.0.pp, qui le sera très probablement aussi.


%NOINDEX%
Un utilitaire précieux : ncdu
Photo, mini-tutoriel :  À la découverte de dcraw

En ligne

#163 Le 29/11/2019, à 15:08

fwehrli

Re : {Résolu}Bugs depuis mercredi 04 juillet TBI Promethean Activinspire

Je ne peux pas installer le noyau 5 car le tableau ne sera pas détecté et je ne pourrai pas utiliser le stylet. Il a déjà fallu attendre presque 2 ans pour que le noyau 4.15 soit compatible...

Hors ligne

#164 Le 29/11/2019, à 15:34

moko138

Re : {Résolu}Bugs depuis mercredi 04 juillet TBI Promethean Activinspire

Je ne peux pas installer le noyau 5 car le tableau ne sera pas détecté.

As-tu essayé après les mises à jour complètes

sudo apt-get update 

puis

sudo apt-get dist-upgrade -y

d'une 18.04.2, suivies d'un redémarrage ?


%NOINDEX%
Un utilitaire précieux : ncdu
Photo, mini-tutoriel :  À la découverte de dcraw

En ligne

#165 Le 29/11/2019, à 16:23

fwehrli

Re : {Résolu}Bugs depuis mercredi 04 juillet TBI Promethean Activinspire

Oui c'est confirmé, j'ai essayé et Promethean me l'a confirmé également. Le driver est compatible avec le 4.18.25 pas plus.

Hors ligne

#166 Le 02/12/2019, à 09:42

fwehrli

Re : {Résolu}Bugs depuis mercredi 04 juillet TBI Promethean Activinspire

Bonjour,
Je souhaiterais enlever l'attribut indestructible au noyau 4.13 pour aller vers un 4.15 sur mon ubuntu 16.04 lts afin que les mises à jour se fassent naturellement sans forcer un noyau qui ne serait pas compatible.
D'après le #139 , il faut que je fasse:

sudo update-initramfs  -k 4.13.0-45-generic

Est-ce qu'il y a autre chose à faire à part des mises à jour ensuite svp?
Merci d'avance.

Dernière modification par fwehrli (Le 02/12/2019, à 09:42)

Hors ligne

#167 Le 02/12/2019, à 16:44

fwehrli

Re : {Résolu}Bugs depuis mercredi 04 juillet TBI Promethean Activinspire

Je viens de faire ceci pour rendre mon noyau 4.13.45 destructible:

cd /boot && sudo chattr -u $(ls /boot | grep "4.13.0-45")

Est-ce qu'il faut que je fasse quelque chose pour que les mises à jour se fassent vers un noyau 4.15 svp?
J'ai toujours la proposition de mise à niveau vers 4.18.3, j'ai peur si je fais cette mise à niveau d'avoir un noyau 5 et il n'est pas compatible pour le moment avec mon tableau interactif.
Il ne faut pas que j'ai un noyau postérieur à 4.18.0.25. C'est pour ça que je pense rester sur une 16.04 avec un noyau 4.15, qu'en pensez-vous?
Merci d'avance.

Hors ligne

#168 Le 02/12/2019, à 16:45

fwehrli

Re : {Résolu}Bugs depuis mercredi 04 juillet TBI Promethean Activinspire

Après 2 redémarrage, voilà ce que ça donne du côté de mon noyau:

wehrli@wehrli-Aspire-E5-575:~$ echo; dpkg -l | grep -Ei "linux-(g|h|i|lo|si|t)" | sort -k3 | tr -s " " | cut -d" " -s -f1,2,3,4 | column -s" " -t ; echo ; uname -mrs

ii  linux-headers-4.13.0-45              4.13.0-45.50~16.04.1  all
ii  linux-image-extra-4.13.0-45-generic  4.13.0-45.50~16.04.1  amd64
ii  linux-headers-4.13.0-45-generic      4.13.0-45.50~16.04.1  amd64
ii  linux-image-4.13.0-45-generic        4.13.0-45.50~16.04.1  amd64
rc  linux-image-extra-4.4.0-137-generic  4.4.0-137.163         amd64
rc  linux-image-4.4.0-137-generic        4.4.0-137.163         amd64
rc  linux-image-extra-4.4.0-138-generic  4.4.0-138.164         amd64
rc  linux-image-4.4.0-138-generic        4.4.0-138.164         amd64
rc  linux-image-extra-4.4.0-139-generic  4.4.0-139.165         amd64
rc  linux-image-4.4.0-139-generic        4.4.0-139.165         amd64
rc  linux-image-extra-4.4.0-140-generic  4.4.0-140.166         amd64
rc  linux-image-4.4.0-140-generic        4.4.0-140.166         amd64
rc  linux-image-extra-4.4.0-141-generic  4.4.0-141.167         amd64
rc  linux-image-4.4.0-141-generic        4.4.0-141.167         amd64
rc  linux-image-extra-4.4.0-142-generic  4.4.0-142.168         amd64
rc  linux-image-4.4.0-142-generic        4.4.0-142.168         amd64
rc  linux-image-4.4.0-143-generic        4.4.0-143.169         amd64
rc  linux-image-4.4.0-145-generic        4.4.0-145.171         amd64
rc  linux-image-4.4.0-146-generic        4.4.0-146.172         amd64
rc  linux-image-4.4.0-148-generic        4.4.0-148.174         amd64
rc  linux-image-4.4.0-150-generic        4.4.0-150.176         amd64
rc  linux-image-4.4.0-151-generic        4.4.0-151.178         amd64
rc  linux-image-4.4.0-154-generic        4.4.0-154.181         amd64
rc  linux-image-4.4.0-159-generic        4.4.0-159.187         amd64
rc  linux-image-4.4.0-161-generic        4.4.0-161.189         amd64
rc  linux-image-4.4.0-164-generic        4.4.0-164.192         amd64
rc  linux-image-4.4.0-165-generic        4.4.0-165.193         amd64
rc  linux-image-4.4.0-166-generic        4.4.0-166.195         amd64
ii  linux-generic                        4.4.0.169.177         amd64
ii  linux-headers-generic                4.4.0.169.177         amd64
ii  linux-image-generic                  4.4.0.169.177         amd64
ii  linux-headers-4.4.0-169              4.4.0-169.198         all
ii  linux-headers-4.4.0-169-generic      4.4.0-169.198         amd64
ii  linux-image-4.4.0-169-generic        4.4.0-169.198         amd64
rc  linux-image-extra-4.4.0-31-generic   4.4.0-31.50           amd64
rc  linux-image-4.4.0-31-generic         4.4.0-31.50           amd64

Linux 4.13.0-45-generic x86_64
wehrli@wehrli-Aspire-E5-575:~$ 

Hors ligne

#169 Le 02/12/2019, à 16:47

xubu1957

Re : {Résolu}Bugs depuis mercredi 04 juillet TBI Promethean Activinspire

Bonjour,

Attends les conseils de moko138, il se peut que sa connexion faiblarde soit actuellement HS.


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#170 Le 02/12/2019, à 17:15

fwehrli

Re : {Résolu}Bugs depuis mercredi 04 juillet TBI Promethean Activinspire

OK je ne ferai rien sans avis ni sans être sûr du résultat. Merci

Hors ligne

#171 Le 02/12/2019, à 17:48

moko138

Re : {Résolu}Bugs depuis mercredi 04 juillet TBI Promethean Activinspire

Je suis rentré, mais laissez-moi le temps
- de renouer les fils ;
- de poser quelques questions.


%NOINDEX%
Un utilitaire précieux : ncdu
Photo, mini-tutoriel :  À la découverte de dcraw

En ligne

#172 Le 02/12/2019, à 19:12

moko138

Re : {Résolu}Bugs depuis mercredi 04 juillet TBI Promethean Activinspire

Je viens de faire ceci pour rendre mon noyau 4.13.45 destructible:

cd /boot && sudo chattr -u $(ls /boot | grep "4.13.0-45")

Opération actuellement nuisible (et d'ailleurs contraire à ce que j'avais clairement écrit en #157(*)).
Refais un +u pendant qu'il est temps.

  - -

Promethean me l'a confirmé. Le driver est compatible avec le 4.18.25 pas plus

Bon à savoir. Mais le 4.18 n'est plus maintenu (bis).
En cas de besoin, je pense que xubu1957 sait comment aller le chercher ;
xubu, le confirmes-tu ?

  - -

Il a déjà fallu attendre presque 2 ans pour que le noyau 4.15 soit compatible....

Donc il existerait un nouveau noyau 4.15.0-xx compatible avec ton TBI ??!
Le(s)quel(s) ?    Merci de partager l'info.
À tester ! Ce serait le mieux pour toi (installation d'une 18.04.1, maintenue jusqu'en 2023).

Si aucun 4.15 n'est compatible, il faudra
  soit le statu quo ;
  soit installer une 18.04.2 et
     > rendre indestructible le 4.18.0-25 (si Promethean et toi parlez bien de ce noyau !)
     > bloquer les mises à jour automatiques,
     > faire des mises à jour manuelles en évitant
                - les apt full-upgrade
                - et les apt-get dist-upgrade

  - -
Montre :

sudo lsblk -o name,fstype,size,label,mountpoint | grep -Ev "loop|sr[0-9]"
echo; df -Thx tmpfs -x devtmpfs -x squashfs
sudo parted -l

= =

  Dans tous les cas, au lieu d'écraser ta 16.04 opérationnelle ou (pire) de prendre le risque de la casser, il me semble judicieux de faire une installation fraîche de ton futur S.E. à côté de ta 16.04. (Comme toujours, d'ailleurs).


___
(*) EDIT du 3/12/2019 :
#157 = ./viewtopic.php?pid=21978525#p21978525
Et orthographe.

Dernière modification par moko138 (Le 03/12/2019, à 12:47)


%NOINDEX%
Un utilitaire précieux : ncdu
Photo, mini-tutoriel :  À la découverte de dcraw

En ligne

#173 Le 02/12/2019, à 19:26

xubu1957

Re : {Résolu}Bugs depuis mercredi 04 juillet TBI Promethean Activinspire


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#174 Le 03/12/2019, à 00:29

moko138

Re : {Résolu}Bugs depuis mercredi 04 juillet TBI Promethean Activinspire

Bravo xubu !

Et aussi :
https://packages.ubuntu.com/bionic-upda … -4.18.0-25
https://packages.ubuntu.com/bionic-upda … 25-generic

  - -
linux-image-extra-4.18.0-25-generic n'existe-t-il pas ?


%NOINDEX%
Un utilitaire précieux : ncdu
Photo, mini-tutoriel :  À la découverte de dcraw

En ligne

#175 Le 03/12/2019, à 08:16

xubu1957

Re : {Résolu}Bugs depuis mercredi 04 juillet TBI Promethean Activinspire


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne