Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 03/10/2018, à 17:49

arzavapi

Temps de démarrage long avec 18.04 LTS + carte graphique [Résolu]

Bonjour

Je possède un MSI Intel® Pentium(R) CPU 3560M @ 2.40GHz × 2 avec 3,8 gigas de mémoire vive
Je suis sous Ubuntu 18.04 LTS

Je trouve que mon temps de démarrage -écran violet pendant plus de 30 secondes- est long.
Est-ce dû à la configuration de mon ordi (manque de mémoire vive ?)

En faisant cette commande

systemd-analyze

voici ce que j'obtiens :

~$ systemd-analyze
Startup finished in 3.921s (kernel) + 37.774s (userspace) = 41.695s
graphical.target reached after 37.767s in userspace

Que veut dire "userspace" ?
Est ce normal la carte graphique qui démarre seulement au bout de 38 secondes ?

Merci de vos réponses smile

Dernière modification par arzavapi (Le 04/10/2018, à 15:58)

Hors ligne

#2 Le 03/10/2018, à 18:49

Mornagest

Re : Temps de démarrage long avec 18.04 LTS + carte graphique [Résolu]

Salut,

Ce n'est pas la carte graphique qui s'allume après ce temps, mais bien l'interface graphique. Si tout se passe bien, ton matériel est allumé strictement au moment où tu appuies sur le bouton d'allumage de ton ordinateur.

Tu as un HDD ou un SSD ? Si tu as un HDD, 40 secondes n'est pas énorme pour un démarrage.

Que donne systemd-analyze blame ? Il y a sûrement moyen de supprimer un ou deux services inutiles dans ton cas.


N'oubliez pas de consulter la documentation pour vous donner un coup de main !
Merci de modifier le premier message de votre sujet pour ajouter [Résolu] lorsque votre problème l'est :)
Xubuntu 18.04.1 sur trois ordinateurs, zéro souci. Passez à Xubuntu ;)

En ligne

#3 Le 03/10/2018, à 21:17

arzavapi

Re : Temps de démarrage long avec 18.04 LTS + carte graphique [Résolu]

Merci de votre réponse

J'ai un HDD -que je peux d'ailleurs démonter, pour insérer un HDD, il y a le branchement je crois-

réponse à la commande :

~$ systemd-analyze blame
         20.831s dev-sda1.device
         19.898s systemd-journal-flush.service
         15.870s keyboard-setup.service
         12.081s systemd-udevd.service
         11.019s systemd-sysctl.service
          9.470s NetworkManager-wait-online.service
          9.181s plymouth-quit-wait.service
          5.558s snapd.service
          4.518s plymouth-start.service
          4.487s networkd-dispatcher.service
          3.562s udisks2.service
          3.348s grub-common.service
          3.051s NetworkManager.service
          2.311s thermald.service
          2.127s ModemManager.service
          2.100s accounts-daemon.service
          1.984s systemd-tmpfiles-setup-dev.service
          1.562s systemd-modules-load.service
          1.354s avahi-daemon.service
          1.039s apparmor.service
           933ms fwupd.service
           880ms wpa_supplicant.service
           868ms snap-gnome\x2dcalculator-222.mount

Quelque chose de trop long ?

Dernière modification par arzavapi (Le 03/10/2018, à 21:18)

Hors ligne

#4 Le 04/10/2018, à 10:03

Mornagest

Re : Temps de démarrage long avec 18.04 LTS + carte graphique [Résolu]

Rien de très choquant, pour un HDD classique en tout cas. Tu peux gagner un peu de temps en désactivant le service NetworkManager-wait-online.service qui est inutile si tu te connectes classiquement au réseau (câble Ethernet, wi-fi...) : sudo systemctl disable NetworkManager-wait-online.service

Personnellement, je n'utilise pas snapd donc je le désactive également (même procédure : sudo systemctl disable snapd mais c'est toi qui vois si tu t'en sers ou non.

Enfin, je démarre en ligne de commandes (j'ai supprimé quiet splash dans GRUB) et je désactive donc aussi plymouth-start.service.

Mais là, c'est vraiment toi qui vois smile

Dernière modification par Mornagest (Le 04/10/2018, à 13:29)


N'oubliez pas de consulter la documentation pour vous donner un coup de main !
Merci de modifier le premier message de votre sujet pour ajouter [Résolu] lorsque votre problème l'est :)
Xubuntu 18.04.1 sur trois ordinateurs, zéro souci. Passez à Xubuntu ;)

En ligne

#5 Le 04/10/2018, à 13:23

arzavapi

Re : Temps de démarrage long avec 18.04 LTS + carte graphique [Résolu]

Ok Merci beaucoup...

Je n'ai pas réussi à désactiver le service Network manager...

sudo sytemctl disable NetworkManager-wait-online.service
[sudo] Mot de passe de pierre : 
sudo: sytemctl : commande introuvable

Hors ligne

#6 Le 04/10/2018, à 13:29

Mornagest

Re : Temps de démarrage long avec 18.04 LTS + carte graphique [Résolu]

Damned, j'ai fait une faute de frappe, désolé !

C'est sudo systemctl disable NetworkManager-wait-online.service (et pareil pour snapd, j'ai copié-collé la commande pour rédiger mon précédent message ; je corrige !)


N'oubliez pas de consulter la documentation pour vous donner un coup de main !
Merci de modifier le premier message de votre sujet pour ajouter [Résolu] lorsque votre problème l'est :)
Xubuntu 18.04.1 sur trois ordinateurs, zéro souci. Passez à Xubuntu ;)

En ligne

#7 Le 04/10/2018, à 15:57

arzavapi

Re : Temps de démarrage long avec 18.04 LTS + carte graphique [Résolu]

Ok Merci beaucoup smile

Hors ligne