Contenu | Rechercher | Menus

Annonce

T-shirt Seiche Cosmic, Série limitée

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.10
T-shirt Ubuntu-FR « Seiche Cosmique » en série limitée ! Prix spécial pré-vente (15€) jusqu'au 4 novembre 2018.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 04/10/2018, à 13:16

Maedid

[Résolu]Affichage impossible ne fonctionne qu'en mode recovery

Bonjour, depuis deux jours après un redémarrage, je ne peux faire fonctionner mon ordi qu'en mode recovery, sinon les deux écrans n'affichent que des sortes de gros pixel, en mode recovery je n'ai plus accès au taux de rafraîchissement de l'écran. J'ai tenté une réinstallation mais l'écran reste identique en boot usb. Ya t'il une panne quelques part et comment la déceler s'il vous plait. Je ne sais pas quoi faire...

xubuntu
Ubuntu 18.04.1 LTS bionic
AMIBIOS(C)2008 American Megatrends, Inc.                                     
GenuineIntel Intel(R) Core(TM)2 Duo CPU     E4600  @ 2.40GHz

Dernière modification par Maedid (Le 05/10/2018, à 10:02)

Hors ligne

#2 Le 04/10/2018, à 14:21

Mornagest

Re : [Résolu]Affichage impossible ne fonctionne qu'en mode recovery

Salut,

Est-ce qu'en mode recovery, tu as tenté de mettre à jour ton système pour voir s'il ne manque pas quelque chose de simple ?

apt update
apt full-upgrade

(en admettant que ta session recovery soit en root ; sinon, tu ajoutes sudo devant chacune de ces deux commandes).

Ensuite, on va avoir besoin d'informations sur ta carte graphique et ton matériel :

sudo lshw -C video (L minuscule) (même chose pour la session root ou non concernant sudo ou non wink)

Si tu n'as pas de moyen de poster directement le résultat ici, n'hésite pas à prendre quelques photos de la réponse. On n'aura pas toutes les infos, mais ça risque d'être long pour toi si tu demandes sudo lshw seul...


N'oubliez pas de consulter la documentation pour vous donner un coup de main !
Merci de modifier le premier message de votre sujet pour ajouter [Résolu] lorsque votre problème l'est :)
Xubuntu 18.04.1 sur trois ordinateurs, zéro souci. Passez à Xubuntu ;)

En ligne

#3 Le 04/10/2018, à 14:54

Maedid

Re : [Résolu]Affichage impossible ne fonctionne qu'en mode recovery

Bonjour,
J'ai suivi vos instructions

sudo lshw -C video
  *-display NON-RÉCLAMÉ     
       description: VGA compatible controller
       produit: G73 [GeForce 7300 GT]
       fabriquant: NVIDIA Corporation
       identifiant matériel: 0
       information bus: pci@0000:04:00.0
       version: a1
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: pm msi pciexpress vga_controller bus_master cap_list
       configuration: latency=0
       ressources: mémoire:fd000000-fdffffff mémoire:d0000000-dfffffff mémoire:fc000000-fcffffff portE/S:dc00(taille=128) mémoire:c0000-dffff

Identifiant =0 bizarre non?
latency=0 aussi?
Enfin je sais pas ce que cela veux dire...

Dernière modification par Maedid (Le 04/10/2018, à 14:55)

Hors ligne

#4 Le 04/10/2018, à 14:56

Mornagest

Re : [Résolu]Affichage impossible ne fonctionne qu'en mode recovery

Ta carte n'a pas de pilote pour la faire fonctionner, ceci explique cela.

On peut installer les pilotes nVidia en ligne de commandes comme ceci :

ubuntu-drivers autoinstall

Lorsque l'installation sera terminée, redémarre et tu nous dis si la session normale fonctionne et si tu as bien un affichage graphique.


N'oubliez pas de consulter la documentation pour vous donner un coup de main !
Merci de modifier le premier message de votre sujet pour ajouter [Résolu] lorsque votre problème l'est :)
Xubuntu 18.04.1 sur trois ordinateurs, zéro souci. Passez à Xubuntu ;)

En ligne

#5 Le 04/10/2018, à 15:10

ylag

Re : [Résolu]Affichage impossible ne fonctionne qu'en mode recovery

Salut,

Cette carte requiert les pilotes nvidia de série 304 qui ne sont plus disponibles dans la 18.04. Si le pilote nouveau ne la supporte pas convenablement, il faudra peut-être retourner sur la 16.04, dans laquelle les pilotes nvidia-304 sont encore installables ?

Si ça démarre bien en mode recovery, c'est fort probablement que l'option nomodeset est nécessaire dans la ligne de commande du noyau.

A+

Dernière modification par ylag (Le 04/10/2018, à 15:18)

Hors ligne

#6 Le 04/10/2018, à 15:10

Maedid

Re : [Résolu]Affichage impossible ne fonctionne qu'en mode recovery

Est-ce-que je dois allez chercher les pilotes manuellement car ...

sudo ubuntu-drivers autoinstall
No drivers found for automatic installation.

Je vais voir sur le site du constructeur...

Hors ligne

#7 Le 04/10/2018, à 15:24

NicoApi73

Re : [Résolu]Affichage impossible ne fonctionne qu'en mode recovery

Bonjour,

Le 304 n'est plus maintenu du tout, même pour la 16.04 (j'en ai fait l'expérience il y a quelques mois). Cette carte est ancienne, par conséquent nouveau devrait faire l'affaire. (Le doute que j'ai est est ce que nouveau sait gérer les 2 écrans...)

En ligne

#8 Le 04/10/2018, à 15:26

Maedid

Re : [Résolu]Affichage impossible ne fonctionne qu'en mode recovery

J'ai trouvé un fichier deb sur https://packages.debian.org/fr/jessie/n … 4xx-driver

NVIDIA metapackage (304xx legacy version) mais il manque une dépendance libgl1-nvidia-legacy-304xx-glx (=304.137-0~deb8u1)
Le paquet n'existe pas pour Ubuntu 18.04.1 LTS bionic

Hors ligne

#9 Le 04/10/2018, à 15:33

ylag

Re : [Résolu]Affichage impossible ne fonctionne qu'en mode recovery

@NicoApi73

Salut,

Les paquets nvidia-304 sont encore présents dans les dépôts de la 16.04, pourtant. Bien que plus supporté par nvidia, ce pilote devrait pourtant être encore utilisable, sinon les paquets concernés auraient été retiré des dépôts ?

NVIDIA fournit encore un fichier *.run de ces pilotes dans la section "Legacy" du site:
nvidia-304
...resterait à voir si ces pilotes anciens sont encore compatibles avec les noyaux récents de la 18.04?

A+

Dernière modification par ylag (Le 04/10/2018, à 15:36)

Hors ligne

#10 Le 04/10/2018, à 15:34

Mornagest

Re : [Résolu]Affichage impossible ne fonctionne qu'en mode recovery

C'est emm**dant, ce manque de suivi des pilotes pour les versions récentes d'Ubuntu, je trouve hmm

Pour le paquet Debian, je pense que ça va être assez compliqué si tu tombes sur des dépendances en cascade.

Est-ce que Nouveau est installé ? Essaie sudo apt install xserver-xorg-video-nouveau


N'oubliez pas de consulter la documentation pour vous donner un coup de main !
Merci de modifier le premier message de votre sujet pour ajouter [Résolu] lorsque votre problème l'est :)
Xubuntu 18.04.1 sur trois ordinateurs, zéro souci. Passez à Xubuntu ;)

En ligne

#11 Le 04/10/2018, à 15:40

ylag

Re : [Résolu]Affichage impossible ne fonctionne qu'en mode recovery

@Mornagest

Salut,

[HS]L'an prochain, ce sera au tour de la série 340 de se retrouver dans la même situation.[/HS]

A+

Hors ligne

#12 Le 04/10/2018, à 15:46

NicoApi73

Re : [Résolu]Affichage impossible ne fonctionne qu'en mode recovery

Mon expérience :
J'ai fait une mise à jour. (j'ai vu par la suite que le noyau avait été mis à jour)

Au reboot (je reboote toujours, pour vérifier que tout fonctionne), l'écran passe en résolution 1024*768 au lieu de 1920*1080. J'ai cherché un peu et j'ai trouvé (je n'ai pas sauvegardé la référence), que le 304 n'était plus maintenu pour le noyau qui venait de s'installer (série 4.15). J'ai modifié le driver et je suis passé sous nouveau et là plus de problème. Je n'ai pas cherché plus loin wink Je n'ai aucun problème de stabilité et la carte graphique est suffisamment performante pour ce PC.

Dernière modification par NicoApi73 (Le 04/10/2018, à 15:46)

En ligne

#13 Le 04/10/2018, à 15:52

ylag

Re : [Résolu]Affichage impossible ne fonctionne qu'en mode recovery

@NicoApi73

Salut,

+1 pour le pilote nouveau: Je serais fort surpris que la GeForce 7300 GT de @Maedid ne soit pas supportée convenablement par ce dernier...

A+

Hors ligne

#14 Le 04/10/2018, à 20:18

Mornagest

Re : [Résolu]Affichage impossible ne fonctionne qu'en mode recovery

J'utilise les 340 pour une 8400 M, les pilotes Nouveau laissent davantage de saccades que les pilotes proprio. Du coup, ça m'embête de savoir qu'ils seront bientôt trop anciens pour être utilisables... hmm

Bon, je compte garder la 18.04 pendant un moment... ensuite, je passerai peut-être à Debian sur cette machine.

Mais je trouve ça dommage comme politique de rétrocompatibilité.


N'oubliez pas de consulter la documentation pour vous donner un coup de main !
Merci de modifier le premier message de votre sujet pour ajouter [Résolu] lorsque votre problème l'est :)
Xubuntu 18.04.1 sur trois ordinateurs, zéro souci. Passez à Xubuntu ;)

En ligne

#15 Le 04/10/2018, à 20:30

ylag

Re : [Résolu]Affichage impossible ne fonctionne qu'en mode recovery

@Mornagest:

Salut,

[HS] Pout ma part, j'ai une 8600GT qui tourne présentement avec les 340.
Lors de l'install de la 18.04, elle a fonctionné correctement sur le pilote libre nouveau: On verra bien si ce sera toujours le cas dans le futur. (Si la carte tient le coup jusque-là. wink ) [/HS]

A+

Dernière modification par ylag (Le 04/10/2018, à 20:32)

Hors ligne

#16 Le 05/10/2018, à 10:00

Maedid

Re : [Résolu]Affichage impossible ne fonctionne qu'en mode recovery

[résolu]
J'aii trouvé sur le site Nvidia
NVIDIA-Linux-x86_64-390.87.run
et j'ai suivi les instructions.
Merci pour vos conseils, ça m'a aidé.

Hors ligne

#17 Le 05/10/2018, à 10:05

NicoApi73

Re : [Résolu]Affichage impossible ne fonctionne qu'en mode recovery

Bonjour,

Le 390 est toujours maintenu. Je ne savais pas que ta carte était supportée par ce driver.

En ligne

#18 Le 05/10/2018, à 13:10

ylag

Re : [Résolu]Affichage impossible ne fonctionne qu'en mode recovery

Salut,

Si on parle bien d'une GeForce 7300 GT tel que dans le retour au commentaire #3, le site de NVIDIA donne les pilotes de série 304, et ne serait pas supportée dans les versions supérieures.

Peut-être donner le retour de:

ubuntu-drivers devices

...histoire d'y voir un peu plus clair ?

A+

Hors ligne

#19 Le 05/10/2018, à 13:13

NicoApi73

Re : [Résolu]Affichage impossible ne fonctionne qu'en mode recovery

ylag a écrit :

Salut,

Si on parle bien d'une GeForce 7300 GT tel que dans le retour au commentaire #3, le site de NVIDIA donne les pilotes de série 304, et ne serait pas supportée dans les versions supérieures.

Peut-être donner le retour de:

ubuntu-drivers devices

...histoire d'y voir un peu plus clair ?

A+

Et :

sudo lshw | grep -A12 display

(@ylag : j'ai l'habitude de regarder les drivers utilisés avec lshw smile , probablement redondant avec ta commande)

Dernière modification par NicoApi73 (Le 05/10/2018, à 13:14)

En ligne

#20 Le 05/10/2018, à 13:17

Mornagest

Re : [Résolu]Affichage impossible ne fonctionne qu'en mode recovery

Les deux se complètent, ubuntu-drivers devices liste tous les pilotes disponibles pour le matériel concerné.


N'oubliez pas de consulter la documentation pour vous donner un coup de main !
Merci de modifier le premier message de votre sujet pour ajouter [Résolu] lorsque votre problème l'est :)
Xubuntu 18.04.1 sur trois ordinateurs, zéro souci. Passez à Xubuntu ;)

En ligne

#21 Le 05/10/2018, à 13:29

ylag

Re : [Résolu]Affichage impossible ne fonctionne qu'en mode recovery

Salut,

Mornagest a écrit :

(@ylag : j'ai l'habitude de regarder les drivers utilisés avec lshw

Excellente suggestion, on saura vraiment quelle est la carte et le pilote utilisés.

A+

Hors ligne

#22 Le 05/10/2018, à 15:46

Mornagest

Re : [Résolu]Affichage impossible ne fonctionne qu'en mode recovery

C'est Nico qui proposait la commande, mais j'abonde dans ce sens également smile


N'oubliez pas de consulter la documentation pour vous donner un coup de main !
Merci de modifier le premier message de votre sujet pour ajouter [Résolu] lorsque votre problème l'est :)
Xubuntu 18.04.1 sur trois ordinateurs, zéro souci. Passez à Xubuntu ;)

En ligne

#23 Le 05/10/2018, à 16:07

ylag

Re : [Résolu]Affichage impossible ne fonctionne qu'en mode recovery

Salut,

Je soupconne fortement que la carte vidéo de @Maedid tourne sous le pilote libre nouveau.
Si le pilote NVIDIA-Linux-x86_64-390.87.run a été installé pour la carte GeForce 7300 GT, ça devra simplement être désinstallé puisque inutile pour ce matériel, à mon avis.

A+

Hors ligne