Contenu | Rechercher | Menus

Annonce

T-shirt Seiche Cosmic, Série limitée

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.10
T-shirt Ubuntu-FR « Seiche Cosmique » en série limitée ! Prix spécial pré-vente (15€) jusqu'au 4 novembre 2018.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 05/10/2018, à 21:48

skilim

Problème au démarrage suite MàJ 18.04

Bonsoir,
Tout d'abord, je sais que d'autres posts ont déjà été créés sur le même sujet, mais n'y ayant pas trouvé la réponse à mon problème, je me permets d'en ouvrir un nouveau. Je précise que je suis plutôt débutant avec Linux...
Je suis passé à la version 18.04LTS lorsque le gestionnaire de mises à jour me l'a proposé. L'installation s'est bien passée, si ce n'est que deux fenêtres "Problème logiciel détecté" (pas très explicite donc...) sont apparues pendant celle-ci (avec seulement deux choix, "OK" ou "Signaler"). L'installation finie, reboot, le logo Ubuntu apparaît avec les 5 points en-dessous qui chargent. Ensuite... plus rien : au lieu de l'écran qui m'invite à saisir mon mot de passe de session, j'ai juste un écran noir avec le pointeur de la souris que je peux déplacer.
Lorsque je fais Ctrl+Alt+F2 pour afficher le tty2, j'ai des messages ACPI Error: Method parse/execution failed et ACPI AException: AE_NOT_FOUND.
La solution de ce post ne fonctionne pas, rien ne se produit lorsque je fais Ctrl+Alt+F1.
Un grand merci d'avance pour votre aide !

Hors ligne

#2 Le 05/10/2018, à 21:55

Mornagest

Re : Problème au démarrage suite MàJ 18.04

Salut,

C'est probablement un souci d'affichage graphique. Pour régler ça, c'est assez simple.

Au démarrage de ton ordinateur, quand GRUB s'affiche, tu appuies sur la touche "e" pour éditer le script de démarrage du noyau.

(si GRUB ne s'affiche pas, appuie plusieurs fois sur Échap quand tu démarres pour forcer son ouverture)

Dans les lignes qui s'affichent, tu repères les paramètres quiet splash que tu peux supprimer afin d'avoir un démarrage en ligne de commandes qui sera plus explicite en cas de souci. À la place, tu indiques nomodeset

Attention, ton clavier est en qwerty, donc il faut taper no,odeset et bien t'assurer de ce qui s'affiche.

/!\ Tous ces changements sont temporaires et valables pour la session en cours, on va déjà s'assurer que ça fonctionne pour les entrer "en dur" dans ta configuration de GRUB. Si tu redémarres entretemps, il faudra refaire la même manip pour éditer le script de démarrage de ton noyau.


N'oubliez pas de consulter la documentation pour vous donner un coup de main !
Merci de modifier le premier message de votre sujet pour ajouter [Résolu] lorsque votre problème l'est :)
Xubuntu 18.04.1 sur trois ordinateurs, zéro souci. Passez à Xubuntu ;)

Hors ligne

#3 Le 05/10/2018, à 22:44

skilim

Re : Problème au démarrage suite MàJ 18.04

Merci pour ta réponse ! Malheureusement, il y a un petit détail qui fait que ce n'est pas si simple... Mon PC est un portable dont l'écran a décidé un beau jour d'arrêter de fonctionner. Plutôt que de jeter l'ordinateur et d'en racheter un, j'ai acheté un écran d'occasion que je branche sur le PC. Mais l'affichage sur cet écran ne démarre qu'avec le logo Ubuntu et la barre de chargement.
J'ai testé ta manip mais rien ne s'affiche sur l'écran fixe, j'imagine que les lignes en question seraient sur l'écran du portable si celui-ci fonctionnait...
Désolé, je suis un cas bien pathologique je crois hmm

Hors ligne

#4 Le 05/10/2018, à 22:48

Mornagest

Re : Problème au démarrage suite MàJ 18.04

Sur ton écran externe, tu vois bien GRUB au démarrage ?


N'oubliez pas de consulter la documentation pour vous donner un coup de main !
Merci de modifier le premier message de votre sujet pour ajouter [Résolu] lorsque votre problème l'est :)
Xubuntu 18.04.1 sur trois ordinateurs, zéro souci. Passez à Xubuntu ;)

Hors ligne

#5 Le 05/10/2018, à 22:56

skilim

Re : Problème au démarrage suite MàJ 18.04

Non justement, je ne l'ai jamais vu. En gros la loupiote de l'écran indique que celui-ci est en veille jusqu'au moment où le logo Ubuntu s'affiche.
Pourtant à l'époque où l'écran du portable fonctionnait je voyais bien le GRUB.

Pour info, je ne sais pas si ça peut aider, mais j'ai l'impression que quand je passe au tty2 je peux taper des instructions dans la console malgré les messages ACPI Error qui s'affichent régulièrement...

Hors ligne

#6 Le 06/10/2018, à 13:19

Mornagest

Re : Problème au démarrage suite MàJ 18.04

Il est possible que GRUB ne s'affiche pas, si Ubuntu est ton seul système d'exploitation installé. On peut forcer l'affichage de GRUB en appuyant plusieurs fois sur Échap au démarrage de l'ordinateur.

Si ça fonctionne, essaie les instructions du message #2.

Si ça ne fonctionne pas mais que tu peux accéder au terminal pur (tty2 ou un autre), ça peut t'aider. Tu vas pouvoir éditer directement le fichier de configuration de GRUB. L'inconvénient, c'est que si ça ne marche pas, il faudra de nouveau l'éditer pour tenter autre chose.

Tu fais sudo nano /etc/default/grub pour éditer le fichier de configuration.

Il ressemble à ceci (ça, c'est le mien) :

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="noresume"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Le tien devrait contenir les termes quiet splash sur cette ligne :

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash noresume"

Tu supprimes quiet splash et tu remplaces par nomodeset

Ensuite, tu enregistres le fichier en faisant Ctrl + o (la lettre, pas le chiffre) et tu valides avec Entrée, puis tu quittes avec Ctrl + x

Enfin, tu redémarres avec sudo reboot


N'oubliez pas de consulter la documentation pour vous donner un coup de main !
Merci de modifier le premier message de votre sujet pour ajouter [Résolu] lorsque votre problème l'est :)
Xubuntu 18.04.1 sur trois ordinateurs, zéro souci. Passez à Xubuntu ;)

Hors ligne

#7 Le 06/10/2018, à 19:30

skilim

Re : Problème au démarrage suite MàJ 18.04

Bonsoir,
Merci pour le temps que tu consacres à m'aider smile j'ai fait la manip que tu décris (il y avait effectivement un "quiet splash" que j'ai remplacé par "nomodeset"), pourtant j'ai toujours le même problème. Et quand je rouvre le fichier de config de GRUB, la modification a bien été enregistrée, le souci doit donc venir d'ailleurs...

Hors ligne

#8 Le 06/10/2018, à 20:53

Mornagest

Re : Problème au démarrage suite MàJ 18.04

On va essayer autrement. Il vaut mieux retirer nomodeset dans /etc/default/grub pour repartir sur la configuration d'origine (ne remets pas quiet splash, ça ne sert  rien pour l'instant).

Lorsque tu redémarres, tu te places en terminal avec ctrl + alt + F2 et une fois loggué, tu tapes

sudo lshw -C video (le l de lshw est un L minuscule).

Si tu n'as pas de moyen de copier le résultat directement ici, n'hésite pas à prendre une photo pour la poster ensuite.


N'oubliez pas de consulter la documentation pour vous donner un coup de main !
Merci de modifier le premier message de votre sujet pour ajouter [Résolu] lorsque votre problème l'est :)
Xubuntu 18.04.1 sur trois ordinateurs, zéro souci. Passez à Xubuntu ;)

Hors ligne

#9 Le 07/10/2018, à 13:44

skilim

Re : Problème au démarrage suite MàJ 18.04

Bonjour,
Voici une photo de l'écran, j'espère que c'est lisible...
https://nsa39.casimages.com/img/2018/10 … 325217.jpg


Modération : merci d'utiliser des images de petite taille (300x300) ou des miniatures pointant sur ces images (Des hébergeurs comme Toile Libre, TDCT'Pix et pix.debian-fr le permettent).

Dernière modification par cqfd93 (Le 07/10/2018, à 13:54)

Hors ligne

#10 Le 07/10/2018, à 13:51

??

Re : Problème au démarrage suite MàJ 18.04

Bonjour
tu n'as pas fourni de photo... Voir procédure https://doc.ubuntu-fr.org/capture_d_ecr … re_d_ecran


Utiliser REFIND au lieu du GRUB https://doc.ubuntu-fr.org/refind . Aidez à vous faire dépanner en suivant le guide et en utilisant les outils de diagnostic J'ai perdu ma gomme. Désolé pour les fautes d'orthographes non corrigées.

Hors ligne

#11 Le 07/10/2018, à 13:51

??

Re : Problème au démarrage suite MàJ 18.04

?? a écrit :

Bonjour
tu n'as pas fourni de photo... Voir procédure https://doc.ubuntu-fr.org/capture_d_ecr … re_d_ecran

Désolé, Elle vient d'arriver.....


Utiliser REFIND au lieu du GRUB https://doc.ubuntu-fr.org/refind . Aidez à vous faire dépanner en suivant le guide et en utilisant les outils de diagnostic J'ai perdu ma gomme. Désolé pour les fautes d'orthographes non corrigées.

Hors ligne

#12 Le 07/10/2018, à 13:55

??

Re : Problème au démarrage suite MàJ 18.04

En plus de l'option nomodeset,  mets aussi l'option acpi=off    afin d'être moins  pollué par le message


Utiliser REFIND au lieu du GRUB https://doc.ubuntu-fr.org/refind . Aidez à vous faire dépanner en suivant le guide et en utilisant les outils de diagnostic J'ai perdu ma gomme. Désolé pour les fautes d'orthographes non corrigées.

Hors ligne

#13 Le 09/10/2018, à 23:03

skilim

Re : Problème au démarrage suite MàJ 18.04

Bonsoir,
Merci du conseil, j'ai donc mis "nomodeset" et "acpi=off" sur la ligne GRUB_CMDLINE_LINUX_DEFAULT mais j'ai toujours cet irritant message et bien sûr toujours le même problème d'écran qui reste noir...

Hors ligne

#14 Le 10/10/2018, à 00:30

??

Re : Problème au démarrage suite MàJ 18.04

Bonsoir.
J'avais trés mal lu la consigne du message 6.

Si tu modifies le fichier /etc/default/grub il faut que tu valides la modification avec la commande

 sudo update-grub

En fait, j'ai  l'habitude de  demander la modification du fichier /boot/grub/grub.cfg

ce n'est plus du tout la même ligne.    Elle contient bien les paramètres indiqués et elle commence par vmlinuz. C'est environ en position 140. Il y a plusieurs lignes de ce style. Seule la première est à faire.

Ce n'est que lorsqu'on est certain que la modification a été efficace qu'on l'installe de façon définitive dans /etc/default/grub

Il y a aussi une autre façon de faire la modification en prenant la main immédiatement au démarrage.
C'est expliqué au paragraphe  7.10.1 de cette documentation https://doc.ubuntu-fr.org/kernel


Utiliser REFIND au lieu du GRUB https://doc.ubuntu-fr.org/refind . Aidez à vous faire dépanner en suivant le guide et en utilisant les outils de diagnostic J'ai perdu ma gomme. Désolé pour les fautes d'orthographes non corrigées.

Hors ligne

#15 Le 10/10/2018, à 09:17

Mornagest

Re : Problème au démarrage suite MàJ 18.04

Évidemment, imbécile que je suis ; j'ai oublié sudo update-grub !

Par contre, quelle différence entre /etc/default/grub et /boot/grub/grub.cfg ? Lequel modifier pour avoir les changements de façon permanente au démarrage ?


N'oubliez pas de consulter la documentation pour vous donner un coup de main !
Merci de modifier le premier message de votre sujet pour ajouter [Résolu] lorsque votre problème l'est :)
Xubuntu 18.04.1 sur trois ordinateurs, zéro souci. Passez à Xubuntu ;)

Hors ligne

#16 Le 10/10/2018, à 10:09

NicoApi73

Re : Problème au démarrage suite MàJ 18.04

Bonjour,

acpi=off est assez impactant. Parfois, c'est effectivement nécessaire. Si en bootant tu as des effets de bord (genre clavier, souris...), il faudra envisager de le retirer. Et à priori, le seul moyen sera d'aller l'effacer dans le fichier cité par ??

tty1 est utilisé par le système sur la 18.04, donc pas accessible.

Hors ligne

#17 Le 10/10/2018, à 10:31

Mornagest

Re : Problème au démarrage suite MàJ 18.04

@ Nico : sur ma Xubuntu 18.04, en faisant Ctrl + Alt + F1, j'arrive bien sur tty1. C'est curieux. (et donc Ctrl + Alt + F7 pour revenir en graphique)


N'oubliez pas de consulter la documentation pour vous donner un coup de main !
Merci de modifier le premier message de votre sujet pour ajouter [Résolu] lorsque votre problème l'est :)
Xubuntu 18.04.1 sur trois ordinateurs, zéro souci. Passez à Xubuntu ;)

Hors ligne

#18 Le 10/10/2018, à 11:00

NicoApi73

Re : Problème au démarrage suite MàJ 18.04

Je suis sur la 16.04. Je viens d'essayer sur une VM pour vérifier et je te confirme que :
- sur Xubuntu 18.04, tty1 est disponible
- sur Ubuntu 18.04, tty1 n'est pas disponible

Donc nous avons raison l'un et l'autre (sauf si skilim est sur autre chose que Ubuntu, et dans ce cas, j'ai peut être tort smile )

Hors ligne