Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 11/09/2018, à 21:38

Radikolibr

Plus de son depuis l'upgrade à Ubuntu 18.04

Bonjour,

Entre autres désagréments, depuis l'upgrade à la version 18.04 LTS le son a "disparu" : je n'ai plus d'icône de volume dans la barre de tâches, et dans les paramètres du son, la zone de modification du volume est grisée, je ne peux pas y toucher.
Ubuntu détecte bien ma carte son, alsamixer fonctionne, mais... pas pulseaudio, qui me donne ceci lorsque je tente de le lancer :

~$ pulseaudio
W: [pulseaudio] module-ladspa-sink.c: The 'master' module argument is deprecated and may be removed in the future, please use the 'sink_master' argument instead.
E: [pulseaudio] ltdl-bind-now.c: Échec d'ouverture du module mbeq_1197.so : mbeq_1197.so: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type
E: [pulseaudio] module-ladspa-sink.c: Failed to load LADSPA plugin: file not found
E: [pulseaudio] module.c: Failed to load module "module-ladspa-sink" (argument: "sink_name=ladspa_output.mbeq_1197.mbeq master=alsa_output.pci-0000_00_1b.0.analog-stereo plugin=mbeq_1197 label=mbeq control=-9.0,-5.5,0.0,1.5,2.1,3.4,3.4,3.4,3.4,3.4,3.4,3.4,2.8,1.6,1.8"): initialization failed.
E: [pulseaudio] main.c: Module load failed.
E: [pulseaudio] main.c: Échec lors de l'initialisation du démon

J'ai essayé un apt full-upgrade mais ça n'a rien changé.

Alsamixer fonctionne comme avant, aucune sortie n'est en sourdine.

J'ai installé le paquet paramètres de pulseaudio mais rien n'y fait.

Le fait que seule la possibilité de changer le volume soit impactée me fait penser que c'est bien de pulseaudio que vient le problème.
Je serais bien tenté de supprimer et réinstaller pulseaudio mais la page de la doc le déconseille plus ou moins.

Qu'est-ce que vous en pensez ?

Dernière modification par Radikolibr (Le 11/09/2018, à 21:41)

Hors ligne

#2 Le 11/09/2018, à 21:41

xubu1957

Re : Plus de son depuis l'upgrade à Ubuntu 18.04

Bonjour,

As-tu installé : pavucontrol ?

Fournis les cartes sons, en te servant du Retour utilisable de commande :

lspci | grep [Aa]udio && lsusb | grep [Aa]udio

et :

cat /proc/asound/pcm

Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#3 Le 11/09/2018, à 22:44

Radikolibr

Re : Plus de son depuis l'upgrade à Ubuntu 18.04

Eh oui, j'ai essayé pavucontrol, qui me dit :
Connection to PulseAudio failed, ce qui, j'imagine, est logique si le démon pulseaudio n'arrive pas à se lancer.

lspci | grep [Aa]udio && lsusb | grep [Aa]udio
00:03.0 Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 05)
cat /proc/asound/pcm
00-03: HDMI 0 : HDMI 0 : playback 1
00-07: HDMI 1 : HDMI 1 : playback 1
00-08: HDMI 2 : HDMI 2 : playback 1
00-09: HDMI 3 : HDMI 3 : playback 1
00-10: HDMI 4 : HDMI 4 : playback 1
01-00: VT1802 Analog : VT1802 Analog : playback 1 : capture 1
01-02: VT1802 Alt Analog : VT1802 Alt Analog : playback 1

J'ai remarqué quelque chose cependant ; par rapport à un live-usb tout neuf, dans le dossier usr > lib > i386-linux-gnu > pulseaudio, il manque 2 fichiers : libpulsecore-11.1.so et libpulsedsp.so
Ça aide ?

Hors ligne

#4 Le 12/09/2018, à 05:43

xubu1957

Re : Plus de son depuis l'upgrade à Ubuntu 18.04

Bonjour,

Tu as des cartes sons Intel, tu avais consulté la Doc > audio_intel_hda ?


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#5 Le 12/09/2018, à 09:39

Radikolibr

Re : Plus de son depuis l'upgrade à Ubuntu 18.04

Bonjour,

J'ai lu la doc, mais je n'ai pas tout compris.
J'ai quand même trouvé le chip de la carte son, j'ai édité /etc/modprobe.d/alsa-base.conf, rajouté la ligne options snd-hda-intel model=VT1802 au cas où, mais dans la sous-liste des modèles de chips, il me propose comme nom de modèle auto (BIOS setup)...

Dans le BIOS, tout est normal.

Je repense à ce que dit pulseaudio, visiblement il manque des fichiers ; si je le supprime puis le réinstalle, ça ne résoudra pas ce problème ?

Hors ligne

#6 Le 12/09/2018, à 10:06

xubu1957

Re : Plus de son depuis l'upgrade à Ubuntu 18.04


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#7 Le 12/09/2018, à 12:38

grandtoubab

Re : Plus de son depuis l'upgrade à Ubuntu 18.04

Salut
Sauf si Ubuntu à bricolé, sous Debian pulseaudio est un service systemd utilisateur
pour vérifier l'état et les erreurs éventuelles

systemctl --user status pulseaudio.service -l

ainsi que la socket

systemctl --user status pulseaudio.socket

pulseaudio.socket - Sound System
   Loaded: loaded (/usr/lib/systemd/user/pulseaudio.socket; enabled; vendor pres
   Active: active (running) since Wed 2018-09-12 10:54:15 CEST; 2h 46min ago
   Listen: /run/user/1001/pulse/native (Stream)
   CGroup: /user.slice/user-1001.slice/user@1001.service/pulseaudio.socket

sept. 12 10:54:15 debian systemd[2495]: Listening on Sound System.

Dernière modification par grandtoubab (Le 12/09/2018, à 12:43)


Linux tout seul sur HP Pavilion DV7 et Acer Aspire T650, Canon MG3650 en wifi
Debian 10 Buster Gnome/Xorg, Gnome/Wayland, Weston/Wayland
https://bidouilledebian.wordpress.com/
ON M'A VU DANS LE VERCORS, SAUTER A L'ELASTIQUE.....

Hors ligne

#8 Le 13/09/2018, à 09:31

Radikolibr

Re : Plus de son depuis l'upgrade à Ubuntu 18.04

Bonjour,

Merci pour vos réponses rapides.

J'ai réinstallé les codecs avec la commande qu'ils proposent, mais rien ne change.

Par contre,

systemctl --user status pulseaudio.service -l

renvoie :

● pulseaudio.service - Sound Service
   Loaded: loaded (/usr/lib/systemd/user/pulseaudio.service; disabled; vendor pr
   Active: inactive (dead)

et

systemctl --user status pulseaudio.socket

renvoie :

● pulseaudio.service - Sound Service
   Loaded: loaded (/usr/lib/systemd/user/pulseaudio.service; disabled; vendor pr
   Active: inactive (dead)

Comparé à

Loaded: loaded (/usr/lib/systemd/user/pulseaudio.socket; enabled; vendor pres
Active: active (running) since Wed 2018-09-12 10:54:15 CEST; 2h 46min ago

J'en déduis qu'il y a un problème !

J'ai recherché et comparé les fichiers qu'il y avait par défaut dans un live usb d'Ubuntu 18 "vierge", et par rapport au live usb, il manque plusieurs fichiers dans les dossiers pulseaudio de mon PC.

Comment faire maintenant ?

Hors ligne

#9 Le 13/09/2018, à 10:27

grandtoubab

Re : Plus de son depuis l'upgrade à Ubuntu 18.04

Sur ton Ubuntu les deux services ne sont pas activés ( etat disabled)
je ne sais pas si c'est un choix d'Ubuntu

Eventuellement, pour activer un service utilisateur

systemctl --user enable pulseaudio.service
systemctl --user enable pulseaudio.socket

pour démarrer un service

systemctl --user start pulseaudio.service

Dernière modification par grandtoubab (Le 13/09/2018, à 10:30)


Linux tout seul sur HP Pavilion DV7 et Acer Aspire T650, Canon MG3650 en wifi
Debian 10 Buster Gnome/Xorg, Gnome/Wayland, Weston/Wayland
https://bidouilledebian.wordpress.com/
ON M'A VU DANS LE VERCORS, SAUTER A L'ELASTIQUE.....

Hors ligne

#10 Le 15/09/2018, à 10:50

Radikolibr

Re : Plus de son depuis l'upgrade à Ubuntu 18.04

Bonjour,

Les 2 premières commandes ont l'air de fonctionner, pas de message d'erreur.
La 3e, pour démarrer le service, renvoie Job for pulseaudio.service failed because the control process exited with error code.

Encore une fois, le fait qu'il manque des fichiers dans les dossiers pulseaudio ne serait pas le problème ? Je ne connais pas la chose en détail, mais s'il manque des fichiers par rapport à une installation neuve (comme je l'expliquais, sur un live usb tout récent), je ne comprends comment le processus peut se lancer correctement.

Est-ce qu'une désinstallation/réinstallation ne résoudrait pas le problème ? Ou est-ce que c'est risqué ?

Hors ligne

#11 Le 15/09/2018, à 11:23

Radikolibr

Re : Plus de son depuis l'upgrade à Ubuntu 18.04

Je viens de désinstaller et réinstaller pulseaudio et le greffon gstreamer pour pulseaudio, via la logithèque, mais j'ai le même retour que sur le message précédent, lorsque je lance systemctl --user start pulseaudio.service, j'obtiens Job for pulseaudio.service failed because the control process exited with error code

Je me suis basé là-dessus : https://doc.ubuntu-fr.org/pulseaudio#su … stallation. Est-ce qu'il serait intéressant d'essayer :

sudo apt-get remove --purge pulseaudio

?

Hors ligne

#12 Le 15/09/2018, à 14:28

grandtoubab

Re : Plus de son depuis l'upgrade à Ubuntu 18.04

déja essayer

sudo apt install --reinstall pulseaudio

Linux tout seul sur HP Pavilion DV7 et Acer Aspire T650, Canon MG3650 en wifi
Debian 10 Buster Gnome/Xorg, Gnome/Wayland, Weston/Wayland
https://bidouilledebian.wordpress.com/
ON M'A VU DANS LE VERCORS, SAUTER A L'ELASTIQUE.....

Hors ligne

#13 Le 15/09/2018, à 14:55

wormwicker1

Re : Plus de son depuis l'upgrade à Ubuntu 18.04

Bonjour, j'ai un problème similaire ICI

Le plus fort c'est que ce foutu son sortait des HP avant le redémarage???


UBUNTU 14.04 LTS
ASUS X75VC / 12 Gio / i3-2370M@2.40GHz x 4 / GT 720M / OS 64 bits / 120 Gio SSD / 750 Gio HDD

Hors ligne

#14 Le 15/09/2018, à 17:50

grandtoubab

Re : Plus de son depuis l'upgrade à Ubuntu 18.04

il se peut aussi qu'une application verrouille la carte son
ça se verifie par la commande

fuser -v /dev/snd/*

quand c'est ok c'est pulseaudio qui doit etre listé


Linux tout seul sur HP Pavilion DV7 et Acer Aspire T650, Canon MG3650 en wifi
Debian 10 Buster Gnome/Xorg, Gnome/Wayland, Weston/Wayland
https://bidouilledebian.wordpress.com/
ON M'A VU DANS LE VERCORS, SAUTER A L'ELASTIQUE.....

Hors ligne

#15 Le 16/09/2018, à 22:20

Radikolibr

Re : Plus de son depuis l'upgrade à Ubuntu 18.04

Bonjour,

Merci pour les propositions de solution, mais toujours rien. Réinstaller pulseaudio s'est fait sans erreur apparente, mais

fuser -v /dev/snd/*

ne renvoie rien du tout.

quand c'est ok c'est pulseaudio qui doit etre listé

Je dois avoir pulseaudio listé en réponse, c'est ça ? Moi ça ne donne strictement rien.

Hors ligne

#16 Le 17/09/2018, à 08:15

grandtoubab

Re : Plus de son depuis l'upgrade à Ubuntu 18.04

Radikolibr a écrit :

quand c'est ok c'est pulseaudio qui doit etre listé

Je dois avoir pulseaudio listé en réponse, c'est ça ? .

Exactement

@debian:~$ fuser -v /dev/snd/*
                     UTIL.       PID ACCÈS  COMMANDE
/dev/snd/controlC0:  guy        2289 F.... pulseaudio
@debian:~$ ls -alrt /dev/snd
total 0
crw-rw----+  1 root audio 116,  1 sept. 17 08:58 seq
drwxr-xr-x   2 root root       60 sept. 17 08:58 by-path
drwxr-xr-x   3 root root      180 sept. 17 08:58 .
crw-rw----+  1 root audio 116, 33 sept. 17 09:01 timer
crw-rw----+  1 root audio 116,  5 sept. 17 09:01 hwC0D0
crw-rw----+  1 root audio 116,  3 sept. 17 09:01 pcmC0D0p
crw-rw----+  1 root audio 116,  4 sept. 17 09:01 pcmC0D0c
crw-rw----+  1 root audio 116,  2 sept. 17 09:01 controlC0
drwxr-xr-x  20 root root     3400 sept. 17 09:02 ..


Et la carte son est listée par cette commande

pacmd list-sources | grep -e device.string -e 'name:'


debian:~$ pacmd list-sources | grep -e device.string -e 'name:'
    name: <alsa_output.pci-0000_00_14.2.analog-stereo.monitor>
        device.string = "0"
    name: <alsa_input.pci-0000_00_14.2.analog-stereo>
        device.string = "front:0"


lspci -nnk | grep -i audio -A1

00:14.2 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA) [1002:4383] (rev 40)
    Subsystem: Hewlett-Packard Company SBx00 Azalia (Intel HDA) [103c:1443]
--
02:00.1 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] Cedar HDMI Audio [Radeon HD 5400/6300/7300 Series] [1002:aa68]
    Subsystem: Hewlett-Packard Company Cedar HDMI Audio [Radeon HD 5400/6300/7300 Series] [103c:1443]
    Kernel modules: snd_hda_intel

Dernière modification par grandtoubab (Le 17/09/2018, à 08:40)


Linux tout seul sur HP Pavilion DV7 et Acer Aspire T650, Canon MG3650 en wifi
Debian 10 Buster Gnome/Xorg, Gnome/Wayland, Weston/Wayland
https://bidouilledebian.wordpress.com/
ON M'A VU DANS LE VERCORS, SAUTER A L'ELASTIQUE.....

Hors ligne

#17 Le 17/09/2018, à 09:21

maxire

Re : Plus de son depuis l'upgrade à Ubuntu 18.04

Salut,

Le message d'erreur fourni par Radikolibr me semble assez clair.
Pulse audio cherche à  charger le module ladspa qui est introuvable (plus exactement ladspa cherche le plugin mbeq1197 qui est absent).
Comme c'est une mise à  niveau et non une réinstallation de Ubuntu je suppose que Radikolibr à du précédemment paramétrer pulse audio afin de charger ce module dont je ne me souviens plus de l'utilité.
En principe ce paramétrage s'effectue en $HOME/.config/pulseaudio/default.pa si ma mémoire est bonne.
Il devrait suffire de supprimer ce fichier pour améliorer la situation mais j'aimerais d'abord voir son contenu ainsi que celui de /etc/pulseaudio/default.pa..

Dernière modification par maxire (Le 17/09/2018, à 09:31)


Maxire
Archlinux/Mate + Debian Stretch/Gnome sur portable -- Archlinux/Mate sur poste de travail

En ligne

#18 Le 02/10/2018, à 10:50

Radikolibr

Re : Plus de son depuis l'upgrade à Ubuntu 18.04

Bonjour,

Désolé pour le délai de réponse.

Voilà ce qu'il y a dans $home/.config/pulse/default.pa

#!/usr/bin/pulseaudio -nF
#
# This file is part of PulseAudio.
#
# PulseAudio is free software; you can redistribute it and/or modify it
# under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
#
# PulseAudio is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU Lesser General Public License
# along with PulseAudio; if not, write to the Free Software Foundation,
# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.

# This startup script is used only if PulseAudio is started per-user
# (i.e. not in system mode)

.nofail

### Load something into the sample cache
#load-sample-lazy x11-bell /usr/share/sounds/gtk-events/activate.wav
#load-sample-lazy pulse-hotplug /usr/share/sounds/startup3.wav
#load-sample-lazy pulse-coldplug /usr/share/sounds/startup3.wav
#load-sample-lazy pulse-access /usr/share/sounds/generic.wav

.fail

### Automatically restore the volume of streams and devices
load-module module-device-restore
load-module module-stream-restore restore_device=false
load-module module-card-restore

### Automatically augment property information from .desktop files
### stored in /usr/share/application
load-module module-augment-properties

### Should be after module-*-restore but before module-*-detect
load-module module-switch-on-port-available

### Load audio drivers statically
### (it's probably better to not load these drivers manually, but instead
### use module-udev-detect -- see below -- for doing this automatically)
#load-module module-alsa-sink
#load-module module-alsa-source device=hw:1,0
#load-module module-oss device="/dev/dsp" sink_name=output source_name=input
#load-module module-oss-mmap device="/dev/dsp" sink_name=output source_name=input
#load-module module-null-sink
#load-module module-pipe-sink

### Automatically load driver modules depending on the hardware available
.ifexists module-udev-detect.so
load-module module-udev-detect
.else
### Use the static hardware detection module (for systems that lack udev support)
load-module module-detect
.endif

.ifexists module-android-audio-hal.so
load-module module-android-audio-hal
.endif

### Automatically connect sink and source if JACK server is present
.ifexists module-jackdbus-detect.so
.nofail
load-module module-jackdbus-detect channels=2
.fail
.endif

### Automatically load driver modules for Bluetooth hardware
.ifexists module-bluetooth-policy.so
load-module module-bluetooth-policy
.endif

.ifexists module-bluetooth-discover.so
load-module module-bluetooth-discover
.endif

### Load several protocols
.ifexists module-esound-protocol-unix.so
load-module module-esound-protocol-unix
.endif
load-module module-native-protocol-unix

### Network access (may be configured with paprefs, so leave this commented
### here if you plan to use paprefs)
#load-module module-esound-protocol-tcp
#load-module module-native-protocol-tcp
#load-module module-zeroconf-publish

### Load the RTP receiver module (also configured via paprefs, see above)
#load-module module-rtp-recv

### Load the RTP sender module (also configured via paprefs, see above)
#load-module module-null-sink sink_name=rtp format=s16be channels=2 rate=44100 sink_properties="device.description='RTP Multicast Sink'"
#load-module module-rtp-send source=rtp.monitor

### Load additional modules from GConf settings. This can be configured with the paprefs tool.
### Please keep in mind that the modules configured by paprefs might conflict with manually
### loaded modules.
.ifexists module-gconf.so
.nofail
load-module module-gconf
.fail
.endif

### Automatically restore the default sink/source when changed by the user
### during runtime
### NOTE: This should be loaded as early as possible so that subsequent modules
### that look up the default sink/source get the right value
load-module module-default-device-restore

### Automatically move streams to the default sink if the sink they are
### connected to dies, similar for sources
load-module module-rescue-streams

### Make sure we always have a sink around, even if it is a null sink.
load-module module-always-sink

### Honour intended role device property
load-module module-intended-roles

### Automatically suspend sinks/sources that become idle for too long
load-module module-suspend-on-idle

### If autoexit on idle is enabled we want to make sure we only quit
### when no local session needs us anymore.
.ifexists module-console-kit.so
load-module module-console-kit
.endif
.ifexists module-systemd-login.so
load-module module-systemd-login
.endif

### Enable positioned event sounds
load-module module-position-event-sounds

### Cork music/video streams when a phone stream is active
#load-module module-role-cork

### Modules to allow autoloading of filters (such as echo cancellation)
### on demand. module-filter-heuristics tries to determine what filters
### make sense, and module-filter-apply does the heavy-lifting of
### loading modules and rerouting streams.
load-module module-filter-heuristics
load-module module-filter-apply

# X11 modules should not be started from default.pa so that one daemon
# can be shared by multiple sessions.

### Load X11 bell module
#load-module module-x11-bell sample=bell-windowing-system

### Register ourselves in the X11 session manager
#load-module module-x11-xsmp

### Publish connection data in the X11 root window
#.ifexists module-x11-publish.so
#.nofail
#load-module module-x11-publish
#.fail
#.endif

### Make some devices default
#set-default-sink output
#set-default-source input

### BEGIN: Equalized audio configuration
### Generated from: pulseaudio-equalizer
load-module module-ladspa-sink sink_name=ladspa_output.mbeq_1197.mbeq master=alsa_output.pci-0000_00_1b.0.analog-stereo plugin=mbeq_1197 label=mbeq control=-9.0,-5.5,0.0,1.5,2.1,3.4,3.4,3.4,3.4,3.4,3.4,3.4,2.8,1.6,1.8
set-default-sink ladspa_output.mbeq_1197.mbeq
set-sink-volume alsa_output.pci-0000_00_1b.0.analog-stereo 65536
set-sink-mute alsa_output.pci-0000_00_1b.0.analog-stereo 0
### END: Equalized audio configuration

et dans etc/pulse/default.pa

#!/usr/bin/pulseaudio -nF
#
# This file is part of PulseAudio.
#
# PulseAudio is free software; you can redistribute it and/or modify it
# under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
#
# PulseAudio is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU Lesser General Public License
# along with PulseAudio; if not, see <http://www.gnu.org/licenses/>.

# This startup script is used only if PulseAudio is started per-user
# (i.e. not in system mode)

.fail

### Automatically restore the volume of streams and devices
load-module module-device-restore
load-module module-stream-restore
load-module module-card-restore

### Automatically augment property information from .desktop files
### stored in /usr/share/application
load-module module-augment-properties

### Should be after module-*-restore but before module-*-detect
load-module module-switch-on-port-available

### Use hot-plugged devices like Bluetooth or USB automatically (LP: #1702794)
.ifexists module-switch-on-connect.so
load-module module-switch-on-connect
.endif

### Load audio drivers statically
### (it's probably better to not load these drivers manually, but instead
### use module-udev-detect -- see below -- for doing this automatically)
#load-module module-alsa-sink
#load-module module-alsa-source device=hw:1,0
#load-module module-oss device="/dev/dsp" sink_name=output source_name=input
#load-module module-oss-mmap device="/dev/dsp" sink_name=output source_name=input
#load-module module-null-sink
#load-module module-pipe-sink

### Automatically load driver modules depending on the hardware available
.ifexists module-udev-detect.so
load-module module-udev-detect
.else
### Use the static hardware detection module (for systems that lack udev support)
load-module module-detect
.endif

### Automatically connect sink and source if JACK server is present
.ifexists module-jackdbus-detect.so
.nofail
load-module module-jackdbus-detect channels=2
.fail
.endif

### Automatically load driver modules for Bluetooth hardware
.ifexists module-bluetooth-policy.so
load-module module-bluetooth-policy
.endif

.ifexists module-bluetooth-discover.so
load-module module-bluetooth-discover
.endif

### Load several protocols
.ifexists module-esound-protocol-unix.so
load-module module-esound-protocol-unix
.endif
load-module module-native-protocol-unix

### Network access (may be configured with paprefs, so leave this commented
### here if you plan to use paprefs)
load-module module-esound-protocol-tcp
#load-module module-native-protocol-tcp
#load-module module-zeroconf-publish

### Load the RTP receiver module (also configured via paprefs, see above)
#load-module module-rtp-recv

### Load the RTP sender module (also configured via paprefs, see above)
#load-module module-null-sink sink_name=rtp format=s16be channels=2 rate=44100 sink_properties="device.description='RTP Multicast Sink'"
#load-module module-rtp-send source=rtp.monitor

### Load additional modules from GConf settings. This can be configured with the paprefs tool.
### Please keep in mind that the modules configured by paprefs might conflict with manually
### loaded modules.
.ifexists module-gconf.so
.nofail
load-module module-gconf
.fail
.endif

### Automatically restore the default sink/source when changed by the user
### during runtime
### NOTE: This should be loaded as early as possible so that subsequent modules
### that look up the default sink/source get the right value
load-module module-default-device-restore

### Automatically move streams to the default sink if the sink they are
### connected to dies, similar for sources
load-module module-rescue-streams

### Make sure we always have a sink around, even if it is a null sink.
load-module module-always-sink

### Honour intended role device property
load-module module-intended-roles

### Automatically suspend sinks/sources that become idle for too long
load-module module-suspend-on-idle

### If autoexit on idle is enabled we want to make sure we only quit
### when no local session needs us anymore.
.ifexists module-console-kit.so
load-module module-console-kit
.endif
.ifexists module-systemd-login.so
load-module module-systemd-login
.endif

### Enable positioned event sounds
load-module module-position-event-sounds

### Cork music/video streams when a phone stream is active
load-module module-role-cork

### Modules to allow autoloading of filters (such as echo cancellation)
### on demand. module-filter-heuristics tries to determine what filters
### make sense, and module-filter-apply does the heavy-lifting of
### loading modules and rerouting streams.
load-module module-filter-heuristics
load-module module-filter-apply

### Make some devices default
#set-default-sink output
#set-default-source input

J'avoue que je commence à avoir envie de refaire une install toute neuve... Ça me prendra moins de temps ^_^

Hors ligne

#19 Le 02/10/2018, à 10:55

Radikolibr

Re : Plus de son depuis l'upgrade à Ubuntu 18.04

Merci pour vos réponses.

Et la carte son est listée par cette commande

pacmd list-sources | grep -e device.string -e 'name:'

donne...
Aucun démon PulseAudio en cours d'exécution, ou ne s'exécutant pas dans une session de type démon.

Et

lspci -nnk | grep -i audio -A1

donne
00:03.0 Audio device [0403]: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller [8086:0c0c] (rev 06)
    Subsystem: CLEVO/KAPOK Computer Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller [1558:0655]
    Kernel driver in use: snd_hda_intel
--
00:1b.0 Audio device [0403]: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller [8086:8c20] (rev 05)
    Subsystem: CLEVO/KAPOK Computer 8 Series/C220 Series Chipset High Definition Audio Controller [1558:0655]
    Kernel driver in use: snd_hda_intel

Une idée d'où peut venir le problème ?

Hors ligne

#20 Le 02/10/2018, à 17:28

maxire

Re : Plus de son depuis l'upgrade à Ubuntu 18.04

Renomme  $HOME/.config/pulse/default.pa en $HOME/.config/pulse/default.bak puis

systemctl --user start pulseaudio

Cela devrait régler le problème.

Dernière modification par maxire (Le 02/10/2018, à 17:28)


Maxire
Archlinux/Mate + Debian Stretch/Gnome sur portable -- Archlinux/Mate sur poste de travail

En ligne

#21 Le 05/10/2018, à 09:06

Radikolibr

Re : Plus de son depuis l'upgrade à Ubuntu 18.04

Bonjour maxire,

Merci pour ta proposition, mais

systemctl --user start pulseaudio

donne

Job for pulseaudio.service failed because the control process exited with error code.
See "systemctl --user status pulseaudio.service" and "journalctl --user -xe" for details.

Je suis donc allé essayer

journalctl --user -xe

qui donne à son tour

oct. 05 10:00:50 marie-ordi systemd[1137]: pulseaudio.service: Service hold-off
oct. 05 10:00:50 marie-ordi systemd[1137]: pulseaudio.service: Scheduled restart
-- Subject: Le redémarrage automatique d'une unité (unit) a été planifié
-- Defined-By: systemd
-- Support: http://www.ubuntu.com/support
--
-- Le redémarrage automatique de l'unité (unit) UNIT a été planifié, en
-- raison de sa configuration avec le paramètre Restart=.
oct. 05 10:00:50 marie-ordi systemd[1137]: Stopped Sound Service.
-- Subject: L'unité (unit) UNIT a terminé son arrêt
-- Defined-By: systemd
-- Support: http://www.ubuntu.com/support
--
-- L'unité (unit) UNIT a terminé son arrêt.
oct. 05 10:00:50 marie-ordi systemd[1137]: pulseaudio.service: Start request rep
oct. 05 10:00:50 marie-ordi systemd[1137]: pulseaudio.service: Failed with resul
oct. 05 10:00:50 marie-ordi systemd[1137]: Failed to start Sound Service.
-- Subject: L'unité (unit) UNIT a échoué
-- Defined-By: systemd
-- Support: http://www.ubuntu.com/support
--
-- L'unité (unit) UNIT a échoué, avec le résultat RESULT.
oct. 05 10:00:50 marie-ordi systemd[1137]: pulseaudio.socket: Failed with result
lines 1544-1566/1566 (END)
oct. 05 10:00:50 marie-ordi systemd[1137]: pulseaudio.service: Service hold-off time over, scheduling restart.
oct. 05 10:00:50 marie-ordi systemd[1137]: pulseaudio.service: Scheduled restart job, restart counter is at 5.
-- Subject: Le redémarrage automatique d'une unité (unit) a été planifié
-- Defined-By: systemd
-- Support: http://www.ubuntu.com/support
--
-- Le redémarrage automatique de l'unité (unit) UNIT a été planifié, en
-- raison de sa configuration avec le paramètre Restart=.
oct. 05 10:00:50 marie-ordi systemd[1137]: Stopped Sound Service.
-- Subject: L'unité (unit) UNIT a terminé son arrêt
-- Defined-By: systemd
-- Support: http://www.ubuntu.com/support
--
-- L'unité (unit) UNIT a terminé son arrêt.
oct. 05 10:00:50 marie-ordi systemd[1137]: pulseaudio.service: Start request repeated too quickly.
oct. 05 10:00:50 marie-ordi systemd[1137]: pulseaudio.service: Failed with result 'exit-code'.
oct. 05 10:00:50 marie-ordi systemd[1137]: Failed to start Sound Service.
-- Subject: L'unité (unit) UNIT a échoué
-- Defined-By: systemd
-- Support: http://www.ubuntu.com/support
--
-- L'unité (unit) UNIT a échoué, avec le résultat RESULT.
oct. 05 10:00:50 marie-ordi systemd[1137]: pulseaudio.socket: Failed with result 'service-start-limit-hit'.

Hors ligne

#22 Le 05/10/2018, à 09:40

maxire

Re : Plus de son depuis l'upgrade à Ubuntu 18.04

Bonjour,

Plutôt qu'un start j'aurais mieux fait de proposer une déconnexion / reconnexion de l'utilisateur. .


Maxire
Archlinux/Mate + Debian Stretch/Gnome sur portable -- Archlinux/Mate sur poste de travail

En ligne

#23 Le 08/10/2018, à 10:36

grandtoubab

Re : Plus de son depuis l'upgrade à Ubuntu 18.04

### BEGIN: Equalized audio configuration
### Generated from: pulseaudio-equalizer
load-module module-ladspa-sink sink_name=ladspa_output.mbeq_1197.mbeq master=alsa_output.pci-0000_00_1b.0.analog-stereo plugin=mbeq_1197 label=mbeq control=-9.0,-5.5,0.0,1.5,2.1,3.4,3.4,3.4,3.4,3.4,3.4,3.4,2.8,1.6,1.8
set-default-sink ladspa_output.mbeq_1197.mbeq
set-sink-volume alsa_output.pci-0000_00_1b.0.analog-stereo 65536
set-sink-mute alsa_output.pci-0000_00_1b.0.analog-stereo 0
### END: Equalized audio configuration

Tu as du jouer un jour avec l'equalizer


le paquet est il toujours installé?

apt list pulseaudio-equalizer

Dernière modification par grandtoubab (Le 08/10/2018, à 10:36)


Linux tout seul sur HP Pavilion DV7 et Acer Aspire T650, Canon MG3650 en wifi
Debian 10 Buster Gnome/Xorg, Gnome/Wayland, Weston/Wayland
https://bidouilledebian.wordpress.com/
ON M'A VU DANS LE VERCORS, SAUTER A L'ELASTIQUE.....

Hors ligne

#24 Le 08/10/2018, à 15:44

provaire

Re : Plus de son depuis l'upgrade à Ubuntu 18.04

Bonjour, essayez de vérifier si le son fonctionne en session invité ?
Si s'est le cas s'est un fichier pulseaudio (il me semble)manquant ou modifié dans votre session.

Dernière modification par provaire (Le 08/10/2018, à 15:48)


Totas las personas naisson liuras e egalas en dignitat e en drech.

Hors ligne

#25 Le 10/10/2018, à 17:19

Radikolibr

Re : Plus de son depuis l'upgrade à Ubuntu 18.04

Bonjour et merci pour votre aide qui ne diminue pas malgré la difficulté à trouver ce qui cloche !

grandtoubab a écrit :

Tu as du jouer un jour avec l'equalizer

Non, Ubuntu a joué avec l'equalizer ; comme je le disais, j'ai fait l'upgrade à la version 18 et je me suis retrouvé là. Et je ne parle pas des autres soucis depuis...

le paquet est il toujours installé?

apt list pulseaudio-equalizer

Voici la réponse :
En train de lister... Fait
pulseaudio-equalizer/bionic-updates,now 1:11.1-1ubuntu7.1 amd64  [installé]
N: Il y a une version supplémentaire 1. Veuillez utiliser l'opérande « -a » pour la voir.

Question (peut-être bête) : en quoi l'égaliseur empêcherait le processus pulseaudio de se lancer ?

maxire a écrit :

Bonjour,
Plutôt qu'un start j'aurais mieux fait de proposer une déconnexion / reconnexion de l'utilisateur.

Comment est-ce que je paramètre ça alors ?

Hors ligne