Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 01/10/2018, à 18:02

Valérie_z

Bug affichage images dans Firefox

Bonjour à vous,

Je suis sous Ubuntu 18.04.01 / 64bits avec Firefox Quantum 62. La recherche d'adresses sur Duckduckgo chargent les cartes (OpenStreetMap avec cartes vectorielles Mapbox) dont l'affichage plante systématiquement : après quelques secondes de chargement, apparaissent de grandes rayures multicolores. Seule la punaise de géolocalisation apparaît clairement.
Le même type de recherche sur mobile avec Firefox pour Android version 61 ne pose aucune difficulté d'affichage.
Et bien entendu, je n'ai pas de souci non plus avec les Google maps :-(.

Par ailleurs, j'ai observé exactement le même bug avec des images canvas, sur certaines démos d'utilisation de frameworks JS  comme MelonJS. Pour le moment, les mises à jour régulières prévues par le gestionnaire ont déjà appliqué quelques MAJ de paquets sur Firefox, sans aucun changement.
Je vous mets une saisie écran à titre d'exemple. Curieusement, le message qui apparaît en bas et à l'envers correspond à un autre onglet de Firefox qui avait été ouvert, puis refermé...
http://www.cnous.lautre.net/bugopenstreetmaps.png

Est-ce que quelqu'un a déjà rencontré le souci / aurait une idée de la façon de remédier à ça ?

Bonne journée,
Valérie


[EDIT] : J'ai modifié la taille de l'image à 300px de large, et en ajoute une seconde (de même taille) qui montre mieux les grandes rayures colorées : http://www.cnous.lautre.net/bugopenstreetmap2.png



Modération : merci d'utiliser des images de petite taille (300x300) ou des miniatures pointant sur ces images (Des hébergeurs comme Toile Libre, TDCT'Pix et pix.debian-fr le permettent).

Dernière modification par Valérie_z (Le 02/10/2018, à 15:56)

Hors ligne

#2 Le 03/10/2018, à 14:19

nam1962

Re : Bug affichage images dans Firefox

As-tu essayé en safe-mode, as-tu essayé en changeant de thème du bureau ?

Dernière modification par nam1962 (Le 10/10/2018, à 10:29)


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing - Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#3 Le 10/10/2018, à 09:41

Valérie_z

Re : Bug affichage images dans Firefox

Hello

Bingo nam1962, c'est ça, merci !

Par contre, en essayant un redémarrage normal et en désactivant plugins / extensions 1 par 1 à la main, pour isoler le fautif, j'ai toujours le même souci, y compris quand tout est désactivé.
Le thème est celui par défaut, je ne peux pas le désactiver, et je n'en ai pas d'autres (dans FF).

Si tu as une idée de comment m'y prendre pour traquer le module en cause, je suis preneuse...

Bonne journée
Valérie

Hors ligne

#4 Le 10/10/2018, à 09:58

inbox

Re : Bug affichage images dans Firefox

Salut,

Tu peux réinitialiser Firefox, tout en notant qu'il te faudra réinstaller tes extensions.

A+


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

En ligne

#5 Le 10/10/2018, à 10:27

Valérie_z

Re : Bug affichage images dans Firefox

Salut inbox, ok, je note ça, s'il n'y a pas plus simple...
Merci,
++

Hors ligne

#6 Le 10/10/2018, à 10:29

nam1962

Re : Bug affichage images dans Firefox

Donne nous :

grep -oP '},"name":"\K[^"]*' ~/.mozilla/firefox/*.default*/addons.json

Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing - Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#7 Le 10/10/2018, à 10:58

Valérie_z

Re : Bug affichage images dans Firefox

voilà :

NoScript Security Suite
One-Click Youtube Videos Download
DuckDuckGo Privacy Essentials
Français Language Pack
English (GB) Language Pack
Web Developer
Simple Download YouTube Videos
English (South African) Language Pack
English (CA) Language Pack

Dernière modification par Valérie_z (Le 10/10/2018, à 10:58)

Hors ligne

#8 Le 10/10/2018, à 11:02

nam1962

Re : Bug affichage images dans Firefox

Essaye en désactivant noscript (qui peut bloquer plein de trucs). Ajoute plutôt ublock origin, désactive aussi les deux extensions youtube
Puis dis-nous


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing - Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#9 Le 10/10/2018, à 11:10

Valérie_z

Re : Bug affichage images dans Firefox

Fait.
Fermeture / redémarrage / restaurer la session précédente pour réouvrir mes onglets et toujours pareil...
J'avais déjà testé en désactivant également les autres (donc sans aucun plugin / extension), et toujours pareil (Je vais sur http://melonjs.org/ pour tester)....

Hors ligne

#10 Le 10/10/2018, à 11:27

nam1962

Re : Bug affichage images dans Firefox

Alors, justement, ne restaure pas la session et au contraire, vide historique cache et cookies


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing - Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#11 Le 10/10/2018, à 12:23

Valérie_z

Re : Bug affichage images dans Firefox

Alors suppression cache / cookies / historique, vérification des désactivations de modules toujours ok, fermeture / redémarrage, puis melonJS pour tester......... :-(

Hors ligne

#12 Le 10/10/2018, à 13:28

nam1962

Re : Bug affichage images dans Firefox

Donne nous :

sudo lshw -short

Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing - Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#13 Le 10/10/2018, à 13:35

Valérie_z

Re : Bug affichage images dans Firefox

Voilà

Chemin matériel         Périphérique  Classe      Description
================================================================
                                         system      Precision WorkStation 390
/0                                       bus         0DN075
/0/0                                     memory      64KiB BIOS
/0/400                                   processor   Intel(R) Core(TM)2 CPU     
/0/400/700                               memory      32KiB L1 cache
/0/400/701                               memory      4MiB L2 cache
/0/1000                                  memory      2GiB Mémoire Système
/0/1000/0                                memory      1GiB DIMM DDR Synchrone 667
/0/1000/1                                memory      DIMM DDR Synchrone 667 MHz 
/0/1000/2                                memory      1GiB DIMM DDR Synchrone 667
/0/1000/3                                memory      DIMM DDR Synchrone 667 MHz 
/0/100                                   bridge      82975X Memory Controller Hu
/0/100/1                                 bridge      82975X PCI Express Root Por
/0/100/1/0                               display     NV44 [Quadro NVS 285]
/0/100/1c                                bridge      NM10/ICH7 Family PCI Expres
/0/100/1c.4                              bridge      82801GR/GH/GHM (ICH7 Family
/0/100/1c.5                              bridge      82801GR/GH/GHM (ICH7 Family
/0/100/1c.5/0            enp4s0          network     NetXtreme BCM5754 Gigabit E
/0/100/1d                                bus         NM10/ICH7 Family USB UHCI C
/0/100/1d/1              usb2            bus         UHCI Host Controller
/0/100/1d.1                              bus         NM10/ICH7 Family USB UHCI C
/0/100/1d.1/1            usb3            bus         UHCI Host Controller
/0/100/1d.1/1/2                          printer     EPSON Epson Stylus SX130 Se
/0/100/1d.2                              bus         NM10/ICH7 Family USB UHCI C
/0/100/1d.2/1            usb4            bus         UHCI Host Controller
/0/100/1d.2/1/2                          input       Dell USB Keyboard
/0/100/1d.3                              bus         NM10/ICH7 Family USB UHCI C
/0/100/1d.3/1            usb5            bus         UHCI Host Controller
/0/100/1d.7                              bus         NM10/ICH7 Family USB2 EHCI 
/0/100/1d.7/1            usb1            bus         EHCI Host Controller
/0/100/1d.7/1/1          scsi6           storage     USB2.0 MFP(Hi-Speed)
/0/100/1d.7/1/1/0.0.0    /dev/sdc        disk        Stylus Storage
/0/100/1d.7/1/1/0.0.0/0  /dev/sdc        disk        
/0/100/1e                                bridge      82801 PCI Bridge
/0/100/1e/4                              multimedia  EMU20k1 [Sound Blaster X-Fi
/0/100/1f                                bridge      82801GB/GR (ICH7 Family) LP
/0/100/1f.1                              storage     82801G (ICH7 Family) IDE Co
/0/100/1f.2                              storage     NM10/ICH7 Family SATA Contr
/0/100/1f.3                              bus         NM10/ICH7 Family SMBus Cont
/0/1                     scsi0           storage     
/0/1/0.0.0               /dev/cdrom      disk        DVD-ROM GDR8164B
/0/1/0.1.0               /dev/cdrw       disk        DVD+-RW DVD8801
/0/2                     scsi2           storage     
/0/2/0.0.0               /dev/sda        disk        160GB WDC WD1600ADFS-7
/0/2/0.0.0/1             /dev/sda1       volume      109MiB Windows FAT volume
/0/2/0.0.0/2             /dev/sda2       volume      148GiB Extended partition
/0/2/0.0.0/2/5           /dev/sda5       volume      147GiB Volume EXT4
/0/2/0.0.0/2/6           /dev/sda6       volume      1905MiB Linux swap volume
/0/3                     scsi4           storage     
/0/3/0.0.0               /dev/sdb        disk        500GB HDS725050KLA360
/0/3/0.0.0/1             /dev/sdb1       volume      465GiB Windows NTFS volume

Hors ligne

#14 Le 10/10/2018, à 13:56

nam1962

Re : Bug affichage images dans Firefox

2Go de RAM c'est très peu.
Une Xubuntu, voire une Lubuntu ou une Debian + Xfce seraient plus efficaces.


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing - Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#15 Le 10/10/2018, à 14:03

inbox

Re : Bug affichage images dans Firefox

Valérie_z a écrit :

Salut inbox, ok, je note ça, s'il n'y a pas plus simple...
Merci,
++

La procédure n'est pas compliquée. Il suffit de quelques clics pour terminer.

Si tu le souhaites, tu peux faire une copie de ton dossier Mozilla avant de réinitialiser. Ce dossier est caché. Il se nomme .Mozilla. Si la manipulation n'améliore pas les choses, il te suffit de restaurer.


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

En ligne

#16 Le 10/10/2018, à 15:20

Valérie_z

Re : Bug affichage images dans Firefox

Bon... alors une réinitialisation pour commencer, et une vérification avec un paramétrage remis à zéro..... et vraiment rien à faire, toujours le même bug. Du coup, j'ai remis le dossier .mozilla d'avant comme conseillé, puisque ça ne changeait rien. Il n'y a que le safe mode qui fonctionne bien....

Hors ligne

#17 Le 10/10/2018, à 18:06

lool_lauris

Re : Bug affichage images dans Firefox

Salut,

À voir :
☰ (menu) > Préférences > Général > sous-section "Performances" > décocher "Utiliser les paramètres de performance recommandés" > décocher "Utiliser l'accélération graphique matériel si disponible" & diminuer le "Nombre maximum de processus de contenu" (passer à 3, voire 2).


Soutenez le Libre => http://www.april.org/

Hors ligne

#18 Le 11/10/2018, à 15:07

Valérie_z

Re : Bug affichage images dans Firefox

Salut lool_lauris, merci du tuyau.

J'ai décoché l'accélérateur graphique, le reste était ok (pas de paramètres de performance, et nb de processus de contenu à 2). Redémarrage, ..... eh non.
On a tout essayé, là, je crois, à part la prochaine MAJ de FF ? (actuellement 62.0.3) ?

Merci...
++
Valérie

Dernière modification par Valérie_z (Le 11/10/2018, à 15:07)

Hors ligne

#19 Le 11/10/2018, à 15:22

grandtoubab

Re : Bug affichage images dans Firefox

Salut
Aucun pb
https://duckduckgo.com/?q=31+rue+Menand … &iaxm=maps

Safe-Mode ne se contente pas de desactiver les extensions mais aussi "

https://support.mozilla.org/fr/kb/resou … =Safe+Mode

Le mode sans échec désactive temporairement l’accélération matérielle, réinitialise certains paramètres et désactive les modules (extensions et thèmes

Donc tu as du triturer un paramètre dans about:config qui perturbe le fonctionnement

il reste à essayer

about:support

Réparer Firefox


Linux tout seul sur HP Pavilion DV7 et Acer Aspire T650, Canon MG3650 en wifi
Debian 10 Buster Gnome/Xorg, Gnome/Wayland, Weston/Wayland
https://bidouilledebian.wordpress.com/
ON M'A VU DANS LE VERCORS, SAUTER A L'ELASTIQUE.....

Hors ligne

#20 Le 11/10/2018, à 16:20

lool_lauris

Re : Bug affichage images dans Firefox

Un truc que tu peux faire : créer un nouveau profil Firefox ( https://support.mozilla.org/fr/kb/utili … er-profils ) sans supprimer l'ancien.
Si cela résout le problème, tu peux conserver ce nouveau profil et y transférer les données perso de ton ancien profil => https://support.mozilla.org/fr/kb/recup … ien-profil


Soutenez le Libre => http://www.april.org/

Hors ligne

#21 Le 12/10/2018, à 17:13

Valérie_z

Re : Bug affichage images dans Firefox

Salut !
Ah tiens, pas mal le gestionnaire de profil, bon tuyau.
Bon, j'ai tenté de créer un nouveau profil, puis ai redémarré dessus avant d'y copier quoi que ce soit de l'ancien profil, et non, toujours pareil.
Alors j'ai fini par une réparation depuis la page

about:support

Et même là, c'est toujours pareil. J'ai l'impression qu'il n'y a vraiment rien à faire.... Merci de vos idées...
++

Hors ligne

#22 Le 12/10/2018, à 17:23

inbox

Re : Bug affichage images dans Firefox

Pour ta carte graphique, utilises-tu le pilote libre Nouveau ou le pilote fournit par nVidia ?


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

En ligne

#23 Le 12/10/2018, à 21:14

Valérie_z

Re : Bug affichage images dans Firefox

Bonne question...J'ai réinstallé Ubuntu from scratch récemment, je ne suis pas allée chercher un pilote spécifique (carte NV44). Je dois utiliser la version libre... Je n'ai pas trouvé le nom du pilote dans les informations de config...

Mais c'est peut-être une bonne piste, essayer de récupérer et installer un pilote spécifique Nvidia (propriétaire...)
Quoi que le problème ne se pose que dans FF, et le safe mode n'est pas concerné...
A étudier en tout cas, merci du tuyau.
++

Hors ligne

#24 Le 16/10/2018, à 15:59

Valérie_z

Re : Bug affichage images dans Firefox

Re,

Je tente la piste du gestionnaire propriétaire pou ma carte graphique. En lisant cette doc : https://doc.ubuntu-fr.org/gestionnaire_ … prietaires
je vois que l'onglet "pilotes additionnels" du gestionnaire de logiciels / mises à jour devrait pouvoir me proposer le pilote correspondant à ma carte Nvidia (si celui-ci existe), dès lors que "Pilotes propriétaires de périphériques (restricted)" est bien activée dans le 1er onglet (logiciels Ubuntu). Pourtant, avec cette case cochée et une mise à jour lancée avec

apt update

ou depuis le gestionnaire (en mode graphique) me laisse un onglet vide, avec à la fin du preocessus
le message suivant concernant videolan :

E:The repository 'http://ppa.launchpad.net/videolan/stable-daily/ubuntu bionic Release' does not have a Release file., 
W:Updating from such a repository can't be done securely, and is therefore disabled by default., 
W:See apt-secure(8) manpage for repository creation and user configuration details., 
E:The repository 'http://ppa.launchpad.net/webupd8team/tor-browser/ubuntu bionic Release' does not have a Release file.

Peut-être qu'il y a une idée de réponse au problème là ? videolan, c'est VLC, il me semble ?
Peut-être que les paquets de dépôt a été à l'origine du pb ? Y a-t-il eu un conflit au moment de l'installation ?
Que peut-on conseiller à partir de là ?
Comment rechercher le bon driver pour la carte que j'ai et trouver un dépôt propriétaire qui correspond ?
Comment chercher un autre dépôt pour VLC ?

Bref, merci de vos pistes
++ V

Dernière modification par Valérie_z (Le 16/10/2018, à 16:10)

Hors ligne

#25 Le 16/10/2018, à 16:22

grandtoubab

Re : Bug affichage images dans Firefox

je ne comprends pas l'interet d'aller chercher VLC dans des dépôts annexes alors qu'il est fourni par ubuntu

apt policy vlc

et tor-browser vaut mieux le prendre à la source
https://www.torproject.org/projects/torbrowser.html.en

Bref beaucoup de bidouilles mal maitrisées visiblement

Dernière modification par grandtoubab (Le 16/10/2018, à 16:25)


Linux tout seul sur HP Pavilion DV7 et Acer Aspire T650, Canon MG3650 en wifi
Debian 10 Buster Gnome/Xorg, Gnome/Wayland, Weston/Wayland
https://bidouilledebian.wordpress.com/
ON M'A VU DANS LE VERCORS, SAUTER A L'ELASTIQUE.....

Hors ligne