Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 05/12/2018, à 14:43

laslack

problème de configuration UMS RESOLU

Bonjour ,
Avec mon 18.04 nouvellement installé suite à 16.04, j'ai installé minidlna pour pouvoir accéder à un apareil mutimedia.
Mes sources  de fichiers sont  situées
-dans mon /home
-sur  2 disques internes lancés à l'ouverture.
J'ai suivi les tutos là:https://www.it-connect.fr/partager-vos-contenus-multimedia-avec-ready-media-minidlna/ et là:https://doc.ubuntu-fr.org/minidlna
ci dessous mon /etc/minidlna.conf

  GNU nano 2.9.3                  /etc/minidlna.conf                            

# This is the configuration file for the MiniDLNA daemon, a DLNA/UPnP-AV media
# server.
#
# Unless otherwise noted, the commented out options show their default value.
#
# On Debian, you can also refer to the minidlna.conf(5) man page for
# documentation about this file.

# Specify the user name or uid to run as (root by default).
# On Debian system command line option (from /etc/default/minidlna) overrides t$
  user=minidlna


# Path to the directory you want scanned for media files.
#
# This option can be specified more than once if you want multiple directories
# scanned.
 media_dir = V,/rep/home/jeanpaul/Vidéos
 media_dir =V,/media/jeanpaul/_homeancien/Vidéos old
                           [ Lecture de 135 lignes ]
^G Aide      ^O Écrire    ^W Chercher  ^K Couper    ^J Justifier ^C Pos. cur.
^X Quitter   ^R Lire fich.^\ Remplacer ^U Coller    ^T Orthograp.^_ Aller lig.

Mais cela ne fonctionne pas !
-le serveur minidlna est en fonction 

jeanpaul@G41M-2SH:~$ /etc/init.d/minidlna restart
[ ok ] Restarting minidlna (via systemctl): minidlna.service.
jeanpaul@G41M-2SH:~$ sudo minidlnad -f /etc/minidlna.conf -R
[2018/12/05 13:59:03] minidlna.c:631: error: Media directory "V,/rep/home/jeanpaul/Vidéos" not accessible [No such file or directory]
[2018/12/05 13:59:03] minidlna.c:631: error: Media directory "V,/media/jeanpaul/_homeancien/Vidéos old" not accessible [No such file or directory]
[2018/12/05 13:59:03] minidlna.c:631: error: Media directory "V,/media/jeanpaul/4dda761b-6c74-46f9-b49b-3d466aba12f2/Films" not accessible [No such file or directory]
[2018/12/05 13:59:03] minidlna.c:631: error: Media directory "P,/media/jeanpaul/_homeancien/Images" not accessible [No such file or directory]
jeanpaul@G41M-2SH:~$ sudo /etc/init.d/minidlna status
● minidlna.service - LSB: minidlna server
   Loaded: loaded (/etc/init.d/minidlna; generated)
   Active: active (exited) since Wed 2018-12-05 13:58:32 CET; 1min 0s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 14368 ExecStop=/etc/init.d/minidlna stop (code=exited, status=0/SUCCESS)
  Process: 14376 ExecStart=/etc/init.d/minidlna start (code=exited, status=0/SUCCESS)

déc. 05 13:58:32 G41M-2SH systemd[1]: Starting LSB: minidlna server...
déc. 05 13:58:32 G41M-2SH minidlna[14376]: [2018/12/05 13:58:32] minidlna.c…ry]
déc. 05 13:58:32 G41M-2SH minidlna[14376]: [2018/12/05 13:58:32] minidlna.c…ed]
déc. 05 13:58:32 G41M-2SH minidlna[14376]: [2018/12/05 13:58:32] minidlna.c…ed]
déc. 05 13:58:32 G41M-2SH minidlna[14376]: [2018/12/05 13:58:32] minidlna.c…ed]
déc. 05 13:58:32 G41M-2SH minidlna[14376]: [2018/12/05 13:58:32] minidlna.c…ed]
déc. 05 13:58:32 G41M-2SH systemd[1]: Started LSB: minidlna server.
Hint: Some lines were ellipsized, use -l to show in full.

Je suis allé voir dans le log :

[2018/12/05 13:58:32] minidlna.c:1060: warn: Starting MiniDLNA version 1.2.1.
[2018/12/05 13:58:32] minidlna.c:359: warn: Removed media_dir detected; rebuilding...
[2018/12/05 13:58:32] minidlna.c:133: error: bind(http): Adresse déjà utilisée
[2018/12/05 13:58:32] minidlna.c:1100: fatal: Failed to open socket for HTTP. EXITING
[2018/12/05 13:58:32] playlist.c:135: warn: Parsing playlists...
[2018/12/05 13:58:32] playlist.c:269: warn: Finished parsing playlists.
[2018/12/05 13:59:03] minidlna.c:1060: warn: Starting MiniDLNA version 1.2.1.
[2018/12/05 13:59:03] minidlna.c:355: warn: Creating new database at /var/lib/minidlna/files.db
[2018/12/05 13:59:03] minidlna.c:133: error: bind(http): Adresse déjà utilisée
[2018/12/05 13:59:03] minidlna.c:1100: fatal: Failed to open socket for HTTP. EXITING
[2018/12/05 13:59:03] scanner.c:730: warn: Analyse de /home/jeanpaul/Images
[2018/12/05 13:59:03] scanner.c:762: warn: Error scanning /home/jeanpaul/Images [Permission non accordée]
[2018/12/05 13:59:03] playlist.c:135: warn: Parsing playlists...
[2018/12/05 13:59:03] playlist.c:269: warn: Finished parsing playlists.
[2018/12/05 14:08:50] minidlna.c:1060: warn: Starting MiniDLNA version 1.2.1.
[2018/12/05 14:08:50] minidlna.c:355: warn: Creating new database at /var/lib/minidlna/files.db
[2018/12/05 14:08:50] minidlna.c:133: error: bind(http): Adresse déjà utilisée
[2018/12/05 14:08:50] minidlna.c:1100: fatal: Failed to open socket for HTTP. EXITING
[2018/12/05 14:08:50] scanner.c:730: warn: Analyse de /home/jeanpaul/Images
[2018/12/05 14:08:50] scanner.c:762: warn: Error scanning /home/jeanpaul/Images [Permission non accordée]
[2018/12/05 14:08:50] playlist.c:135: warn: Parsing playlists...
[2018/12/05 14:08:50] playlist.c:269: warn: Finished parsing playlists.

Sur mon  appareil multimedia ,les dossiers sont affiches , mais vides .
Quand je veux forcer le scan :

jeanpaul@G41M-2SH:~$ sudo minidlnad -R
[sudo] Mot de passe de jeanpaul : 
[2018/12/05 14:32:42] minidlna.c:631: error: Media directory "V,/rep/home/jeanpaul/Vidéos" not accessible [No such file or directory]
[2018/12/05 14:32:42] minidlna.c:631: error: Media directory "V,/media/jeanpaul/_homeancien/Vidéos old" not accessible [No such file or directory]
[2018/12/05 14:32:42] minidlna.c:631: error: Media directory "V,/media/jeanpaul/4dda761b-6c74-46f9-b49b-3d466aba12f2/Films" not accessible [No such file or directory]
[2018/12/05 14:32:42] minidlna.c:631: error: Media directory "P,/media/jeanpaul/_homeancien/Images" not accessible [No such file or directory]

J'ai regardé d'autres tutos et forums , mais je n'ai rien trouvé qui puisse me servir

Je demande votre aide
Merci d'avance


PS pourquoi avoir supprimé gedit  facile à utiliser pour Nano qui est pour moi une véritable purge.

Dernière modification par laslack (Le 09/12/2018, à 16:30)

En ligne

#2 Le 05/12/2018, à 17:19

erresse

Re : problème de configuration UMS RESOLU

Bonjour,
Mon message ne va pas répondre à ta question,mais juste te proposer de te documenter sur une autre application de serveur multimédia : UMS (Universal Media Server) qui dispose d'une interface graphique très complète pour la gestion du serveur et est assez simple à prendre en main.
Avant, j'utilisais "minidlna", mais le paramétrage est en un peu délicat, et lorsque j'ai connu UMS, je l'ai essayé et adopté.
Ça ne coûte rien à essayer...


Plus de 50 ans d'informatique, ça en fait des lignes de commandes en console, mais on n'avait pas le choix...
Excellente raison pour, aujourd'hui qu'on le peut, utiliser au maximum les INTERFACES GRAPHIQUES !
Important : Une fois résolu, pensez à clore votre sujet en ajoutant [Résolu] devant le titre du 1er message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Hors ligne

#3 Le 05/12/2018, à 18:10

laslack

Re : problème de configuration UMS RESOLU

Merci bien !

Je viens d'installer UMS mais pendant la configuration , l'interface graphique a disparu ??( environnement gnome shell) et je ne vois pa comment relancer , j'ai essayé de désinstaller pour réinstaller , mais je ne sait pas faire avec un fichier.sh

En ligne

#4 Le 05/12/2018, à 18:40

erresse

Re : problème de configuration UMS RESOLU

Dans mon système, le lancement de UMS est paramétré sur "minimisé" pour ne faire apparaître qu'une icône dans le tableau de bord. Peut-être est-ce la valeur par défaut de ce paramètre ?
Malheureusement, je ne connais pas l'environnement de Ubuntu avec Gnome shell, personnellement, j'utilise Ubuntu-Mate qui est plus "classique" comme interface...
Edit : Un "fichier.sh" est un script bash. On le lance depuis un terminal ou avec le lanceur de commande. Chez moi, j'ai créé un lanceur graphique (fichier Universal Media Server.desktop) qui lance la commande "UMS.sh".

Dernière modification par erresse (Le 05/12/2018, à 18:45)


Plus de 50 ans d'informatique, ça en fait des lignes de commandes en console, mais on n'avait pas le choix...
Excellente raison pour, aujourd'hui qu'on le peut, utiliser au maximum les INTERFACES GRAPHIQUES !
Important : Une fois résolu, pensez à clore votre sujet en ajoutant [Résolu] devant le titre du 1er message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Hors ligne

#5 Le 06/12/2018, à 18:35

laslack

Re : problème de configuration UMS RESOLU

OK merci !
je viens de paramétrer UMS ,mais, j'ai des fichiers multimedias sur plusieurs disques
-mon home
- 2 dd internes  montés au démarrage.

En ce qui concerne les fichiers sur le /home , pas de problème , mais concernant les autres support ils ne sont pas reconnus.

eanpaul@G41M-2SH:~/ums-7.6.2$ ./UMS.sh
INFO  18:07:06.346 [main] Starting Universal Media Server 7.6.2
INFO  18:07:06.347 [main] Based on PS3 Media Server by shagrath, copyright 2008-2014
INFO  18:07:06.347 [main] https://www.universalmediaserver.com
INFO  18:07:06.347 [main] 
INFO  18:07:06.347 [main] Build: 2392f22e3 (2018-11-22)
INFO  18:07:06.348 [main] Java: Java HotSpot(TM) 64-Bit Server VM 1.8.0_191 (64-bit) by Oracle Corporation
INFO  18:07:06.348 [main] OS: Linux 64-bit 4.15.0-42-generic
INFO  18:07:06.350 [main] Maximum JVM Memory: 683 MiB
INFO  18:07:06.356 [main] Language: French
INFO  18:07:06.356 [main] Encoding: UTF-8
INFO  18:07:06.356 [main] 
INFO  18:07:06.356 [main] Working directory: /home/jeanpaul/ums-7.6.2
INFO  18:07:06.357 [main] Temporary directory: /tmp/UMS-jeanpaul
INFO  18:07:06.357 [main] Logging configuration file: /home/jeanpaul/ums-7.6.2/logback.xml
INFO  18:07:06.357 [main] Logfile: /home/jeanpaul/.config/UMS/debug.log
INFO  18:07:06.357 [main] 
INFO  18:07:06.357 [main] Profile directory: /home/jeanpaul/.config/UMS
INFO  18:07:06.357 [main] Profile directory permissions: drwx
INFO  18:07:06.357 [main] Profile configuration file: /home/jeanpaul/.config/UMS/UMS.conf
INFO  18:07:06.358 [main] Profile configuration file permissions: -rw-
INFO  18:07:06.358 [main] Profile name: G41M-2SH
INFO  18:07:06.358 [main] 
INFO  18:07:06.358 [main] Web configuration file: /home/jeanpaul/.config/UMS/WEB.conf
WARN  18:07:06.358 [main] Web configuration file not found: File "/home/jeanpaul/.config/UMS/WEB.conf" not found
INFO  18:07:06.358 [main] 
INFO  18:07:06.373 [main] Using database located at: "/home/jeanpaul/.config/UMS/database"
INFO  18:07:06.974 [main] Checking shared folder: "/home/jeanpaul/Vidéos"
INFO  18:07:06.974 [main] Checking shared folder: "/home/media/4dda761b-6c74-46f9-b49b-3d466aba12f2/films"
WARN  18:07:06.975 [main] "/home/media/4dda761b-6c74-46f9-b49b-3d466aba12f2/films" does not exist. Please remove it from your shared folders list on the "Paramètres de navigation / partage" tab or in the configuration file.
INFO  18:07:06.975 [main] Checking shared folder: "/media/homeancien/Videos old"
WARN  18:07:06.975 [main] "/media/homeancien/Videos old" does not exist. Please remove it from your shared folders list on the "Paramètres de navigation / partage" tab or in the configuration file.
INFO  18:07:06.975 [main] Checking shared folder: "/media/homeancien/images"
WARN  18:07:06.975 [main] "/media/homeancien/images" does not exist. Please remove it from your shared folders list on the "Paramètres de navigation / partage" tab or in the configuration file.
INFO  18:07:06.975 [main] Checking shared folder: "/home/jeanpaul/Images"
INFO  18:07:07.400 [main] Using the following UUID configured in UMS.conf: dc936447-3440-4031-bfae-2d5c3a9a76bd
INFO  18:07:07.450 [main] Loading MediaInfo library
INFO  18:07:07.491 [main] Loaded MediaInfoLib - v17.12
INFO  18:07:07.494 [main] Loading renderer configurations from /home/jeanpaul/ums-7.6.2/renderers

Ne  pouvant les inscrire depuis la fenêtre de configuration de USM ,je les ai rajoutés a la main /media/.....
Quel chemin indiquer pour que ces disques soient pris en compte ??
Merci

En ligne

#6 Le 07/12/2018, à 11:51

laslack

Re : problème de configuration UMS RESOLU

J'ai modifié le chemin pour mes dd ( j'avais mis /media)  pour /mnt , pas ce la n'a pas donné de résultats.

En ligne

#7 Le 07/12/2018, à 19:01

erresse

Re : problème de configuration UMS RESOLU

Je ne comprends pas très bien où tu bloques, puisqu'on peut lister les volumes à explorer dans UMS...
Si tu regardes le fichier de configuration dans "~/.config/UMS/UMS.conf", tu verras le(s) dossier(s) indiqués en adressage absolu (donc le chemin complet vers le répertoire objet). Les répertoires sont juste séparés par une virgule.
Plusieurs volumes sont possibles, à mon avis, en indiquant :

/home/user/Musique,/media/user/Vidéos,mnt/Images

Note: Attention au codage des lettres accentuées : Vidéos devient Vid\u00E9os dans le fichier de configuration.

laslack a écrit :

- 2 dd internes  montés au démarrage.

Je pense que ton problème provient plutôt des chemins que tu as indiqués pour l'accès à tes données, qui ne doivent pas être corrects. Que donne la commande :

mount | grep sd

Plus de 50 ans d'informatique, ça en fait des lignes de commandes en console, mais on n'avait pas le choix...
Excellente raison pour, aujourd'hui qu'on le peut, utiliser au maximum les INTERFACES GRAPHIQUES !
Important : Une fois résolu, pensez à clore votre sujet en ajoutant [Résolu] devant le titre du 1er message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Hors ligne

#8 Le 07/12/2018, à 23:39

laslack

Re : problème de configuration UMS RESOLU

Merci ,
voilà ce que ça donne :

jeanpaul@G41M-2SH:~$ mount | grep sd
/dev/sdd1 on / type ext4 (rw,relatime,errors=remount-ro,data=ordered)
cgroup on /sys/fs/cgroup/unified type cgroup2 (rw,nosuid,nodev,noexec,relatime,nsdelegate)
/dev/sdd3 on /home type ext4 (rw,relatime,data=ordered)
/dev/sdc1 on /mnt/b78b0088-f858-4525-9c92-5abe20619e9a type ext4 (rw,nosuid,nodev,relatime,stripe=32748,data=ordered,x-gvfs-show)
/dev/sda1 on /mnt/4dda761b-6c74-46f9-b49b-3d466aba12f2 type ext4 (rw,nosuid,nodev,relatime,data=ordered,x-gvfs-show)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)
/dev/sde1 on /media/jeanpaul/56825d5d-9526-4486-8de8-141bedfe5cc3 type ext4 (rw,nosuid,nodev,relatime,data=ordered,uhelper=udisks2)

sdd1 = systeme 18.04
sdd3=/home/jeanpaul/videos,/home/jeanpaul/images
sdc1=/mnt/homeancien/videos old,/mnt/omeancien/images
sda1=/mnt/stock/films
sde1= sauvegarde externe

et en retour du lancement de USM:

jeanpaul@G41M-2SH:~/ums-7.6.2$ ./UMS.sh
INFO  23:26:01.957 [main] Starting Universal Media Server 7.6.2
INFO  23:26:01.958 [main] Based on PS3 Media Server by shagrath, copyright 2008-2014
INFO  23:26:01.958 [main] https://www.universalmediaserver.com
INFO  23:26:01.958 [main] 
INFO  23:26:01.958 [main] Build: 2392f22e3 (2018-11-22)
INFO  23:26:01.958 [main] Java: Java HotSpot(TM) 64-Bit Server VM 1.8.0_191 (64-bit) by Oracle Corporation
INFO  23:26:01.959 [main] OS: Linux 64-bit 4.15.0-42-generic
INFO  23:26:01.961 [main] Maximum JVM Memory: 683 MiB
INFO  23:26:01.967 [main] Language: French
INFO  23:26:01.968 [main] Encoding: UTF-8
INFO  23:26:01.968 [main] 
INFO  23:26:01.968 [main] Working directory: /home/jeanpaul/ums-7.6.2
INFO  23:26:01.968 [main] Temporary directory: /tmp/UMS-jeanpaul
INFO  23:26:01.971 [main] Logging configuration file: /home/jeanpaul/ums-7.6.2/logback.xml
INFO  23:26:01.971 [main] Logfile: /home/jeanpaul/.config/UMS/debug.log
INFO  23:26:01.971 [main] 
INFO  23:26:01.971 [main] Profile directory: /home/jeanpaul/.config/UMS
INFO  23:26:01.971 [main] Profile directory permissions: drwx
INFO  23:26:01.971 [main] Profile configuration file: /home/jeanpaul/.config/UMS/UMS.conf
INFO  23:26:01.972 [main] Profile configuration file permissions: -rw-
INFO  23:26:01.972 [main] Profile name: G41M-2SH
INFO  23:26:01.972 [main] 
INFO  23:26:01.972 [main] Web configuration file: /home/jeanpaul/.config/UMS/WEB.conf
WARN  23:26:01.972 [main] Web configuration file not found: File "/home/jeanpaul/.config/UMS/WEB.conf" not found
INFO  23:26:01.972 [main] 
INFO  23:26:01.981 [main] Using database located at: "/home/jeanpaul/.config/UMS/database"
INFO  23:26:02.529 [main] Checking shared folder: "/home/jeanpaul/Vidéos"
INFO  23:26:02.529 [main] Checking shared folder: "/home/jeanpaul/Images"
INFO  23:26:02.530 [main] Checking shared folder: "/mnt/homeancien/videos old"
WARN  23:26:02.530 [main] "/mnt/homeancien/videos old" does not exist. Please remove it from your shared folders list on the "Paramètres de navigation / partage" tab or in the configuration file.
INFO  23:26:02.530 [main] Checking shared folder: "/mnt/homeancien/images"
WARN  23:26:02.530 [main] "/mnt/homeancien/images" does not exist. Please remove it from your shared folders list on the "Paramètres de navigation / partage" tab or in the configuration file.
INFO  23:26:02.530 [main] Checking shared folder: "/mnt/stock/films"
WARN  23:26:02.530 [main] "/mnt/stock/films" does not exist. Please remove it from your shared folders list on the "Paramètres de navigation / partage" tab or in the configuration file.
INFO  23:26:02.869 [main] Using the following UUID configured in UMS.conf: dc936447-3440-4031-bfae-2d5c3a9a76bd
INFO  23:26:02.913 [main] Loading MediaInfo library
INFO  23:26:02.939 [main] Loaded MediaInfoLib - v17.12
INFO  23:26:02.942 [main] Loading renderer configurations from /home/jeanpaul/ums-7.6.2/renderers

Voilà,j'espère que tu pourras me renseigner
Merci d'avance

En ligne

#9 Le 09/12/2018, à 16:30

laslack

Re : problème de configuration UMS RESOLU

J'ai trouvé un biais, j'ai cré un lien entre les dossiers de mon/home et les 2 dd  , et maintenant j'ai accès à tout

Merci pour ton aide

Chou Rave

En ligne

#10 Le 09/12/2018, à 17:02

erresse

Re : problème de configuration UMS RESOLU

Comme je le soupçonnais, il s'agit bien d'un problème de chemin incorrect. Regarde :
- Ton montage pour par exemple "homeancien"

/dev/sdc1 on /mnt/b78b0088-f858-4525-9c92-5abe20619e9a

- Ton adresse dans les paramètres de UMS

"/mnt/homeancien/videos old"

Tu donnes comme chemin "/mnt/homeancien/..." alors que le vrai chemin est "/mnt/b78b0088-f858-4525-9c92-5abe20619e9a/..." puisque le point de montage a hérité de l'UUID du volume et non de son nom...
Évidemment que le système ne trouve pas les dossiers dans ce cas !


Plus de 50 ans d'informatique, ça en fait des lignes de commandes en console, mais on n'avait pas le choix...
Excellente raison pour, aujourd'hui qu'on le peut, utiliser au maximum les INTERFACES GRAPHIQUES !
Important : Une fois résolu, pensez à clore votre sujet en ajoutant [Résolu] devant le titre du 1er message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Hors ligne