Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous souhaite d'excellentes fêtes de fin d'année !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 21/12/2018, à 19:34

descourvieresjm

suite à mise a niveau LTS16.04 LTS18.04, pb d'accès mon NAS [vers=1.0]

Suite à la mise à niveau d'ubuntu LTS16.04 32 bits vers LTS 18.04, je n'ai plus un acces automatique vers les partitions de mon NAS, comme d'ailleurs de la partition DATA en NTFS de mon disque dur:.
Par le gestionnaire de fichiers Nautilus ces différentes partitions ne sont plus visibles directements (passer par "autres emplacements" et cliquer sur Diskstation et donner le mot de passe...
De même problème avec Libre office, qui ne peut accéder aux documents récemment utilisés.

Lorsque je lance la commande :

sudo mount -a

J'ai comme réponse:

mount: /etc/fstab : erreur d'analyse à la ligne 15 — ignorée
mount: /etc/fstab : erreur d'analyse à la ligne 17 — ignorée

Dans fstab, j'ai en ligne 15 et 17:

//192.168.1.12/descjmf /media/jmf/descjmfdiskstation cifs credentials=/root/.smbcredentials,gid=100,uid=1000, iocharset=utf8	0	0

//192.168.1.12/photo /media/jmf/photodiskstation cifs credentials=/root/.smbcredentials,gid=100, uid=1000, iocharset=utf8	0	0

J'ai recréer le fichier .smbcredentials (qui était déjà présent) et j'ai toujours le problème.…

Pour l’accès à la partition de données du disque dur (appelée DATA) ; elle n'est pas montée dans le fstab, mais sur mon PC portable où elle est présente dans le fstab, la partition DATA n'est toujours pas présente dans le gestionnaire de fichier, et libreoffice n'y accède pas par la fonction "derniers documents utilisés..

J'ai donc là 2 problèmes , je les ai mis dans la meme discussion car il me semble que la réponse doit être du même type pour les 2...

Merci pour vos réponses et bonnes fêtes de fin d'année
Descourvières Jean-Marie

Modération : merci d'utiliser les balises code pour les commandes et leur retour (icône < >). Déplacé dans la section NAS.

Dernière modification par Ayral (Le 16/01/2019, à 21:09)

Hors ligne

#2 Le 28/12/2018, à 16:50

Fredouillemugen

Re : suite à mise a niveau LTS16.04 LTS18.04, pb d'accès mon NAS [vers=1.0]

Salut,
1) Questions bêtes, mais tes dossiers "descjmfdiskstation" et "photodiskstation" sont-ils bien existants dans /media/jmf tels qu'écrit dans ton fstab ?
2) Pourrais-tu donner le résultat de la commande "id" dans un terminal ?
3) Je me demande si le gid n'est pas faux, ton user semble être le principal, du coup son gid devrait selon moi être 1000 (et non 100).
4) Je déplacerais le fichier ".smbcredentials" dans le dossier user, ici pour toi dans "/home/jmf" (dans root c'est plus secure, mais ma logique veut que les cred d'un user soient dans son /home/user)
5) Ensuite, voici ma proposition d'entrées dans le fstab :

//192.168.1.12/descjmf /media/jmf/descjmfdiskstation cifs credentials=/home/jmf/.smbcredentials,iocharset=utf8,gid=1000,uid=1000,_netdev	0	0
//192.168.1.12/photo /media/jmf/photodiskstation cifs credentials=/home/jmf/.smbcredentials,iocharset=utf8,gid=1000,uid=1000,_netdev	0	0

Dernière modification par Fredouillemugen (Le 28/12/2018, à 19:49)


La raison a ses raisons que la raison ne connait pas...
---
Chérie apportes-moi une bière, stp ! Non lèves-toi...
Sudo Chérie apporte moi une bière stp ! ...

Hors ligne

#3 Le 28/12/2018, à 17:21

michel_04

Re : suite à mise a niveau LTS16.04 LTS18.04, pb d'accès mon NAS [vers=1.0]

Bonjour,


Sur la page Accéder à votre NAS depuis toutes les applications de la documentation :

Doc a écrit :

Depuis La version 17.04 d' Ubuntu il faut rajouter:[vers=1.0] dans les options pour que ça fonctionne. Par exemple après [_netdev]


A+

Hors ligne

#4 Le 28/12/2018, à 17:34

Fredouillemugen

Re : suite à mise a niveau LTS16.04 LTS18.04, pb d'accès mon NAS [vers=1.0]

Bonjour Michel,
Ok, bon à savoir en cas de besoin :-) merci de la précision !
Toutefois, chez moi en 18.04, je fonctionne sans et tout ok :-)


La raison a ses raisons que la raison ne connait pas...
---
Chérie apportes-moi une bière, stp ! Non lèves-toi...
Sudo Chérie apporte moi une bière stp ! ...

Hors ligne

#5 Le 15/01/2019, à 20:52

descourvieresjm

Re : suite à mise a niveau LTS16.04 LTS18.04, pb d'accès mon NAS [vers=1.0]

excusez de mon temps à répondre: il y a eu un décès et je viens d'être opéré d'une hanche.. Tout va bien.
J'ai fait la procédure préconisée par Fredouillemugen:
1-J'ai bien les dossiers descjmfdiskstation et ...... dans /media/jmf.  Mais je remarque que le dossier /media/jmf est verouillé (acces uniquement par le root)
2-Par la commande "id", j'ai bien un gid=1000.
3 j'ai donc mis le gid à 1000.
4 j'ai créé un.smbcredentials dans le home/jmf.
5 et j'ai modifié le fstab comme proposé.
Mais j'ai toujours le même problème : ligne 15 et 17 ignorée par la commande mount. et quand j'essaie d'accéder à descjmfdiskstation par le gestionnaire de fichiers, j'ai en réponse:
"impossible d'accéder à descdiskstation; mount : etc/fstab: erreur d'analyse à la ligne 17 -ignorée  et "mount /media/jmf/media/descjmfdiskstation: opération permited for root only".
Si je comprends bien est un problème d'acces au répertoire /média/jmf.  Mais je ne sais comment en donner la permision. 
Merci pour vos réponses à venir...

nb: je ne sais comment faire pour rajouter:[vers=1.0]. proposé par Michel.. Où rajouter celà et comment??
jean-Marie Descourvières

Hors ligne

#6 Le 16/01/2019, à 21:12

Ayral

Re : suite à mise a niveau LTS16.04 LTS18.04, pb d'accès mon NAS [vers=1.0]

Modération ! Suite à un problème de santé, l'auteur de cette discussion reprend le fil. merci de reprendre le fil avec lui. Merci.

Dernière modification par Ayral (Le 16/01/2019, à 21:12)


Pour mettre les retours de commande entre deux balises code, les explications sont là : https://forum.ubuntu-fr.org/viewtopic.php?id=1614731
Blog d'un retraité
Site de graphisme du fiston Loïc
Ubuntu 14.04 LTS sur un desktop et 16.04 sur un Dell Latitude 820

Hors ligne

#7 Le 17/01/2019, à 11:33

descourvieresjm

Re : suite à mise a niveau LTS16.04 LTS18.04, pb d'accès mon NAS [vers=1.0]

Merci à Ayral de faire la relance: J'ai donc repris le fil dans la réponse #5... dans laquelle il m'est signalé que mon dossier /media/jmf est verrouillé. Mais comment déverrouiller?

Hors ligne

#8 Le 17/01/2019, à 19:55

Fredouillemugen

Re : suite à mise a niveau LTS16.04 LTS18.04, pb d'accès mon NAS [vers=1.0]

Hello, toutes mes condoléances, et bon rétablissement aussi !
Juste pour assurer le coups, pourrais-tu vérifier les droits de ton user dans la config de ton NAS pour les dossiers concernés ? (Quelle marque et modèle de NAS as-tu ?)
Je suis chargé en ce moment professionnellement et ne promet pas pouvoir revenir rapidement, dimanche je repasse, et nous ne te laisserons pas tomber, nous sommes beaucoup ici :-)

Dernière modification par Fredouillemugen (Le 17/01/2019, à 19:56)


La raison a ses raisons que la raison ne connait pas...
---
Chérie apportes-moi une bière, stp ! Non lèves-toi...
Sudo Chérie apporte moi une bière stp ! ...

Hors ligne

#9 Le 18/01/2019, à 14:21

descourvieresjm

Re : suite à mise a niveau LTS16.04 LTS18.04, pb d'accès mon NAS [vers=1.0]

merci pour cette reprise de contact.
Concernant mon nas. c'est un synology DS210j. J'utilise le meme nom et mot de pass que les ordinateurs qui y sont connectés.
Le problème est apparu lors de la mise à niveau d'ubuntu 16.04 vers 18.04. et comme je le dis en #5, c'est un problème d'acces à media/jmf, qui est verrouillé par root.
Je ne sais pas par quelle commande, supprimer ce verrou....
NB: J'ai également le meme problème avec mon ordinateur portable sur lequel j'ai fait la même mise à niveau
Pour acceder aux partitions du Nas, je dois passer par le gestionnaire de fichiers, "autres emplacements" puis par le réseau, en donnant mon nom d'utilisateur et mot de pass.
Ca marche, mais je n'ai pas avec mes logiciels courants (libre-office....etc...) accès aux dossiers du Nas.....

Pour l'instant, je ne vois qu'une solution: supprimer les dossiers répertoires media/jmf/ et les recreer.....
merci pour votre aide de dimanche...

Hors ligne

#10 Le 18/01/2019, à 20:14

Fredouillemugen

Re : suite à mise a niveau LTS16.04 LTS18.04, pb d'accès mon NAS [vers=1.0]

Ok tentes voir de réinstaller samba :
    sudo apt install --reinstall samba

et d'installer ceci :
    sudo apt-get install cifs-utils

Puis redémarre et test, je repasse dimanche ou lundi soir, mais d'ici là d'autres pourront peut-être t'aider également :-)

Pour info : https://doc.ubuntu-fr.org/tutoriel/monterpartagewindows


La raison a ses raisons que la raison ne connait pas...
---
Chérie apportes-moi une bière, stp ! Non lèves-toi...
Sudo Chérie apporte moi une bière stp ! ...

Hors ligne

#11 Le 19/01/2019, à 10:31

descourvieresjm

Re : suite à mise a niveau LTS16.04 LTS18.04, pb d'accès mon NAS [vers=1.0]

Je viens de réinstaller samba, et cifs-utils était déjà installé.
J'ai toujours erreur ligne17 de fstab quand je veux acceder à descjmfdiskstation par le gestionnaire de fichier.
1-Je vous redonne le fstab ligne 17:

//192.168.1.12/descjmf /media/jmf/descjmfdiskstation cifs credentials=/home/jmf/.smbcredentials,iocharset=utf8,gid=1000,uid=1000,_netdev	0	0

2- je vous confirme que mon user (media/jmf/) est verouillé par root...
3-le ".smbcredentials" est dans le dossier "/home/jmf"

nb: j'ai essayé de supprimer mon dossier média/jmf , mais je n'ai pas pu. 

a bientôt
jmdescourvieres

merci pour la suite

Hors ligne

#12 Hier à 15:01

Fredouillemugen

Re : suite à mise a niveau LTS16.04 LTS18.04, pb d'accès mon NAS [vers=1.0]

Essaies-voir de recréer un nouveau dossier dans /media, par exemple descjmfdiskstation2, avec la commande suivante :
#sudo mkdir /media/descjmfdiskstation2
Puis adapte ton fstab avec le nouveau dossier
(j'ai fait exprès de te proposer de ne pas le monter dans jmf, pour voir)

Ensuite, va editer le fichier nsswith.conf
#sudo gedit /etc/nsswitch.conf

Trouves la ligne suivante :
hosts: files mdns4_minimal [NOTFOUND=return] dns

Modifies là comme suit :
hosts: files mdns4_minimal [NOTFOUND=return] wins dns

Redémarre la machine et test à nouveau !

Dernière modification par Fredouillemugen (Hier à 15:05)


La raison a ses raisons que la raison ne connait pas...
---
Chérie apportes-moi une bière, stp ! Non lèves-toi...
Sudo Chérie apporte moi une bière stp ! ...

Hors ligne

#13 Hier à 15:08

Fredouillemugen

Re : suite à mise a niveau LTS16.04 LTS18.04, pb d'accès mon NAS [vers=1.0]

Accessoirement, pourrais-tu te positionner dans /media et me donner le retour de "ls -all", pour voir les droits du dossier jmf, stp

Dernière modification par Fredouillemugen (Hier à 15:10)


La raison a ses raisons que la raison ne connait pas...
---
Chérie apportes-moi une bière, stp ! Non lèves-toi...
Sudo Chérie apporte moi une bière stp ! ...

Hors ligne

#14 Hier à 17:40

descourvieresjm

Re : suite à mise a niveau LTS16.04 LTS18.04, pb d'accès mon NAS [vers=1.0]

-Je réponds à votre question #13:

jmf@jmf-PCnoir:/media$ ls -all
total 12
drwxrwxrwx   3 root root 4096 jan 17 16:22 .
drwxr-xr-x  23 root root 4096 déc 21 16:56 ..
drwxr-x---+  7 root root 4096 jan 16 18:41 jmf
jmf@jmf-PCnoir:/media$ 

celà correspond-il à votre attente...
et j'essaie de réaliser #12

Hors ligne

#15 Hier à 18:12

descourvieresjm

Re : suite à mise a niveau LTS16.04 LTS18.04, pb d'accès mon NAS [vers=1.0]

Et je viens de réaliser la proposition #12:
Une première fois sans changer l'adresse de .smbcredentials que j'avais mis sous /home/jmf/ comme demandé en #2
une 2ieme fois en remettant le .smbcredentials sous /root/
mais j'ai toujours un refus d'accès à descdiskstation:
"erreur d'analyse à la ligne 17. ignorer mount:/media/diskstation2: opération for root only...

merci pour la suite à dobnner.........

Hors ligne

#16 Hier à 20:17

Fredouillemugen

Re : suite à mise a niveau LTS16.04 LTS18.04, pb d'accès mon NAS [vers=1.0]

Tente voir un truc tout bête qui me titille en relisant le résultat de ton post #14
va dans ton dossier media en terminal :

cd /media

puis ton user étant jmf et ton dossier dans media étant aussi jmf, il me semble sinon adapte les infos, entre la commande suivante :

sudo chown -R jmf:jmf /jmf

ensuite :

sudo mount -a

est-ce que cela aura résolu ton soucis ?
redonnes-moi le retour de ls -all dans le dossier /media et dans le dossier /media/jmf
stp
Bonne nuit

Dernière modification par Fredouillemugen (Hier à 20:53)


La raison a ses raisons que la raison ne connait pas...
---
Chérie apportes-moi une bière, stp ! Non lèves-toi...
Sudo Chérie apporte moi une bière stp ! ...

Hors ligne