Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 02/01/2019, à 13:36

Segbru

problème HDMI : écran noir ; xrandr semble bien détecter l'écran

Bonjour à toutes et à tous,

J'ai un problème depuis quelques jours : mon port HDMI semble KO :
Tout marchait convenablement jusqu'à ce qu'hier l'écran reste noir.

Il ne me semble pas avoir fait de mise à jour depuis la dernière utilisation.

J'ai essayé de changer de cable hdmi : ce n'est pas le problème.
J'ai essayé de changer d'écran : ce n'est pas le problème.
J'ai essayé de brancher un autre PC : cet autre PC n'a eu aucun problème à se connecter.

xrandr renvoie :

bouddhius@Phoenix-III:~$ xrandr
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
eDP-1-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 193mm
   1920x1080     60.01*+  60.01    59.97    59.96    59.93  
   1680x1050     59.95    59.88  
   1600x1024     60.17  
   1400x1050     59.98  
   1600x900      59.99    59.94    59.95    59.82  
   1280x1024     60.02  
   1440x900      59.89  
   1400x900      59.96    59.88  
   1280x960      60.00  
   1440x810      60.00    59.97  
   1368x768      59.88    59.85  
   1360x768      59.80    59.96  
   1280x800      59.99    59.97    59.81    59.91  
   1152x864      60.00  
   1280x720      60.00    59.99    59.86    59.74  
   1024x768      60.04    60.00  
   960x720       60.00  
   928x696       60.05  
   896x672       60.01  
   1024x576      59.95    59.96    59.90    59.82  
   960x600       59.93    60.00  
   960x540       59.96    59.99    59.63    59.82  
   800x600       60.00    60.32    56.25  
   840x525       60.01    59.88  
   864x486       59.92    59.57  
   800x512       60.17  
   700x525       59.98  
   800x450       59.95    59.82  
   640x512       60.02  
   720x450       59.89  
   700x450       59.96    59.88  
   640x480       60.00    59.94  
   720x405       59.51    58.99  
   684x384       59.88    59.85  
   680x384       59.80    59.96  
   640x400       59.88    59.98  
   576x432       60.06  
   640x360       59.86    59.83    59.84    59.32  
   512x384       60.00  
   512x288       60.00    59.92  
   480x270       59.63    59.82  
   400x300       60.32    56.34  
   432x243       59.92    59.57  
   320x240       60.05  
   360x202       59.51    59.13  
   320x180       59.84    59.32  
DP-1-1 disconnected (normal left inverted right x axis y axis)
HDMI-1-1 disconnected (normal left inverted right x axis y axis)
HDMI-1-2 connected (normal left inverted right x axis y axis)
   1920x1080     60.00 +  60.00    50.00    50.00    59.94    24.00    23.98  
   1920x1080i    60.00    60.00    50.00    50.00    59.94  
   1280x1024     60.02  
   1280x720      60.00    60.00    50.00    50.00    59.94  
   1024x768      60.00  
   800x600       60.32  
   720x576       50.00    50.00  
   720x576i      50.00    50.00  
   720x480       60.00    60.00    59.94    59.94  
   720x480i      60.00    60.00    59.94    59.94  
   640x480       60.00    59.94    59.94  

Donc l'écran est bien reconnu, comme le confirme l'onglet préférences->périphériques->écrans ainsi que d'après ce que me renvoie arandr.

J'étais jusqu'alors avec le driver nvidia 415.
Je suis repassé sous le pilote nouveau : pas de changement.
J'ai fait la mise à jour vers ubuntu 18.10 : pas de changement
J'ai essayé de booter sur une vieille debian : pareil quand je connecte le HDMI tout semble fonctionner correctement d'après le logiciel, mais l'écran reste noir. Sur un deuxième PC, cette version de debian marchait fort bien en HDMI.

J'ajoute dans les choses qui m'ont un peu dérouté (et qui font un peu peur) : cela faisait un petit moment que j'avais un bug lorsque j'essayais de joindre les écrans : parfois les écrans clignotait jusqu'à ce que je débranche/rebranche le cable HDMI ou encore, il arrivait dans les même circonstances qu'une zone de l'écran mal affichée (je n'ai malheureusement pas de capture d'écran). Mais ce problème semble s'être résolu depuis le passage sous ubuntu 18.10...

Finalement ce fameux jour où l'hdmi n'a plus marché, en rebootant le PC, celui-ci a booté sur le bios direct, sans que je me souvienne avoir touché la fameuse touche qui permet d'y rentrer...

Je commence à penser que le problème est un problème de bios ou de hardware en général. Je ne trouve pas d'option spécifique aux cartes graphiques ou aux ports HDMI...
Si vous avez quelque idée de ce qui peut bien se passer, ou de comment régler le problème, ou même si vous pensez à quelque chose à laquelle je n'ai pas pensé, vous êtes les bienvenus.

La bonne journée -et la bonne année- à vous !!

Hors ligne

#2 Le 03/01/2019, à 11:10

TheSun

Re : problème HDMI : écran noir ; xrandr semble bien détecter l'écran

Peut être que le HDMI ou la carte graphique à des soucis niveau hardware, c'est un pc de bureau ou un pc portable ? car si c'est un pc de bureau la solution est simple : tu changes la carte graphique par une autre intégrant un port HDMI. Sur leboncoin t'en trouvera des pas cher, pas besoin d'un truc récent. De préférence prendre une Nvidia et pas une Ati.

C'est quoi le modèle de PC que tu as ? et quelle est la référence de ta carte Nvidia actuelle ?

Hors ligne

#3 Le 03/01/2019, à 15:52

Segbru

Re : problème HDMI : écran noir ; xrandr semble bien détecter l'écran

Bonjour, le PC en question est un MSI GL62M 7RDX - portable donc :-( avec une carte graphique Nvidia Geforce GTX 1050 mobile.

Je vais tenter une mise à jour du BIOS dans quelques jours car je ne suis pas chez moi actuellement, des fois que cela permette de résoudre le problème. Mais je ne comprend vraiment pas pourquoi je "vois les écrans" : je peux les activer, les désactiver, les résolutions et leurs noms sont corrects, mais ceux-ci restent toujours noir...

Hors ligne