Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 02/01/2019, à 14:01

Kisis

[LXQt] Le bureau a disparu

Bonjour à toutes et à tous !!

Si je viens quérir votre aide aujourd'hui, c'est que j'ai à faire avec un bug que je ne comprends absolument pas.
Il y a maintenant une semaine, j'ai supprimé Windows de mon laptop pour installer linux dessus. J'ai essayé arch, mais étant relou à installer, je me suis focalisé sur un truc plus simple à mettre et léger : Lubuntu (dont la dernière version utilise LXQt).

Tout marchait bien (excepté le wi-fi car ma carte réseau n'a aucun "driver" sous linux, mais c'est un autre sujet), jusqu'au jour où je lance ma session et que je voit que je n'ai plus de bureau. Comment ça, plus de bureau, me direz vous ?

Eh bien c'est difficile à expliquer, mais en gros, quand il n y a aucune fenêtre d'active, mon bureau "prend" l'aspect de la dernière image affiché. Genre quand j'ouvre ma session et que LXQt se lance, ben mon bureau ressemble au login screen. Quand j'ai une fenêtre firefox et que je la réduit sur la barre des tâches, mon bureau prend l'aspect de firefox. Comme si c'était un trou noir et qu'il n'existait plus.

La seule chose dont je me rappelle avoir fait pour subir cette divine punition, c'est d'avoir lancé un sudo apt update puis un sudo apt upgrade pour mettre à jour mes paquets.

Ci-dessous la vision horrifique que cela me provoque parfois :
http://image.noelshack.com/fichiers/201 … ubuntu.png
Pour obtenir ça, j'ai juste changé la taille de ma fenêtre firefox et je l'ai baladé un peu partout. Sympa, non ?

Je suis bien sûr prêt à fournir quoi que ce soit qui vous permettrait de mieux comprendre la situation et éventuellement de trouver une solution à ce problème.

Merci d'avance !


Modération : merci d'utiliser des images de petite taille (300x300) ou des miniatures pointant sur ces images (Des hébergeurs comme Toile Libre ou TDCT'Pix le permettent).

Dernière modification par cqfd93 (Le 02/01/2019, à 18:53)

Hors ligne

#2 Le 02/01/2019, à 17:25

Martial34

Re : [LXQt] Le bureau a disparu

Bonjour.
Commence par réinstaller Pcmanfm.
Puis fais un clic droit sur le bureau, et regarde si quelque chose cloche dans les « préférences du bureau ».

En ligne

#3 Le 03/01/2019, à 16:03

Kisis

Re : [LXQt] Le bureau a disparu

Du coup j'ai reinstallé pcmanfm avec cette commande :

sudo apt install --reinstall pcmanfm pcmanfm-qt pcmanfm-qt-l10n

Cela n'a rien changé sad
Pour ce qui est du bureau, c'est assez intriguant car le clic droit sur le bureau ressemble à ça :
1546523866.png
Quand j'essaye d'aller sur desktop settings, cela charge dans le vide et ne fait rien.
Quand j'essaye d'aller sur openbox config, ça me met un message d'erreur qu'on peut voir au milieu de l'image précedente.

EDIT :
J'ai refait un screenshot pour que tu puisses mieux voir à quoi ressemble le clic-droit sur le bureau :
1546524686.png

Dernière modification par Kisis (Le 03/01/2019, à 16:14)

Hors ligne

#4 Le 03/01/2019, à 18:52

Martial34

Re : [LXQt] Le bureau a disparu

Tu as changé ton gestionnaire de fenêtres ?
Voici une liste des paquets que tu dois avoir, sachant que « qt » n’est pas encore opérationnel sur tous les ordinateurs, et qu’en attendant, il vaut mieux s’en tenir à « gtk ».
lxpanel
openbox
obconf
lxrandr
lxsession

En ligne

#5 Le 03/01/2019, à 20:14

Coeur Noir

Re : [LXQt] Le bureau a disparu

Comment ça « qt » n’est pas encore opérationnel sur tous les ordinateurs ???

Ça ressemble assez à un problème de pilote graphique / problème de rafraîchissement d'image.

Y-a-t-il sur cet ordinateur une carte graphique nvidia ou amd qui nécessiterait un pilote spécifique ?

Hors ligne

#6 Le 03/01/2019, à 20:22

Kisis

Re : [LXQt] Le bureau a disparu

Pas à ma connaissance, la seule chose que j'ai faite est un

sudo apt autoremove

, puis un

sudo apt update

suivi d'un

sudo apt upgrade

Et après, au reboot, le bureau était comme ça... sad

Martial34 a écrit :

Voici une liste des paquets que tu dois avoir, sachant que « qt » n’est pas encore opérationnel sur tous les ordinateurs, et qu’en attendant, il vaut mieux s’en tenir à « gtk ».

Ah bon ? En tout cas moi, je n'ai rien installé par initiative personnelle, lxqt était déjà  mon environnement par défaut quand j'ai installé Lubuntu. Et, cela marchait bien avant ! sad

J'ai réinstallé les paquets signifiés, et cela n'a rien changé au problème. Par contre maintenant, j'ai deux fenêtres de configuration pour openbox ! Du coup quand je clique droit sur le bureau et vais dans "Openbox configuration", j'ai accés à un tout nouveau panneau de configuration flambant neuf. Après une recherche dans mes paquets, j'avais bien obconf mais version qt (obconf-qt). Je suppose que c'est le panel de configuration que j'accédais par le panel de configuration général de lxqt.

EDIT :

Coeur Noir a écrit :

Ça ressemble assez à un problème de pilote graphique / problème de rafraîchissement d'image.

Y-a-t-il sur cet ordinateur une carte graphique nvidia ou amd qui nécessiterait un pilote spécifique ?

Non, c'est un tout petit pc qui n'a qu'une chipset Intel au niveau graphique.

Dernière modification par Kisis (Le 03/01/2019, à 20:29)

Hors ligne

#7 Le 03/01/2019, à 21:59

Roschan

Re : [LXQt] Le bureau a disparu

Kisis a écrit :
Martial34 a écrit :

Voici une liste des paquets que tu dois avoir, sachant que « qt » n’est pas encore opérationnel sur tous les ordinateurs, et qu’en attendant, il vaut mieux s’en tenir à « gtk ».

Ah bon ? En tout cas moi, je n'ai rien installé par initiative personnelle, lxqt était déjà  mon environnement par défaut quand j'ai installé Lubuntu. Et, cela marchait bien avant ! sad

Ne t'inquiète pas il raconte n'importe quoi, ça fait 20 ans que Qt est opérationnel, et LXQt est un environnement qui a eu une longue phase de test avant d'être installé par défaut, il est donc assez fiable pour être utilisé.

En ligne

#8 Le 04/01/2019, à 00:11

Coeur Noir

Re : [LXQt] Le bureau a disparu

sudo apt full-upgrade

plutôt, suivi d'un

sudo apt install -f

des fois qu'un paquet aurait été oublié ?

En postant les retours de commande ici.

Es-tu en mesure de démarrer ton pc sur un noyau Linux précédent ( recovery mode ) et si oui est-ce que ça change quelque chose ?

Hors ligne

#9 Le 04/01/2019, à 15:28

Kisis

Re : [LXQt] Le bureau a disparu

J'ai effectué un :

sudo apt full-upgrade

Le retour de la commande :

kisis@kisis-pc:~$ sudo apt full-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants seront mis à jour :
  tzdata
1 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 189 ko dans les archives.
Après cette opération, 14,3 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
Réception de:1 http://archive.ubuntu.com/ubuntu cosmic-updates/main amd64 tzdata all 2018i-0ubuntu0.18.10 [189 kB]
189 ko réceptionnés en 2s (94,9 ko/s)
Préconfiguration des paquets...
(Lecture de la base de données... 253541 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../tzdata_2018i-0ubuntu0.18.10_all.deb ...
Dépaquetage de tzdata (2018i-0ubuntu0.18.10) sur (2018g-0ubuntu0.18.10) ...
Paramétrage de tzdata (2018i-0ubuntu0.18.10) ...

Current default time zone: 'Europe/Paris'
Local time is now:      vendredi 4 janvier 2019, 13:29:42 (UTC+0100).
Universal Time is now:  Fri Jan  4 12:29:42 UTC 2019.
Run 'dpkg-reconfigure tzdata' if you wish to change it.

Pour ce qui est de sudo apt install -f, je ne sais pas sur quel paquet le faire sad

Lancement en mode recovery :
Le bureau ne bug plus en recovery mode, il est juste noir mais "agit" normalement.
J'en ai profité pour lancer un utilitaire (dkpkg je crois) me permettant de "réparer" les paquets cassés, mais cela n'a eu aucun effet.

J'ai eu quelques observations supplémentaires qui pourraient peut-être préciser le problème :
Quand j'essaye d'aller dans les paramètres du bureau dans le panneau de configuration LXQt, cela charge dans le vide et ne me donne rien (comme lors du clic droit sur le bureau).
En lancant Compton (qui est inactif par défaut), le bureau devient gris et ne bug plus (mais je n'ai toujours pas accés à ses paramètres dans le panneau de configuration).
En lançant "Préférences du Bureau" (il apparaît dans la sorte de menu démarrer quand je tape "comp"), celui-ci me met un message d'erreur qui indique que "Le gestionnaire de bureau est inactif".
Veuillez trouver ci dessous une image résumant un peu toutes ces découvertes :
1546608375.png

Dernière modification par Kisis (Le 04/01/2019, à 15:30)

Hors ligne