Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 29/08/2018, à 22:16

JME44

[Résolu] 18.04 Perte de la liaison filaire

Bonjour,

Ce message est une amélioration de celui-ci.

Après quelques mois d'utilisation, j'ai perdu mon accès filaire en 18.04 cependant il fonctionne toujours parfaitement en 16.04 (multiboot).
*- On ne peut incriminer le BIOS car le boot 16.04 gère bien la liaison filaire.
*- Ce n'est pas un problème matériel pour la même raison.

On est donc en présence d'un problème logiciel.

Je n'ai pas trouvé comment réinstaller les paquets réseau alors je me torture avec les nouvelles fonctions netplan en vain.

(note : je n'indique pas les sudo car j'ai fait sudo su)

La commande ip addr donne

root@maMachine:monRepertoire# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp2s0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether 10:bf:48:d9:b7:ae brd ff:ff:ff:ff:ff:ff
3: wlp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether d0:df:9a:ea:fb:fc brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.36/24 brd 192.168.0.255 scope global dynamic noprefixroute wlp3s0
       valid_lft 40912sec preferred_lft 40912sec
    inet6 fe80::2c9f:a058:d9fd:cd66/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
root@maMachine:monRepertoire# 

Je déduis que mon rj45 et le n° 2 enp2s0 qui est DOWN
La connexion internet via mon smartphone en point d'accès mobile/modem usb ne fonctionne pas plus.

La commande nmcli indique

root@maMachine:monRepertoire# nmcli
wlp3s0: connecté to monWifi
        "Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express)"
        wifi (ath9k), D0:DF:9A:EA:FB:FC, hw, mtu 1500
        ip4 par défaut
        inet4 192.168.0.36/24
        route4 0.0.0.0/0
        route4 192.168.0.0/24
        route4 169.254.0.0/16
        inet6 fe80::2c9f:a058:d9fd:cd66/64
        route6 ff00::/8
        route6 fe80::/64
        route6 fe80::/64

enp2s0: non-géré
        "Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller"
        ethernet (r8169), 10:BF:48:D9:B7:AE, hw, mtu 1500

lo: non-géré
        "lo"
        loopback (unknown), 00:00:00:00:00:00, sw, mtu 65536

DNS configuration:
        servers: 192.168.0.254
        interface: wlp3s0

Utilisez « nmcli device show » pour obtenir des informations complètes sur les périphériques connus et « nmcli connection show » pour obtenir une vue d'ensemble des profils de connexions actifs.

Consultez les pages de manuel nmcli(1) et nmcli-examples(5) pour les détails complets d'utilisation.
root@maMachine:monRepertoire# 

La Connexion filaire 1 n'est pas liée au périphérique enp2s0.

Les commandes systemctl restart NetworkManager.service et netplan -d apply donnent

root@maMachine:monRepertoire# netplan systemctl restart NetworkManager.service,
bind: Address already in use
netplan: fatal error: cannot bind to port 2983, is another daemon running?, exiting.
root@maMachine:monRepertoire# netplan -d apply
netplan: netplan version 2.2 starting at Wed Aug 29 21:57:38 2018
netplan: database directory is /var/lib/plan/netplan.dir
netplan: user "netplan" is uid 63434 gid 63434
netplan: switching from user <root> to <uid 63434 gid 63434>
netplan: running with uid=63434 gid=63434 euid=63434 egid=63434
netplan: reading access list file /var/lib/plan/netplan.dir/.netplan-acl
netplan: netplan/tcp not found in /etc/services, using ports 2983 and 5444
bind: Address already in use
netplan: fatal error: cannot bind to port 2983, is another daemon running?, exiting.
netplan: exiting, writing all modified files to disk
root@maMachine:monRepertoire# netplan -d apply

Donc, il manque des services et le port 2983 est occupé ! Par qui ?

J'ai aussi remarqué la création d'un nouvel utilisateur netplan daemon user.
Comme il n'était pas plus daemon que moi, je l'ai détruit.

Il me semble envisageable de corriger ce problème en installant les paquets ifconfig mais si ubuntu passe à netplan, autant participer à la démarche plutôt que de se retrouver avec les logiciels périmés.

Merci de m'indiquer par quel bout prendre les choses ?

Dernière modification par JME44 (Le 10/01/2019, à 22:10)


Ubuntu 18.04 LTS GNOME 3.28.1 sur Asus X93S.

Hors ligne

#2 Le 10/01/2019, à 22:05

JME44

Re : [Résolu] 18.04 Perte de la liaison filaire

Sans réponse, j'ai fait une ré-installation : sans formatage du / ne donne aucun bénéfice, avec formatage, tout roule mais il le faut réinstaller tous les logiciels !


Ubuntu 18.04 LTS GNOME 3.28.1 sur Asus X93S.

Hors ligne