Contenu | Rechercher | Menus

Annonce

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 09/02/2019, à 10:47

Zococo

[Résolu]Paramétrage ssh

Bonjour,

Je ne parviens pas à me connecter en ssh à un autre Pc sur mon réseau local lorsque je suis dans mon terminal (authentification par mdp), la connexion des répertoires via Nautilus ne fonctionne pas non plus en revanche je peux me connecter avec Putty. J'ai le même problème avec mon NAS.
Pourtant avec un autre Pc ça fonctionne bien (échange de clés).
J'ai pensé qu'il y avait un problème d'autorisation dans sshd_config mais comme ça fonctionne avec Putty il y a peut-être une autre explication et je ne trouve pas laquelle.
Les explications sur le net sont très largement axées sur les question de PasswordAuthentication et d’échange de clés mais sur mon problème je ne trouve pas grand chose.
Je me connecte en mode Password (en réseau local) et les ip et password sont bons (d'ailleurs ils fonctionnent avec Putty !).
Quelqu’un peut-il m'expliquer pourquoi ça fonctionne avec Putty et pas avec le terminal ?
Je suis en train de me battre avec le PC serveur, je voudrais éviter l'échange de clés si je dois réinstaller 3 fois (je suis déjà à 7 ou 8). Et ça fonctionne avec Putty !
Merci !

Nom du PC client : Pc-Client
Utilisateur sur PC client : utilisateur
IP du client : 192.168.0.25
Nom du PC serveur : PC-Serveur
Utilisateur sur PC serveur : usr-srvr
IP du serveur : 192.168.0.47

Port utilisé : 2222

Fichier sshd-config du Serveur (j'ai mis les paramètres perso en fin de fichier, je n'ai pas dé-commenté. Par ex. le port est bien à 2222)

#	$OpenBSD: sshd_config,v 1.102 2018/02/16 02:32:40 djm Exp $

# This is the sshd server system-wide configuration file.  See
# sshd_config(5) for more information.

# This sshd was compiled with PATH=/usr/bin:/bin:/usr/sbin:/sbin

# The strategy used for options in the default sshd_config shipped with
# OpenSSH is to specify options with their default value where
# possible, but leave them commented.  Uncommented options override the
# default value.

# Attention : personnalise !
#Port 22
#AddressFamily any
#ListenAddress 0.0.0.0
#ListenAddress ::

#HostKey /etc/ssh/ssh_host_rsa_key
#HostKey /etc/ssh/ssh_host_ecdsa_key
#HostKey /etc/ssh/ssh_host_ed25519_key

# Ciphers and keying
#RekeyLimit default none

# Logging
#SyslogFacility AUTH
#LogLevel INFO

# Authentication:

#LoginGraceTime 2m
# Attention : personnalise !
#PermitRootLogin prohibit-password
#StrictModes yes
#MaxAuthTries 6
#MaxSessions 10

# Parametres personnalises 
#PubkeyAuthentication yes

# Expect .ssh/authorized_keys2 to be disregarded by default in future.
#AuthorizedKeysFile	.ssh/authorized_keys .ssh/authorized_keys2

#AuthorizedPrincipalsFile none

#AuthorizedKeysCommand none
#AuthorizedKeysCommandUser nobody

# For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
#HostbasedAuthentication no
# Change to yes if you don't trust ~/.ssh/known_hosts for
# HostbasedAuthentication
#IgnoreUserKnownHosts no
# Don't read the user's ~/.rhosts and ~/.shosts files
#IgnoreRhosts yes

# To disable tunneled clear text passwords, change to no here!
# Attention : personnalise !
#PasswordAuthentication yes
#PermitEmptyPasswords no

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no

# Kerberos options
#KerberosAuthentication no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes
#KerberosGetAFSToken no

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes
#GSSAPIStrictAcceptorCheck yes
#GSSAPIKeyExchange no

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication and
# PasswordAuthentication.  Depending on your PAM configuration,
# PAM authentication via ChallengeResponseAuthentication may bypass
# the setting of "PermitRootLogin without-password".
# If you just want the PAM account and session checks to run without
# PAM authentication, then enable this but set PasswordAuthentication
# and ChallengeResponseAuthentication to 'no'.
# Attention : personnalise !
#UsePAM yes


#AllowAgentForwarding yes
#AllowTcpForwarding yes
#GatewayPorts no
X11Forwarding yes
#X11DisplayOffset 10
#X11UseLocalhost yes
#PermitTTY yes
PrintMotd no
#PrintLastLog yes
#TCPKeepAlive yes
#UseLogin no
#PermitUserEnvironment no
#Compression delayed
#ClientAliveInterval 0
#ClientAliveCountMax 3
#UseDNS no
#PidFile /var/run/sshd.pid
#MaxStartups 10:30:100
#PermitTunnel no
#ChrootDirectory none
#VersionAddendum none

# no default banner path
#Banner none

# Allow client to pass locale environment variables
AcceptEnv LANG LC_*

# override default of no subsystems
Subsystem	sftp	/usr/lib/openssh/sftp-server

# Example of overriding settings on a per-user basis
#Match User anoncvs
#	X11Forwarding no

#	AllowTcpForwarding no
#	PermitTTY no
#	ForceCommand cvs server

# Parametres personnalises 
# Port de connexion
Port 2222
PasswordAuthentication yes
PubkeyAuthentication yes
UsePAM no
PermitRootLogin yes
AllowUsers usr-srvr

Logs sur le client :

utilisateur@Pc-Client:~$ ssh -v usr-srvr@192.168.0.47 -p 2222
OpenSSH_7.2p2 Ubuntu-4ubuntu2.7, OpenSSL 1.0.2g  1 Mar 2016
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: Connecting to 192.168.0.47 [192.168.0.47] port 2222.
debug1: Connection established.
debug1: identity file /home/utilisateur/.ssh/id_rsa type 1
debug1: key_load_public: No such file or directory
debug1: identity file /home/utilisateur/.ssh/id_rsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/utilisateur/.ssh/id_dsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/utilisateur/.ssh/id_dsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/utilisateur/.ssh/id_ecdsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/utilisateur/.ssh/id_ecdsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/utilisateur/.ssh/id_ed25519 type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/utilisateur/.ssh/id_ed25519-cert type -1
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_7.2p2 Ubuntu-4ubuntu2.7
debug1: Remote protocol version 2.0, remote software version OpenSSH_7.7p1 Ubuntu-4ubuntu0.2
debug1: match: OpenSSH_7.7p1 Ubuntu-4ubuntu0.2 pat OpenSSH* compat 0x04000000
debug1: Authenticating to 192.168.0.47:2222 as 'usr-srvr'
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: algorithm: curve25519-sha256@libssh.org
debug1: kex: host key algorithm: ecdsa-sha2-nistp256
debug1: kex: server->client cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: kex: client->server cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug1: Server host key: ecdsa-sha2-nistp256 SHA256:wuZYe3flR56sWHGYwpGowd8y12/AZS+zy9ElK0F4EdQ
debug1: Host '[192.168.0.47]:2222' is known and matches the ECDSA host key.
debug1: Found key in /home/utilisateur/.ssh/known_hosts:1
debug1: rekey after 134217728 blocks
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: rekey after 134217728 blocks
debug1: SSH2_MSG_EXT_INFO received
debug1: kex_input_ext_info: server-sig-algs=<ssh-ed25519,ssh-rsa,rsa-sha2-256,rsa-sha2-512,ssh-dss,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521>
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,password
debug1: Next authentication method: publickey
debug1: Offering RSA public key: /home/utilisateur/.ssh/id_rsa
debug1: Authentications that can continue: publickey,password
debug1: Trying private key: /home/utilisateur/.ssh/id_dsa
debug1: Trying private key: /home/utilisateur/.ssh/id_ecdsa
debug1: Trying private key: /home/utilisateur/.ssh/id_ed25519
debug1: No more authentication methods to try.
Permission denied (publickey,password).
utilisateur@Pc-Client:~$ 

Logs sur le serveur :

usr-srvr@PC-Serveur:~$ sudo systemctl status ssh
● ssh.service - OpenBSD Secure Shell server
   Loaded: loaded (/lib/systemd/system/ssh.service; enabled; vendor preset: enabled)
   Active: active (running) since Sat 2019-02-09 10:10:48 CET; 28s ago
     Docs: man:sshd(8)
           man:sshd_config(5)
  Process: 3868 ExecReload=/bin/kill -HUP $MAINPID (code=exited, status=0/SUCCESS)
  Process: 3862 ExecReload=/usr/sbin/sshd -t (code=exited, status=0/SUCCESS)
  Process: 4365 ExecStartPre=/usr/sbin/sshd -t (code=exited, status=0/SUCCESS)
 Main PID: 4376 (sshd)
    Tasks: 1 (limit: 4448)
   Memory: 1.6M
   CGroup: /system.slice/ssh.service
           └─4376 /usr/sbin/sshd -D

févr. 09 10:10:48 PC-Serveur systemd[1]: Starting OpenBSD Secure Shell server...
févr. 09 10:10:48 PC-Serveur sshd[4376]: Server listening on 0.0.0.0 port 2222.
févr. 09 10:10:48 PC-Serveur sshd[4376]: Server listening on :: port 2222.
févr. 09 10:10:48 PC-Serveur systemd[1]: Started OpenBSD Secure Shell server.
févr. 09 10:10:54 PC-Serveur sshd[4384]: Connection closed by authenticating user utilisateur 192.168.0.25 port 35848 [preauth]

Dernière modification par Zococo (Le 09/02/2019, à 16:52)


Ubuntu 16.04 (64 bits) - Gigabyte B250M-DS3H / Core i5-7600K (Kaby lake)

Hors ligne

#2 Le 09/02/2019, à 12:57

jamesbad000

Re : [Résolu]Paramétrage ssh

bonjour,

Je me connecte en mode Password (en réseau local) et les ip et password sont bons

est-ce que la demande de mot de passe s'affiche ?

peut-on voir aussi le paramétrage du client

cat /etc/ssh/ssh_config

Et aussi

ls -ld ~/.ssh
ls -l ~/.ssh

Dernière modification par jamesbad000 (Le 09/02/2019, à 13:03)


L'espace et le temps sont les modes par lesquels nous pensons, et non les conditions dans lesquelles nous vivons. (Signé Albert)

Hors ligne

#3 Le 09/02/2019, à 13:15

Zococo

Re : [Résolu]Paramétrage ssh

Merci pour l'aide.

Non la demande de mot de passe ne s'affiche pas, je n'ai que celle du sudo quand j'essaie en sudoer mais ça bloque de la même manière, sudoer ou pas, sachant que les fichiers de ~/.ssh sont identiques pour root et utilisateur.

utilisateur@Pc-Client:~$ cat /etc/ssh/ssh_config

# This is the ssh client system-wide configuration file.  See
# ssh_config(5) for more information.  This file provides defaults for
# users, and the values can be changed in per-user configuration files
# or on the command line.

# Configuration data is parsed as follows:
#  1. command line options
#  2. user-specific file
#  3. system-wide file
# Any configuration value is only changed the first time it is set.
# Thus, host-specific definitions should be at the beginning of the
# configuration file, and defaults at the end.

# Site-wide defaults for some commonly used options.  For a comprehensive
# list of available options, their meanings and defaults, please see the
# ssh_config(5) man page.

Host *
#   ForwardAgent no
#   ForwardX11 no
#   ForwardX11Trusted yes
#   RhostsRSAAuthentication no
#   RSAAuthentication yes
#   PasswordAuthentication yes
#   HostbasedAuthentication no
#   GSSAPIAuthentication no
#   GSSAPIDelegateCredentials no
#   GSSAPIKeyExchange no
#   GSSAPITrustDNS no
#   BatchMode no
#   CheckHostIP yes
#   AddressFamily any
#   ConnectTimeout 0
#   StrictHostKeyChecking ask
#   IdentityFile ~/.ssh/identity
#   IdentityFile ~/.ssh/id_rsa
#   IdentityFile ~/.ssh/id_dsa
#   Port 22
#   Protocol 2,1
#   Cipher 3des
#   Ciphers aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc
#   MACs hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-ripemd160
#   EscapeChar ~
#   Tunnel no
#   TunnelDevice any:any
#   PermitLocalCommand no
#   VisualHostKey no
#   ProxyCommand ssh -q -W %h:%p gateway.example.com
#   RekeyLimit 1G 1h
    SendEnv LANG LC_*
    HashKnownHosts yes
    GSSAPIAuthentication yes
    GSSAPIDelegateCredentials no
PreferredAuthentications publickey
utilisateur@Pc-Client:~$ ls -ld ~/.ssh
drwxrwxr-x 2 root utilisateur 4096 févr.  8 23:31 /home/utilisateur/.ssh
utilisateur@Pc-Client:~$ ls -l ~/.ssh
total 48
-rwx------ 1 utilisateur utilisateur 2365 févr. 10  2018 authorized_keys
-rw------- 1 utilisateur utilisateur 1766 févr. 10  2018 id_rsa
-rw-r--r-- 1 utilisateur utilisateur  395 févr. 10  2018 id_rsa.pub
-rw-r--r-- 1 utilisateur utilisateur  222 févr.  8 23:31 known_hosts

Est-ce que le PreferredAuthentications publickey du fichier ssh_config pourrait bloquer ? Je ne sais plus ce que j'avais pu paramétrer il y a bien longtemps.

Dernière modification par Zococo (Le 09/02/2019, à 13:27)


Ubuntu 16.04 (64 bits) - Gigabyte B250M-DS3H / Core i5-7600K (Kaby lake)

Hors ligne

#4 Le 09/02/2019, à 13:36

jamesbad000

Re : [Résolu]Paramétrage ssh

Si le mot de passe ne s'affiche pas, c'est à peu prêt certain qu'il considère uniquement l'authentification par clé

tente déjà d'ajouter l'option  -oPasswordAuthentication dans ta commande ssh pour voir

edit : non la syntaxe que j'ai indiquée n'est pas bonne...

Dernière modification par jamesbad000 (Le 09/02/2019, à 13:45)


L'espace et le temps sont les modes par lesquels nous pensons, et non les conditions dans lesquelles nous vivons. (Signé Albert)

Hors ligne

#5 Le 09/02/2019, à 13:51

jamesbad000

Re : [Résolu]Paramétrage ssh

la bonne syntaxe est

-oPasswordAuthentication=yes

Edit:
pour avoir le prompt du mot de passe sans avoir à ajouter l'option ci-dessus à la ligne de commande il faut dans ssh_config:
soit supprimer l'option PreferredAuthentications (autorise tous les modes d'authentification)

soit (en conservant la possibilité d'utiliser une clé public)

PreferredAuthentications publickey,keyboard-interactive,password

Et pourquoi ça fonctionne avec putty : parce qu'il utilise son propre paramétrage client, pas celui du paquet ssh

Dernière modification par jamesbad000 (Le 09/02/2019, à 14:10)


L'espace et le temps sont les modes par lesquels nous pensons, et non les conditions dans lesquelles nous vivons. (Signé Albert)

Hors ligne

#6 Le 09/02/2019, à 14:07

Zococo

Re : [Résolu]Paramétrage ssh

Malheureusement ça ne lui plait pas...

ssh -v -o PasswordAuthentication=yes usr-srvr@192.168.0.47 -p 2222
OpenSSH_7.2p2 Ubuntu-4ubuntu2.7, OpenSSL 1.0.2g  1 Mar 2016
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: Connecting to 192.168.0.47 [192.168.0.47] port 2222.
debug1: Connection established.
debug1: identity file /home/utilisateur/.ssh/id_rsa type 1
debug1: key_load_public: No such file or directory
debug1: identity file /home/utilisateur/.ssh/id_rsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/utilisateur/.ssh/id_dsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/utilisateur/.ssh/id_dsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/utilisateur/.ssh/id_ecdsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/utilisateur/.ssh/id_ecdsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/utilisateur/.ssh/id_ed25519 type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/utilisateur/.ssh/id_ed25519-cert type -1
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_7.2p2 Ubuntu-4ubuntu2.7
debug1: Remote protocol version 2.0, remote software version OpenSSH_7.7p1 Ubuntu-4ubuntu0.2
debug1: match: OpenSSH_7.7p1 Ubuntu-4ubuntu0.2 pat OpenSSH* compat 0x04000000
debug1: Authenticating to 192.168.0.47:2222 as 'usr-srvr'
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: algorithm: curve25519-sha256@libssh.org
debug1: kex: host key algorithm: ecdsa-sha2-nistp256
debug1: kex: server->client cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: kex: client->server cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug1: Server host key: ecdsa-sha2-nistp256 SHA256:wHG4Z8flR56sDRFwpKowd8y12/AZS+zyU2lKK5ESdQ
debug1: Host '[192.168.0.47]:2222' is known and matches the ECDSA host key.
debug1: Found key in /home/utilisateur/.ssh/known_hosts:1
debug1: rekey after 134217728 blocks
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: rekey after 134217728 blocks
debug1: SSH2_MSG_EXT_INFO received
debug1: kex_input_ext_info: server-sig-algs=<ssh-ed25519,ssh-rsa,rsa-sha2-256,rsa-sha2-512,ssh-dss,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521>
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,password
debug1: Next authentication method: publickey
debug1: Offering RSA public key: /home/utilisateur/.ssh/id_rsa
debug1: Authentications that can continue: publickey,password
debug1: Trying private key: /home/utilisateur/.ssh/id_dsa
debug1: Trying private key: /home/utilisateur/.ssh/id_ecdsa
debug1: Trying private key: /home/utilisateur/.ssh/id_ed25519
debug1: No more authentication methods to try.
Permission denied (publickey,password).

Ubuntu 16.04 (64 bits) - Gigabyte B250M-DS3H / Core i5-7600K (Kaby lake)

Hors ligne

#7 Le 09/02/2019, à 14:26

jamesbad000

Re : [Résolu]Paramétrage ssh

Effectivement je viens de faire un test en ajoutant "PreferredAuthentications publickey" dans mon ssh_config,
et l'option à la ligne de commande ne permet pas de contredire le paramétrage, ni l'ajout de -oKbdInteractiveAuthentication=yes

en revanche

-oPreferredAuthentications=keyboard-interactive,password

fonctionne. Mais autant le faire dans le fichier ssh_config (cf mon message précédent que j'ai complété entre temps)

Dernière modification par jamesbad000 (Le 09/02/2019, à 14:40)


L'espace et le temps sont les modes par lesquels nous pensons, et non les conditions dans lesquelles nous vivons. (Signé Albert)

Hors ligne

#8 Le 09/02/2019, à 15:33

Zococo

Re : [Résolu]Paramétrage ssh

Merci beaucoup.
Je regarde ce soir mais je pense que ça va être solutionné.
Bon après-midi.


Ubuntu 16.04 (64 bits) - Gigabyte B250M-DS3H / Core i5-7600K (Kaby lake)

Hors ligne

#9 Le 09/02/2019, à 16:52

Zococo

Re : [Résolu]Paramétrage ssh

ça fonctionne ! super merci.


Ubuntu 16.04 (64 bits) - Gigabyte B250M-DS3H / Core i5-7600K (Kaby lake)

Hors ligne