Contenu | Rechercher | Menus

Annonce

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 10/02/2019, à 17:14

maiden65

Partage scanner réseau impossible

Bonjour,

Je viens d'acquérir un scanner CANON LIDE120.

J'ai installé  libsane1 libsane-common libsane-extras libsane-extras-common sane-utils

   configuré les fichier saned.conf, dll.conf

# cat /etc/sane.d/canon.conf 
#canon.conf
scsi CANON IX

# canon LIDE120
usb 0x04a9 0x190e

Vérification du bon fonctionnement

# sane-find-scanner 

  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x04a9 [Canon], product=0x190e [CanoScan], chip=GL848+) at libusb:002:004
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.
# scanimage -L
device `genesys:libusb:002:004' is a Canon LiDE 120 flatbed scanner
# netstat -anlp | grep 6566
tcp6       0      0 :::6566                 :::*                    LISTEN      12583/xinetd

Coté client
installation de sane-utils sane
configuration de

/etc/sane.d# cat net.conf
# This is the net backend config file.

## net backend options
# Timeout for the initial connection to saned. This will prevent the backend
# from blocking for several minutes trying to connect to an unresponsive
# saned host (network outage, host down, ...). Value in seconds.
# connect_timeout = 60

## saned hosts
# Each line names a host to attach to.
# If you list "localhost" then your backends can be accessed either
# directly or through the net backend.  Going through the net backend
# may be necessary to access devices that need special privileges.
# localhost
10.0.0.3

et quand je tente le scanimage -L sur le client il ne voit rien

scanimage -L

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

le telnet fonctionne

# telnet 10.0.0.3 6566
Trying 10.0.0.3...
Connected to 10.0.0.3.
Escape character is '^]'.

J'ai pointé tout ce que je pouvais mais ca ne fonctionne pas.
Quelqu"un aurait une idée pour faire fonctionner SANE en réseau et donc mon scanner ???
Car il fonctionne bien sur le poste standalone, mais je voudrais que le pc de ma compagne puisse également l'utiliser sans devoir promener le scanner !!!

Merci d'avance.

Hors ligne