Contenu | Rechercher | Menus

Annonce

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 10/02/2019, à 13:42

Pleney

Problème JRE avec LibreOffice

Bonjour !

Je suis en Ubuntu 18.04 64 bits, à jour ; et j'ai installé LibreOffice 6.1.4.2 en snap.

Depuis quelques semaines, chaque fois que j'ouvre LibreOffice une fenêtre s'affiche :

JRE est défectueux
LibreOffice nécessite un environnement d'exécution java (JRE)
pour réaliser cette tâche. Le JRE sélectionné est défectueux.
Veuillez sélectionnez une autre version ou installer un nouveau JRE
et le sélectionner sous Outils - Options - LibreOffice - Avancé.
Valider

Bon, je valide, et tout marche bien quand même (peut-être parce que je n'utilise que Writer et Calc). Mais cet avis récurrent est agaçant ; et quand même ça correspond peut-être à un vrai problème.

Dernièrement j'ai essayé d'utiliser le logiciel d'architecture SweetHome3D ; mais il plante très rapidement. Or il paraît que ça pourrait être également dû à un JRE défectueux.

Je ne sais trop que faire, ni comment réparer ou réinstaller un JRE, ni lequel, ni où le trouver... Quelques conseils d'utilisateurs plus pointus que moi seraient fort utiles...

Hors ligne

#2 Le 10/02/2019, à 13:47

nam1962

Re : Problème JRE avec LibreOffice

Il n'y a aucun intérêt à installer LO via Snap.
Supprime le et installe la version des dépôts, si vraiment tu veux une mouture plus récente, utilise le PPA officiel.


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing - Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#3 Le 10/02/2019, à 15:25

Pleney

Re : Problème JRE avec LibreOffice

nam1962 a écrit :

Il n'y a aucun intérêt à installer LO via Snap.

Eh bien si, justement : tu trouveras ici la description des problèmes que j'ai eus avec la version des dépôts, puis les conseils qu'on m'avait donnés, qui ont tout résolu :
https://forum.ubuntu-fr.org/viewtopic.p … #p21968863

Quoi qu'il en soit, ça n'arrange pas mon JRE (problème beaucoup plus récent, et qui apparemment n'est pas lié à l'installation snap -- d'ailleurs SweetHome3D, dont le dysfonctionnement semble également lié à JRE, n'est pas en snap).

Hors ligne

#4 Le 10/02/2019, à 15:38

nam1962

Re : Problème JRE avec LibreOffice

Tu as du faire des bidouilles : LO 6 PPA fonctionne comme une horloge chez moi.
Donne :

cat /etc/apt/sources.list
ls /etc/apt/sources.list.d -1

Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing - Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#5 Le 10/02/2019, à 16:34

Pleney

Re : Problème JRE avec LibreOffice

Voilà :

cat /etc/apt/sources.list
# deb cdrom:[Ubuntu 18.04 LTS _Bionic Beaver_ - Release amd64 (20180426)]/ bionic main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://archive.ubuntu.com/ubuntu bionic main restricted
# deb-src http://fr.archive.ubuntu.com/ubuntu/ bionic main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://archive.ubuntu.com/ubuntu bionic-updates main restricted
# deb-src http://fr.archive.ubuntu.com/ubuntu/ bionic-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://archive.ubuntu.com/ubuntu bionic universe
# deb-src http://fr.archive.ubuntu.com/ubuntu/ bionic universe
deb http://archive.ubuntu.com/ubuntu bionic-updates universe
# deb-src http://fr.archive.ubuntu.com/ubuntu/ bionic-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://archive.ubuntu.com/ubuntu bionic multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ bionic multiverse
deb http://archive.ubuntu.com/ubuntu bionic-updates multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ bionic-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb-src http://fr.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu bionic partner
# deb-src http://archive.canonical.com/ubuntu bionic partner

deb http://archive.ubuntu.com/ubuntu bionic-security main restricted
# deb-src http://security.ubuntu.com/ubuntu bionic-security main restricted
deb http://archive.ubuntu.com/ubuntu bionic-security universe
# deb-src http://security.ubuntu.com/ubuntu bionic-security universe
deb http://archive.ubuntu.com/ubuntu bionic-security multiverse
# deb-src http://security.ubuntu.com/ubuntu bionic-security multiverse

et

ls /etc/apt/sources.list.d -1
google-earth-pro.list.save
libreoffice-ubuntu-ppa-bionic.list
libreoffice-ubuntu-ppa-bionic.list.save
skype-stable.list
skype-stable.list.save
unit193-ubuntu-encryption-bionic.list
unit193-ubuntu-encryption-bionic.list.save

Hors ligne

#6 Le 10/02/2019, à 17:24

nam1962

Re : Problème JRE avec LibreOffice

Tu as toujours le PPA.
que donne :

java -XshowSettings:properties -version

Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux) -Debian Testing - Et vous ?
57 convertis  IRL (n'ont pas eu le choix...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#7 Le 10/02/2019, à 17:41

Pleney

Re : Problème JRE avec LibreOffice

En ce qui concerne Java :

java -XshowSettings:properties -version
Property settings:
    awt.toolkit = sun.awt.X11.XToolkit
    file.encoding = UTF-8
    file.encoding.pkg = sun.io
    file.separator = /
    java.awt.graphicsenv = sun.awt.X11GraphicsEnvironment
    java.awt.printerjob = sun.print.PSPrinterJob
    java.class.path = 
    java.class.version = 54.0
    java.home = /usr/lib/jvm/java-11-openjdk-amd64
    java.io.tmpdir = /tmp
    java.library.path = /usr/java/packages/lib
        /usr/lib/x86_64-linux-gnu/jni
        /lib/x86_64-linux-gnu
        /usr/lib/x86_64-linux-gnu
        /usr/lib/jni
        /lib
        /usr/lib
    java.runtime.name = OpenJDK Runtime Environment
    java.runtime.version = 10.0.2+13-Ubuntu-1ubuntu0.18.04.4
    java.specification.name = Java Platform API Specification
    java.specification.vendor = Oracle Corporation
    java.specification.version = 10
    java.vendor = Oracle Corporation
    java.vendor.url = http://java.oracle.com/
    java.vendor.url.bug = http://bugreport.java.com/bugreport/
    java.version = 10.0.2
    java.version.date = 2018-07-17
    java.vm.compressedOopsMode = 32-bit
    java.vm.info = mixed mode
    java.vm.name = OpenJDK 64-Bit Server VM
    java.vm.specification.name = Java Virtual Machine Specification
    java.vm.specification.vendor = Oracle Corporation
    java.vm.specification.version = 10
    java.vm.vendor = Oracle Corporation
    java.vm.version = 10.0.2+13-Ubuntu-1ubuntu0.18.04.4
    jdk.debug = release
    line.separator = \n 
    os.arch = amd64
    os.name = Linux
    os.version = 4.15.0-45-generic
    path.separator = :
    sun.arch.data.model = 64
    sun.boot.library.path = /usr/lib/jvm/java-11-openjdk-amd64/lib
    sun.cpu.endian = little
    sun.cpu.isalist = 
    sun.desktop = gnome
    sun.io.unicode.encoding = UnicodeLittle
    sun.java.launcher = SUN_STANDARD
    sun.jnu.encoding = UTF-8
    sun.management.compiler = HotSpot 64-Bit Tiered Compilers
    sun.os.patch.level = unknown
    user.country = FR
    user.dir = /home/martin
    user.home = /home/martin
    user.language = fr
    user.name = martin
    user.timezone = 

openjdk version "10.0.2" 2018-07-17
OpenJDK Runtime Environment (build 10.0.2+13-Ubuntu-1ubuntu0.18.04.4)
OpenJDK 64-Bit Server VM (build 10.0.2+13-Ubuntu-1ubuntu0.18.04.4, mixed mode)

Excuse mes éventuels délais de réponse : je fais du bricolage en même temps wink (pas sur un ordi : avec un pinceau...)

Hors ligne

#8 Le 10/02/2019, à 17:56

JBF

Re : Problème JRE avec LibreOffice

Il n'y a plus de JRE dans Java 10/11 (le nom du dossier d'installation indique 11), il faut installer le JDK complet.
Pour exécuter un programme avec Java 11 il faut lancer la VM avec

/usr/lib/jvm/java-11-openjdk-amd64/bin/java

Si tu utilises java 8 qui a encore un JRE ce sera :

/usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java

LibreOffice : http://fr.libreoffice.org/ (téléchargement, documentation, FAQ, assistance, contribuer, ...)
Aide pour LibreOffice par la communauté francophone : https://ask.libreoffice.org/fr/

Hors ligne

#9 Le 10/02/2019, à 18:14

GammaDraconis

Re : Problème JRE avec LibreOffice

LibreOffice fonctionne bien mieux avec le PPA qu'avec le Snap !


Ultrabook : Xiaomi Air 13 [ Intel i5 7e, 8 Go ram, 2xSSD, GeForce MX150, dualboot Archlinux/Xfce & Ubuntu 18.04/GS
Tour : AMD Ryzen 7 2700X Octo-Core/16 Threads 3.7GHz, 32 Go de Ram ddr4 3000Mhz - 4.5 To dont 512 Go SSD - nVidia GeForce 2060RTX 6Go GDDR6) : tripleboot UbuntuDev & Arch & w10
Mon script de post-install Ubuntu/Arch : https://forum.ubuntu-fr.org/viewtopic.php?id=2026344

Hors ligne

#10 Le 10/02/2019, à 21:55

Pleney

Re : Problème JRE avec LibreOffice

JBF a écrit :

il faut installer le JDK complet.

Soit, mais comment on fait ? Il faut télécharger quelque chose ? Ou installer via le terminal ? Version 8 ou 11 ? Je nage complètement, là...

Ensuite je ne comprends pas ce que tu dis à propos de Java 11 et de Java 8. Moi, comme la plupart des utilisateurs, je veux juste installer ce qui est nécessaire, et ne plus m'en occuper...

(Remarque, à part la petite fenêtre qui apparaît à chaque ouverture pour critiquer mon JRE, LibreOffice marche parfaitement !)


GammaDraconis a écrit :

LibreOffice fonctionne bien mieux avec le PPA qu'avec le Snap !

C'est ton expérience, que je ne mets pas en doute. Mais la mienne est très différente, comme indiqué plus haut et dans le lien vers une intervention précédente.

Hors ligne

#11 Le 10/02/2019, à 22:09

Coeur Noir

Re : Problème JRE avec LibreOffice

C'est étonnant… en général le snap de LO ça donne :
- des problèmes d'apparence,
- des problèmes d'accès à certaines partitions, ou disques externes et autres clés usb,
- des difficultés pour imprimer…

…faut croire que ça progresse, tant mieux !
Pour les accès aux médias amovibles / autres partitions, c'est réglable via « Logiciels Ubuntu » sur la page de LO, rubrique « autorisations » ou terme approchant.

Comme suggéré par le message d'erreur, as-tu jeté un œil à :

Veuillez sélectionnez une autre version ou installer un nouveau JRE
et le sélectionner sous Outils - Options - LibreOffice - Avancé.

…quelle est la machine java utilisée ?

Cela dit si la tentative d'installation précédente via dépôt ou ppa a posé problème, c'est qu'il doit manquer quelque chose dans ton système.

De quel environnement s'agit-il ( gnome, kde, xfce, autre ) ?

Dernière modification par Coeur Noir (Le 10/02/2019, à 22:10)

Hors ligne

#12 Le 10/02/2019, à 22:29

Pleney

Re : Problème JRE avec LibreOffice

Des problèmes d'apparence ? Pas vu. De quel genre ?

Quant aux difficultés pour imprimer, c'est avant que je les avais ! L'installation en snap m'a au contraire "rendu" mes imprimantes.

Pour ce qui est de l'environnement, j'utilise habituellement Unity (à vrai dire, ,je ne sais pas si c'est la version 2D ou 3D).

Quand je vais dans Outils - Options - LibreOffice - Avancé, je vois que « Utiliser un environnement d'exécution Java » est coché. Le JRE déjà installé est la version 10.0.2 d'Oracle Corporation.
Emplacement :
/snap/libreoffice/100/usr/lib/jvm/java-11-openjdk-amd64

Hors ligne

#13 Le 10/02/2019, à 23:03

JBF

Re : Problème JRE avec LibreOffice

Pleney a écrit :

(Remarque, à part la petite fenêtre qui apparaît à chaque ouverture pour critiquer mon JRE, LibreOffice marche parfaitement !)

Dans ce cas je conjecture que tu as l'extension wiki-publisher qui est installée. Elle est installée par défaut quand on installe LO à partir des dépôts, j'imagine que le snap fait pareil. C'est souvent cette extension (écrite en Java) qui pose problème au démarrage de LO. Il suffit de la désinstaller. C'est le paquet libreoffice-wiki-publisher quand on installe à partir des dépôts. Sur un snap je ne sais pas comment on fait.
Pour voir si une extension LO est installée : lancer LO puis aller dans Outils > Gestionnaire des extensions.


LibreOffice : http://fr.libreoffice.org/ (téléchargement, documentation, FAQ, assistance, contribuer, ...)
Aide pour LibreOffice par la communauté francophone : https://ask.libreoffice.org/fr/

Hors ligne

#14 Le 10/02/2019, à 23:17

Coeur Noir

Re : Problème JRE avec LibreOffice

Apparence : problème de thème ( en gros seul le thème ambiance par défaut passe bien avec les snap ).

Unity sous Ubuntu 18.04 ? Why not… sache cependant qu'Unity n'est plus maintenu sous 18.04 ( entendre par là qu'à moins d'un bug terriblement bloquant, il ne fera l'objet d'aucune correction ).
C'est Ubuntu 16.04 qui est encore fourni par défaut avec Unity et maintenu jusqu'en 2021.

Cette 18.04 c'est une installation « fraîche » ou une mise à niveau depuis 16.04 ?

Ce qui est curieux ici c'est qu'un snap est censé venir avec toutes ses dépendances, et il semble bien qu'il y a un machin java dans /snap/libreoffice/100/usr/lib/jvm/java-11-openjdk-amd64

Tu as toujours LibreOffice installé en .deb à côté ? Est-ce que par hasard tu ne lancerais pas celui-là des fois ? Au pire supprime la version dépôt / ppa pour ne garder que le snap.

Hors ligne

#15 Le 11/02/2019, à 00:38

Pleney

Re : Problème JRE avec LibreOffice

JBF a écrit :

je conjecture que tu as l'extension wiki-publisher qui est installée.

Je viens d'aller voir dans Outils > Gestionnaire des extensions, où se trouvent pas mal de choses : plusieurs extensions linguistiques, GeOOo, Connecteur MySQL, Recherche alternative, et en effet Wiki Publisher 1.2.0.

Puisque j'y étais, j'ai cliqué sur le bouton pour vérifier les mises à jour.
Il y en a une pour LanguageTool. Je demande donc qu'elle soit téléchargée et installée ; et après un long moment, j'obtiens ce message :

Installation terminée
Résultat
Erreur lors de l'installation de l'extension LanguageTool. Le message d'erreur
est le suivant : Could not create Java implementation loader
L'extension ne sera pas installée.

Le problème avec JRE serait-il donc venu de cette extension ? Maintenant qu'elle est désinstallée, je vais voir si ça change quelque chose. Sinon, j'essaierai de désinstaller Wiki Publisher, comme tu le suggères.


Coeur Noir a écrit :

en gros seul le thème ambiance par défaut passe bien avec les snap

Ça s'est amélioré, apparemment : je suis en Radiance, et mes deux logiciels en snap (LibreOffice et VLC) ne semblent pas en souffrir.

Coeur Noir a écrit :

Cette 18.04 c'est une installation « fraîche » ou une mise à niveau depuis 16.04 ?

Fraîche : j'avais 16.04 en 32 bits, et après moult péripéties j'ai été obligé de tout réinstaller pour avoir 18.04 en 64 bits (avec même un nouveau partitionnement du disque dur).

Oui, je sais que Unity n'est plus maintenu -- on se demande bien pourquoi, d'ailleurs : avoir le choix serait un plus ; et plus d'un, comme moi, n'aiment pas du tout l'actuel GNOME.

La version deb de LibreOffice a été complètement désinstallée, dès que j'ai vu que la version snap fonctionnait mieux. J'ai même supprimé ensuite le dossier  libreoffice < .config < home, qui était resté après la désinstallation. Peut-il y avoir d'autres traces ?

Je verrai demain si le problème avec JRE a disparu... En tout cas, merci à ceux qui ont eu la patience de se pencher dessus et de suggérer des solutions.

Dernière modification par Pleney (Le 11/02/2019, à 00:48)

Hors ligne

#16 Le 11/02/2019, à 01:57

Coeur Noir

Re : Problème JRE avec LibreOffice

On peut trouver aussi des traces de config' logicielles dans ~/.local/share ou ~/.cache mais LO est gentil il ne range ses affaires que dans un seul dossier semble-t-il.

libreoffice < .config < home → ça te paraîtra un détail mais de grâce écris les chemins correctement, ici soit

/home/utilisateur/.config/libreoffice

soit

~/.config/libreoffice

~/ est un raccourci qui désigne /home/utilisateur_en_cours

Ambiance et Radiance sont les thèmes par défaut d'Ubuntu, donc à priori tu es à l'abri des problèmes de thème.

Could not create Java implementation loader → à priori la mise à jour de cette extension ne peut pas être installée parce qu'il y a ( toujours ) un problème avec Java. Suis la recommandation de JBF ( qui connaît très bien LO ) et supprime d'abord l'extension Wiki Publisher.

Hors ligne