Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 03/03/2019, à 19:53

Calyp

Flatpak qui ne fonctionne plus...

Bonsoir à tous.

Purement ludique !
J'ai un jeu installé par flatpak qui pour je ne sais quel raison ne fonctionne plus.
Je l'ai désinstallé une première fois, vérifié qu'il n'était plus dans le list et réinstallé.

Je me dis que j'ai fais une connerie qui a peut-être un lien avec l'utilisation de Synkron... sad

Ça dit quelque-chose à quelqu'un ?

:~$ [b]flatpak list[/b]
Description                                                                                           Application                     Version Branch Arch   Origin                                     Installation
Base                                                                                                  com.gog.Base                            master x86_64 com.gog.Base-origin                        user
Pillars of Eternity - Definitive Edition - Pillars of Eternity sur PC est un jeu de rôle exclusiveme… …arsOfEternityDefinitiveEdition         master x86_64 pillarsofeternitydefinitiveedition3-origin user
qTox - Powerful Tox chat client that follows the Tox design guidelines.                               io.github.qtox.qTox                     stable x86_64 flathub                                    system
default                                                                                               …reedesktop.Platform.GL.default         1.6    x86_64 gnome                                      user
Intel VAAPI Driver - Intel driver for hardware accelerated video decoding and playback                …eedesktop.Platform.VAAPI.Intel         1.6    x86_64 flathub                                    system
Intel VAAPI Driver - Intel driver for hardware accelerated video decoding and playback                …eedesktop.Platform.VAAPI.Intel         1.6    x86_64 gnome                                      user
FFmpeg extension - Add support for aac, mpeg4 and h264                                                org.freedesktop.Platform.ffmpeg         1.6    x86_64 flathub                                    system
FFmpeg extension - Add support for aac, mpeg4 and h264                                                org.freedesktop.Platform.ffmpeg         1.6    x86_64 gnome                                      user
GNOME Application Platform version 3.24 - Shared libraries used by GNOME applications                 org.gnome.Platform                      3.24   x86_64 flathub                                    system
GNOME Application Platform version 3.24 - Shared libraries used by GNOME applications                 org.gnome.Platform                      3.24   x86_64 gnome                                      user
Ambiance Gtk theme - Ambiance Gtk theme used by Ubuntu                                                org.gtk.Gtk3theme.Ambiance              3.22   x86_64 flathub                                    system
KDE Application Platform version master - Shared libraries used by KDE applications                   org.kde.Platform                        5.11   x86_64 flathub                                    system
QGnomePlatform - Qt Platform Theme aimed to accommodate GNOME settings                                …e.PlatformTheme.QGnomePlatform         5.11   x86_64 flathub                                    system

...

:~$ flatpak run com.gog.PillarsOfEternityDefinitiveEdition 
bwrap: execvp starter: [b]Permission denied[/b]

:~$ flatpak update 
Looking for updates…
Nothing to do.



Merci

Dernière modification par Calyp (Le 03/03/2019, à 19:55)


Ubuntu 18.04.1 (64)

Hors ligne

#2 Le 04/03/2019, à 19:58

Calyp

Re : Flatpak qui ne fonctionne plus...

Des idées, des commentaires pour m'aider à résoudre ce problème ?

J'ajoute, que j'ai tout désinstaller flatpak et réinstaller en suivant la procédure  - c'est-à-dire cette liste de commandes :

  1. flatpak --user remote-add --from gnome https://sdk.gnome.org/gnome.flatpakrepo

  2. flatpak --user install gnome org.gnome.Platform/x86_64/3.24

  3. flatpak --user install -y --app --bundle com.gog.Base-x86_64.flatpak

  4. flatpak --user install -y --app --bundle Pillar.of.Eternity.Definitive.Edition.3.7.0.1318-x86_64.flatpak

  5. flatpak run com.gog.PillarsOfEternityDefinitiveEdition

Et rien ne se lance tout simplement... Alors que ça fonctionnait il y a encore quelques semaines.

Dernière modification par Calyp (Le 04/03/2019, à 19:59)


Ubuntu 18.04.1 (64)

Hors ligne

#3 Le 05/03/2019, à 20:17

Calyp

Re : Flatpak qui ne fonctionne plus...

C'est peut-être une erreur de me part de poser cette question ?

Si jamais c’est le cas, n'hésitez pas à me le dire.


Ubuntu 18.04.1 (64)

Hors ligne

#4 Le 06/03/2019, à 00:05

Calyp

Re : Flatpak qui ne fonctionne plus...

Problème réglé !

Suppression des ppa:alexlarsson/flatpak
Suppression complète (pas uniquement le programme flatpak et le paquet flatpak, mais le tout... )

flatpak uninstall --all

Réinstallation de Flatpak en suivant scrupuleusement les étapes Installation de flatpak
Réinstallation de l'application.

Run OK !


Ubuntu 18.04.1 (64)

Hors ligne