Contenu | Rechercher | Menus

Annonce

Ubuntu Party les 18 et 19 mai 2019 à Paris
Grand rendez-vous tout public organisé par Ubuntu-FR, avec install-party, ateliers et conférences.
Venez y (re)découvrir ou faire découvrir le Libre et Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 13/05/2019, à 21:28

Bizaro

Problème réseau entre VM

Bonjour,
Merci pour ce tuto.
Je suis sous Xubuntu 18_04 avec un accès internet par wifi,      avec Version 5.2.18 j'ai 2 VM : linux et windows.
Lorsque je suis en NAT les VM on bien accès à internet, mais ni L’hôte ni les VM ne se ping.
Pour avoir une liaison entre mon réseau virtuel et mon réseau hôte je passe en PONT(enp2s0),  Mais pas plus de succès et je perds internet sur les VM.
Après avoir essayé pas mal de config réseau différentes je suis un peu perdu  sad .
Voici ma configuration :

Virtualbox :
vboxnet0
ipv4 192.168.56.1 ipv6 ""  dhcp: non

Hote Linux :
enp2s0
ipv4 manuel 192.168.56.100/24    ipv6 ignorer

enp2s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether   txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Boucle locale)
        RX packets 1387  bytes 125551 (125.5 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1387  bytes 125551 (125.5 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

VM linux:
enp0s3 
ipv4 manuel 192.168.56.20/24    ipv6 ignorer
ifconfig
enp0s3: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 10.0.2.15  netmask 255.255.255.0  broadcast 10.0.2.255
        inet6 fe80::a00:27ff:fe9d:f4b7  prefixlen 64  scopeid 0x20<link>
        ether 08:00:27:9d:f4:b7  txqueuelen 1000  (Ethernet)
        RX packets 79  bytes 6942 (6.9 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 166  bytes 17476 (17.4 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 31706  bytes 6955844 (6.9 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 31706  bytes 6955844 (6.9 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

VM Windows 7
Carte Intel(R) PRO/1000 MT
ipv4 manuel 192.168.56.70/24    ipv6 automatique
Configuration IP de Windows


Carte Ethernet Connexion au réseau local :

   Suffixe DNS propre à la connexion. . . :
   Adresse IPv6 de liaison locale. . . . .: fe80::f9f4:4026:b56:a64e%11
   Adresse IPv4. . . . . . . . . . . . . .: 192.168.56.70
   Masque de sous-réseau. . . . . . . . . : 255.255.255.0
   Passerelle par défaut. . . . . . . . . :

Carte Tunnel isatap.{E5F33224-76DA-4452-884D-71CA42460439} :

   Statut du média. . . . . . . . . . . . : Média déconnecté
   Suffixe DNS propre à la connexion. . . :

Modération : merci d'utiliser les balises code (explications ici).

Modération bis : ouverture d'un nouveau fil plutôt que d'utiliser un vieux tuto.

Dernière modification par bruno (Le 14/05/2019, à 09:43)

Hors ligne

#2 Le 15/05/2019, à 16:20

rogn...

Re : Problème réseau entre VM

Salut.
Si tu veux que tes VM dialoguent entre elles, il faut un minimum qu'elles soient au même niveau de sous-réseau, sinon, ce sera bien plus compliqué. Tu as commencé par les connecter à internet via pont, tu aurais du continuer sur cette piste.
Via pont, tu auras ton host et tes VM au même niveau, il faut cependant que tu choisisses l'interface wlp4s0 (wifi) et non enp3s0 (ethernet). Mais ce n'est pas tout. Tes adresses Mac virtuelles doivent être différentes les unes des autres, mais aussi, si tu es derrière une box, que celle-ci n'aie pas de filtrage MAC actif ou de quantité de connexions limitée.

Dernière modification par rogn... (Le 15/05/2019, à 16:21)


Rogn on GitHub
Manjaro XFCE / Xubuntu 19.10
"Je pisse sur les Pommes de riches et les mises à jour de w$ qui foirent !" (A. Vatar)

Hors ligne

#3 Le 16/05/2019, à 17:56

Bizaro

Re : Problème réseau entre VM

J'ai utilisé l'utilitaire de connexion réseau croyant régler ma carte Ethernet, l'erreur est corrigée.

Hors ligne