Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 22/07/2019, à 23:34

zephyre123

Erreur lors du lancement d'éclipse [RESOLU]

Bonjour,

Je me lance dans la programmation java.
Je suis beau comme un sous neuf dans le domaine de la programmation.
En gros je suis un néophyte total dans la programmation et dans ubuntu.
Pour ce faire j'ai lancer en ligne de commande :

sudo apt-get install eclipse

Mais lorsque je cherche a lancé eclipse via la ligne de commande en tapant eclipse j'ai le message d'erreur suivant :

~$ eclipse
OpenJDK 64-Bit Server VM warning: Ignoring option MaxPermSize; support was removed in 8.0
Gtk-Message: 22:52:40.360: Failed to load module "canberra-gtk-module"

Et lorsque je cherche à le lancer dans le menu avec les icônes j'ai le message d'erreur suivant :
http://pix.toile-libre.org/?img=1563832721.png
Merci pour votre aide.

Dernière modification par zephyre123 (Le 24/07/2019, à 15:40)

Hors ligne

#2 Le 23/07/2019, à 00:21

kamaris

Re : Erreur lors du lancement d'éclipse [RESOLU]

Tu peux donner le retour de

cat /home/pierre/.eclipse/org.eclipse.platform_3.8_155965261/configuration/1563830675967.log

Hors ligne

#3 Le 23/07/2019, à 11:13

zephyre123

Re : Erreur lors du lancement d'éclipse [RESOLU]

cat /home/pierre/.eclipse/org.eclipse.platform_3.8_155965261/configuration/1563830675967.log
!SESSION Mon Jul 22 23:24:35 CEST 2019 -----------------------------------------
!ENTRY org.eclipse.equinox.launcher 4 0 2019-07-22 23:24:35.985
!MESSAGE Exception launching the Eclipse Platform:
!STACK
java.lang.ClassNotFoundException: org.eclipse.core.runtime.adaptor.EclipseStarter
	at java.base/java.net.URLClassLoader.findClass(URLClassLoader.java:471)
	at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:588)
	at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:626)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
	at org.eclipse.equinox.launcher.Main.main(Main.java:1414)

Hors ligne

#4 Le 23/07/2019, à 12:23

kamaris

Re : Erreur lors du lancement d'éclipse [RESOLU]

Ouaip, même erreur que j'avais eu il y a quelque temps, au mois d'avril : https://forum.ubuntu-fr.org/viewtopic.php?id=2039146
J'avais cherché un peu sans trouver, et comme je dis là-bas, j'avais laissé tomber car étant passé sous Ubuntu 19.04, eclipse n'était plus dans les dépôts (je suppose que toi tu es sous Ubuntu 18.04).

Sinon comme alternative à eclipse qui est bien, il y a atom : https://atom.io/
Tu peux ajouter leur ppa pour installer ensuite atom via apt : https://flight-manual.atom.io/getting-s … form-linux
Et si la base ne suffit pas, il y a tout un tas de plugins, dont ceux pour java : https://atom.io/packages/search?q=java

Hors ligne

#5 Le 23/07/2019, à 13:13

rogn...

Re : Erreur lors du lancement d'éclipse [RESOLU]

Peut être aurait-il fallu commencer par savoir quelle version je java et d'eclipse sont installées avant d'aller chercher des PPA tordus. roll


Rogn on GitHub
Manjaro XFCE MATE / Xubuntu 19.10
"Marcher à contre sens du vent permet de péter dans le sens de celui-ci."
Timezone[MonCul]

Hors ligne

#6 Le 23/07/2019, à 14:02

zephyre123

Re : Erreur lors du lancement d'éclipse [RESOLU]

Connaître la version de java installé :

java --version
openjdk 11.0.3 2019-04-16
OpenJDK Runtime Environment (build 11.0.3+7-Ubuntu-1ubuntu218.04.1)
OpenJDK 64-Bit Server VM (build 11.0.3+7-Ubuntu-1ubuntu218.04.1, mixed mode, sharing)

Connaître la version d'eclipse installé :
Je n'ai pas trouvé comment faire car après une recherche sur le net il faut que éclipse se lance pour voir la version installé de éclipse.

La version d'ubuntu :

uname -a
Linux pierre-MS-7916 4.18.0-25-generic #26~18.04.1-Ubuntu SMP Thu Jun 27 07:28:31 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

J'ai vraiment besoins d'éclipse c'est le logiciel le plus utilisé en entreprise avec visual studio.

Dernière modification par zephyre123 (Le 23/07/2019, à 14:17)

Hors ligne

#7 Le 23/07/2019, à 14:13

kamaris

Re : Erreur lors du lancement d'éclipse [RESOLU]

Pour visual studio, si jamais tu ne connais pas, il y a vscodium (code source de microsoft moins la télémétrie) : https://github.com/VSCodium/vscodium
De même que plus haut, il est possible de l'avoir par ppa : https://gitlab.com/paulcarroty/vscodium … linux-mint

Hors ligne

#8 Le 23/07/2019, à 14:18

zephyre123

Re : Erreur lors du lancement d'éclipse [RESOLU]

Je suis d'accord avec toi kamaris il y a plein d'alternative sans doute mais dans le monde du travail il faut utiliser les outils de marchés
donc eclipse et visual studio.

Hors ligne

#9 Le 23/07/2019, à 14:19

kamaris

Re : Erreur lors du lancement d'éclipse [RESOLU]

Eh bien ci-dessus je te parle de visual studio…

Hors ligne

#10 Le 23/07/2019, à 14:39

rogn...

Re : Erreur lors du lancement d'éclipse [RESOLU]

Visual Studio pour du Java, on aura tout vu... roll

Une seule bonne alternative à Eclipse pour du Java et dérivés , c'est Netbeans : Il peut s'installer via flatpak et mode utilisateur et non root, donc pas de risque de foutoir dans les dépendances. --> https://flathub.org/apps/details/org.apache.netbeans

Dernière modification par rogn... (Le 23/07/2019, à 14:43)


Rogn on GitHub
Manjaro XFCE MATE / Xubuntu 19.10
"Marcher à contre sens du vent permet de péter dans le sens de celui-ci."
Timezone[MonCul]

Hors ligne

#11 Le 23/07/2019, à 14:49

zephyre123

Re : Erreur lors du lancement d'éclipse [RESOLU]

J'ai réussi à installé eclipse en suivant à la lettre ce tuto :
https://linuxize.com/post/how-to-instal … ntu-18-04/

Hors ligne

#12 Le 23/07/2019, à 15:20

rogn...

Re : Erreur lors du lancement d'éclipse [RESOLU]

zephyre123 a écrit :

J'ai réussi à installé eclipse en suivant à la lettre ce tuto :
https://linuxize.com/post/how-to-instal … ntu-18-04/

Se fader un snap alors que coucou que voilà eclipse ici : https://www.eclipse.org/downloads/downl … x64.tar.gz sad


Rogn on GitHub
Manjaro XFCE MATE / Xubuntu 19.10
"Marcher à contre sens du vent permet de péter dans le sens de celui-ci."
Timezone[MonCul]

Hors ligne

#13 Le 23/07/2019, à 17:07

zephyre123

Re : Erreur lors du lancement d'éclipse [RESOLU]

pourquoi se fader un snap ca veux dire quoi ?
C'est pas bien les snap ?

Hors ligne

#14 Le 24/07/2019, à 06:55

rogn...

Re : Erreur lors du lancement d'éclipse [RESOLU]

Les snaps sont énergivores, mal optimisés, lourds et permettent des dérives. Ton lien préconise d'installer eclipse en snap.

EDIT : j'ai testé ce que je t'ai préconisé précédemment, c'est un script d'installation qui va t'installer en session locale eclipse. Il faut suivre pas à pas la procédure et ça te dira à la fin où faut il lancer eclipse. SI tu as java d'installé, ça ne te sera que plus facile à faire.
Le résultat chez moi :
1563945538.png

Si jamais eclipse ne te satisfait pas, tu peux te rabattre sur Netbeans qui est son concurrent direct et tout aussi utilisé dans le monde pro.

Dernière modification par rogn... (Le 24/07/2019, à 07:22)


Rogn on GitHub
Manjaro XFCE MATE / Xubuntu 19.10
"Marcher à contre sens du vent permet de péter dans le sens de celui-ci."
Timezone[MonCul]

Hors ligne

#15 Le 24/07/2019, à 15:40

zephyre123

Re : Erreur lors du lancement d'éclipse [RESOLU]

ok merci rogn

Hors ligne