Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 10/08/2019, à 17:30

jjcojax

[résolu]Bloquer les derniers noyaux pour garder la mises en veille.

Bonjour,

J'ai un PC fixe (carte mère Asus et processeur Intel i5 6600) qui a toujours fonctionné correctement depuis Ubuntu Mate 16.04 LTS (64 bits en mode EFI)

Il est passé à Ubuntu Mate 18.04 LTS sans problème, mais dernièrement, avec le noyau 4.15.0-55, si j'utilise la mise en veille, le PC ne se remet pas en service.
Le ventilo fait quelques tours et s’arrête, l'écran reste noir, la souris et le clavier restent inertes.

Pour ce PC, les noyaux précédents n’ont pas ce problème (4.15.0-51 et 4.15.0-54) Vue de ce que j'ai encore

Pour le moment, j'ai encore accès au noyaux qui fonctionnent, mais de mises à jours en mises à jours, il ne va plus me rester que des noyaux qui ne me conviennent pas.

(sur des PC plus anciens, c'est pire, tout fonctionne correctement si je rejette les noyaux plus nouveaux que le 4.15.0-45)

Quelle est la bonne manière pour garder au moins un noyau qui me convient, et/ou le moyen de rajouter un noyau ancien qui fonctionne correctement.
---
Parmi les choses bizarres, si je sélectionne ce qui peut être supprimé, on me propose de supprimer le noyau actif !!! capture

Merci à ceux qui me donneront une piste.

jjcojax

Dernière modification par jjcojax (Le 15/08/2019, à 12:56)

Hors ligne

#2 Le 11/08/2019, à 15:01

Babdu89

Re : [résolu]Bloquer les derniers noyaux pour garder la mises en veille.

Bonjour.

Si j'ai bien compris, pour une affaire de mise en veille (qui peut être momentanément désactivée), tu te prives de pouvoir utiliser les futures versions du noyau mises à jour et donc mieux sécurisées. Oui, puisque tu démarreras sur le noyau 4.15.0-54.

Est-ce un bon choix? .

@+.   Babdu89   .


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#3 Le 11/08/2019, à 15:24

ylag

Re : [résolu]Bloquer les derniers noyaux pour garder la mises en veille.

Salut,

jjcojax a écrit :

Parmi les choses bizarres, si je sélectionne ce qui peut être supprimé, on me propose de supprimer le noyau actif !!!

Peut-être pas si bizarre: Puisque tu as trois noyaux d'installés, la routine suggère d'enlever le plus ancien et de garder les deux plus récents. C'est le même comportement que si tu avais fait:

sudo apt autoremove --purge

Si tu tiens absolument à garder le 4.15.0-51, faudrait probablement que tu passes les paquets de ce noyau en mode «installés manuellement» avec des commandes du genre de:

sudo apt-mark manual <le-nom-du-paquet-à-conserver>

...de façon à ce que l'autoremove n'en propose plus la désinstallation ?

Qu'en penserait @Babdu89 ?

A+

Dernière modification par ylag (Le 11/08/2019, à 15:31)

En ligne

#4 Le 11/08/2019, à 16:02

GammaDraconis

Re : [résolu]Bloquer les derniers noyaux pour garder la mises en veille.

C'est étonnant car normalement quand tu passes par exemple du noyau 4.15.0-54 au 4.15.0-55, c'est uniquement des patchs de sécurité et correction de bug mais ça ne touche pas au fonctionnalité/gestion du matériel.
Par contre pour un changement complet du noyau (par exemple du 4.15 au 5.0) là oui il y a des gros changements sur le comportement lié au matériel.

D'ailleurs si tu as des soucis avec le dernier correctif en 4.15, tu peux essayer de voir si tu as le même soucis avec le 5.0 (qui est dans les dépots puisque c'est celui de la 18.04.3).


Dell XPS 13 version 2019 (9380) : i7-8565U / 16 Go de ram / 1 To SSD M2 Nvme / Intel Graphic UHD 620 (Ubuntu 20.04LTS / Gnome & ArchLinux / KDE-Plasma)
Tour : AMD Ryzen 7 2700X Octo-Core/16T 3.7GHz, 32 Go Ram - 1 To SSD + 4 To HDD - GeForce 2060RTX 6Go) : (Ubuntu 20.04LTS+Manjaro+W10)
Mon script de post-install pour la 18.04 : https://forum.ubuntu-fr.org/viewtopic.php?id=2026344

Hors ligne

#5 Le 11/08/2019, à 16:20

Babdu89

Re : [résolu]Bloquer les derniers noyaux pour garder la mises en veille.

ylag a écrit :

Salut,

jjcojax a écrit :

Parmi les choses bizarres, si je sélectionne ce qui peut être supprimé, on me propose de supprimer le noyau actif !!!

Peut-être pas si bizarre: Puisque tu as trois noyaux d'installés, la routine suggère d'enlever le plus ancien et de garder les deux plus récents. C'est le même comportement que si tu avais fait:

sudo apt autoremove --purge

Si tu tiens absolument à garder le 4.15.0-51, faudrait probablement que tu passes les paquets de ce noyau en mode «installés manuellement» avec des commandes du genre de:

sudo apt-mark manual <le-nom-du-paquet-à-conserver>

...de façon à ce que l'autoremove n'en propose plus la désinstallation ?

Qu'en penserait @Babdu89 ?

A+

Il me semble; La suppression des noyaux anciens n'est effective en fait que lors du redémarrage de la machine.
Tu démarres sur le 4.15.0-51, tu supprimes cette version, (si çà veut bien s'exécuter). Au redémarrage tu ne pourras plus redémarrer dessus.

@+.   Babdu89   .


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#6 Le 11/08/2019, à 18:51

jjcojax

Re : [résolu]Bloquer les derniers noyaux pour garder la mises en veille.

Re, à tous,

Babdu89 à écrit:
pour une affaire de mise en veille (qui peut être momentanément désactivée)

Pour moi, la veille est importante, cela limite l'usure de ce qui tourne, et ensuite, c'est moi qui paye l'électricité.

L'utilisation est du genre bureautique et j'ai régulièrement des documents ou mails en cours de rédaction.

Tel que c'est depuis 2016, le bureau réparait en 1 seconde, le réseau est actif 2 secondes après. (je fais bien sûr des sauvegardes de temps à autre)

Suite au blocage,j'ai du faire une réparation de la partition Ubuntu Mate et constaté que le problème concerne uniquement le dernier noyau.

ylag a écrit :
Si tu tiens absolument à garder le 4.15.0-51, faudrait probablement que tu passes les paquets de ce noyau en mode «installés manuellement»

sudo apt-mark manual <le-nom-du-paquet-à-conserver>

OK, si je choisis un noyau à garder, le paquet, c'est lequel ???

config-4.15.0-51-generic
ou
initrd.img-4.15.0-51-generic
ou
vmlinuz-4.15.0-51-generic.

Ou le 3 ?

En ce qui concerne l'autoremove des anciens noyaux, cela ce fait tout seul depuis plusieurs mois, et après avoir démarré sur le noyau ..54, le ..51 était déjà viré.

Mon intention reste celle du départ, c.a.d. rejeter les mises à jours du noyau qui à mon sens concerne surtout les derniers processeur AMD type Ryzen
(j'essayerai les prochains noyaux par la suite)

jjcojax

Dernière modification par jjcojax (Le 11/08/2019, à 18:56)

Hors ligne

#7 Le 11/08/2019, à 19:04

ylag

Re : [résolu]Bloquer les derniers noyaux pour garder la mises en veille.

Salut,

Ce que tu cites au #6 sont des fichiers (à ne pas toucher), non des paquets.

Je suis présentement sur un appareil mobile, donc impossible de te donner (de mémoire...) la liste des paquets concernés, mais tu devrais pouvoir le déterminer avec la commande:

dpkg -l | grep ^ii | grep 4.15.0-5X

...où tu remplaces X par le dernier chiffre de la version du noyau à conserver.
Normalement, il s'agit de 3 à 5 paquets du genre de linux-image-4.15.0-5X-generic  et
linux-headers-....

Note que cette manip n'empêche pas les mises à jour de noyau, mais fait en sorte de ne pas désinstaller automatiquement tout noyau marqué en installation manuelle, ce qui te permet de le conserver et de pouvoir le choisir pour démarrer.
Lors d'une prochaine mise à jour du noyau, si tu te rends compte que le nouveau noyau fonctionne bien, il te sera possible de repasser les paquets du noyau conservé en mode auto pour qu'il puisse être désinstallé normalement par la fonction autoremove.

A+

Dernière modification par ylag (Le 11/08/2019, à 19:16)

En ligne

#8 Le 11/08/2019, à 19:29

NicoApi73

Re : [résolu]Bloquer les derniers noyaux pour garder la mises en veille.

Bonsoir, 

Une fois le noyau marqué comme installé manuellement (enfin, les paquets), il te suffit de configurer grub.
Je pense à deux possibilités :
- soit mémoriser le dernier noyau utilisé
- soit configurer pour démarrer sur un noyau du sous menu

J'essayerai de retrouver la config

Hors ligne

#9 Le 11/08/2019, à 19:35

ylag

Re : [résolu]Bloquer les derniers noyaux pour garder la mises en veille.

Bonsoir,

NicoApi73 a écrit :

J'essayerai de retrouver la config

Merci! smile
Aussi, si tu peux poster la liste des paquets à marquer en installation manuelle avant que je ne retourne sur ma machine Linux...

A+

Dernière modification par ylag (Le 11/08/2019, à 19:35)

En ligne

#10 Le 11/08/2019, à 20:28

ylag

Re : [résolu]Bloquer les derniers noyaux pour garder la mises en veille.

@jjcojax:

Bonsoir,

La liste des paquets à passer en mode installation manuelle devrait être la suivante:

linux-headers-4.15.0-5X
linux-headers-4.15.0-5X-generic 
linux-image-4.15.0-5X-generic 
linux-modules-4.15.0-5X-generic 
linux-modules-extra-4.15.0-5X-generic

...encore une fois, remplacer X par le dernier chiffre de la version à conserver. Donc si le noyau à conserver est le 4.15.0-54, la commande sera:

sudo apt-mark manual linux-headers-4.15.0-54 linux-headers-4.15.0-54-generic linux-image-4.15.0-54-generic linux-modules-4.15.0-54-generic linux-modules-extra-4.15.0-54-generic

Pour inverser et remettre les paquets en installation automatique, simplement remplacer manual par auto dans la commande.

A+

Dernière modification par ylag (Le 11/08/2019, à 20:29)

En ligne

#11 Le 12/08/2019, à 01:41

moko138

Re : [résolu]Bloquer les derniers noyaux pour garder la mises en veille.

Merci de montrer, séparément :

sudo cat /var/log/apt/history.log | grep -C2 "4\.15\.0-5"
sudo zless /var/log/apt/history.log.1.gz | grep -C2 "4\.15\.0-5"
dpkg -l | grep "4\.15\.0-54"

et

dpkg -l | grep "4\.15\.0-55"

(Ces commandes sont purement descriptives.)


%NOINDEX%
Un utilitaire précieux : ncdu
Photo, mini-tutoriel :  À la découverte de dcraw

Hors ligne

#12 Le 12/08/2019, à 20:02

piolet

Re : [résolu]Bloquer les derniers noyaux pour garder la mises en veille.

Bonsoir,
si tu veux bloquer les mises à jour des noyaux
supprimes les paquets linux-generic linux-image-generic linux-headers-generic


lenovo T430 RAM 8Go Xubuntu 18.04 LTS

Hors ligne

#13 Le 13/08/2019, à 08:23

NicoApi73

Re : [résolu]Bloquer les derniers noyaux pour garder la mises en veille.

voici ce que j'ai dans mes tablettes smile

==================================================Mémoriser le dernier noyau utilisé par grub==============================================

Source : https://wiki.centos.org/HowTos/Grub2 (il y a quelques modifs à faire dans ce lien)

sudo cp /etc/default/grub /etc/default/grub.old
sudo nano /etc/default/grub

Chercher une ligne où il y a :
GRUB_DEFAULT=0

Remplacer par (en fait sur cette ligne, seul le 0 est effacé et remplacé par saved) :
GRUB_DEFAULT=saved
Appuyer sur Entrée (pour créer une ligne)
Ajouter GRUB_SAVEDEFAULT=true

CTRL+o - Entrée - CTRL+x

Tu te retrouves avec quelque chose comme

(...)
GRUB_DEFAULT=saved
GRUB_SAVEDEFAULT=true
(...)

Puis mettre à jour grub :

sudo update-grub

======================================================Choisir un ancien noyau avec grub====================================================

https://help.ubuntu.com/community/Grub2/Submenus

Pour mettre en pratique, il faut faire :

cat /boot/grub/grub.cfg | grep menuentry

Repérer le numéro du submenu contenant les anciens noyau (1 dans le cas d'une installation standard non-bricolée, à vérifier, le premier menuentry portant le n°0) Repérer le nom du noyau (par exemple) : Ubuntu, avec Linux 4.15.0-43-generic

Modifier /etc/default/grub
changer la ligne GRUB_DEFAULT=0 en GRUB_DEFAULT="1>Ubuntu, avec Linux 4.15.0-43-generic"

sudo update-grub

Et empêcher l'effacement du noyau en question.
Puis mettre à jour grub :

sudo update-grub

Hors ligne

#14 Le 15/08/2019, à 12:12

jjcojax

Re : [résolu]Bloquer les derniers noyaux pour garder la mises en veille.

Merci à tous,

moko138
Merci de montrer, séparément :

Voici les 4 retours de commandes ...

jjcojax@ASUS-I5-UBM164:~$ sudo cat /var/log/apt/history.log | grep -C2 "4\.15\.0-5"
[sudo] Mot de passe de jjcojax : 
Start-Date: 2019-08-11  06:19:13
Commandline: /usr/bin/unattended-upgrade
Remove: linux-modules-extra-4.15.0-51-generic:amd64 (4.15.0-51.55)
End-Date: 2019-08-11  08:19:41

Start-Date: 2019-08-11  08:19:44
Commandline: /usr/bin/unattended-upgrade
Remove: linux-image-4.15.0-51-generic:amd64 (4.15.0-51.55)
End-Date: 2019-08-11  08:22:24

Start-Date: 2019-08-11  08:22:28
Commandline: /usr/bin/unattended-upgrade
Remove: linux-headers-4.15.0-51-generic:amd64 (4.15.0-51.55)
End-Date: 2019-08-11  08:22:40

Start-Date: 2019-08-11  08:22:43
Commandline: /usr/bin/unattended-upgrade
Remove: linux-headers-4.15.0-51:amd64 (4.15.0-51.55)
End-Date: 2019-08-11  08:22:49

Start-Date: 2019-08-11  08:22:52
Commandline: /usr/bin/unattended-upgrade
Remove: linux-modules-4.15.0-51-generic:amd64 (4.15.0-51.55)
End-Date: 2019-08-11  08:22:53

--
Commandline: /usr/sbin/synaptic
Requested-By: jjcojax (1000)
Install: linux-headers-4.15.0-52-generic:amd64 (4.15.0-52.56), linux-headers-4.15.0-52:amd64 (4.15.0-52.56)
Remove: linux-headers-generic:amd64 (4.15.0.55.57), linux-headers-4.15.0-55-generic:amd64 (4.15.0-55.60), linux-headers-4.15.0-55:amd64 (4.15.0-55.60), linux-signed-generic:amd64 (4.15.0.55.57), linux-generic:amd64 (4.15.0.55.57)
End-Date: 2019-08-11  08:41:01

--
Commandline: /usr/sbin/synaptic
Requested-By: jjcojax (1000)
Remove: linux-image-generic:amd64 (4.15.0.55.57), linux-modules-extra-4.15.0-55-generic:amd64 (4.15.0-55.60)
End-Date: 2019-08-11  08:42:09

--
Commandline: /usr/sbin/synaptic
Requested-By: jjcojax (1000)
Install: linux-tools-4.15.0-51:amd64 (4.15.0-51.55, automatic), linux-tools-common:amd64 (4.15.0-55.60, automatic), linux-tools-4.15.0-51-generic:amd64 (4.15.0-51.55)
End-Date: 2019-08-11  08:45:40

--
Commandline: /usr/sbin/synaptic
Requested-By: jjcojax (1000)
Install: linux-image-4.15.0-51-generic:amd64 (4.15.0-51.55), linux-modules-4.15.0-51-generic:amd64 (4.15.0-51.55, automatic)
Remove: linux-tools-4.15.0-51:amd64 (4.15.0-51.55), linux-tools-4.15.0-51-generic:amd64 (4.15.0-51.55)
End-Date: 2019-08-11  08:49:41

--
Commandline: /usr/sbin/synaptic
Requested-By: jjcojax (1000)
Install: linux-headers-4.15.0-51:amd64 (4.15.0-51.55), linux-headers-4.15.0-51-generic:amd64 (4.15.0-51.55)
End-Date: 2019-08-11  08:53:31

--
Commandline: /usr/sbin/synaptic
Requested-By: jjcojax (1000)
Purge: linux-modules-4.15.0-55-generic:amd64 (4.15.0-55.60), linux-image-4.15.0-55-generic:amd64 (4.15.0-55.60)
End-Date: 2019-08-11  09:14:21

--
Commandline: /usr/sbin/synaptic
Requested-By: jjcojax (1000)
Purge: linux-image-4.15.0-47-generic:amd64 (), linux-image-4.15.0-48-generic:amd64 (), linux-image-4.15.0-50-generic:amd64 (), linux-modules-extra-4.15.0-47-generic:amd64 (), linux-modules-4.15.0-47-generic:amd64 (), linux-modules-extra-4.15.0-48-generic:amd64 (), linux-modules-4.15.0-46-generic:amd64 (), linux-modules-extra-4.15.0-50-generic:amd64 (), linux-modules-4.15.0-48-generic:amd64 (), linux-modules-4.15.0-50-generic:amd64 (), linux-modules-extra-4.15.0-51-generic:amd64 (), linux-modules-extra-4.15.0-55-generic:amd64 ()
End-Date: 2019-08-14  20:04:32

Start-Date: 2019-08-14  21:55:54
Commandline: aptdaemon role='role-commit-packages' sender=':1.96'
Upgrade: libkf5config-data:amd64 (5.44.0-0ubuntu1, 5.44.0-0ubuntu1.1), poppler-utils:amd64 (0.62.0-2ubuntu2.9, 0.62.0-2ubuntu2.10), libgles2-mesa:amd64 (19.0.2-1ubuntu1.1~18.04.2, 19.0.8-0ubuntu0~18.04.1), linux-libc-dev:amd64 (4.15.0-55.60, 4.15.0-58.64), python3-software-properties:amd64 (0.96.24.32.9, 0.96.24.32.11), libegl-mesa0:amd64 (19.0.2-1ubuntu1.1~18.04.2, 19.0.8-0ubuntu0~18.04.1), libgs9:amd64 (9.26~dfsg+0-0ubuntu0.18.04.9, 9.26~dfsg+0-0ubuntu0.18.04.10), libglapi-mesa:amd64 (19.0.2-1ubuntu1.1~18.04.2, 19.0.8-0ubuntu0~18.04.1), libglapi-mesa:i386 (19.0.2-1ubuntu1.1~18.04.2, 19.0.8-0ubuntu0~18.04.1), libkf5configcore5:amd64 (5.44.0-0ubuntu1, 5.44.0-0ubuntu1.1), libxatracker2:amd64 (19.0.2-1ubuntu1.1~18.04.2, 19.0.8-0ubuntu0~18.04.1), libegl1-mesa:amd64 (19.0.2-1ubuntu1.1~18.04.2, 19.0.8-0ubuntu0~18.04.1), software-properties-gtk:amd64 (0.96.24.32.9, 0.96.24.32.11), libgbm1:amd64 (19.0.2-1ubuntu1.1~18.04.2, 19.0.8-0ubuntu0~18.04.1), libkf5configgui5:amd64 (5.44.0-0ubuntu1, 5.44.0-0ubuntu1.1), libwayland-egl1-mesa:amd64 (19.0.2-1ubuntu1.1~18.04.2, 19.0.8-0ubuntu0~18.04.1), ghostscript:amd64 (9.26~dfsg+0-0ubuntu0.18.04.9, 9.26~dfsg+0-0ubuntu0.18.04.10), wpasupplicant:amd64 (2:2.6-15ubuntu2.3, 2:2.6-15ubuntu2.4), ghostscript-x:amd64 (9.26~dfsg+0-0ubuntu0.18.04.9, 9.26~dfsg+0-0ubuntu0.18.04.10), libgl1-mesa-dri:amd64 (19.0.2-1ubuntu1.1~18.04.2, 19.0.8-0ubuntu0~18.04.1), libgl1-mesa-dri:i386 (19.0.2-1ubuntu1.1~18.04.2, 19.0.8-0ubuntu0~18.04.1), libosmesa6:amd64 (19.0.2-1ubuntu1.1~18.04.2, 19.0.8-0ubuntu0~18.04.1), libosmesa6:i386 (19.0.2-1ubuntu1.1~18.04.2, 19.0.8-0ubuntu0~18.04.1), libgs9-common:amd64 (9.26~dfsg+0-0ubuntu0.18.04.9, 9.26~dfsg+0-0ubuntu0.18.04.10), libgl1-mesa-glx:amd64 (19.0.2-1ubuntu1.1~18.04.2, 19.0.8-0ubuntu0~18.04.1), libgl1-mesa-glx:i386 (19.0.2-1ubuntu1.1~18.04.2, 19.0.8-0ubuntu0~18.04.1), libkf5config-bin:amd64 (5.44.0-0ubuntu1, 5.44.0-0ubuntu1.1), mesa-vdpau-drivers:amd64 (19.0.2-1ubuntu1.1~18.04.2, 19.0.8-0ubuntu0~18.04.1), linux-tools-common:amd64 (4.15.0-55.60, 4.15.0-58.64), libpoppler-glib8:amd64 (0.62.0-2ubuntu2.9, 0.62.0-2ubuntu2.10), libpoppler73:amd64 (0.62.0-2ubuntu2.9, 0.62.0-2ubuntu2.10), mesa-va-drivers:amd64 (19.0.2-1ubuntu1.1~18.04.2, 19.0.8-0ubuntu0~18.04.1), libglx-mesa0:amd64 (19.0.2-1ubuntu1.1~18.04.2, 19.0.8-0ubuntu0~18.04.1), libglx-mesa0:i386 (19.0.2-1ubuntu1.1~18.04.2, 19.0.8-0ubuntu0~18.04.1), software-properties-common:amd64 (0.96.24.32.9, 0.96.24.32.11)
End-Date: 2019-08-14  21:57:08

jjcojax@ASUS-I5-UBM164:~$ 
jjcojax@ASUS-I5-UBM164:~$ sudo zless /var/log/apt/history.log.1.gz | grep -C2 "4\.15\.0-5"
[sudo] Mot de passe de jjcojax : 
Start-Date: 2019-08-10  07:41:01
Commandline: aptdaemon role='role-commit-packages' sender=':1.69'
Install: linux-modules-4.15.0-55-generic:amd64 (4.15.0-55.60, automatic), linux-headers-4.15.0-55-generic:amd64 (4.15.0-55.60, automatic), linux-headers-4.15.0-55:amd64 (4.15.0-55.60, automatic), linux-image-4.15.0-55-generic:amd64 (4.15.0-55.60, automatic), linux-modules-extra-4.15.0-55-generic:amd64 (4.15.0-55.60, automatic)
Upgrade: vlc-bin:amd64 (3.0.4-1ubuntu0.2, 3.0.7.1-0ubuntu18.04.1), vlc-plugin-video-output:amd64 (3.0.4-1ubuntu0.2, 3.0.7.1-0ubuntu18.04.1), gstreamer1.0-alsa:amd64 (1.14.4-1ubuntu1.1~ubuntu18.04.1, 1.14.5-0ubuntu1~18.04.1), libgles2-mesa:amd64 (19.0.2-1ubuntu1.1~18.04.1, 19.0.2-1ubuntu1.1~18.04.2), language-pack-gnome-en:amd64 (1:18.04+20180712, 1:18.04+20190718), language-pack-gnome-fr:amd64 (1:18.04+20190117, 1:18.04+20190718), linux-headers-generic:amd64 (4.15.0.54.56, 4.15.0.55.57), gir1.2-gtk-3.0:amd64 (3.22.30-1ubuntu3, 3.22.30-1ubuntu4), linux-libc-dev:amd64 (4.15.0-54.58, 4.15.0-55.60), libldap-2.4-2:amd64 (2.4.45+dfsg-1ubuntu1.2, 2.4.45+dfsg-1ubuntu1.3), libldap-2.4-2:i386 (2.4.45+dfsg-1ubuntu1.2, 2.4.45+dfsg-1ubuntu1.3), openjdk-8-jre:amd64 (8u212-b03-0ubuntu1.18.04.1, 8u222-b10-1ubuntu1~18.04.1), sane-utils:amd64 (1.0.27-1~experimental3ubuntu2, 1.0.27-1~experimental3ubuntu2.1), libegl-mesa0:amd64 (19.0.2-1ubuntu1.1~18.04.1, 19.0.2-1ubuntu1.1~18.04.2), vlc-plugin-qt:amd64 (3.0.4-1ubuntu0.2, 3.0.7.1-0ubuntu18.04.1), libsystemd0:amd64 (237-3ubuntu10.24, 237-3ubuntu10.25), libsystemd0:i386 (237-3ubuntu10.24, 237-3ubuntu10.25), libgtk-3-common:amd64 (3.22.30-1ubuntu3, 3.22.30-1ubuntu4), gstreamer1.0-tools:amd64 (1.14.4-1~ubuntu18.04.1, 1.14.5-0ubuntu1~18.04.1), linux-image-generic:amd64 (4.15.0.54.56, 4.15.0.55.57), libgtk-3-0:amd64 (3.22.30-1ubuntu3, 3.22.30-1ubuntu4), gstreamer1.0-plugins-good:amd64 (1.14.4-1ubuntu1~ubuntu18.04.1, 1.14.5-0ubuntu1~18.04.1), libglapi-mesa:amd64 (19.0.2-1ubuntu1.1~18.04.1, 19.0.2-1ubuntu1.1~18.04.2), libglapi-mesa:i386 (19.0.2-1ubuntu1.1~18.04.1, 19.0.2-1ubuntu1.1~18.04.2), libebml4v5:amd64 (1.3.5-2, 1.3.5-2ubuntu0.1), iputils-arping:amd64 (3:20161105-1ubuntu2, 3:20161105-1ubuntu3), libcephfs2:amd64 (12.2.11-0ubuntu0.18.04.2, 12.2.12-0ubuntu0.18.04.1), vlc-plugin-skins2:amd64 (3.0.4-1ubuntu0.2, 3.0.7.1-0ubuntu18.04.1), vlc-plugin-visualization:amd64 (3.0.4-1ubuntu0.2, 3.0.7.1-0ubuntu18.04.1), vlc-l10n:amd64 (3.0.4-1ubuntu0.2, 3.0.7.1-0ubuntu18.04.1), kde-style-breeze:amd64 (4:5.12.7-0ubuntu0.1, 4:5.12.8-0ubuntu0.1), usb-creator-common:amd64 (0.3.5ubuntu18.04.1, 0.3.5ubuntu18.04.2), ubuntu-standard:amd64 (1.417.1, 1.417.3), libxatracker2:amd64 (19.0.2-1ubuntu1.1~18.04.1, 19.0.2-1ubuntu1.1~18.04.2), vlc-plugin-notify:amd64 (3.0.4-1ubuntu0.2, 3.0.7.1-0ubuntu18.04.1), libvlc5:amd64 (3.0.4-1ubuntu0.2, 3.0.7.1-0ubuntu18.04.1), iputils-tracepath:amd64 (3:20161105-1ubuntu2, 3:20161105-1ubuntu3), virtualbox-dkms:amd64 (5.2.18-dfsg-2~ubuntu18.04.5, 5.2.32-dfsg-0~ubuntu18.04.1), skypeforlinux:amd64 (8.49.0.49, 8.50.0.38), gstreamer1.0-plugins-bad:amd64 (1.14.4-1ubuntu1~ubuntu18.04.1, 1.14.5-0ubuntu1~18.04.1), udev:amd64 (237-3ubuntu10.24, 237-3ubuntu10.25), usb-creator-gtk:amd64 (0.3.5ubuntu18.04.1, 0.3.5ubuntu18.04.2), libegl1-mesa:amd64 (19.0.2-1ubuntu1.1~18.04.1, 19.0.2-1ubuntu1.1~18.04.2), gstreamer1.0-plugins-base:amd64 (1.14.4-1ubuntu1.1~ubuntu18.04.1, 1.14.5-0ubuntu1~18.04.1), gstreamer1.0-plugins-base:i386 (1.14.4-1ubuntu1.1~ubuntu18.04.1, 1.14.5-0ubuntu1~18.04.1), language-pack-en:amd64 (1:18.04+20180712, 1:18.04+20190718), language-pack-fr:amd64 (1:18.04+20190117, 1:18.04+20190718), dkms:amd64 (2.3-3ubuntu9.3, 2.3-3ubuntu9.5), virtualbox:amd64 (5.2.18-dfsg-2~ubuntu18.04.5, 5.2.32-dfsg-0~ubuntu18.04.1), openjdk-11-jre-headless:amd64 (11.0.3+7-1ubuntu2~18.04.1, 11.0.4+11-1ubuntu2~18.04.3), linux-signed-generic:amd64 (4.15.0.54.56, 4.15.0.55.57), kde-style-breeze-qt4:amd64 (4:5.12.7-0ubuntu0.1, 4:5.12.8-0ubuntu0.1), libgstreamer-plugins-good1.0-0:amd64 (1.14.4-1ubuntu1~ubuntu18.04.1, 1.14.5-0ubuntu1~18.04.1), libvlccore9:amd64 (3.0.4-1ubuntu0.2, 3.0.7.1-0ubuntu18.04.1), libudev1:amd64 (237-3ubuntu10.24, 237-3ubuntu10.25), libudev1:i386 (237-3ubuntu10.24, 237-3ubuntu10.25), libvlc-bin:amd64 (3.0.4-1ubuntu0.2, 3.0.7.1-0ubuntu18.04.1), gstreamer1.0-pulseaudio:amd64 (1.14.4-1ubuntu1~ubuntu18.04.1, 1.14.5-0ubuntu1~18.04.1), libgbm1:amd64 (19.0.2-1ubuntu1.1~18.04.1, 19.0.2-1ubuntu1.1~18.04.2), ubuntu-minimal:amd64 (1.417.1, 1.417.3), libinput-bin:amd64 (1.10.4-1, 1.10.4-1ubuntu0.18.04.1), gstreamer1.0-gtk3:amd64 (1.14.4-1ubuntu1~ubuntu18.04.1, 1.14.5-0ubuntu1~18.04.1), libsane1:amd64 (1.0.27-1~experimental3ubuntu2, 1.0.27-1~experimental3ubuntu2.1), libsane1:i386 (1.0.27-1~experimental3ubuntu2, 1.0.27-1~experimental3ubuntu2.1), libgtk-3-bin:amd64 (3.22.30-1ubuntu3, 3.22.30-1ubuntu4), libnss-myhostname:amd64 (237-3ubuntu10.24, 237-3ubuntu10.25), libgstreamer-gl1.0-0:amd64 (1.14.4-1ubuntu1.1~ubuntu18.04.1, 1.14.5-0ubuntu1~18.04.1), libmspack0:amd64 (0.6-3ubuntu0.2, 0.6-3ubuntu0.3), systemd-sysv:amd64 (237-3ubuntu10.24, 237-3ubuntu10.25), firefox-locale-en:amd64 (68.0+build3-0ubuntu0.18.04.1, 68.0.1+build1-0ubuntu0.18.04.1), firefox-locale-fr:amd64 (68.0+build3-0ubuntu0.18.04.1, 68.0.1+build1-0ubuntu0.18.04.1), chromium-codecs-ffmpeg-extra:amd64 (75.0.3770.90-0ubuntu0.18.04.1, 76.0.3809.87-0ubuntu0.18.04.1), openjdk-11-jre:amd64 (11.0.3+7-1ubuntu2~18.04.1, 11.0.4+11-1ubuntu2~18.04.3), libldap-common:amd64 (2.4.45+dfsg-1ubuntu1.2, 2.4.45+dfsg-1ubuntu1.3), firefox-locale-nl:amd64 (68.0+build3-0ubuntu0.18.04.1, 68.0.1+build1-0ubuntu0.18.04.1), libwayland-egl1-mesa:amd64 (19.0.2-1ubuntu1.1~18.04.1, 19.0.2-1ubuntu1.1~18.04.2), vlc:amd64 (3.0.4-1ubuntu0.2, 3.0.7.1-0ubuntu18.04.1), libpam-systemd:amd64 (237-3ubuntu10.24, 237-3ubuntu10.25), libgstreamer-plugins-base1.0-0:amd64 (1.14.4-1ubuntu1.1~ubuntu18.04.1, 1.14.5-0ubuntu1~18.04.1), libgstreamer-plugins-base1.0-0:i386 (1.14.4-1ubuntu1.1~ubuntu18.04.1, 1.14.5-0ubuntu1~18.04.1), libgail-3-0:amd64 (3.22.30-1ubuntu3, 3.22.30-1ubuntu4), vlc-data:amd64 (3.0.4-1ubuntu0.2, 3.0.7.1-0ubuntu18.04.1), gstreamer1.0-x:amd64 (1.14.4-1ubuntu1.1~ubuntu18.04.1, 1.14.5-0ubuntu1~18.04.1), systemd:amd64 (237-3ubuntu10.24, 237-3ubuntu10.25), gir1.2-gst-plugins-base-1.0:amd64 (1.14.4-1ubuntu1.1~ubuntu18.04.1, 1.14.5-0ubuntu1~18.04.1), libgl1-mesa-dri:amd64 (19.0.2-1ubuntu1.1~18.04.1, 19.0.2-1ubuntu1.1~18.04.2), libgl1-mesa-dri:i386 (19.0.2-1ubuntu1.1~18.04.1, 19.0.2-1ubuntu1.1~18.04.2), iputils-ping:amd64 (3:20161105-1ubuntu2, 3:20161105-1ubuntu3), libosmesa6:amd64 (19.0.2-1ubuntu1.1~18.04.1, 19.0.2-1ubuntu1.1~18.04.2), libosmesa6:i386 (19.0.2-1ubuntu1.1~18.04.1, 19.0.2-1ubuntu1.1~18.04.2), libmysqlclient20:i386 (5.7.26-0ubuntu0.18.04.1, 5.7.27-0ubuntu0.18.04.1), libnss-systemd:amd64 (237-3ubuntu10.24, 237-3ubuntu10.25), vlc-plugin-video-splitter:amd64 (3.0.4-1ubuntu0.2, 3.0.7.1-0ubuntu18.04.1), openjdk-8-jre-headless:amd64 (8u212-b03-0ubuntu1.18.04.1, 8u222-b10-1ubuntu1~18.04.1), gstreamer1.0-libav:amd64 (1.14.4-0ubuntu1~ubuntu18.04.1, 1.14.5-0ubuntu1~18.04.1), libgl1-mesa-glx:amd64 (19.0.2-1ubuntu1.1~18.04.1, 19.0.2-1ubuntu1.1~18.04.2), libgl1-mesa-glx:i386 (19.0.2-1ubuntu1.1~18.04.1, 19.0.2-1ubuntu1.1~18.04.2), libsane-common:amd64 (1.0.27-1~experimental3ubuntu2, 1.0.27-1~experimental3ubuntu2.1), apache2-bin:amd64 (2.4.29-1ubuntu4.7, 2.4.29-1ubuntu4.8), virtualbox-qt:amd64 (5.2.18-dfsg-2~ubuntu18.04.5, 5.2.32-dfsg-0~ubuntu18.04.1), firefox:amd64 (68.0+build3-0ubuntu0.18.04.1, 68.0.1+build1-0ubuntu0.18.04.1), gir1.2-gstreamer-1.0:amd64 (1.14.4-1~ubuntu18.04.1, 1.14.5-0ubuntu1~18.04.1), gtk-update-icon-cache:amd64 (3.22.30-1ubuntu3, 3.22.30-1ubuntu4), mesa-vdpau-drivers:amd64 (19.0.2-1ubuntu1.1~18.04.1, 19.0.2-1ubuntu1.1~18.04.2), linux-firmware:amd64 (1.173.8, 1.173.9), vlc-plugin-base:amd64 (3.0.4-1ubuntu0.2, 3.0.7.1-0ubuntu18.04.1), gstreamer1.0-vaapi:amd64 (1.14.4-1~ubuntu18.04.1, 1.14.5-0ubuntu1~ubuntu18.04.1), patch:amd64 (2.7.6-2ubuntu1, 2.7.6-2ubuntu1.1), libgstreamer-plugins-bad1.0-0:amd64 (1.14.4-1ubuntu1~ubuntu18.04.1, 1.14.5-0ubuntu1~18.04.1), libgstreamer1.0-0:amd64 (1.14.4-1~ubuntu18.04.1, 1.14.5-0ubuntu1~18.04.1), libgstreamer1.0-0:i386 (1.14.4-1~ubuntu18.04.1, 1.14.5-0ubuntu1~18.04.1), linux-generic:amd64 (4.15.0.54.56, 4.15.0.55.57), librados2:amd64 (12.2.11-0ubuntu0.18.04.2, 12.2.12-0ubuntu0.18.04.1), gstreamer1.0-gl:amd64 (1.14.4-1ubuntu1.1~ubuntu18.04.1, 1.14.5-0ubuntu1~18.04.1), libinput10:amd64 (1.10.4-1, 1.10.4-1ubuntu0.18.04.1), mesa-va-drivers:amd64 (19.0.2-1ubuntu1.1~18.04.1, 19.0.2-1ubuntu1.1~18.04.2), base-files:amd64 (10.1ubuntu2.4, 10.1ubuntu2.6), gstreamer1.0-plugins-ugly:amd64 (1.14.4-1~ubuntu18.04.1, 1.14.5-0ubuntu1~18.04.1), libglx-mesa0:amd64 (19.0.2-1ubuntu1.1~18.04.1, 19.0.2-1ubuntu1.1~18.04.2), libglx-mesa0:i386 (19.0.2-1ubuntu1.1~18.04.1, 19.0.2-1ubuntu1.1~18.04.2)
jjcojax@ASUS-I5-UBM164:~$ 
jjcojax@ASUS-I5-UBM164:~$ dpkg -l | grep "4\.15\.0-54"
ii  linux-headers-4.15.0-54                       4.15.0-54.58                                        all          Header files related to Linux kernel version 4.15.0
ii  linux-headers-4.15.0-54-generic               4.15.0-54.58                                        amd64        Linux kernel headers for version 4.15.0 on 64 bit x86 SMP
ii  linux-image-4.15.0-54-generic                 4.15.0-54.58                                        amd64        Signed kernel image generic
ii  linux-modules-4.15.0-54-generic               4.15.0-54.58                                        amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
ii  linux-modules-extra-4.15.0-54-generic         4.15.0-54.58                                        amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
jjcojax@ASUS-I5-UBM164:~$ 
jjcojax@ASUS-I5-UBM164:~$ dpkg -l | grep "4\.15\.0-55"
jjcojax@ASUS-I5-UBM164:~$ 

La raison pour laquelle, la dernière commande ne retourne rien est ici
-----------------------------------

ylag à écrit ...

sudo apt-mark manual linux-headers-4.15.0-54 linux-headers-4.15.0-54-generic linux-image-4.15.0-54-generic linux-modules-4.15.0-54-generic linux-modules-extra-4.15.0-54-generic

C'est ce qui correspond le mieux à ma demande,
Merci à lui,
-----------------------------------
Il y a maintenant une version l4.15.0-58, je vais l'essayer d'ici peux, et je reviendrais pour marquer résolu ou pas dans quelques jours.

Merci

jjcojax

Hors ligne

#15 Le 15/08/2019, à 13:55

jjcojax

Re : [résolu]Bloquer les derniers noyaux pour garder la mises en veille.

Suite,

La version 4.15.0-58 n'a plus ce problèmes de mise en veille = problème résolu !

Merci à tous,

J'ai un question supplémentaire concernant les noyaux:

Quand je sélectionne 4.15.0-58 dans le gestionnaire de paquets, j’obtiens ceci

Pour le moment, je sélectionne les paquets (à pouf) sur base de ce que je vois parmi les anciens paquets.

Qu'est-ce qui est indispensable? ,
Qu'est ce qui est l'est moins? ,
Le rôle de linux-tool, lowlatency, unsigned ?
Est-ce que les modules nvidia apporte quelque chose aux vieux PC qui comporte une carte vidéo nvidia (PC utilisés uniquement pour mes sauvegardes)

Vos réponses peuvent être partielles, ou me renvoyer sur un (ou des) page(s) d'infos.

Rien ne presse pour vos réponses, je ne viens que quand j'ai du temps libre après le boulot.

Merci

jjcojax

Hors ligne

#16 Le 15/08/2019, à 14:11

ylag

Re : [résolu]Bloquer les derniers noyaux pour garder la mises en veille.

Salut,

Si tu considères ne plus devoir garder le noyau 4.15.0-54, repasse la commande du commentaire #10 en y remplaçant manual par auto, ce qui permettra d'enlever automatiquement ce noyau lors d'une commande apt autoremove.

Pour les noyaux, il ne faut pas sélectionner de paquets à la pièce dans synaptic. C'est la présence sur ton système des méta-paquets linux-generic, linux-image-generic et linux-headers-generic qui fait en sorte que les bons paquets seront installés sur ton système.
Si tu n'as pas ces paquets, installe simplement le paquet linux-generic, qui devrait tirer les bonnes dépendances et s'occuper par la suite de garder tes noyaux à jour.

A+

Dernière modification par ylag (Le 15/08/2019, à 14:26)

En ligne

#17 Le 15/08/2019, à 14:15

xubu1957

Re : [résolu]Bloquer les derniers noyaux pour garder la mises en veille.

Bonjour,

Pour lowlatency, la Doc linux-lowlatency

Noyau Linux-lowlatency
Un noyau à faible latence est un noyau spécialisé optimisé pour les opérations de calcul en temps réel. Un usage spécifique pour l'informatique domestique est la musique assistée par ordinateur, puisque le noyau low-latency permet de réduire la consommation CPU pour un même temps de latence lors du traitement audio. Ce qui permet in fine d'optimiser ses réglages audio afin de réduire ce temps de latence.

Cette optimisation se fait généralement au détriment de certaines règles assurant la sécurité ou la fiabilité générale du système.

Certaines variantes d'Ubuntu et autres distributions GNU/Linux disposent nativement du noyau low-latency.

Dernière modification par xubu1957 (Le 15/08/2019, à 14:16)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne