Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 11/09/2019, à 09:32

MarkoK

Installer une old-release d'OpenShot Video Editor

Salut à tous !

Je vous explique mon problème : j'ai fais la mise à niveau vers Ubuntu 18.04 très récemment et OpenShot a changé de version. Maintenant et depuis 2017, une version QT est en développement. Ça fait de nombreux mois que j'essaie de la prendre en main et que j'ai testé des solutions alternatives comme Shotcut, Flowblade ou Kdenlive, mais rien n'y fait : tout ça n'est pas aussi précis qu'OpenShot dans sa version antérieure à 2017. Sur la nouvelle version, la précision de l'emplacement des images clés est douteuse, les propriétés sont peu ergonomiques, etc...

Je suis dos au mur, pour mes études je dois produire une vidéo et le seul outil de montage qui pourrait me permettre de vraiment avoir un résultat pro serait OpenShot tel qu'il est dans les dépôts de la 16.04. Avant de migrer vers Ubuntu 16.04, je vous demande donc si il n'est pas possible d'installer cette ancienne version sur une 18.04.

Voici quelque liens que j'ai trouvé ! wink
- Wiki Ubuntu : https://doc.ubuntu-fr.org/openshot
- Question semblable n'ayant pas aboutie : https://github.com/OpenShot/openshot-qt/issues/944
- Historique des versions sur le Launchpad : https://launchpad.net/openshot/+downloa … 0&start=10
Note : openshot_1.4.3-1_all.deb nécessite un blocage de sa mise à jour dans dpkg/apt-get sinon, la version actuelle l'écrase lors d'une mise à jour. Il y a également un problème de dépendances qui ne sont pas présentes dans le paquet ".deb".

Merci d'avance pour votre aide ! J'en ai vraiment besoin ! smile

Marko !

PS : Je comprends bien les instabilités systèmes qui peuvent être crées mais comprenez que si je vous demande, c'est que j'ai tout essayé.

Hors ligne

#2 Le 12/09/2019, à 22:54

MarkoK

Re : Installer une old-release d'OpenShot Video Editor

Salut à tous ! J'ai du nouveau.

J'ai récupéré "openshot_1.4.3-1_all.deb" ici.
Je l'ai installé avec dpkg et ai bloqué la mise à jour automatique comme expliqué dans ce fil.
Problème : quand j'installe les dépendances automatiquement :

sudo apt-get -f install

Voici ce qui advient :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Correction des dépendances... a échoué.
Les paquets suivants contiennent des dépendances non satisfaites :
 openshot : Dépend: melt mais il n'est pas installé
            Dépend: python-httplib2 mais il n'est pas installé
            Dépend: python-imaging mais il n'est pas installable
            Dépend: python-mlt5 mais il n'est pas installable ou
                     python-mlt3 mais il n'est pas installable ou
                     python-mlt2 mais il n'est pas installable
            Dépend: python-pygoocanvas mais il n'est pas installable
            Dépend: python-xdg mais il n'est pas installé
            Dépend: python-support (>= 0.90.0) mais il n'est pas installable
            Recommande: openshot-doc mais il n'est pas installé
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.
E: Impossible de corriger les dépendances

J'ai recensé les paquest suivants disponibles sur pkgs.org :
Dépend: melt https://pkgs.org/download/melt
python-httplib2 https://pkgs.org/download/python-httplib2
python-imaging https://pkgs.org/download/python-imaging
python-mlt5 introuvable
python-pygoocanvas https://pkgs.org/download/python-pygoocanvas
python-xdg https://pkgs.org/download/python-xdg
python-support https://pkgs.org/download/python-support
Mais les installer manuellement requiert d'installer leur dépendances qui requièrent des dépendances, etc... Y a t-il une solution propre en ligne de commande ?

Merci de votre aide !

Hors ligne

#3 Le 13/09/2019, à 09:23

rogn...

Re : Installer une old-release d'OpenShot Video Editor

Salut.
Suggestion : pourquoi tu ne te montes pas une VM Ubuntu 16.04 ? Tu installes la version d'openshot pour 16.04 en ne la mettant pas à jour.


Rogn on GitHub
Manjaro MATE / Ubuntu & Xubuntu 19.10
"Marcher à contre sens du vent permet de péter dans le sens de celui-ci."

Hors ligne