Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 10/10/2019, à 09:51

le-peyo

[RÉSOLU] Carte son Usb non reconnue sur un Hub (Lenovo W540)

¡ Holà !

J'ai acquis un Lenovo Thinkpad W540, que j'ai installé sur ma tablette refroidissante qui me sert de Hub Usb en même temps.
La carte est immédiatement reconnue si je la branche directement sur l'ordi, mais si je passe par la tablette elle n'est pas détectée, alors qu'une clef Usb est vue sans problème...

Je sèche...

Si quelqu'un a une idée...

lsusb en direct :

peyo@Saturn-5:~$ lsusb
Bus 002 Device 002: ID 8087:8000 Intel Corp. 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8008 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 004: ID 138a:0017 Validity Sensors, Inc. Fingerprint Reader
Bus 003 Device 038: ID 09ef:0101 Xitel MD-Port DG2 MiniDisc Interface
Bus 003 Device 011: ID 0e8f:00a4 GreenAsia Inc. 
Bus 003 Device 006: ID 5986:026a Acer, Inc 
Bus 003 Device 005: ID 8087:07dc Intel Corp. 
Bus 003 Device 002: ID 1a2c:2124 China Resource Semico Co., Ltd 
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
peyo@Saturn-5:~$ 

La carte son est la «Xitel MD-Port DG2 MiniDisc Interface».


lsusb en passant par la tablette :

peyo@Saturn-5:~$ lsusb
Bus 002 Device 002: ID 8087:8000 Intel Corp. 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8008 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 004: ID 138a:0017 Validity Sensors, Inc. Fingerprint Reader
Bus 003 Device 011: ID 0e8f:00a4 GreenAsia Inc. 
Bus 003 Device 006: ID 5986:026a Acer, Inc 
Bus 003 Device 005: ID 8087:07dc Intel Corp. 
Bus 003 Device 002: ID 1a2c:2124 China Resource Semico Co., Ltd 
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
peyo@Saturn-5:~$ 

À plus.

Dernière modification par le-peyo (Le 13/10/2019, à 21:12)


Sous Linux depuis 2009 | Xubuntu 18.04 LTS | Lenovo Thinkpad W540
Windows... ? J'connais pas...
Lire du Flash... sans Flash... C'est par là =>

Hors ligne

#2 Le 12/10/2019, à 06:56

xubu1957

Re : [RÉSOLU] Carte son Usb non reconnue sur un Hub (Lenovo W540)

Bonjour,

Je trouve cette discussion > how do I push audio to a usb device? [SOLVED]


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#3 Le 12/10/2019, à 08:37

moko138

Re : [RÉSOLU] Carte son Usb non reconnue sur un Hub (Lenovo W540)

Salut à tous !
1) Le problème se présente-t-il identiquement, que ton portable soit sur batterie ou sur secteur ?
      1a) Sur mon netbook (seulement 2 prises usb2), l'alimentation est conçue pour délivrer deux ampères (2 A). Et si je débranche l'alimentation secteur, mon netbook cesse d'alimenter les périphériques branchés au hub.
     1b) Quel courant (en Ampères) est-il gravé ou écrit sous ton portable ?


2) Le problème se présente-t-il identiquement, que la carte-son soit branchée au hub avant ou après démarrage ?
[Croisé avec le 1), ça fait quatre cas de figure].


3) Quand ta carte est reconnue, merci de montrer

lsusb | sort ; echo; lsusb -t

4)  Toujours se rappeler qu'un hub reçoit le courant pour UN périphérique  et ne peut ensuite que le partager.
       Donc
- Si les périphériques branchés n'ont qu'une consommation intermittente (comme un clavier ou une souris), ça passe encore.
- Avec une simple clef usb de stockage, ça peut coincer.
- Mais s'ils sont plusieurs et que certains ont besoin continûment de tout le courant disponible (comme un HDD rotatif ou une carte son), ça coince.


%NOINDEX%
Un utilitaire précieux : ncdu
Photo, mini-tutoriel :  À la découverte de dcraw

Hors ligne

#4 Le 12/10/2019, à 10:29

cqfd93

Re : [RÉSOLU] Carte son Usb non reconnue sur un Hub (Lenovo W540)

Bonjour,

moko138 a écrit :

4)  Toujours se rappeler qu'un hub reçoit le courant pour UN périphérique  et ne peut ensuite que le partager.
       Donc
- Si les périphériques branchés n'ont qu'une consommation intermittente (comme un clavier ou une souris), ça passe encore.
- Avec une simple clef usb de stockage, ça peut coincer.
- Mais s'ils sont plusieurs et que certains ont besoin continûment de tout le courant disponible (comme un HDD rotatif ou une carte son), ça coince.

Peut-on supposer qu'un hub alimenté sur secteur peut résoudre le problème ?


cqfd93

Hors ligne

#5 Le 12/10/2019, à 10:54

krodelabestiole

Re : [RÉSOLU] Carte son Usb non reconnue sur un Hub (Lenovo W540)

oui, mais ça fait une alim de plus à trimballer.

Hors ligne

#6 Le 12/10/2019, à 10:59

moko138

Re : [RÉSOLU] Carte son Usb non reconnue sur un Hub (Lenovo W540)

le-peyo a écrit :

... installé sur ma tablette refroidissante qui me sert de Hub Usb en même temps.

Alors, le-peyo, ta tablette refroidissante est-elle alimentée par usb ou a-t-elle son alimentation autonome ?


%NOINDEX%
Un utilitaire précieux : ncdu
Photo, mini-tutoriel :  À la découverte de dcraw

Hors ligne

#7 Le 12/10/2019, à 12:25

le-peyo

Re : [RÉSOLU] Carte son Usb non reconnue sur un Hub (Lenovo W540)

Par Usb, ce montage fonctionnait avec l'EasyNote de Packard-Bell, je n'ai rien changé (à part l'ordi wink )


Sous Linux depuis 2009 | Xubuntu 18.04 LTS | Lenovo Thinkpad W540
Windows... ? J'connais pas...
Lire du Flash... sans Flash... C'est par là =>

Hors ligne

#8 Le 12/10/2019, à 13:13

krodelabestiole

Re : [RÉSOLU] Carte son Usb non reconnue sur un Hub (Lenovo W540)

ta tablette n'a pas son alimentation autonome ? donc ça dépend de l'ampérage de l'usb de l'ordi, et ça ça varie d'un ordi à l'autre.

Hors ligne

#9 Le 12/10/2019, à 13:41

cqfd93

Re : [RÉSOLU] Carte son Usb non reconnue sur un Hub (Lenovo W540)

Si ni le hub ni la tablette refroidissante n'ont une alimentation secteur, c'est à l'ordinateur de fournir… ça fait sûrement trop pour lui.


cqfd93

Hors ligne

#10 Le 12/10/2019, à 21:21

le-peyo

Re : [RÉSOLU] Carte son Usb non reconnue sur un Hub (Lenovo W540)

Qu'on se comprenne bien, c'est la tablette qui est aussi un Hub : elle est branchée sur un port Usb, et elle redonne cet Usb dans un esprit de partage wink .
J'ai essayé de brancher la carte son sur la tablette en coupant les ventilos pour réduire l'intensité demandée => j'entend le craquement dans les enceintes qui indique bien que le courant passe mais elle reste invisible et muette.

Serait-ce un problème de gestion de la redirection des flux Usb  par mon Pc ?

@moko

1) Le problème se présente-t-il identiquement, que ton portable soit sur batterie ou sur secteur ?

C'est pareil.


1a) Sur mon netbook (seulement 2 prises usb2), l'alimentation est conçue pour délivrer deux ampères (2 A). Et si je débranche l'alimentation secteur, mon netbook cesse d'alimenter les périphériques branchés au hub.

Ça se règle dans le bios, c'est alimenté.


1b) Quel courant (en Ampères) est-il gravé ou écrit sous ton portable ?

Rien d'écrit...


2) Le problème se présente-t-il identiquement, que la carte-son soit branchée au hub avant ou après démarrage ?

Oui, ça ne change rien.


3) Quand ta carte est reconnue, merci de montrer
lsusb | sort ; echo; lsusb -t

Voilà :

peyo@Saturn-5:~$ lsusb | sort ; echo; lsusb -t
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8008 Intel Corp. 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 002: ID 8087:8000 Intel Corp. 
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 002: ID 1a2c:2124 China Resource Semico Co., Ltd 
Bus 003 Device 004: ID 0e8f:00a4 GreenAsia Inc. 
Bus 003 Device 005: ID 138a:0017 Validity Sensors, Inc. Fingerprint Reader
Bus 003 Device 006: ID 8087:07dc Intel Corp. 
Bus 003 Device 007: ID 5986:026a Acer, Inc 
Bus 003 Device 012: ID 09ef:0101 Xitel MD-Port DG2 MiniDisc Interface
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

/:  Bus 04.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/6p, 5000M
/:  Bus 03.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/15p, 480M
    |__ Port 1: Dev 2, If 0, Class=Human Interface Device, Driver=usbhid, 1.5M
    |__ Port 1: Dev 2, If 1, Class=Human Interface Device, Driver=usbhid, 1.5M
    |__ Port 2: Dev 12, If 1, Class=Audio, Driver=snd-usb-audio, 12M
    |__ Port 2: Dev 12, If 2, Class=Human Interface Device, Driver=usbhid, 12M
    |__ Port 2: Dev 12, If 0, Class=Audio, Driver=snd-usb-audio, 12M
    |__ Port 3: Dev 4, If 0, Class=Human Interface Device, Driver=usbhid, 1.5M
    |__ Port 3: Dev 4, If 1, Class=Human Interface Device, Driver=usbhid, 1.5M
    |__ Port 7: Dev 5, If 0, Class=Vendor Specific Class, Driver=, 12M
    |__ Port 11: Dev 6, If 0, Class=Wireless, Driver=btusb, 12M
    |__ Port 11: Dev 6, If 1, Class=Wireless, Driver=btusb, 12M
    |__ Port 12: Dev 7, If 1, Class=Video, Driver=uvcvideo, 480M
    |__ Port 12: Dev 7, If 0, Class=Video, Driver=uvcvideo, 480M
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/3p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/8p, 480M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/3p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/6p, 480M
peyo@Saturn-5:~$ 

À plus.


Sous Linux depuis 2009 | Xubuntu 18.04 LTS | Lenovo Thinkpad W540
Windows... ? J'connais pas...
Lire du Flash... sans Flash... C'est par là =>

Hors ligne

#11 Le 12/10/2019, à 21:26

cqfd93

Re : [RÉSOLU] Carte son Usb non reconnue sur un Hub (Lenovo W540)

La tablette a-t-elle sa propre alimentation électrique ?


cqfd93

Hors ligne

#12 Le 12/10/2019, à 21:46

le-peyo

Re : [RÉSOLU] Carte son Usb non reconnue sur un Hub (Lenovo W540)

Non, elle est branchée sur l'usb qui l'alimente pour nourrir les deux ventilos, ainsi que la carte son (qui est toute petite).

La tablette en question est visible . On la voit branchée sur le portable, et le port libre est celui sur lequel je mets ma carte son externe.

Dans cette vidéo (à 0:40)on voit que les ventilos consomment 0.28A chacun.

Dernière modification par le-peyo (Le 12/10/2019, à 22:12)


Sous Linux depuis 2009 | Xubuntu 18.04 LTS | Lenovo Thinkpad W540
Windows... ? J'connais pas...
Lire du Flash... sans Flash... C'est par là =>

Hors ligne

#13 Le 12/10/2019, à 22:27

le-peyo

Re : [RÉSOLU] Carte son Usb non reconnue sur un Hub (Lenovo W540)

Alors, suite de l'enquête...

Je suis allé déterrer un vieux hub usb 2.0 (alimenté par usb) pour savoir si c'était mon ordi qui ne voyait pas la carte branchée sur un hub :

Quand je branche le hub sur l'ordi et que je mets la carte son elle est bien détectée.
Quand je branche le hub avec la carte son dessus sur la tablette... ça marche.
Quand je branche la carte son directement sur la tablette, ça ne marche pas...

'comprends pas... hmm

Dernière modification par le-peyo (Le 12/10/2019, à 22:41)


Sous Linux depuis 2009 | Xubuntu 18.04 LTS | Lenovo Thinkpad W540
Windows... ? J'connais pas...
Lire du Flash... sans Flash... C'est par là =>

Hors ligne

#14 Le 13/10/2019, à 08:34

cqfd93

Re : [RÉSOLU] Carte son Usb non reconnue sur un Hub (Lenovo W540)

Bonjour,

Ah oui, c'est curieux !

Ta tablette est-elle USB 3 et si oui, utilises-tu un de ses ports USB 3 ? Le problème pourrait venir d'une incompatibilité de la carte son avec l'USB 3.


cqfd93

Hors ligne

#15 Le 13/10/2019, à 09:11

le-peyo

Re : [RÉSOLU] Carte son Usb non reconnue sur un Hub (Lenovo W540)

Non, c'est du vieux matos, usb 2.
Sur l'ordi il y a 2 usb2 et 2 usb3, quelle que soit la prise que j'utilise ça fait pareil.

C'est comme si la tablette empêchait l'ordi de voir la carte son, alors que l'ancien y arrivait.

J'ai contourné le problème en utilisant le vieux hub sur lequel j'ai relié la tablette et la carte son, ainsi que le clavier et le récepteur de la souris sans fil... comme ça je libère mes autres prises usb.

Mais je ne comprends toujours pas pourquoi ça fait ça...


Sous Linux depuis 2009 | Xubuntu 18.04 LTS | Lenovo Thinkpad W540
Windows... ? J'connais pas...
Lire du Flash... sans Flash... C'est par là =>

Hors ligne

#16 Le 13/10/2019, à 13:07

cqfd93

Re : [RÉSOLU] Carte son Usb non reconnue sur un Hub (Lenovo W540)

Les joies de la (dé)connectique…


cqfd93

Hors ligne

#17 Le 13/10/2019, à 21:11

le-peyo

Re : [RÉSOLU] Carte son Usb non reconnue sur un Hub (Lenovo W540)

Et bien, j'ai fini par trouver ! big_smile big_smile big_smile

Le problème venait d'un câble audio branché après la carte son !
Il était plié à angle droit et devait créer un léger mini court-circuit. L'ordi devait le détecter et il se mettait en sécurité en cessant d'alimenter le port usb. J'y ai pensé car, parfois, au démarrage il fallait débrancher et rebrancher la prise pour que la carte soit vue et ce, même avec l'ancien ordi.
La non-détection depuis la tablette viendrait (à mon avis) du fait que la tablette doit amplifier le signal électrique (ou alors disposer d'un filtre pour éliminer les parasites crées par les ventilos), ce que l'ordi comprenait comme étant un danger, et il coupait le jus. Je m'en suis rendu compte quand le clavier et la souris (branchés sur le même hub) ont cessé de fonctionner en même temps que le son tongue .

J'en conclus que la carte son devait détecter ce court-circuit et renvoyer un signal quelconque à l'ordi. Le fait que ça marchait en intercalant le hub entre la tablette et la carte est à mon avis dû au fait que le hub devait "absorber" ledit signal.

Si un expert en matos passe par-là j'aimerais bien avoir son avis.

Je passe en Résolu


À plus.

Dernière modification par le-peyo (Le 13/10/2019, à 22:56)


Sous Linux depuis 2009 | Xubuntu 18.04 LTS | Lenovo Thinkpad W540
Windows... ? J'connais pas...
Lire du Flash... sans Flash... C'est par là =>

Hors ligne