Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 08/11/2019, à 11:44

Dom_du_64

Nvidia Geforce 9300M GS sur Asus X71 SL démarrage Recovery obligé

Bonjour,
Je n'ai pas l'habitude de poster des messages car mon Ubuntu est d'une stabilité exemplaire ...
Voici mon problème. J'étais en version 16 et tout marchait bien. Après le passage en 18 04 3 LTS, écran presque noir au démarrage (une ligne violette vers le milieu de l'écran et c'est tout).
Mon PC est un portable Asus X71 SL désormais avec la 18. (avec une partition Windaube qui dort).
Je suis obligé de démarrer à chaque fois de la façon suivante :
"options avancées" puis "Recovery" puis "démarrage normal" puis "ok" et j'obtiens ensuite ma session avec un mode graphique basique :
Carte graphique llvmpipe (LLVM 8.0, 128 bits)
J'ai recherché dans Pilotes additionnels et il m'est proposé :
Nvidia binary driver version 340.107 depuis Nvidia 340 (propriétaire, testé)
Je suis allé sur le site de Nvidia, pas mieux ... seule la 340 est proposée.
Avec cette carte déclarée j'obtiens un écran noir.
Bien entendu j'ai cherché sur ce forum et essayé de trouver qq chose mais sans succès.
Merci d'avance pour votre aide,
Dom

Hors ligne

#2 Le 08/11/2019, à 16:43

ylag

Re : Nvidia Geforce 9300M GS sur Asus X71 SL démarrage Recovery obligé

Salut,

Quel pilote utilisais-tu sur la 16.04 ?
As-tu essayé avec le pilote libre « nouveau » ?
J'ai une GeForce 8600GT sur un ancien PC de bureau datant de 2009 qui fonctionne toujours très bien en 18.04.1 sur les noyaux 4.15.x.xx  avec le pilote NVIDIA 340.

Si tu as installé directement la 18.04.3, tu devrais avoir un noyau de série 5.0.x.xx; il y a déjà eu des problèmes pour le pilote nvidia-340 sur cette série de noyaux:
https://bugs.launchpad.net/ubuntu/+sour … ug/1838867
...qui semble avoir été réglé lors d'une mise à jour.

Donne peut-être les retours de:

uname -rm
lsmod | egrep "nouveau|nvidia"
dpkg -l | egrep "nvidia|nouveau"
dkms status

...histoire de voir ce que tu as présentement.

A+

Dernière modification par ylag (Le 09/11/2019, à 15:04)

En ligne

#3 Le 09/11/2019, à 15:00

Dom_du_64

Re : Nvidia Geforce 9300M GS sur Asus X71 SL démarrage Recovery obligé

Bonjour,
Désolé pour le retard ... voici les résultats.
Je ne me souviens pas de la carte que j'avais déclaré en 16.04.
Comme je ne savais pas quoi mettre dans "nouveau" alors j'ai mis "nouveau" (ne pas rigoler !).
https://nsm09.casimages.com/img/2019/11/09//1911090253269240016500821.png
https://nsm09.casimages.com/img/2019/11/09//1911090253259240016500820.png
La carte 340 indiquée ne marche pas si je la sélectionne.
Merci d'avance pour vos éclairages !
Dom


Modération : merci d'utiliser des images de petite taille (300x300) ou des miniatures pointant sur ces images (Des hébergeurs comme Toile Libre ou TDCT'Pix le permettent).

Dernière modification par cqfd93 (Le 09/11/2019, à 15:20)

Hors ligne

#4 Le 09/11/2019, à 15:11

ylag

Re : Nvidia Geforce 9300M GS sur Asus X71 SL démarrage Recovery obligé

Salut,

Coquille dans les commandes demandées au #2, à la place de dkms --status, c'est plutôt:

dkms status

...désolé.

Place ce genre de retour de commande entre les balises code - (ce sont les crochets bleus dans la barre d'outils de mise en forme en haut de la fenêtre de composition des messages) - plutôt que de faire une copie d'écran du terminal: Retour utilisable de commande

Ton retour indique que tu utilisais le pilote libre « nouveau », est-ce que ton affichage était correct à ce moment ? Si oui, je te suggérarais de le garder et de ne pas tenter de passer sur le pilote nvidia-340.


Dom_du_64 a écrit :

La carte 340 indiquée ne marche pas si je la sélectionne.

«340» n'est pas la carte, mais bien un pilote propriétaire NVIDIA de série 340 qui serait apte à faire fonctionner ta carte, une GeForce 9300M GS si on se fie au titre de la discussion.

Pour déterminer quelle est ta carte graphique ainsi que le pilote utilisé, donne le retour de:

lspci -nn -k | grep -i vga -A 3

Par exemple, ça donne ceci sur ma machine:

yvan@yvan-maison:~$ lspci -nn -k | grep -i vga -A 3
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation G84 [GeForce 8600 GT] [10de:0401] (rev a1)
	Subsystem: ASUSTeK Computer Inc. G84 [GeForce 8600 GT] [1043:8272]
	Kernel driver in use: nvidia
	Kernel modules: nvidiafb, nouveau, nvidia_340
yvan@yvan-maison:~$

...pour une carte NVIDIA GeForce 8600 GT utilisant présentement le pilote NVIDIA de série 340.

A+

Dernière modification par ylag (Le 09/11/2019, à 15:49)

En ligne

#5 Le 10/11/2019, à 11:04

Dom_du_64

Re : Nvidia Geforce 9300M GS sur Asus X71 SL démarrage Recovery obligé

Bonjour,
Tout d'abord merci pour le tuyau Balises de Code qui évitent la capture d'écran en format image.
Voilà où j'en suis :
dkms status ne renvoie rien (bizarre ?)
lspci renvoie ça :

dom@Asus-X71SL:~$ lspci -nn -k | grep -i vga -A 3
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation G98M [GeForce 9300M GS] [10de:06e9] (rev a1)
	Subsystem: ASUSTeK Computer Inc. U6V laptop [1043:19b2]
	Kernel modules: nvidiafb, nouveau
02:00.0 Network controller [0280]: Qualcomm Atheros AR928X Wireless Network Adapter (PCI-Express) [168c:002a] (rev 01)
dom@Asus-X71SL:~$

L'affichage est "relativement" correct mais je suis obligé de démarrer à chaque fois en mode Recovery sinon écran noir avec un vague trait violet au milieu.
Merci beaucoup par avance pour la suite,
Dom

Hors ligne

#6 Le 10/11/2019, à 13:00

ylag

Re : Nvidia Geforce 9300M GS sur Asus X71 SL démarrage Recovery obligé

Salut,

Le retour au #5 indiquerait que tu n'étais pas sous le pilote « nouveau » au moment où tu as passé la commande. Pourtant, ta deuxième copie d'écran au commentaire #3 semble indiquer que ce pilote devrait être utilisé.
Faudrait voir le retour de:

lsmod | sort

...pour déterminer quel module est chargé.

Pour s'assurer que le pilote nouveau est bien installé, vérifier le retour de:

apt policy xserver-xorg-video-nouveau

Et pour vérifier que le module nouveau ne soit pas « blacklisté» (empêché de se charger au démarrage), donne le retour de:

grep -i nouveau /etc/modprobe.d/*

...qui devrait retourner toutes les lignes contenant la chaîne de caractères « nouveau » dans les fichiers de config du dossier /etc/modprobe.d

En dernier, pour vérifier la présence de paquets du pilote NVIDIA:

dpkg -l | grep nvidia



Dom_du_64, au #5 a écrit :

dkms status ne renvoie rien (bizarre ?)

Ça indique simplement que le pilote NVIDIA n'est pas installé.

A+

Dernière modification par ylag (Le 10/11/2019, à 13:22)

En ligne

#7 Le 10/11/2019, à 14:39

Dom_du_64

Re : Nvidia Geforce 9300M GS sur Asus X71 SL démarrage Recovery obligé

Rebonjour,
Les résultats :

dom@Asus-X71SL:~$ lsmod | sort
arc4                   16384  2
asus_laptop            24576  0
ath                    24576  3 ath9k_hw,ath9k,ath9k_common
ath9k                 139264  0
ath9k_common           36864  1 ath9k
ath9k_hw              458752  2 ath9k,ath9k_common
autofs4                40960  2
bch                    20480  1 nand_bch
binfmt_misc            20480  1
bluetooth             466944  31 btrtl,btintel,bnep,btbcm,rfcomm,btusb
bnep                   20480  2
btbcm                  16384  1 btusb
btintel                16384  1 btusb
btrtl                  16384  1 btusb
btusb                  40960  0
ccm                    20480  6
cfg80211              536576  4 mac80211,ath9k,ath,ath9k_common
coretemp               16384  0
crc_itu_t              16384  1 firewire_core
drm                   344064  3 nouveau,ttm,drm_kms_helper
drm_kms_helper        151552  1 nouveau
ecdh_generic           28672  1 bluetooth
fb_sys_fops            16384  1 drm_kms_helper
firewire_core          57344  1 firewire_ohci
firewire_ohci          36864  0
hid                    98304  3 hid_generic,usbhid
hid_generic            16384  0
i2c_algo_bit           16384  1 nouveau
input_leds             16384  0
input_polldev          16384  1 asus_laptop
ip_tables              20480  0
joydev                 20480  0
lp                     20480  0
mac80211              679936  1 ath9k
mac_hid                16384  0
media                  32768  2 uvcvideo,videodev
memstick               16384  1 r592
mii                    16384  1 sis190
Module                  Size  Used by
mtd                    61440  3 nand_bch,sm_common,nand
mxm_wmi                16384  1 nouveau
nand                   77824  2 r852,sm_common
nand_bch               16384  1 nand
nand_ecc               16384  1 nand
nouveau              1531904  0
parport                45056  3 lp,parport_pc,ppdev
parport_pc             32768  0
pata_acpi              16384  0
ppdev                  20480  0
psmouse               131072  0
r592                   20480  0
r852                   20480  0
rfcomm                 61440  4
sata_sis               16384  2
sch_fq_codel           20480  2
sdhci                  49152  1 sdhci_pci
sdhci_pci              28672  0
serio_raw              16384  0
shpchp                 32768  0
sis190                 24576  0
sis_agp                16384  0
sm_common              16384  1 r852
snd                    69632  22 snd_hda_intel,snd_hwdep,snd_seq,snd_hda_codec,snd_timer,snd_rawmidi,snd_hda_codec_generic,snd_seq_device,snd_hda_codec_realtek,snd_pcm
snd_hda_codec         114688  3 snd_hda_intel,snd_hda_codec_generic,snd_hda_codec_realtek
snd_hda_codec_generic    69632  1 snd_hda_codec_realtek
snd_hda_codec_realtek    98304  1
snd_hda_core           69632  4 snd_hda_intel,snd_hda_codec,snd_hda_codec_generic,snd_hda_codec_realtek
snd_hda_intel          36864  6
snd_hwdep              16384  1 snd_hda_codec
snd_pcm                86016  3 snd_hda_intel,snd_hda_codec,snd_hda_core
snd_rawmidi            28672  1 snd_seq_midi
snd_seq                57344  2 snd_seq_midi_event,snd_seq_midi
snd_seq_device         16384  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_seq_midi           16384  0
snd_seq_midi_event     16384  1 snd_seq_midi
snd_timer              28672  2 snd_seq,snd_pcm
soundcore              16384  1 snd
sparse_keymap          16384  1 asus_laptop
syscopyarea            16384  1 drm_kms_helper
sysfillrect            16384  1 drm_kms_helper
sysimgblt              16384  1 drm_kms_helper
ttm                    94208  1 nouveau
usbhid                 49152  0
uvcvideo               81920  0
video                  40960  2 nouveau,asus_laptop
videobuf2_core         40960  2 uvcvideo,videobuf2_v4l2
videobuf2_memops       16384  1 videobuf2_vmalloc
videobuf2_v4l2         20480  1 uvcvideo
videobuf2_vmalloc      16384  1 uvcvideo
videodev              155648  3 uvcvideo,videobuf2_core,videobuf2_v4l2
wmi                    20480  2 mxm_wmi,nouveau
x_tables               28672  1 ip_tables
dom@Asus-X71SL:~$ 

et la suite :

dom@Asus-X71SL:~$ apt policy xserver-xorg-video-nouveau
xserver-xorg-video-nouveau:
  Installé : 1:1.0.15-2
  Candidat : 1:1.0.15-2
 Table de version :
 *** 1:1.0.15-2 500
        500 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 Packages
        100 /var/lib/dpkg/status
dom@Asus-X71SL:~$

dom@Asus-X71SL:~$ grep -i nouveau /etc/modprobe.d/*
dom@Asus-X71SL:~$ 
dom@Asus-X71SL:~$ dpkg -l | grep nvidia
ii  nvidia-settings                                             390.77-0ubuntu0.18.04.1                             i386         Tool for configuring the NVIDIA graphics driver
dom@Asus-X71SL:~$ 

et avec toujours mon "merci" qui ne coûte rien mais qui encourage ...
Dom

Hors ligne

#8 Le 10/11/2019, à 16:05

ylag

Re : Nvidia Geforce 9300M GS sur Asus X71 SL démarrage Recovery obligé

Salut,

Les retours au #7 indiquent que le module du pilote libre « nouveau » est chargé -> donc probablement utilisé, qu'il n'y a rien de spécial du côté de /etc/modprobe.d et que le pilote «NVIDIA 340 » semble correctement désinstallé. En théorie, ça devrait démarrer normalement... hmm
Peut-être que le pilote nouveau ne supporte pas bien cette carte?
Dommage de ne pas savoir quel pilote tu utilisais sous Ubuntu 16.xx avant de faire ta mise à niveau...

Je serais tenté de suggérer un  autre essai avec le pilote NVIDIA 340 en le sélectionnant dans « Pilotes additionnels », puis redémarrer et dire si tu dois toujours passer par le mode « recovery » pour accéder à ta session ?
Si pas satisfaisant, tu retournes dans « Pilotes additionnels » et rechoisis « nouveau » puis redémarrage...

A+

Dernière modification par ylag (Le 11/11/2019, à 12:08)

En ligne

#9 Le 13/11/2019, à 10:58

Dom_du_64

Re : Nvidia Geforce 9300M GS sur Asus X71 SL démarrage Recovery obligé

Salut,
Bon, voilà où j'en suis.
Avec le pilote NVidia 340 sélectionné
Démarrage normal : écran noir
Démarrage Recovery : écran noir
Retour à la case départ ... je dois maintenant remettre le pilote standard en mode commande Root (depuis Recovery), et bien sûr j'ai oublié comment faire ...
puis rester avec ce pilote et un affichage vraiment quelconque ... mais c'est mieux que rien ...
Je retourne chercher à partir d'un autre PC ...
Merci de m'avoir aidé,
Dom

Hors ligne

#10 Le 13/11/2019, à 13:16

ylag

Re : Nvidia Geforce 9300M GS sur Asus X71 SL démarrage Recovery obligé

Bonjour,

Bon, il semble bien que le pilote NVIDIA 340 ne fonctionne vraiment pas correctement pour ta carte, désolé... sad

Dom_du_64 a écrit :

je dois maintenant remettre le pilote standard en mode commande Root (depuis Recovery)...

Si tu peux basculer sur une console au démarrage (Ctrl+Alt+F3, par exemple...) , tente de désinstaller le pilote NVIDIA:

sudo apt purge nvidia-*

Il devrait aussi être possible de le faire depuis le mode «recovery»?
Dans ce cas, il faut peut-être remonter le système de fichier en mode lecture/écriture pour pouvoir purger les paquets NVIDIA; si c'est le cas, la commande à passer serait:

mount -o remount,rw /

...avant de tenter la désinstallation des paquets NVIDIA.

A+

Dernière modification par ylag (Le 13/11/2019, à 14:04)

En ligne

#11 Le 13/11/2019, à 15:39

Dom_du_64

Re : Nvidia Geforce 9300M GS sur Asus X71 SL démarrage Recovery obligé

Re-bonjour,
La commande sudo apt purge nvidia-* semble avoir marché car j'ai à nouveau un affichage graphique, le pilote standard étant revenu implicitement.
Il me reste le mode Recovery qui est à faire à chaque fois, sinon écran noir ... comment me débarrasser de ce mode et revenir à un démarrage normal ?
Merci d'avance,
Dom

Hors ligne

#12 Le 13/11/2019, à 15:48

ylag

Re : Nvidia Geforce 9300M GS sur Asus X71 SL démarrage Recovery obligé

Salut,

Peut-être tenter de démarrer sur une session "live"?
Si le démarrage est normal dans ce cas, une solution drastique serait de tenter une réinstallation.

Avant d'en arriver là, il faudrait l'intervention d'aidant(e)s plus ferrés que moi en ce domaine.

Encore désolé de n'avoir rien d'autre à te suggérer...

A+

En ligne

#13 Le 15/11/2019, à 22:23

Dom_du_64

Re : Nvidia Geforce 9300M GS sur Asus X71 SL démarrage Recovery obligé

Salut Ylag,
Juste un petit merci pour ton aide, ça m'a quand même permis d'avancer.
Je laisse le sujet ouvert et NON RÉSOLU au cas où quelqu'un aurai des idées ...
Bonne continuation,
Dom

Hors ligne