Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 01/11/2008, à 14:33

Jmgr

Flash et Ubuntu 8.10 64 bits

Salut à tous,

je suis passé d'Ubuntu 8.04 (64bits également) à la 8.10, et hélas cela a provoqué l'arrêt du fonctionnement de flash pour Firefox.

J'ai tenté de multiples manipulations à partir de tutos trouvés sur Google et dans la doc, mais sans succès.
Mon dernier essai en utilisant nspluginwrapper et la version 10 de flash d'Adobe se solde par un échec avec le message

LoadPlugin: failed to initialize shared library /usr/lib/mozilla/plugins/libflashplayer.so /usr/lib/mozilla/plugins/libflashplayer.so: mauvaise classe ELF: ELFCLASS32

lors du chargement de pages avec du Flash...

Donc voila je suis un peu désespéré, j'aimerais cambrioler les locaux d'Adobe pour compiler leur plugin en 64 bits (ça doit pouvoir se faire en 5 min), mais bon cela ne me semble pas trop possible.

Bref si quelqu'un a une idée...

Hors ligne

#2 Le 01/11/2008, à 22:50

Korak

Re : Flash et Ubuntu 8.10 64 bits

Bonsoir,

Bizare, j'ai fais la mise-à-jour d'Ubuntu 8.04 vers Ubuntu 8.10 et le Flash fonctionne toujours.

Au moins sur le site www.allocine.fr


OS: Ubuntu 14.04 64 bits + Windows 8.1 64 bits en dualboot (BIOS UEFI, Secure Boot activé et table de partitions GPT)
PC portable HP Pavilion 17-f055nb: Processeur: AMD A8-6410 APU   Carte graphique: AMD Radeon R5   Mémoire vive: 8 Go RAM
Je suis Parrain-Linux

En ligne

#3 Le 02/11/2008, à 10:57

mrniko

Re : Flash et Ubuntu 8.10 64 bits

Je ne suis pas passé à la 8.10 et j'ai le problème depuis hier. Du blanc à la place des contenus flash...

flash_blanc_small.png

Mozilla/5.0 (X11; U; Linux x86_64; fr; rv:1.9.0.3) Gecko/2008092510 Ubuntu/8.04 (hardy) Firefox/3.0.3

Avec "about:plugins" :
Shockwave Flash
Nom de fichier : npwrapper.libflashplayer.so
Shockwave Flash 9.0 r124


Une idée...

Dernière modification par mrniko (Le 02/11/2008, à 11:05)

Hors ligne

#4 Le 02/11/2008, à 12:15

Jmgr

Re : Flash et Ubuntu 8.10 64 bits

Ah oui bonne idée, donc moi j'ai :
Mozilla/5.0 (X11; U; Linux x86_64; fr; rv:1.9.0.3) Gecko/2008101315 Ubuntu/8.10 (intrepid) Firefox/3.0.3

Shockwave Flash
Nom de fichier : npwrapper.libflashplayer.so
Shockwave Flash 10.0 r12

Hors ligne

#5 Le 02/11/2008, à 13:41

mrniko

Re : Flash et Ubuntu 8.10 64 bits

Jmgr a écrit :

Ah oui bonne idée, donc moi j'ai :
[...]
Shockwave Flash 10.0 r12

J'ai téléchargé la version 10 de Flash (install_flash_player_10_linux.deb) mais l'installeur m'a répondu :

Error : Wrong architecture 'i386'

Hors ligne

#6 Le 02/11/2008, à 16:09

Danzisso

Re : Flash et Ubuntu 8.10 64 bits

moi perso j'ai installé flashplugin-nonfree, qui en fait s'est mis quand j'ai mis le package ubuntu-restricted-extras.
Ensuite j'ai installé swfdec-mozilla, et maintenant le flash marche nickel


Passé à Fedora (et bientôt chez Foresight?). Mais je ne regrette rien, merci Ubuntu de m'avoir permis d'entrer dans cet univers.

Hors ligne

#7 Le 02/11/2008, à 18:26

mrniko

Re : Flash et Ubuntu 8.10 64 bits

Danzisso a écrit :

moi perso j'ai installé flashplugin-nonfree, qui en fait s'est mis quand j'ai mis le package ubuntu-restricted-extras.
Ensuite j'ai installé swfdec-mozilla, et maintenant le flash marche nickel

Welldone !!!

Merci ça marche maintenant.

Hors ligne

#8 Le 02/11/2008, à 19:16

brakbabord

Re : Flash et Ubuntu 8.10 64 bits

swfdec-mozilla ça te fait utiliser swfdec à la place de flashplayer non?

Hors ligne

#9 Le 02/11/2008, à 21:42

yostral

Re : Flash et Ubuntu 8.10 64 bits

Oui. C'est une implémentation libre de Flash, comme Gnash. Il marche pas mal mais foirera encore sur un bon paquet de sites...


Quand tout le reste a échoué, lisez le mode d'emploi.

Hors ligne

#10 Le 02/11/2008, à 23:23

Jmgr

Re : Flash et Ubuntu 8.10 64 bits

Hm ça ne marche pas mieux chez moi, maintenant dans about:plugins j'ai :

Shockwave Flash

    Nom de fichier : npwrapper.libflashplayer.so
    Shockwave Flash 10.0 r12

Type MIME     Description     Suffixes     Autorisé
application/x-shockwave-flash     Shockwave Flash     swf     Oui
application/futuresplash     FutureSplash Player     spl     Oui

Ya un moyen simple de "faire le vide" de tous les plugins FF liés au flash pour repartir sur de bonne bases ?

Hors ligne

#11 Le 03/11/2008, à 00:19

Jmgr

Re : Flash et Ubuntu 8.10 64 bits

Bon, j'ai recherché et renommé tous les libflashplayer.so en libflashplayer.so.old et j'ai réussi à avoir FF sans plugin Flash. J'ai ensuite réinstallé flashplugin-nonfree.

Maintenant quand je veux lire du flash j'ai droit à ça :

(npviewer.bin:30273): Gdk-WARNING **: GdkWindow 0x500001a unexpectedly destroyed

(npviewer.bin:30273): Gdk-WARNING **: GdkWindow 0x5000019 unexpectedly destroyed

(npviewer.bin:30273): Gdk-WARNING **: GdkWindow 0x5000018 unexpectedly destroyed

(npviewer.bin:30273): Gdk-WARNING **: GdkWindow 0x5000003 unexpectedly destroyed

(npviewer.bin:30273): Gtk-CRITICAL **: gtk_style_detach: assertion `style->attach_count > 0' failed
The program 'npviewer.bin' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 232 error_code 3 request_code 18 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

(firefox:30246): GLib-CRITICAL **: g_hash_table_insert_internal: assertion `hash_table != NULL' failed
*** NSPlugin Wrapper *** ERROR: NPP_NewStream() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_Destroy() invoke: Connection closed

(firefox:30246): GLib-CRITICAL **: g_hash_table_remove_internal: assertion `hash_table != NULL' failed
*** NSPlugin Wrapper *** ERROR: NPObject 0x3f501a0 is not valid!

Je crois que je vais tenter la méthode qui consiste à installer une version 32 bits de FF...

Hors ligne

#12 Le 03/11/2008, à 03:03

brakbabord

Re : Flash et Ubuntu 8.10 64 bits

Essaye de supprimer flashplugin-nonfree ainsi que le répertoire /usr/lib/xulrunner-addons/plugins

Ensuite tu réinstalle ton flashplugin-nonfree

Hors ligne

#13 Le 18/11/2008, à 03:07

coeurdechene

Re : Flash et Ubuntu 8.10 64 bits

Bonjour / soir tout le monde.
J'ai un problème avec flash depuis un petit moment. je suis en 64 bits et j'avais une version 8.04 sous KDE 3.5 jusqu'à il y a peu. Et lorsque Adobe à mis en ligne la v.10 de Flash, ma version a décrété un arrêt de travail. Pour Konqueror et Firefox. J'ai installé le .deb récupéré sur le site, Firefox n'a rien voulu savoir mais Konqueror s'est déclaré satisfait (sauf pour quelques rares sites).

Hier soir je suis passé à KDE4.1 et Kubuntu 8.10, me disant chouette, je vais repartir avec une bonne version de flash. Tu parles. Il a décidé de me faire tourner chèvre... Rien n'y fait. Ni le téléchargement du paquet .deb sur le site officiel, ni la doc d'Ubuntu que j'ai pourtant appliqué à la lettre, et lorsque j'ai tenté à l'instant la manip décrite par Danzisso, Adept m'a aimablement répondu :

APT Error. Context:
    Running dpkg, 
    [ /usr/bin/dpkg, --status-fd, 3, --unpack, /var/cache/apt/archives/nspluginwrapper_1.1.2-0ubuntu1_amd64.deb, /var/cache/apt/archives/flashplugin-nonfree_10.0.12.36ubuntu1_amd64.deb, /var/cache/apt/archives/gstreamer0.10-plugins-ugly-multiverse_0.10.7-2_amd64.deb, /var/cache/apt/archives/ubuntu-restricted-extras_25_amd64.deb ], 
    Sup-process returned error code 1, 
    Error processing /var/cache/apt/archives/flashplugin-nonfree_10.0.12.36ubuntu1_amd64.deb : paquets en conflit - flashplugin-nonfree non installé.

Dois-je renoncer définitivement à flash ou quelqu'un peut-il me fournir un début de solution ? Considérant que je suis une véritable quiche qui sait juste suivre une méthode pas à pas, mais il faut que ça soit bien expliqué...
D'avance, merci !

[Info config : KDE 4.1 Kubuntu 8.10, AMD 64 avec carte graphique 7600 GT Nvidia]

Hors ligne

#14 Le 18/11/2008, à 04:16

R. Ouellette

Re : Flash et Ubuntu 8.10 64 bits

coeurdechene a écrit :

[...]
J'ai un problème avec flash depuis un petit moment. je suis en 64 bits [...]

Bonne nouvelle, flash est maintenant disponible (depuis aujourd'hui le 17 novembre) en version 64 bits. Bon, flash ce n'est pas libre, :-( mais c'est drôlement commode dans notre furetage dans l'Internet...

1. Téléchargez la version 64 bits à http://labs.adobe.com/downloads/flashplayer10.html
2. Supprimez toutes les instances de nspluginwrapper pour flash (faites un locate libflash pour vous aider)
3. Décompressez la version 64 bits dans le répertoire /usr/lib/firefox/plugins/
4. si ça ne fonctionne pas (rien dans about:plugins), ajoutez des liens symboliques pointant vers /usr/lib/firefox/plugins/
libflashplayer.so dans /usr/lib/firefox-addons/plugins/

Jusqu'à maintenant la version Shockwave Flash 10.0 d20 fonctionne très bien sur ma Ubuntu 8.04.1 et Firefox 3.0.4.

Raymond

#15 Le 18/11/2008, à 05:19

R. Ouellette

Re : Flash et Ubuntu 8.10 64 bits

R. Ouellette a écrit :

Jusqu'à maintenant la version Shockwave Flash 10.0 d20 fonctionne très bien sur ma Ubuntu 8.04.1 et Firefox 3.0.4.

Hem, j'ai peut-être parlé trop vite... J'ai à peu près gelé mon système en testant cette simple adresse : http://www.usbwine.com pour vérifier les effets de transparence. La vidéo s'est lancé en double et, après en avoir fermé une instance, la vidéo a gelé à la toute fin...

Remarquez que le site de Adobe indique qu'il y a encore des bogues, soyons indulgents ;-)

#16 Le 18/11/2008, à 12:05

coeurdechene

Re : Flash et Ubuntu 8.10 64 bits

Merci Raymond, mais le flash 64 est encore en développement et je ne me sens pas encore suffisamment l'âme d'un bidouilleur en informatique pour installer quelque chose qui est une version alpha et qui donc foirer à un moment ou un autre...

Si quelqu'un peut me donner un check-list à suivre pour installer une version de flash stable pour AMD 64, je suis preneur (sachant que jusqu'à présent je l'avais installé en utilisant :

--force-architecture

et que ça marchait plutôt bien comme ça...

Hors ligne

#17 Le 18/11/2008, à 18:25

Frédéric Stemmelin

Re : Flash et Ubuntu 8.10 64 bits

Je viens également d'installer la version Flash 64 bits native.
C'est très simple en fait.

J'ai enlevé l'ancienne version flash-plugin-nonfree avec synaptic (option purge), puis j'ai effacer les fichiers qui trainaient encore, puis j'ai copié le fichier libflashplayer.so à deux endroits:

root@serveur:~# cp /home/fred/libflashplayer.so /usr/lib/firefox/plugins/
root@serveur:~# cp /home/fred/libflashplayer.so /usr/lib/mozilla/plugins/

J'ai redémarré firefox, et ca fonctionne.

Je vais tester dailymotion en HD pour voir smile

Hors ligne

#18 Le 19/11/2008, à 02:56

yostral

Re : Flash et Ubuntu 8.10 64 bits

Suffit de mettre le fichier libflashplayer.so dans ~/.mozilla/plugins , dans son home quoi.
Pour le moment, aucun soucis ni plantage (pas même avec usbwine wink).


Quand tout le reste a échoué, lisez le mode d'emploi.

Hors ligne

#19 Le 19/11/2008, à 04:44

coeurdechene

Re : Flash et Ubuntu 8.10 64 bits

Je veux bien avec le "il suffit de..."
Je vais le faire pour Mozilla, mais concrètement, en ce moment, j'utilise Konquéror.
Alors je le mets où mon fichier ?
Et pis pourquoi qu'il veut pas s'installer de manière "normale" et qu'il faut bidouiller à chaque fois ? C'est normal, ça, docteur ???

Hors ligne

#20 Le 19/11/2008, à 05:09

coeurdechene

Re : Flash et Ubuntu 8.10 64 bits

Bon, je viens de faire la MaJ proposée et pour Firefox ça marche nickel !
Merci les gars...
Serait-il possible d'avoir la marche à suivre pour Konqueror maintenant ? (j'ai regardé si il y avait pas un fichier /usr/lib/konqueror/plugins/ mais ça n'existe pas. Donc là j'ai pas d'autre idée...)

Hors ligne

#21 Le 19/11/2008, à 05:22

yostral

Re : Flash et Ubuntu 8.10 64 bits

Je n'utilise pas konqueror, mais il me semble que tu dois pouvoir définir les répertoires à scanner pour qu'il les utilise comme répertoire pour plugins. Indique-lui celui de .mozilla/plugins.

En ligne de commande c'est (c'était ?) un truc genre "nspluginscan". Sinon, faut chercher dans les menus wink.

Et il s'installera de manière "normale" quand il ne sera plus en version alpha et que quelqu'un l'aura packagé...


Quand tout le reste a échoué, lisez le mode d'emploi.

Hors ligne

#22 Le 26/11/2008, à 21:26

raoults

Re : Flash et Ubuntu 8.10 64 bits

Étape 1 - Suppression de la version 32 bits de Flash Player

Vous devez supprimer l’installation existante de la version 32 bits de Flash Player avant d’installer la version 64 bits. Pour effectuer cette tâche, ouvrez Synaptic (Système -> Administration -> Gestionnaire de paquets Synaptic) …

Quand Synaptic est prêt, tapez simplement “nsplugin” (sans les guillemets) dans la case de recherche. Il va immédiatement trouver le paquet. Faites un clic droit sur “NSPluginWrapper” et sélectionnez l’option “Sélectionner pour suppression complète” …

Vous serez également informés de la suppression du paquet “flashplugin-nonfree” …

Maintenant, cliquez sur le bouton “Appliquer“, une fenêtre de confirmation s’affiche, cliquez encore une fois sur “Appliquer“, et attendez la fin de la suppression des paquets de votre système. Fermez Synaptic une fois la suppression de la version 32 bits de Flash Player terminée.
Étape 2 - Installez flash player 64-bit

Extraire l’archive flash player 64-bit précédemment téléchargé ici et trouvez le fichier “libflashplayer.so” …

Maintenant, ouvrez votre dossier personnel, allez dans le menu Affichage -> Afficher les fichiers cachés (Ctrl+H) pour voir les fichiers cachés …

Allez dans le répertoire .Mozilla et créez un nouveau répertoire “plugins” (sans les guillemets) si bien sûr il n’existe pas déjà. Copiez et collez le fichier “libflashplayer.so” dans le dossier “plugins” …

Étape 3 - Vérifier l’installation de Flash Player 64 bits

Vous pouvez ouvrir votre navigateur web Firefox et aller vers le site de YouTube ou de tout autre site Web avec du contenu Flash. Essayez de regarder un film. Et ça fonctionne en plus !

Hors ligne

#23 Le 27/11/2008, à 14:41

BaltiK

Re : Flash et Ubuntu 8.10 64 bits

Bonjour,

@ raoults

Étape 1 - Simple

Étape 2 - Didactique

Étape 3 - Efficace

Merci


Ubuntu 12.04 LTS

Hors ligne

#24 Le 27/12/2008, à 13:23

Schneider

Re : Flash et Ubuntu 8.10 64 bits

raoults,ta solution ne fonctionne pas sous ubuntu 8.10 64 bits,deezer ne s'affiche pas correctemement!!

EDIT:Ma faute!!!Ca fonctionne PARFAITEMENT!!!Incroyable depuis le temps que je galère avec flash!!!Merci Merci IT WORKS

Dernière modification par Schneider (Le 27/12/2008, à 13:35)

Hors ligne

#25 Le 27/12/2008, à 22:56

Bristow

Re : Flash et Ubuntu 8.10 64 bits

Bonjour à tous,

Je voulais avoir votre avis sur les videos Dailymotion par exemple. En effet, j'ai acheté un portable MSI VR630-023 sur I-ventive.

Il est sur Intrepid 8.1, en 64 bits.

Le plugin flash d'adobe est correctement installé, sauf que les vidéos sur Dailymotion laguent. 2 secondes correctes puis stop, puis ca reprend, bref, c'est saccadé !

Avez-vous le même problème ?

Merci d'avance pour vos réponses...


Membre de l'April - « promouvoir et défendre le logiciel libre » - http://www.april.org
Ubuntu 14.04 LTS x86_64 avec Unity

Hors ligne

Haut de page ↑