Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 08/09/2020, à 13:57

philippe.guilpain

[Résolu] Partage Nas

Bonjour

J'ai changé d'ordinateur et je suis passé d'Ubuntu 16.04 à le version 18.04.
J'ai recopié la partie accés au NAS de mon ancien fstab qui me permet d'accéder à des données stockées sur un NAS.
Cela fonctionnait bien sur l'ancien ordinateur mais pas sur le nouveau.
Quand je teste (sudo mount -a) jai les erreurs suivantes :

mount: /etc/fstab : erreur d'analyse à la ligne 13 — ignorée
mount: /etc/fstab : erreur d'analyse à la ligne 14 — ignorée
mount: /etc/fstab : erreur d'analyse à la ligne 15 — ignorée

et voici mon fstab :

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=355e5daa-392b-4fcf-b713-a95ded73d2d2 /               ext4    errors=remount-ro 0       1
/swapfile                                 none            swap    sw              0       0
/dev/disk/by-id/usb-_Cle_0700078B0A5B00E6-0:1 /mnt/usb-_Cle_0700078B0A5B00E6-0:1 auto nosuid,nodev,nofail,noauto,x-gvfs-show 0 0
# //192.168.0.6/Volume_1/sauve /home/pguilpain/Documents/sauve cifs	credentials=/home/marielise/.smbcredentials guest,iocharset=utf8,gid=100,uid=1000,_netdev	vers=1.0	0	0
//192.168.0.6/Volume_1/Images_ml	/home/marielise/Images cifs	credentials=/home/marielise/.smbcredentials	guest,iocharset=utf8,gid=100,uid=1001,_netdev	vers=1.0	0	0
//192.168.0.6/Volume_1/Data_ml	/home/marielise/Documents cifs	credentials=/home/marielise/.smbcredentials	guest,iocharset=utf8,gid=100,uid=1001,_netdev	vers=1.0	0	0
//192.168.0.6/Volume_1/Audio_ml	/home/marielise/Musique	cifs	credentials=/home/marielise/.smbcredentials	guest,iocharset=utf8,gid=100,uid=1001,_netdev	vers=1.0	0	0

Si je peux avoir un petit coup de main afin de résoudre ce problème
Merci d'avance
Philippe

Dernière modification par philippe.guilpain (Le 08/09/2020, à 15:16)

Hors ligne

#2 Le 08/09/2020, à 14:23

abelthorne

Re : [Résolu] Partage Nas

Il y a un problème au niveau des options : "credentials" et "vers" devraient être séparées des autres par une virgule, pas une tabulation. Ça fait des champs supplémentaires qui ne correspondent pas à ce que le fstab attend. Corrige les quatre lignes comme ça :

# //192.168.0.6/Volume_1/sauve /home/pguilpain/Documents/sauve cifs	credentials=/home/marielise/.smbcredentials,guest,iocharset=utf8,gid=100,uid=1000,_netdev,vers=1.0	0	0
//192.168.0.6/Volume_1/Images_ml	/home/marielise/Images cifs	credentials=/home/marielise/.smbcredentials,guest,iocharset=utf8,gid=100,uid=1001,_netdev,vers=1.0	0	0
//192.168.0.6/Volume_1/Data_ml	/home/marielise/Documents cifs	credentials=/home/marielise/.smbcredentials,guest,iocharset=utf8,gid=100,uid=1001,_netdev,vers=1.0	0	0
//192.168.0.6/Volume_1/Audio_ml	/home/marielise/Musique	cifs	credentials=/home/marielise/.smbcredentials,guest,iocharset=utf8,gid=100,uid=1001,_netdev,vers=1.0	0	0

Il y aurait peut-être d'autres corrections à faire : je ne suis pas sûr que ce soit utile d'avoir l'option guest s'il y a des credentials et un id/gid d'utilisateur spécifiés (à vérifier). Et c'est normal que l'uid soit sur 1001 (deuxième compte utilisateur créé) plutôt que 1000 (premier compte utilisateur) ?

À part ça, l'IP du NAS est toujours la même (192.168.0.6) ? le nom de ton compte aussi (marielise) ? le fichier .smbcredentials a bien été remis dedans ?

Dernière modification par abelthorne (Le 08/09/2020, à 14:35)


Installation de Steam (obsolète sauf 16.04) / Battle.net / Neverwinter Nights • Groupe Steam Ubuntu-fr : http://steamcommunity.com/groups/ubuntufr

En ligne

#3 Le 08/09/2020, à 15:14

philippe.guilpain

Re : [Résolu] Partage Nas

Merci de ta réponse.
J'ai modifier le Fstab  et cela fonctionne mais j'ai du installer cifs-util.

Hors ligne